Class Diagram: Microsoft.Deployment.Compression

Microsoft.Deployment.Compression Namespace


Class Diagram: Microsoft.Deployment.WindowsInstaller

Microsoft.Deployment.WindowsInstaller Namespace


Microsoft.Deployment.Compression Namespace

Deployment Tools Foundation
Microsoft.Deployment.Compression Namespace
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression
Framework for archive packing and unpacking.
Declaration Syntax
C# Visual Basic Visual C++
namespace Microsoft.Deployment.Compression
Namespace Microsoft.Deployment.Compression
namespace Microsoft.Deployment.Compression
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | ArchiveException | Base exception class for compression operations. Compression libraries should derive subclass exceptions with more specific error information relevent to the file format.
 | ArchiveFileInfo | Abstract object representing a compressed file within an archive; provides operations for getting the file properties and unpacking the file.
 | ArchiveFileStreamContext | Provides a basic implementation of the archive pack and unpack stream context interfaces, based on a list of archive files, a default directory, and an optional mapping from internal to external file paths.
 | ArchiveInfo | Abstract object representing a compressed archive on disk; provides access to file-based operations on the archive.
 | ArchiveProgressEventArgs | Contains the data reported in an archive progress event.
 | ArchiveProgressType | The type of progress event.
 | BasicUnpackStreamContext | Stream context used to extract a single file from an archive into a memory stream.
 | CargoStream | Wraps a source stream and carries additional items that are disposed when the stream is closed.
 | CompressionEngine | Base class for an engine capable of packing and unpacking a particular compressed file format.
 | CompressionLevel | Specifies the compression level ranging from minimum compresion to maximum compression, or no compression at all.
 | DuplicateStream | Duplicates a source stream by maintaining a separate position.
 | IPackStreamContext | This interface provides the methods necessary for the CompressionEngine to open and close streams for archives and files. The implementor of this interface can use any kind of logic to determine what kind of streams to open and where.
 | IUnpackStreamContext | This interface provides the methods necessary for the CompressionEngine to open and close streams for archives and files. The implementor of this interface can use any kind of logic to determine what kind of streams to open and where
 | OffsetStream | Wraps a source stream and offsets all read/write/seek calls by a given value.

Send comments on this topic to wix-users@lists.sourceforge.net


ArchiveException Class

ArchiveException Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveException
Base exception class for compression operations. Compression libraries should derive subclass exceptions with more specific error information relevent to the file format.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ArchiveException : IOException
<SerializableAttribute> _
Public Class ArchiveException _
    Inherits IOException
[SerializableAttribute]
public ref class ArchiveException : public IOException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveException(String, Exception) | Creates a new ArchiveException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | ArchiveException(String) | Creates a new ArchiveException with a specified error message.
 | ArchiveException()()() | Creates a new ArchiveException.
 | ArchiveException(SerializationInfo, StreamingContext) | Initializes a new instance of the ArchiveException class with serialized data.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SystemException
 |  |  | IOException
 |  |  |  | ArchiveException
 |  |  |  |  | CabException
 |  |  |  |  | ZipException

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveException Constructor

ArchiveException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveException ► ArchiveException()()()
Members
Icon | Member | Description
 | ArchiveException(String, Exception) | Creates a new ArchiveException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | ArchiveException(String) | Creates a new ArchiveException with a specified error message.
 | ArchiveException()()() | Creates a new ArchiveException.
 | ArchiveException(SerializationInfo, StreamingContext) | Initializes a new instance of the ArchiveException class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveException Constructor

ArchiveException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveException ► ArchiveException()()()
Creates a new ArchiveException.
Declaration Syntax
C# Visual Basic Visual C++
public ArchiveException()
Public Sub New
public:
ArchiveException()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveException Constructor (info, context)

ArchiveException Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveException ► ArchiveException(SerializationInfo, StreamingContext)
Initializes a new instance of the ArchiveException class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected ArchiveException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ArchiveException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveException Constructor (message)

ArchiveException Constructor (message)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveException ► ArchiveException(String)
Creates a new ArchiveException with a specified error message.
Declaration Syntax
C# Visual Basic Visual C++
public ArchiveException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
ArchiveException(
    String^ message
)
Parameters
message (String)
The message that describes the error.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveException Constructor (message, innerException)

ArchiveException Constructor (message, innerException)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveException ► ArchiveException(String, Exception)
Creates a new ArchiveException with a specified error message and a reference to the inner exception that is the cause of this exception.
Declaration Syntax
C# Visual Basic Visual C++
public ArchiveException(
    string message,
    Exception innerException
)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
public:
ArchiveException(
    String^ message,
    Exception^ innerException
)
Parameters
message (String)
The message that describes the error.
innerException (Exception)
The exception that is the cause of the current exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveFileInfo Class

ArchiveFileInfo Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo
Abstract object representing a compressed file within an archive; provides operations for getting the file properties and unpacking the file.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ArchiveFileInfo : FileSystemInfo
<SerializableAttribute> _
Public MustInherit Class ArchiveFileInfo _
    Inherits FileSystemInfo
[SerializableAttribute]
public ref class ArchiveFileInfo abstract : public FileSystemInfo
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveFileInfo(ArchiveInfo, String) | Creates a new ArchiveFileInfo object representing a file within an archive in a specified path.
 | ArchiveFileInfo(String, Int32, FileAttributes, DateTime, Int64) | Creates a new ArchiveFileInfo object with all parameters specified; used by subclasses when reading the metadata out of an archive.
 | ArchiveFileInfo(SerializationInfo, StreamingContext) | Initializes a new instance of the ArchiveFileInfo class with serialized data.
 | Archive | Gets or sets the archive that contains this file.
 | ArchiveName | Gets the full path of the archive that contains this file.
 | ArchiveNumber | Gets the number of the archive where this file starts.
 | Attributes | Gets the attributes of the file.
 | CopyTo(String) | Extracts the file.
 | CopyTo(String, Boolean) | Extracts the file, optionally overwriting any existing file.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreationTime | Gets or sets the creation time of the current FileSystemInfo object. (Inherited from FileSystemInfo.)
 | CreationTimeUtc | Gets or sets the creation time, in coordinated universal time (UTC), of the current FileSystemInfo object. (Inherited from FileSystemInfo.)
 | Delete()()() | Deletes the file. NOT SUPPORTED. (Overrides FileSystemInfo.Delete()()().)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists | Checks if the file exists within the archive. (Overrides FileSystemInfo.Exists.)
 | Extension | Gets the string representing the extension part of the file. (Inherited from FileSystemInfo.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets the full path to the file. (Overrides FileSystemInfo.FullName.)
 | FullPath | Represents the fully qualified path of the directory or file. (Inherited from FileSystemInfo.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo with information about the archive. (Overrides FileSystemInfo.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LastAccessTime | Gets or sets the time the current file or directory was last accessed. (Inherited from FileSystemInfo.)
 | LastAccessTimeUtc | Gets or sets the time, in coordinated universal time (UTC), that the current file or directory was last accessed. (Inherited from FileSystemInfo.)
 | LastWriteTime | Gets the last modification time of the file.
 | LastWriteTimeUtc | Gets or sets the time, in coordinated universal time (UTC), when the current file or directory was last written to. (Inherited from FileSystemInfo.)
 | Length | Gets the uncompressed size of the file.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the file. (Overrides FileSystemInfo.Name.)
 | OpenRead()()() | Opens the archive file for reading without actually extracting the file to disk.
 | OpenText()()() | Opens the archive file reading text with UTF-8 encoding without actually extracting the file to disk.
 | OriginalPath | The path originally specified by the user, whether relative or absolute. (Inherited from FileSystemInfo.)
 | Path | Gets the internal path of the file in the archive.
 | Refresh()()() | Refreshes the attributes and other cached information about the file, by re-reading the information from the archive.
 | Refresh(ArchiveFileInfo) | Refreshes the information in this object with new data retrieved from an archive.
 | ToString()()() | Gets the full path to the file. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | FileSystemInfo
 |  |  | ArchiveFileInfo
 |  |  |  | CabFileInfo
 |  |  |  | ZipFileInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveFileInfo Constructor

ArchiveFileInfo Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► ArchiveFileInfo()()()
Members
Icon | Member | Description
 | ArchiveFileInfo(ArchiveInfo, String) | Creates a new ArchiveFileInfo object representing a file within an archive in a specified path.
 | ArchiveFileInfo(String, Int32, FileAttributes, DateTime, Int64) | Creates a new ArchiveFileInfo object with all parameters specified; used by subclasses when reading the metadata out of an archive.
 | ArchiveFileInfo(SerializationInfo, StreamingContext) | Initializes a new instance of the ArchiveFileInfo class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveFileInfo Constructor (archiveInfo, filePath)

ArchiveFileInfo Constructor (archiveInfo, filePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► ArchiveFileInfo(ArchiveInfo, String)
Creates a new ArchiveFileInfo object representing a file within an archive in a specified path.
Declaration Syntax
C# Visual Basic Visual C++
protected ArchiveFileInfo(
    ArchiveInfo archiveInfo,
    string filePath
)
Protected Sub New ( _
    archiveInfo As ArchiveInfo, _
    filePath As String _
)
protected:
ArchiveFileInfo(
    ArchiveInfo^ archiveInfo,
    String^ filePath
)
Parameters
archiveInfo (ArchiveInfo)
An object representing the archive containing the file.
filePath (String)
The path to the file within the archive. Usually, this is a simple file name, but if the archive contains a directory structure this may include the directory.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveFileInfo Constructor (info, context)

ArchiveFileInfo Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► ArchiveFileInfo(SerializationInfo, StreamingContext)
Initializes a new instance of the ArchiveFileInfo class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected ArchiveFileInfo(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ArchiveFileInfo(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveFileInfo Constructor (filePath, archiveNumber, attributes, lastWriteTime, length)

ArchiveFileInfo Constructor (filePath, archiveNumber, attributes, lastWriteTime, length)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► ArchiveFileInfo(String, Int32, FileAttributes, DateTime, Int64)
Creates a new ArchiveFileInfo object with all parameters specified; used by subclasses when reading the metadata out of an archive.
Declaration Syntax
C# Visual Basic Visual C++
protected ArchiveFileInfo(
    string filePath,
    int archiveNumber,
    FileAttributes attributes,
    DateTime lastWriteTime,
    long length
)
Protected Sub New ( _
    filePath As String, _
    archiveNumber As Integer, _
    attributes As FileAttributes, _
    lastWriteTime As DateTime, _
    length As Long _
)
protected:
ArchiveFileInfo(
    String^ filePath,
    int archiveNumber,
    FileAttributes attributes,
    DateTime lastWriteTime,
    long long length
)
Parameters
filePath (String)
The internal path and name of the file in the archive.
archiveNumber (Int32)
The archive number where the file starts.
attributes (FileAttributes)
The stored attributes of the file.
lastWriteTime (DateTime)
The stored last write time of the file.
length (Int64)
The uncompressed size of the file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Archive Property

Archive Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► Archive
Gets or sets the archive that contains this file.
Declaration Syntax
C# Visual Basic Visual C++
public ArchiveInfo Archive { get; internal set; }
Public Property Archive As ArchiveInfo
public:
property ArchiveInfo^ Archive {
    ArchiveInfo^ get ();
    void set (ArchiveInfo^ value);
}
Value
The ArchiveInfo instance that retrieved this file information -- this may be null if the ArchiveFileInfo object was returned directly from a stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveName Property

ArchiveName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► ArchiveName
Gets the full path of the archive that contains this file.
Declaration Syntax
C# Visual Basic Visual C++
public string ArchiveName { get; }
Public ReadOnly Property ArchiveName As String
public:
property String^ ArchiveName {
    String^ get ();
}
Value
The full path of the archive that contains this file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveNumber Property

ArchiveNumber Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► ArchiveNumber
Gets the number of the archive where this file starts.
Declaration Syntax
C# Visual Basic Visual C++
public int ArchiveNumber { get; }
Public ReadOnly Property ArchiveNumber As Integer
public:
property int ArchiveNumber {
    int get ();
}
Value
The number of the archive where this file starts.
Remarks
A single archive or the first archive in a chain is numbered 0.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Attributes Property

Attributes Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► Attributes
Gets the attributes of the file.
Declaration Syntax
C# Visual Basic Visual C++
public FileAttributes Attributes { get; }
Public ReadOnly Property Attributes As FileAttributes
public:
property FileAttributes Attributes {
    FileAttributes get ();
}
Value
The attributes of the file as stored in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method

CopyTo Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► CopyTo()()()
Members
Icon | Member | Description
 | CopyTo(String) | Extracts the file.
 | CopyTo(String, Boolean) | Extracts the file, optionally overwriting any existing file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (destFileName)

CopyTo Method (destFileName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► CopyTo(String)
Extracts the file.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    string destFileName
)
Public Sub CopyTo ( _
    destFileName As String _
)
public:
void CopyTo(
    String^ destFileName
)
Parameters
destFileName (String)
The destination path where the file will be extracted.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (destFileName, overwrite)

CopyTo Method (destFileName, overwrite)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► CopyTo(String, Boolean)
Extracts the file, optionally overwriting any existing file.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    string destFileName,
    bool overwrite
)
Public Sub CopyTo ( _
    destFileName As String, _
    overwrite As Boolean _
)
public:
void CopyTo(
    String^ destFileName,
    bool overwrite
)
Parameters
destFileName (String)
The destination path where the file will be extracted.
overwrite (Boolean)
If true, destFileName will be overwritten if it exists.
Exceptions
Exception | Condition
IOException | overwrite is false and destFileName exists.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Delete Method

Delete Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► Delete()()()
Deletes the file. NOT SUPPORTED.
Declaration Syntax
C# Visual Basic Visual C++
public override void Delete()
Public Overrides Sub Delete
public:
virtual void Delete() override
Exceptions
Exception | Condition
NotSupportedException | Files cannot be deleted from an existing archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Exists Property

Exists Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► Exists
Checks if the file exists within the archive.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Exists { get; }
Public Overrides ReadOnly Property Exists As Boolean
public:
virtual property bool Exists {
    bool get () override;
}
Value
True if the file exists, false otherwise.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


FullName Property

FullName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► FullName
Gets the full path to the file.
Declaration Syntax
C# Visual Basic Visual C++
public override string FullName { get; }
Public Overrides ReadOnly Property FullName As String
public:
virtual property String^ FullName {
    String^ get () override;
}
Value
The full path to the file, including the full path to the archive, the internal path in the archive, and the file name.
Remarks
For example, the path "C:\archive.cab\file.txt" refers to a file "file.txt" inside the archive "archive.cab".

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► GetObjectData(SerializationInfo, StreamingContext)
Sets the SerializationInfo with information about the archive.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


LastWriteTime Property

LastWriteTime Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► LastWriteTime
Gets the last modification time of the file.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastWriteTime { get; }
Public ReadOnly Property LastWriteTime As DateTime
public:
property DateTime LastWriteTime {
    DateTime get ();
}
Value
The last modification time of the file as stored in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Length Property

Length Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► Length
Gets the uncompressed size of the file.
Declaration Syntax
C# Visual Basic Visual C++
public long Length { get; }
Public ReadOnly Property Length As Long
public:
property long long Length {
    long long get ();
}
Value
The uncompressed size of the file in bytes.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Name Property

Name Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► Name
Gets the name of the file.
Declaration Syntax
C# Visual Basic Visual C++
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
public:
virtual property String^ Name {
    String^ get () override;
}
Value
The name of the file, not including any path.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenRead Method

OpenRead Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► OpenRead()()()
Opens the archive file for reading without actually extracting the file to disk.
Declaration Syntax
C# Visual Basic Visual C++
public Stream OpenRead()
Public Function OpenRead As Stream
public:
Stream^ OpenRead()
Return Value
A stream for reading directly from the packed file. Like any stream this should be closed/disposed as soon as it is no longer needed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenText Method

OpenText Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► OpenText()()()
Opens the archive file reading text with UTF-8 encoding without actually extracting the file to disk.
Declaration Syntax
C# Visual Basic Visual C++
public StreamReader OpenText()
Public Function OpenText As StreamReader
public:
StreamReader^ OpenText()
Return Value
A reader for reading text directly from the packed file. Like any reader this should be closed/disposed as soon as it is no longer needed.
Remarks
To open an archived text file with different encoding, use the OpenRead()()() method and pass the returned stream to one of the StreamReader constructor overloads.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Path Property

Path Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► Path
Gets the internal path of the file in the archive.
Declaration Syntax
C# Visual Basic Visual C++
public string Path { get; }
Public ReadOnly Property Path As String
public:
property String^ Path {
    String^ get ();
}
Value
The internal path of the file in the archive, not including the file name.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Refresh Method

Refresh Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► Refresh()()()
Members
Icon | Member | Description
 | Refresh()()() | Refreshes the attributes and other cached information about the file, by re-reading the information from the archive.
 | Refresh(ArchiveFileInfo) | Refreshes the information in this object with new data retrieved from an archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Refresh Method

Refresh Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► Refresh()()()
Refreshes the attributes and other cached information about the file, by re-reading the information from the archive.
Declaration Syntax
C# Visual Basic Visual C++
public void Refresh()
Public Sub Refresh
public:
void Refresh()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Refresh Method (newFileInfo)

Refresh Method (newFileInfo)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► Refresh(ArchiveFileInfo)
Refreshes the information in this object with new data retrieved from an archive.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Refresh(
    ArchiveFileInfo newFileInfo
)
Protected Overridable Sub Refresh ( _
    newFileInfo As ArchiveFileInfo _
)
protected:
virtual void Refresh(
    ArchiveFileInfo^ newFileInfo
)
Parameters
newFileInfo (ArchiveFileInfo)
Fresh instance for the same file just read from the archive.
Remarks
Subclasses may override this method to refresh sublcass fields. However they should always call the base implementation first.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ToString Method

ToString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► ToString()()()
Gets the full path to the file.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The same as FullName

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveFileStreamContext Class

ArchiveFileStreamContext Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext
Provides a basic implementation of the archive pack and unpack stream context interfaces, based on a list of archive files, a default directory, and an optional mapping from internal to external file paths.
Declaration Syntax
C# Visual Basic Visual C++
public class ArchiveFileStreamContext : IPackStreamContext,
    IUnpackStreamContext
Public Class ArchiveFileStreamContext _
    Implements IPackStreamContext, IUnpackStreamContext
public ref class ArchiveFileStreamContext : IPackStreamContext,
    IUnpackStreamContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveFileStreamContext(String) | Creates a new ArchiveFileStreamContext with a archive file and no default directory or file mapping.
 | ArchiveFileStreamContext(String, String, IDictionary<(Of <(String, String>)>)) | Creates a new ArchiveFileStreamContext with a archive file, default directory and mapping from internal to external file paths.
 | ArchiveFileStreamContext(IList<(Of <(String>)>), String, IDictionary<(Of <(String, String>)>)) | Creates a new ArchiveFileStreamContext with a list of archive files, a default directory and a mapping from internal to external file paths.
 | ArchiveFiles | Gets or sets the list of archive files that are created or extracted.
 | CloseArchiveReadStream(Int32, String, Stream) | Closes a stream where an archive was read.
 | CloseArchiveWriteStream(Int32, String, Stream) | Closes a stream where an archive package was written.
 | CloseFileReadStream(String, Stream) | Closes a stream that has been used to read a file.
 | CloseFileWriteStream(String, Stream, FileAttributes, DateTime) | Closes a stream where an extracted file was written.
 | Directory | Gets or sets the default root directory where files are located.
 | EnableOffsetOpen | Gets or sets a flag that enables creating or extracting an archive at an offset within an existing file. (This is typically used to open archive-based self-extracting packages.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractOnlyNewerFiles | Gets or sets a flag that can prevent extracted files from overwriting newer files that already exist.
 | Files | Gets or sets the mapping from internal file paths to external file paths.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetArchiveName(Int32) | Gets the name of the archive with a specified number.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOption(String, array<Object>[]()[]) | Gets extended parameter information specific to the compression format being used.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OpenArchiveReadStream(Int32, String, CompressionEngine) | Opens the archive stream for reading.
 | OpenArchiveWriteStream(Int32, String, Boolean, CompressionEngine) | Opens a stream for writing an archive.
 | OpenFileReadStream(String, FileAttributes%, DateTime%) | Opens a stream to read a file that is to be included in an archive.
 | OpenFileWriteStream(String, Int64, DateTime) | Opens a stream for writing extracted file bytes.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class can also handle creating or extracting chained archive packages.
Inheritance Hierarchy
Object
ArchiveFileStreamContext

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveFileStreamContext Constructor

ArchiveFileStreamContext Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► ArchiveFileStreamContext()()()
Members
Icon | Member | Description
 | ArchiveFileStreamContext(String) | Creates a new ArchiveFileStreamContext with a archive file and no default directory or file mapping.
 | ArchiveFileStreamContext(String, String, IDictionary<(Of <(String, String>)>)) | Creates a new ArchiveFileStreamContext with a archive file, default directory and mapping from internal to external file paths.
 | ArchiveFileStreamContext(IList<(Of <(String>)>), String, IDictionary<(Of <(String, String>)>)) | Creates a new ArchiveFileStreamContext with a list of archive files, a default directory and a mapping from internal to external file paths.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveFileStreamContext Constructor (archiveFiles, directory, files)

ArchiveFileStreamContext Constructor (archiveFiles, directory, files)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► ArchiveFileStreamContext(IList<(Of <(String>)>), String, IDictionary<(Of <(String, String>)>))
Creates a new ArchiveFileStreamContext with a list of archive files, a default directory and a mapping from internal to external file paths.
Declaration Syntax
C# Visual Basic Visual C++
public ArchiveFileStreamContext(
    IList<string> archiveFiles,
    string directory,
    IDictionary<string, string> files
)
Public Sub New ( _
    archiveFiles As IList(Of String), _
    directory As String, _
    files As IDictionary(Of String, String) _
)
public:
ArchiveFileStreamContext(
    IList<String^>^ archiveFiles,
    String^ directory,
    IDictionary<String^, String^>^ files
)
Parameters
archiveFiles (IList <(Of <( String >)>))
A list of paths to archive files that will be created or extracted.
directory (String)
The default root directory where files will be located, optional.
files (IDictionary <(Of <( String, String >)>))
A mapping from internal file paths to external file paths, optional.
Remarks
When creating chained archives, the archiveFiles list should include at least enough archives to handle the entire set of input files, based on the maximum archive size that is passed to the CompressionEngine.Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64).

If the mapping is not null and a file is not included in the mapping, the file will be skipped.

If the external path in the mapping is a simple file name or relative file path, it will be concatenated onto the default directory, if one was specified.

For more about how the default directory and files mapping are used, see OpenFileReadStream(String, FileAttributes%, DateTime%) and OpenFileWriteStream(String, Int64, DateTime).

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveFileStreamContext Constructor (archiveFile)

ArchiveFileStreamContext Constructor (archiveFile)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► ArchiveFileStreamContext(String)
Creates a new ArchiveFileStreamContext with a archive file and no default directory or file mapping.
Declaration Syntax
C# Visual Basic Visual C++
public ArchiveFileStreamContext(
    string archiveFile
)
Public Sub New ( _
    archiveFile As String _
)
public:
ArchiveFileStreamContext(
    String^ archiveFile
)
Parameters
archiveFile (String)
The path to a archive file that will be created or extracted.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveFileStreamContext Constructor (archiveFile, directory, files)

ArchiveFileStreamContext Constructor (archiveFile, directory, files)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► ArchiveFileStreamContext(String, String, IDictionary<(Of <(String, String>)>))
Creates a new ArchiveFileStreamContext with a archive file, default directory and mapping from internal to external file paths.
Declaration Syntax
C# Visual Basic Visual C++
public ArchiveFileStreamContext(
    string archiveFile,
    string directory,
    IDictionary<string, string> files
)
Public Sub New ( _
    archiveFile As String, _
    directory As String, _
    files As IDictionary(Of String, String) _
)
public:
ArchiveFileStreamContext(
    String^ archiveFile,
    String^ directory,
    IDictionary<String^, String^>^ files
)
Parameters
archiveFile (String)
The path to a archive file that will be created or extracted.
directory (String)
The default root directory where files will be located, optional.
files (IDictionary <(Of <( String, String >)>))
A mapping from internal file paths to external file paths, optional.
Remarks
If the mapping is not null and a file is not included in the mapping, the file will be skipped.

If the external path in the mapping is a simple file name or relative file path, it will be concatenated onto the default directory, if one was specified.

For more about how the default directory and files mapping are used, see OpenFileReadStream(String, FileAttributes%, DateTime%) and OpenFileWriteStream(String, Int64, DateTime).

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveFiles Property

ArchiveFiles Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► ArchiveFiles
Gets or sets the list of archive files that are created or extracted.
Declaration Syntax
C# Visual Basic Visual C++
public IList<string> ArchiveFiles { get; }
Public ReadOnly Property ArchiveFiles As IList(Of String)
public:
property IList<String^>^ ArchiveFiles {
    IList<String^>^ get ();
}
Value
The list of archive files that are created or extracted.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CloseArchiveReadStream Method (archiveNumber, archiveName, stream)

CloseArchiveReadStream Method (archiveNumber, archiveName, stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► CloseArchiveReadStream(Int32, String, Stream)
Closes a stream where an archive was read.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CloseArchiveReadStream(
    int archiveNumber,
    string archiveName,
    Stream stream
)
Public Overridable Sub CloseArchiveReadStream ( _
    archiveNumber As Integer, _
    archiveName As String, _
    stream As Stream _
)
public:
virtual void CloseArchiveReadStream(
    int archiveNumber,
    String^ archiveName,
    Stream^ stream
)
Parameters
archiveNumber (Int32)
The archive number of the stream to close.
archiveName (String)
The name of the archive being closed.
stream (Stream)
The stream that was previously returned by OpenArchiveReadStream(Int32, String, CompressionEngine) and is now ready to be closed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CloseArchiveWriteStream Method (archiveNumber, archiveName, stream)

CloseArchiveWriteStream Method (archiveNumber, archiveName, stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► CloseArchiveWriteStream(Int32, String, Stream)
Closes a stream where an archive package was written.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CloseArchiveWriteStream(
    int archiveNumber,
    string archiveName,
    Stream stream
)
Public Overridable Sub CloseArchiveWriteStream ( _
    archiveNumber As Integer, _
    archiveName As String, _
    stream As Stream _
)
public:
virtual void CloseArchiveWriteStream(
    int archiveNumber,
    String^ archiveName,
    Stream^ stream
)
Parameters
archiveNumber (Int32)
The 0-based index of the archive within the chain.
archiveName (String)
The name of the archive that was previously returned by GetArchiveName(Int32).
stream (Stream)
A stream that was previously returned by OpenArchiveWriteStream(Int32, String, Boolean, CompressionEngine) and is now ready to be closed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CloseFileReadStream Method (path, stream)

CloseFileReadStream Method (path, stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► CloseFileReadStream(String, Stream)
Closes a stream that has been used to read a file.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CloseFileReadStream(
    string path,
    Stream stream
)
Public Overridable Sub CloseFileReadStream ( _
    path As String, _
    stream As Stream _
)
public:
virtual void CloseFileReadStream(
    String^ path,
    Stream^ stream
)
Parameters
path (String)
The path of the file within the archive; the same as the path provided when the stream was opened.
stream (Stream)
A stream that was previously returned by OpenFileReadStream(String, FileAttributes%, DateTime%) and is now ready to be closed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CloseFileWriteStream Method (path, stream, attributes, lastWriteTime)

CloseFileWriteStream Method (path, stream, attributes, lastWriteTime)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► CloseFileWriteStream(String, Stream, FileAttributes, DateTime)
Closes a stream where an extracted file was written.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void CloseFileWriteStream(
    string path,
    Stream stream,
    FileAttributes attributes,
    DateTime lastWriteTime
)
Public Overridable Sub CloseFileWriteStream ( _
    path As String, _
    stream As Stream, _
    attributes As FileAttributes, _
    lastWriteTime As DateTime _
)
public:
virtual void CloseFileWriteStream(
    String^ path,
    Stream^ stream,
    FileAttributes attributes,
    DateTime lastWriteTime
)
Parameters
path (String)
The path of the file within the archive.
stream (Stream)
The stream that was previously returned by OpenFileWriteStream(String, Int64, DateTime) and is now ready to be closed.
attributes (FileAttributes)
The attributes of the extracted file.
lastWriteTime (DateTime)
The last write time of the file.
Remarks
After closing the extracted file stream, this method applies the date and attributes to that file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Directory Property

Directory Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► Directory
Gets or sets the default root directory where files are located.
Declaration Syntax
C# Visual Basic Visual C++
public string Directory { get; }
Public ReadOnly Property Directory As String
public:
property String^ Directory {
    String^ get ();
}
Value
The default root directory where files are located.
Remarks
For details about how the default directory is used, see OpenFileReadStream(String, FileAttributes%, DateTime%) and OpenFileWriteStream(String, Int64, DateTime).

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


EnableOffsetOpen Property

EnableOffsetOpen Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► EnableOffsetOpen
Gets or sets a flag that enables creating or extracting an archive at an offset within an existing file. (This is typically used to open archive-based self-extracting packages.)
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableOffsetOpen { get; set; }
Public Property EnableOffsetOpen As Boolean
public:
property bool EnableOffsetOpen {
    bool get ();
    void set (bool value);
}
Value
True to search an existing package file for an archive offset or the end of the file;/ false to always create or open a plain archive file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ExtractOnlyNewerFiles Property

ExtractOnlyNewerFiles Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► ExtractOnlyNewerFiles
Gets or sets a flag that can prevent extracted files from overwriting newer files that already exist.
Declaration Syntax
C# Visual Basic Visual C++
public bool ExtractOnlyNewerFiles { get; set; }
Public Property ExtractOnlyNewerFiles As Boolean
public:
property bool ExtractOnlyNewerFiles {
    bool get ();
    void set (bool value);
}
Value
True to prevent overwriting newer files that already exist during extraction; false to always extract from the archive regardless of existing files.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Files Property

Files Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► Files
Gets or sets the mapping from internal file paths to external file paths.
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<string, string> Files { get; }
Public ReadOnly Property Files As IDictionary(Of String, String)
public:
property IDictionary<String^, String^>^ Files {
    IDictionary<String^, String^>^ get ();
}
Value
A mapping from internal file paths to external file paths.
Remarks
For details about how the files mapping is used, see OpenFileReadStream(String, FileAttributes%, DateTime%) and OpenFileWriteStream(String, Int64, DateTime).

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetArchiveName Method (archiveNumber)

GetArchiveName Method (archiveNumber)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► GetArchiveName(Int32)
Gets the name of the archive with a specified number.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetArchiveName(
    int archiveNumber
)
Public Overridable Function GetArchiveName ( _
    archiveNumber As Integer _
) As String
public:
virtual String^ GetArchiveName(
    int archiveNumber
)
Parameters
archiveNumber (Int32)
The 0-based index of the archive within the chain.
Return Value
The name of the requested archive. May be an empty string for non-chained archives, but may never be null.
Remarks
This method returns the file name of the archive from the archiveFiles()()() list with the specified index, or an empty string if the archive number is outside the bounds of the list. The file name should not include any directory path.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetOption Method (optionName, parameters)

GetOption Method (optionName, parameters)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► GetOption(String, array<Object>[]()[])
Gets extended parameter information specific to the compression format being used.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object GetOption(
    string optionName,
    Object[] parameters
)
Public Overridable Function GetOption ( _
    optionName As String, _
    parameters As Object() _
) As Object
public:
virtual Object^ GetOption(
    String^ optionName,
    array<Object^>^ parameters
)
Parameters
optionName (String)
Name of the option being requested.
parameters (array< Object >[]()[])
Parameters for the option; for per-file options, the first parameter is typically the internal file path.
Return Value
Option value, or null to use the default behavior.
Remarks
This implementation does not handle any options. Subclasses may override this method to allow for non-default behavior.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenArchiveReadStream Method (archiveNumber, archiveName, compressionEngine)

OpenArchiveReadStream Method (archiveNumber, archiveName, compressionEngine)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► OpenArchiveReadStream(Int32, String, CompressionEngine)
Opens the archive stream for reading.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Stream OpenArchiveReadStream(
    int archiveNumber,
    string archiveName,
    CompressionEngine compressionEngine
)
Public Overridable Function OpenArchiveReadStream ( _
    archiveNumber As Integer, _
    archiveName As String, _
    compressionEngine As CompressionEngine _
) As Stream
public:
virtual Stream^ OpenArchiveReadStream(
    int archiveNumber,
    String^ archiveName,
    CompressionEngine^ compressionEngine
)
Parameters
archiveNumber (Int32)
The zero-based index of the archive to open.
archiveName (String)
The name of the archive being opened.
compressionEngine (CompressionEngine)
Instance of the compression engine doing the operations.
Return Value
A stream from which archive bytes are read, or null to cancel extraction of the archive.
Remarks
This method opens the file from the ArchiveFiles list with the specified index. If the archive number is outside the bounds of the list, this method returns null.

If the EnableOffsetOpen flag is set, this method will seek to the start of any existing archive in the file, or to the end of the file if the existing file is not an archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenArchiveWriteStream Method (archiveNumber, archiveName, truncate, compressionEngine)

OpenArchiveWriteStream Method (archiveNumber, archiveName, truncate, compressionEngine)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► OpenArchiveWriteStream(Int32, String, Boolean, CompressionEngine)
Opens a stream for writing an archive.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Stream OpenArchiveWriteStream(
    int archiveNumber,
    string archiveName,
    bool truncate,
    CompressionEngine compressionEngine
)
Public Overridable Function OpenArchiveWriteStream ( _
    archiveNumber As Integer, _
    archiveName As String, _
    truncate As Boolean, _
    compressionEngine As CompressionEngine _
) As Stream
public:
virtual Stream^ OpenArchiveWriteStream(
    int archiveNumber,
    String^ archiveName,
    bool truncate,
    CompressionEngine^ compressionEngine
)
Parameters
archiveNumber (Int32)
The 0-based index of the archive within the chain.
archiveName (String)
The name of the archive that was returned by GetArchiveName(Int32).
truncate (Boolean)
True if the stream should be truncated when opened (if it already exists); false if an existing stream is being re-opened for writing additional data.
compressionEngine (CompressionEngine)
Instance of the compression engine doing the operations.
Return Value
A writable Stream where the compressed archive bytes will be written, or null to cancel the archive creation.
Remarks
This method opens the file from the ArchiveFiles list with the specified index. If the archive number is outside the bounds of the list, this method returns null.

If the EnableOffsetOpen flag is set, this method will seek to the start of any existing archive in the file, or to the end of the file if the existing file is not an archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenFileReadStream Method (path, attributes, lastWriteTime)

OpenFileReadStream Method (path, attributes, lastWriteTime)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► OpenFileReadStream(String, FileAttributes%, DateTime%)
Opens a stream to read a file that is to be included in an archive.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Stream OpenFileReadStream(
    string path,
    out FileAttributes attributes,
    out DateTime lastWriteTime
)
Public Overridable Function OpenFileReadStream ( _
    path As String, _
    <OutAttribute> ByRef attributes As FileAttributes, _
    <OutAttribute> ByRef lastWriteTime As DateTime _
) As Stream
public:
virtual Stream^ OpenFileReadStream(
    String^ path,
    [OutAttribute] FileAttributes% attributes,
    [OutAttribute] DateTime% lastWriteTime
)
Parameters
path (String)
The path of the file within the archive.
attributes ( FileAttributes %)
The returned attributes of the opened file, to be stored in the archive.
lastWriteTime ( DateTime %)
The returned last-modified time of the opened file, to be stored in the archive.
Return Value
A readable Stream where the file bytes will be read from before they are compressed, or null to skip inclusion of the file and continue to the next file.
Remarks
This method opens a file using the following logic: If the Directory and the Files mapping are both null, the path is treated as relative to the current directory, and that file is opened. If the Directory is not null but the Files mapping is null, the path is treated as relative to that directory, and that file is opened. If the Directory is null but the Files mapping is not null, the path parameter is used as a key into the mapping, and the resulting value is the file path that is opened, relative to the current directory (or it may be an absolute path). If no mapping exists, the file is skipped. If both the Directory and the Files mapping are specified, the path parameter is used as a key into the mapping, and the resulting value is the file path that is opened, relative to the specified directory (or it may be an absolute path). If no mapping exists, the file is skipped.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenFileWriteStream Method (path, fileSize, lastWriteTime)

OpenFileWriteStream Method (path, fileSize, lastWriteTime)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileStreamContext ► OpenFileWriteStream(String, Int64, DateTime)
Opens a stream for writing extracted file bytes.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Stream OpenFileWriteStream(
    string path,
    long fileSize,
    DateTime lastWriteTime
)
Public Overridable Function OpenFileWriteStream ( _
    path As String, _
    fileSize As Long, _
    lastWriteTime As DateTime _
) As Stream
public:
virtual Stream^ OpenFileWriteStream(
    String^ path,
    long long fileSize,
    DateTime lastWriteTime
)
Parameters
path (String)
The path of the file within the archive.
fileSize (Int64)
The uncompressed size of the file to be extracted.
lastWriteTime (DateTime)
The last write time of the file to be extracted.
Return Value
A stream where extracted file bytes are to be written, or null to skip extraction of the file and continue to the next file.
Remarks
This method opens a file using the following logic: If the Directory and the Files mapping are both null, the path is treated as relative to the current directory, and that file is opened. If the Directory is not null but the Files mapping is null, the path is treated as relative to that directory, and that file is opened. If the Directory is null but the Files mapping is not null, the path parameter is used as a key into the mapping, and the resulting value is the file path that is opened, relative to the current directory (or it may be an absolute path). If no mapping exists, the file is skipped. If both the Directory and the Files mapping are specified, the path parameter is used as a key into the mapping, and the resulting value is the file path that is opened, relative to the specified directory (or it may be an absolute path). If no mapping exists, the file is skipped.

If the ExtractOnlyNewerFiles flag is set, the file is skipped if a file currently exists in the same path with an equal or newer write time.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveInfo Class

ArchiveInfo Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo
Abstract object representing a compressed archive on disk; provides access to file-based operations on the archive.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class ArchiveInfo : FileSystemInfo
<SerializableAttribute> _
Public MustInherit Class ArchiveInfo _
    Inherits FileSystemInfo
[SerializableAttribute]
public ref class ArchiveInfo abstract : public FileSystemInfo
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveInfo(String) | Creates a new ArchiveInfo object representing an archive in a specified path.
 | ArchiveInfo(SerializationInfo, StreamingContext) | Initializes a new instance of the ArchiveInfo class with serialized data.
 | Attributes | Gets or sets the FileAttributes of the current FileSystemInfo. (Inherited from FileSystemInfo.)
 | CopyTo(String) | Copies an existing archive to another location.
 | CopyTo(String, Boolean) | Copies an existing archive to another location, optionally overwriting the destination file.
 | CreateCompressionEngine()()() | Creates a compression engine that does the low-level work for this object.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreationTime | Gets or sets the creation time of the current FileSystemInfo object. (Inherited from FileSystemInfo.)
 | CreationTimeUtc | Gets or sets the creation time, in coordinated universal time (UTC), of the current FileSystemInfo object. (Inherited from FileSystemInfo.)
 | Delete()()() | Deletes the archive. (Overrides FileSystemInfo.Delete()()().)
 | Directory | Gets the directory that contains the archive.
 | DirectoryName | Gets the full path of the directory that contains the archive.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists | Checks if the archive exists. (Overrides FileSystemInfo.Exists.)
 | Extension | Gets the string representing the extension part of the file. (Inherited from FileSystemInfo.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets the full path of the directory or file. (Inherited from FileSystemInfo.)
 | FullPath | Represents the fully qualified path of the directory or file. (Inherited from FileSystemInfo.)
 | GetFiles()()() | Gets information about the files contained in the archive.
 | GetFiles(String) | Gets information about the certain files contained in the archive file.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo object with the file name and additional exception information. (Inherited from FileSystemInfo.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsValid()()() | Checks if the archive contains a valid archive header.
 | LastAccessTime | Gets or sets the time the current file or directory was last accessed. (Inherited from FileSystemInfo.)
 | LastAccessTimeUtc | Gets or sets the time, in coordinated universal time (UTC), that the current file or directory was last accessed. (Inherited from FileSystemInfo.)
 | LastWriteTime | Gets or sets the time when the current file or directory was last written to. (Inherited from FileSystemInfo.)
 | LastWriteTimeUtc | Gets or sets the time, in coordinated universal time (UTC), when the current file or directory was last written to. (Inherited from FileSystemInfo.)
 | Length | Gets the size of the archive.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveTo(String) | Moves an existing archive to another location.
 | Name | Gets the file name of the archive. (Overrides FileSystemInfo.Name.)
 | OpenRead(String) | Opens a file inside the archive for reading without actually extracting the file to disk.
 | OpenText(String) | Opens a file inside the archive for reading text with UTF-8 encoding without actually extracting the file to disk.
 | OriginalPath | The path originally specified by the user, whether relative or absolute. (Inherited from FileSystemInfo.)
 | Pack(String) | Compresses all files in a directory into the archive. Does not include subdirectories.
 | Pack(String, Boolean, CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses all files in a directory into the archive, optionally including subdirectories.
 | PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.
 | PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.
 | PackFileSet(String, IDictionary<(Of <(String, String>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.
 | PackFileSet(String, IDictionary<(Of <(String, String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.
 | Refresh()()() | Refreshes the state of the object. (Inherited from FileSystemInfo.)
 | ToString()()() | Gets the full path of the archive. (Overrides Object.ToString()()().)
 | Unpack(String) | Extracts all files from an archive to a destination directory.
 | Unpack(String, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts all files from an archive to a destination directory, optionally extracting only newer files.
 | UnpackFile(String, String) | Extracts a single file from the archive.
 | UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>)) | Extracts multiple files from the archive.
 | UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>), EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts multiple files from the archive, optionally extracting only newer files.
 | UnpackFileSet(IDictionary<(Of <(String, String>)>), String) | Extracts multiple files from the archive.
 | UnpackFileSet(IDictionary<(Of <(String, String>)>), String, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts multiple files from the archive.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | FileSystemInfo
 |  |  | ArchiveInfo
 |  |  |  | CabInfo
 |  |  |  | ZipInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveInfo Constructor

ArchiveInfo Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► ArchiveInfo()()()
Members
Icon | Member | Description
 | ArchiveInfo(String) | Creates a new ArchiveInfo object representing an archive in a specified path.
 | ArchiveInfo(SerializationInfo, StreamingContext) | Initializes a new instance of the ArchiveInfo class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveInfo Constructor (info, context)

ArchiveInfo Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► ArchiveInfo(SerializationInfo, StreamingContext)
Initializes a new instance of the ArchiveInfo class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected ArchiveInfo(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ArchiveInfo(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveInfo Constructor (path)

ArchiveInfo Constructor (path)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► ArchiveInfo(String)
Creates a new ArchiveInfo object representing an archive in a specified path.
Declaration Syntax
C# Visual Basic Visual C++
protected ArchiveInfo(
    string path
)
Protected Sub New ( _
    path As String _
)
protected:
ArchiveInfo(
    String^ path
)
Parameters
path (String)
The path to the archive. When creating an archive, this file does not necessarily exist yet.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method

CopyTo Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► CopyTo()()()
Members
Icon | Member | Description
 | CopyTo(String) | Copies an existing archive to another location.
 | CopyTo(String, Boolean) | Copies an existing archive to another location, optionally overwriting the destination file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (destFileName)

CopyTo Method (destFileName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► CopyTo(String)
Copies an existing archive to another location.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    string destFileName
)
Public Sub CopyTo ( _
    destFileName As String _
)
public:
void CopyTo(
    String^ destFileName
)
Parameters
destFileName (String)
The destination file path.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (destFileName, overwrite)

CopyTo Method (destFileName, overwrite)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► CopyTo(String, Boolean)
Copies an existing archive to another location, optionally overwriting the destination file.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    string destFileName,
    bool overwrite
)
Public Sub CopyTo ( _
    destFileName As String, _
    overwrite As Boolean _
)
public:
void CopyTo(
    String^ destFileName,
    bool overwrite
)
Parameters
destFileName (String)
The destination file path.
overwrite (Boolean)
If true, the destination file will be overwritten if it exists.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CreateCompressionEngine Method

CreateCompressionEngine Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► CreateCompressionEngine()()()
Creates a compression engine that does the low-level work for this object.
Declaration Syntax
C# Visual Basic Visual C++
protected abstract CompressionEngine CreateCompressionEngine()
Protected MustOverride Function CreateCompressionEngine As CompressionEngine
protected:
virtual CompressionEngine^ CreateCompressionEngine() abstract
Return Value
A new compression engine instance that matches the specific subclass of archive.
Remarks
Each instance will be Dispose()()()d immediately after use.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Delete Method

Delete Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► Delete()()()
Deletes the archive.
Declaration Syntax
C# Visual Basic Visual C++
public override void Delete()
Public Overrides Sub Delete
public:
virtual void Delete() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Directory Property

Directory Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► Directory
Gets the directory that contains the archive.
Declaration Syntax
C# Visual Basic Visual C++
public DirectoryInfo Directory { get; }
Public ReadOnly Property Directory As DirectoryInfo
public:
property DirectoryInfo^ Directory {
    DirectoryInfo^ get ();
}
Value
A DirectoryInfo object representing the parent directory of the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


DirectoryName Property

DirectoryName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► DirectoryName
Gets the full path of the directory that contains the archive.
Declaration Syntax
C# Visual Basic Visual C++
public string DirectoryName { get; }
Public ReadOnly Property DirectoryName As String
public:
property String^ DirectoryName {
    String^ get ();
}
Value
The full path of the directory that contains the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Exists Property

Exists Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► Exists
Checks if the archive exists.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Exists { get; }
Public Overrides ReadOnly Property Exists As Boolean
public:
virtual property bool Exists {
    bool get () override;
}
Value
True if the archive exists; else false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method

GetFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► GetFiles()()()
Members
Icon | Member | Description
 | GetFiles()()() | Gets information about the files contained in the archive.
 | GetFiles(String) | Gets information about the certain files contained in the archive file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method

GetFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► GetFiles()()()
Gets information about the files contained in the archive.
Declaration Syntax
C# Visual Basic Visual C++
public IList<ArchiveFileInfo> GetFiles()
Public Function GetFiles As IList(Of ArchiveFileInfo)
public:
IList<ArchiveFileInfo^>^ GetFiles()
Return Value
A list of ArchiveFileInfo objects, each containing information about a file in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method (searchPattern)

GetFiles Method (searchPattern)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► GetFiles(String)
Gets information about the certain files contained in the archive file.
Declaration Syntax
C# Visual Basic Visual C++
public IList<ArchiveFileInfo> GetFiles(
    string searchPattern
)
Public Function GetFiles ( _
    searchPattern As String _
) As IList(Of ArchiveFileInfo)
public:
IList<ArchiveFileInfo^>^ GetFiles(
    String^ searchPattern
)
Parameters
searchPattern (String)
The search string, such as "*.txt".
Return Value
A list of ArchiveFileInfo objects, each containing information about a file in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


IsValid Method

IsValid Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► IsValid()()()
Checks if the archive contains a valid archive header.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
Return Value
True if the file is a valid archive; false otherwise.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Length Property

Length Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► Length
Gets the size of the archive.
Declaration Syntax
C# Visual Basic Visual C++
public long Length { get; }
Public ReadOnly Property Length As Long
public:
property long long Length {
    long long get ();
}
Value
The size of the archive in bytes.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


MoveTo Method (destFileName)

MoveTo Method (destFileName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► MoveTo(String)
Moves an existing archive to another location.
Declaration Syntax
C# Visual Basic Visual C++
public void MoveTo(
    string destFileName
)
Public Sub MoveTo ( _
    destFileName As String _
)
public:
void MoveTo(
    String^ destFileName
)
Parameters
destFileName (String)
The destination file path.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Name Property

Name Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► Name
Gets the file name of the archive.
Declaration Syntax
C# Visual Basic Visual C++
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
public:
virtual property String^ Name {
    String^ get () override;
}
Value
The file name of the archive, not including any path.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenRead Method (fileName)

OpenRead Method (fileName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► OpenRead(String)
Opens a file inside the archive for reading without actually extracting the file to disk.
Declaration Syntax
C# Visual Basic Visual C++
public Stream OpenRead(
    string fileName
)
Public Function OpenRead ( _
    fileName As String _
) As Stream
public:
Stream^ OpenRead(
    String^ fileName
)
Parameters
fileName (String)
The name of the file in the archive. Also includes the internal path of the file, if any. File name matching is case-insensitive.
Return Value
A stream for reading directly from the packed file. Like any stream this should be closed/disposed as soon as it is no longer needed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenText Method (fileName)

OpenText Method (fileName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► OpenText(String)
Opens a file inside the archive for reading text with UTF-8 encoding without actually extracting the file to disk.
Declaration Syntax
C# Visual Basic Visual C++
public StreamReader OpenText(
    string fileName
)
Public Function OpenText ( _
    fileName As String _
) As StreamReader
public:
StreamReader^ OpenText(
    String^ fileName
)
Parameters
fileName (String)
The name of the file in the archive. Also includes the internal path of the file, if any. File name matching is case-insensitive.
Return Value
A reader for reading text directly from the packed file. Like any reader this should be closed/disposed as soon as it is no longer needed.
Remarks
To open an archived text file with different encoding, use the OpenRead(String) method and pass the returned stream to one of the StreamReader constructor overloads.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Pack Method

Pack Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► Pack()()()
Members
Icon | Member | Description
 | Pack(String) | Compresses all files in a directory into the archive. Does not include subdirectories.
 | Pack(String, Boolean, CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses all files in a directory into the archive, optionally including subdirectories.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Pack Method (sourceDirectory)

Pack Method (sourceDirectory)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► Pack(String)
Compresses all files in a directory into the archive. Does not include subdirectories.
Declaration Syntax
C# Visual Basic Visual C++
public void Pack(
    string sourceDirectory
)
Public Sub Pack ( _
    sourceDirectory As String _
)
public:
void Pack(
    String^ sourceDirectory
)
Parameters
sourceDirectory (String)
The directory containing the files to be included.
Remarks
Uses maximum compression level.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Pack Method (sourceDirectory, includeSubdirectories, compLevel, progressHandler)

Pack Method (sourceDirectory, includeSubdirectories, compLevel, progressHandler)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► Pack(String, Boolean, CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>))
Compresses all files in a directory into the archive, optionally including subdirectories.
Declaration Syntax
C# Visual Basic Visual C++
public void Pack(
    string sourceDirectory,
    bool includeSubdirectories,
    CompressionLevel compLevel,
    EventHandler<ArchiveProgressEventArgs> progressHandler
)
Public Sub Pack ( _
    sourceDirectory As String, _
    includeSubdirectories As Boolean, _
    compLevel As CompressionLevel, _
    progressHandler As EventHandler(Of ArchiveProgressEventArgs) _
)
public:
void Pack(
    String^ sourceDirectory,
    bool includeSubdirectories,
    CompressionLevel compLevel,
    EventHandler<ArchiveProgressEventArgs^>^ progressHandler
)
Parameters
sourceDirectory (String)
This parameter may be null, but if specified it is the root directory for any relative paths in sourceFileNames.
includeSubdirectories (Boolean)
If true, recursively include files in subdirectories.
compLevel (CompressionLevel)
The compression level used when creating the archive.
progressHandler (EventHandler <(Of <( ArchiveProgressEventArgs >)>))
Handler for receiving progress information; this may be null if progress is not desired.
Remarks
The files are stored in the archive using their relative file paths in the directory tree, if supported by the archive file format.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


PackFiles Method

PackFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► PackFiles()()()
Members
Icon | Member | Description
 | PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.
 | PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


PackFiles Method (sourceDirectory, sourceFileNames, fileNames)

PackFiles Method (sourceDirectory, sourceFileNames, fileNames)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>))
Compresses files into the archive, specifying the names used to store the files in the archive.
Declaration Syntax
C# Visual Basic Visual C++
public void PackFiles(
    string sourceDirectory,
    IList<string> sourceFileNames,
    IList<string> fileNames
)
Public Sub PackFiles ( _
    sourceDirectory As String, _
    sourceFileNames As IList(Of String), _
    fileNames As IList(Of String) _
)
public:
void PackFiles(
    String^ sourceDirectory,
    IList<String^>^ sourceFileNames,
    IList<String^>^ fileNames
)
Parameters
sourceDirectory (String)
This parameter may be null, but if specified it is the root directory for any relative paths in sourceFileNames.
sourceFileNames (IList <(Of <( String >)>))
The list of files to be included in the archive.
fileNames (IList <(Of <( String >)>))
The names of the files as they are stored in the archive. Each name includes the internal path of the file, if any. This parameter may be null, in which case the files are stored in the archive with their source file names and no path information.
Remarks
Uses maximum compression level.

Duplicate items in the fileNames array will cause an ArchiveException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


PackFiles Method (sourceDirectory, sourceFileNames, fileNames, compLevel, progressHandler)

PackFiles Method (sourceDirectory, sourceFileNames, fileNames, compLevel, progressHandler)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>))
Compresses files into the archive, specifying the names used to store the files in the archive.
Declaration Syntax
C# Visual Basic Visual C++
public void PackFiles(
    string sourceDirectory,
    IList<string> sourceFileNames,
    IList<string> fileNames,
    CompressionLevel compLevel,
    EventHandler<ArchiveProgressEventArgs> progressHandler
)
Public Sub PackFiles ( _
    sourceDirectory As String, _
    sourceFileNames As IList(Of String), _
    fileNames As IList(Of String), _
    compLevel As CompressionLevel, _
    progressHandler As EventHandler(Of ArchiveProgressEventArgs) _
)
public:
void PackFiles(
    String^ sourceDirectory,
    IList<String^>^ sourceFileNames,
    IList<String^>^ fileNames,
    CompressionLevel compLevel,
    EventHandler<ArchiveProgressEventArgs^>^ progressHandler
)
Parameters
sourceDirectory (String)
This parameter may be null, but if specified it is the root directory for any relative paths in sourceFileNames.
sourceFileNames (IList <(Of <( String >)>))
The list of files to be included in the archive.
fileNames (IList <(Of <( String >)>))
The names of the files as they are stored in the archive. Each name includes the internal path of the file, if any. This parameter may be null, in which case the files are stored in the archive with their source file names and no path information.
compLevel (CompressionLevel)
The compression level used when creating the archive.
progressHandler (EventHandler <(Of <( ArchiveProgressEventArgs >)>))
Handler for receiving progress information; this may be null if progress is not desired.
Remarks
Duplicate items in the fileNames array will cause an ArchiveException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


PackFileSet Method

PackFileSet Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► PackFileSet()()()
Members
Icon | Member | Description
 | PackFileSet(String, IDictionary<(Of <(String, String>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.
 | PackFileSet(String, IDictionary<(Of <(String, String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


PackFileSet Method (sourceDirectory, fileNames)

PackFileSet Method (sourceDirectory, fileNames)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► PackFileSet(String, IDictionary<(Of <(String, String>)>))
Compresses files into the archive, specifying the names used to store the files in the archive.
Declaration Syntax
C# Visual Basic Visual C++
public void PackFileSet(
    string sourceDirectory,
    IDictionary<string, string> fileNames
)
Public Sub PackFileSet ( _
    sourceDirectory As String, _
    fileNames As IDictionary(Of String, String) _
)
public:
void PackFileSet(
    String^ sourceDirectory,
    IDictionary<String^, String^>^ fileNames
)
Parameters
sourceDirectory (String)
This parameter may be null, but if specified it is the root directory for any relative paths in fileNames.
fileNames (IDictionary <(Of <( String, String >)>))
A mapping from internal file paths to external file paths.
Remarks
Uses maximum compression level.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


PackFileSet Method (sourceDirectory, fileNames, compLevel, progressHandler)

PackFileSet Method (sourceDirectory, fileNames, compLevel, progressHandler)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► PackFileSet(String, IDictionary<(Of <(String, String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>))
Compresses files into the archive, specifying the names used to store the files in the archive.
Declaration Syntax
C# Visual Basic Visual C++
public void PackFileSet(
    string sourceDirectory,
    IDictionary<string, string> fileNames,
    CompressionLevel compLevel,
    EventHandler<ArchiveProgressEventArgs> progressHandler
)
Public Sub PackFileSet ( _
    sourceDirectory As String, _
    fileNames As IDictionary(Of String, String), _
    compLevel As CompressionLevel, _
    progressHandler As EventHandler(Of ArchiveProgressEventArgs) _
)
public:
void PackFileSet(
    String^ sourceDirectory,
    IDictionary<String^, String^>^ fileNames,
    CompressionLevel compLevel,
    EventHandler<ArchiveProgressEventArgs^>^ progressHandler
)
Parameters
sourceDirectory (String)
This parameter may be null, but if specified it is the root directory for any relative paths in fileNames.
fileNames (IDictionary <(Of <( String, String >)>))
A mapping from internal file paths to external file paths.
compLevel (CompressionLevel)
The compression level used when creating the archive.
progressHandler (EventHandler <(Of <( ArchiveProgressEventArgs >)>))
Handler for receiving progress information; this may be null if progress is not desired.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ToString Method

ToString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► ToString()()()
Gets the full path of the archive.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The full path of the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Unpack Method

Unpack Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► Unpack()()()
Members
Icon | Member | Description
 | Unpack(String) | Extracts all files from an archive to a destination directory.
 | Unpack(String, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts all files from an archive to a destination directory, optionally extracting only newer files.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Unpack Method (destDirectory)

Unpack Method (destDirectory)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► Unpack(String)
Extracts all files from an archive to a destination directory.
Declaration Syntax
C# Visual Basic Visual C++
public void Unpack(
    string destDirectory
)
Public Sub Unpack ( _
    destDirectory As String _
)
public:
void Unpack(
    String^ destDirectory
)
Parameters
destDirectory (String)
Directory where the files are to be extracted.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Unpack Method (destDirectory, progressHandler)

Unpack Method (destDirectory, progressHandler)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► Unpack(String, EventHandler<(Of <(ArchiveProgressEventArgs>)>))
Extracts all files from an archive to a destination directory, optionally extracting only newer files.
Declaration Syntax
C# Visual Basic Visual C++
public void Unpack(
    string destDirectory,
    EventHandler<ArchiveProgressEventArgs> progressHandler
)
Public Sub Unpack ( _
    destDirectory As String, _
    progressHandler As EventHandler(Of ArchiveProgressEventArgs) _
)
public:
void Unpack(
    String^ destDirectory,
    EventHandler<ArchiveProgressEventArgs^>^ progressHandler
)
Parameters
destDirectory (String)
Directory where the files are to be extracted.
progressHandler (EventHandler <(Of <( ArchiveProgressEventArgs >)>))
Handler for receiving progress information; this may be null if progress is not desired.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


UnpackFile Method (fileName, destFileName)

UnpackFile Method (fileName, destFileName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► UnpackFile(String, String)
Extracts a single file from the archive.
Declaration Syntax
C# Visual Basic Visual C++
public void UnpackFile(
    string fileName,
    string destFileName
)
Public Sub UnpackFile ( _
    fileName As String, _
    destFileName As String _
)
public:
void UnpackFile(
    String^ fileName,
    String^ destFileName
)
Parameters
fileName (String)
The name of the file in the archive. Also includes the internal path of the file, if any. File name matching is case-insensitive.
destFileName (String)
The path where the file is to be extracted on disk.
Remarks
If destFileName already exists, it will be overwritten.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


UnpackFiles Method

UnpackFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► UnpackFiles()()()
Members
Icon | Member | Description
 | UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>)) | Extracts multiple files from the archive.
 | UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>), EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts multiple files from the archive, optionally extracting only newer files.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


UnpackFiles Method (fileNames, destDirectory, destFileNames)

UnpackFiles Method (fileNames, destDirectory, destFileNames)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>))
Extracts multiple files from the archive.
Declaration Syntax
C# Visual Basic Visual C++
public void UnpackFiles(
    IList<string> fileNames,
    string destDirectory,
    IList<string> destFileNames
)
Public Sub UnpackFiles ( _
    fileNames As IList(Of String), _
    destDirectory As String, _
    destFileNames As IList(Of String) _
)
public:
void UnpackFiles(
    IList<String^>^ fileNames,
    String^ destDirectory,
    IList<String^>^ destFileNames
)
Parameters
fileNames (IList <(Of <( String >)>))
The names of the files in the archive. Each name includes the internal path of the file, if any. File name matching is case-insensitive.
destDirectory (String)
This parameter may be null, but if specified it is the root directory for any relative paths in destFileNames.
destFileNames (IList <(Of <( String >)>))
The paths where the files are to be extracted on disk. If this parameter is null, the files will be extracted with the names from the archive.
Remarks
If any extracted files already exist on disk, they will be overwritten.

The destDirectory and destFileNames parameters cannot both be null.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


UnpackFiles Method (fileNames, destDirectory, destFileNames, progressHandler)

UnpackFiles Method (fileNames, destDirectory, destFileNames, progressHandler)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>), EventHandler<(Of <(ArchiveProgressEventArgs>)>))
Extracts multiple files from the archive, optionally extracting only newer files.
Declaration Syntax
C# Visual Basic Visual C++
public void UnpackFiles(
    IList<string> fileNames,
    string destDirectory,
    IList<string> destFileNames,
    EventHandler<ArchiveProgressEventArgs> progressHandler
)
Public Sub UnpackFiles ( _
    fileNames As IList(Of String), _
    destDirectory As String, _
    destFileNames As IList(Of String), _
    progressHandler As EventHandler(Of ArchiveProgressEventArgs) _
)
public:
void UnpackFiles(
    IList<String^>^ fileNames,
    String^ destDirectory,
    IList<String^>^ destFileNames,
    EventHandler<ArchiveProgressEventArgs^>^ progressHandler
)
Parameters
fileNames (IList <(Of <( String >)>))
The names of the files in the archive. Each name includes the internal path of the file, if any. File name matching is case-insensitive.
destDirectory (String)
This parameter may be null, but if specified it is the root directory for any relative paths in destFileNames.
destFileNames (IList <(Of <( String >)>))
The paths where the files are to be extracted on disk. If this parameter is null, the files will be extracted with the names from the archive.
progressHandler (EventHandler <(Of <( ArchiveProgressEventArgs >)>))
Handler for receiving progress information; this may be null if progress is not desired.
Remarks
If any extracted files already exist on disk, they will be overwritten.

The destDirectory and destFileNames parameters cannot both be null.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


UnpackFileSet Method

UnpackFileSet Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► UnpackFileSet()()()
Members
Icon | Member | Description
 | UnpackFileSet(IDictionary<(Of <(String, String>)>), String) | Extracts multiple files from the archive.
 | UnpackFileSet(IDictionary<(Of <(String, String>)>), String, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts multiple files from the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


UnpackFileSet Method (fileNames, destDirectory)

UnpackFileSet Method (fileNames, destDirectory)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► UnpackFileSet(IDictionary<(Of <(String, String>)>), String)
Extracts multiple files from the archive.
Declaration Syntax
C# Visual Basic Visual C++
public void UnpackFileSet(
    IDictionary<string, string> fileNames,
    string destDirectory
)
Public Sub UnpackFileSet ( _
    fileNames As IDictionary(Of String, String), _
    destDirectory As String _
)
public:
void UnpackFileSet(
    IDictionary<String^, String^>^ fileNames,
    String^ destDirectory
)
Parameters
fileNames (IDictionary <(Of <( String, String >)>))
A mapping from internal file paths to external file paths. Case-senstivity when matching internal paths depends on the IDictionary implementation.
destDirectory (String)
This parameter may be null, but if specified it is the root directory for any relative external paths in fileNameMap.
Remarks
If any extracted files already exist on disk, they will be overwritten.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


UnpackFileSet Method (fileNames, destDirectory, progressHandler)

UnpackFileSet Method (fileNames, destDirectory, progressHandler)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► UnpackFileSet(IDictionary<(Of <(String, String>)>), String, EventHandler<(Of <(ArchiveProgressEventArgs>)>))
Extracts multiple files from the archive.
Declaration Syntax
C# Visual Basic Visual C++
public void UnpackFileSet(
    IDictionary<string, string> fileNames,
    string destDirectory,
    EventHandler<ArchiveProgressEventArgs> progressHandler
)
Public Sub UnpackFileSet ( _
    fileNames As IDictionary(Of String, String), _
    destDirectory As String, _
    progressHandler As EventHandler(Of ArchiveProgressEventArgs) _
)
public:
void UnpackFileSet(
    IDictionary<String^, String^>^ fileNames,
    String^ destDirectory,
    EventHandler<ArchiveProgressEventArgs^>^ progressHandler
)
Parameters
fileNames (IDictionary <(Of <( String, String >)>))
A mapping from internal file paths to external file paths. Case-senstivity when matching internal paths depends on the IDictionary implementation.
destDirectory (String)
This parameter may be null, but if specified it is the root directory for any relative external paths in fileNameMap.
progressHandler (EventHandler <(Of <( ArchiveProgressEventArgs >)>))
Handler for receiving progress information; this may be null if progress is not desired.
Remarks
If any extracted files already exist on disk, they will be overwritten.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveProgressEventArgs Class

ArchiveProgressEventArgs Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs
Contains the data reported in an archive progress event.
Declaration Syntax
C# Visual Basic Visual C++
public class ArchiveProgressEventArgs : EventArgs
Public Class ArchiveProgressEventArgs _
    Inherits EventArgs
public ref class ArchiveProgressEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveProgressEventArgs(ArchiveProgressType, String, Int32, Int32, Int64, Int64, String, Int32, Int32, Int64, Int64, Int64, Int64) | Creates a new ArchiveProgressEventArgs object from specified event parameters.
 | CurrentArchiveBytesProcessed | Gets the number of compressed bytes processed so far during extraction of the current archive. Valid for all extraction messages.
 | CurrentArchiveName | Gets the name of the current archive. Not necessarily the name of the archive on disk. Valid for all message types.
 | CurrentArchiveNumber | Gets the current archive number, when processing a chained set of archives. Valid for all message types.
 | CurrentArchiveTotalBytes | Gets the total number of compressed bytes to be processed during extraction of the current archive. Valid for all extraction messages.
 | CurrentFileBytesProcessed | Gets the number of bytes processed so far when compressing or extracting a file. Valid for StartFile, PartialFile, and FinishFile messages.
 | CurrentFileName | Gets the name of the file being processed. (The name of the file within the Archive; not the external file path.) Also includes the internal path of the file, if any. Valid for StartFile, PartialFile, and FinishFile messages.
 | CurrentFileNumber | Gets the number of the current file being processed. The first file is number 0, and the last file is TotalFiles-1. Valid for StartFile, PartialFile, and FinishFile messages.
 | CurrentFileTotalBytes | Gets the total number of bytes in the current file. Valid for StartFile, PartialFile, and FinishFile messages.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileBytesProcessed | Gets the number of uncompressed bytes processed so far among all files. Valid for all message types.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProgressType | Gets the type of status message.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalArchives | Gets the total number of known archives in a chained set. Valid for all message types.
 | TotalFileBytes | Gets the total number of uncompressed file bytes to be processed. Valid for all message types.
 | TotalFiles | Gets the total number of files to be processed. Valid for all message types.
Inheritance Hierarchy
Object
 | EventArgs
 |  | ArchiveProgressEventArgs

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveProgressEventArgs Constructor (progressType, currentFileName, currentFileNumber, totalFiles, currentFileBytesProcessed, currentFileTotalBytes, currentArchiveName, currentArchiveNumber, totalArchives, currentArchiveBytesProcessed, currentArchiveTotalBytes, fileBytesProcessed, totalFileBytes)

ArchiveProgressEventArgs Constructor (progressType, currentFileName, currentFileNumber, totalFiles, currentFileBytesProcessed, currentFileTotalBytes, currentArchiveName, currentArchiveNumber, totalArchives, currentArchiveBytesProcessed, currentArchiveTotalBytes, fileBytesProcessed, totalFileBytes)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► ArchiveProgressEventArgs(ArchiveProgressType, String, Int32, Int32, Int64, Int64, String, Int32, Int32, Int64, Int64, Int64, Int64)
Creates a new ArchiveProgressEventArgs object from specified event parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ArchiveProgressEventArgs(
    ArchiveProgressType progressType,
    string currentFileName,
    int currentFileNumber,
    int totalFiles,
    long currentFileBytesProcessed,
    long currentFileTotalBytes,
    string currentArchiveName,
    int currentArchiveNumber,
    int totalArchives,
    long currentArchiveBytesProcessed,
    long currentArchiveTotalBytes,
    long fileBytesProcessed,
    long totalFileBytes
)
Public Sub New ( _
    progressType As ArchiveProgressType, _
    currentFileName As String, _
    currentFileNumber As Integer, _
    totalFiles As Integer, _
    currentFileBytesProcessed As Long, _
    currentFileTotalBytes As Long, _
    currentArchiveName As String, _
    currentArchiveNumber As Integer, _
    totalArchives As Integer, _
    currentArchiveBytesProcessed As Long, _
    currentArchiveTotalBytes As Long, _
    fileBytesProcessed As Long, _
    totalFileBytes As Long _
)
public:
ArchiveProgressEventArgs(
    ArchiveProgressType progressType,
    String^ currentFileName,
    int currentFileNumber,
    int totalFiles,
    long long currentFileBytesProcessed,
    long long currentFileTotalBytes,
    String^ currentArchiveName,
    int currentArchiveNumber,
    int totalArchives,
    long long currentArchiveBytesProcessed,
    long long currentArchiveTotalBytes,
    long long fileBytesProcessed,
    long long totalFileBytes
)
Parameters
progressType (ArchiveProgressType)
type of status message
currentFileName (String)
name of the file being processed
currentFileNumber (Int32)
number of the current file being processed
totalFiles (Int32)
total number of files to be processed
currentFileBytesProcessed (Int64)
number of bytes processed so far when compressing or extracting a file
currentFileTotalBytes (Int64)
total number of bytes in the current file
currentArchiveName (String)
name of the current Archive
currentArchiveNumber (Int32)
current Archive number, when processing a chained set of Archives
totalArchives (Int32)
total number of Archives in a chained set
currentArchiveBytesProcessed (Int64)
number of compressed bytes processed so far during an extraction
currentArchiveTotalBytes (Int64)
total number of compressed bytes to be processed during an extraction
fileBytesProcessed (Int64)
number of uncompressed file bytes processed so far
totalFileBytes (Int64)
total number of uncompressed file bytes to be processed

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CurrentArchiveBytesProcessed Property

CurrentArchiveBytesProcessed Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► CurrentArchiveBytesProcessed
Gets the number of compressed bytes processed so far during extraction of the current archive. Valid for all extraction messages.
Declaration Syntax
C# Visual Basic Visual C++
public long CurrentArchiveBytesProcessed { get; }
Public ReadOnly Property CurrentArchiveBytesProcessed As Long
public:
property long long CurrentArchiveBytesProcessed {
    long long get ();
}
Value
The number of compressed bytes processed so far during extraction of the current archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CurrentArchiveName Property

CurrentArchiveName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► CurrentArchiveName
Gets the name of the current archive. Not necessarily the name of the archive on disk. Valid for all message types.
Declaration Syntax
C# Visual Basic Visual C++
public string CurrentArchiveName { get; }
Public ReadOnly Property CurrentArchiveName As String
public:
property String^ CurrentArchiveName {
    String^ get ();
}
Value
The name of the current archive, or an empty string if no name was specified.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CurrentArchiveNumber Property

CurrentArchiveNumber Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► CurrentArchiveNumber
Gets the current archive number, when processing a chained set of archives. Valid for all message types.
Declaration Syntax
C# Visual Basic Visual C++
public int CurrentArchiveNumber { get; }
Public ReadOnly Property CurrentArchiveNumber As Integer
public:
property int CurrentArchiveNumber {
    int get ();
}
Value
The number of the current archive.
Remarks
The first archive is number 0, and the last archive is TotalArchives-1.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CurrentArchiveTotalBytes Property

CurrentArchiveTotalBytes Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► CurrentArchiveTotalBytes
Gets the total number of compressed bytes to be processed during extraction of the current archive. Valid for all extraction messages.
Declaration Syntax
C# Visual Basic Visual C++
public long CurrentArchiveTotalBytes { get; }
Public ReadOnly Property CurrentArchiveTotalBytes As Long
public:
property long long CurrentArchiveTotalBytes {
    long long get ();
}
Value
The total number of compressed bytes to be processed during extraction of the current archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CurrentFileBytesProcessed Property

CurrentFileBytesProcessed Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► CurrentFileBytesProcessed
Gets the number of bytes processed so far when compressing or extracting a file. Valid for StartFile, PartialFile, and FinishFile messages.
Declaration Syntax
C# Visual Basic Visual C++
public long CurrentFileBytesProcessed { get; }
Public ReadOnly Property CurrentFileBytesProcessed As Long
public:
property long long CurrentFileBytesProcessed {
    long long get ();
}
Value
The number of uncompressed bytes processed so far for the current file, or 0 if processing is currently at the stream or archive level.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CurrentFileName Property

CurrentFileName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► CurrentFileName
Gets the name of the file being processed. (The name of the file within the Archive; not the external file path.) Also includes the internal path of the file, if any. Valid for StartFile, PartialFile, and FinishFile messages.
Declaration Syntax
C# Visual Basic Visual C++
public string CurrentFileName { get; }
Public ReadOnly Property CurrentFileName As String
public:
property String^ CurrentFileName {
    String^ get ();
}
Value
The name of the file currently being processed, or null if processing is currently at the stream or archive level.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CurrentFileNumber Property

CurrentFileNumber Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► CurrentFileNumber
Gets the number of the current file being processed. The first file is number 0, and the last file is TotalFiles-1. Valid for StartFile, PartialFile, and FinishFile messages.
Declaration Syntax
C# Visual Basic Visual C++
public int CurrentFileNumber { get; }
Public ReadOnly Property CurrentFileNumber As Integer
public:
property int CurrentFileNumber {
    int get ();
}
Value
The number of the file currently being processed, or the most recent file processed if processing is currently at the stream or archive level.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CurrentFileTotalBytes Property

CurrentFileTotalBytes Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► CurrentFileTotalBytes
Gets the total number of bytes in the current file. Valid for StartFile, PartialFile, and FinishFile messages.
Declaration Syntax
C# Visual Basic Visual C++
public long CurrentFileTotalBytes { get; }
Public ReadOnly Property CurrentFileTotalBytes As Long
public:
property long long CurrentFileTotalBytes {
    long long get ();
}
Value
The uncompressed size of the current file being processed, or 0 if processing is currently at the stream or archive level.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


FileBytesProcessed Property

FileBytesProcessed Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► FileBytesProcessed
Gets the number of uncompressed bytes processed so far among all files. Valid for all message types.
Declaration Syntax
C# Visual Basic Visual C++
public long FileBytesProcessed { get; }
Public ReadOnly Property FileBytesProcessed As Long
public:
property long long FileBytesProcessed {
    long long get ();
}
Value
The number of uncompressed file bytes processed so far among all files.
Remarks
When compared to TotalFileBytes, this can be used as a measure of overall progress.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ProgressType Property

ProgressType Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► ProgressType
Gets the type of status message.
Declaration Syntax
C# Visual Basic Visual C++
public ArchiveProgressType ProgressType { get; }
Public ReadOnly Property ProgressType As ArchiveProgressType
public:
property ArchiveProgressType ProgressType {
    ArchiveProgressType get ();
}
Value
A ArchiveProgressType value indicating what type of progress event occurred.
Remarks
The handler may choose to ignore some types of progress events. For example, if the handler will only list each file as it is compressed/extracted, it can ignore events that are not of type FinishFile.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


TotalArchives Property

TotalArchives Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► TotalArchives
Gets the total number of known archives in a chained set. Valid for all message types.
Declaration Syntax
C# Visual Basic Visual C++
public int TotalArchives { get; }
Public ReadOnly Property TotalArchives As Integer
public:
property int TotalArchives {
    int get ();
}
Value
The total number of known archives in a chained set.
Remarks
When using the compression option to auto-split into multiple archives based on data size, this value will not be accurate until the end.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


TotalFileBytes Property

TotalFileBytes Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► TotalFileBytes
Gets the total number of uncompressed file bytes to be processed. Valid for all message types.
Declaration Syntax
C# Visual Basic Visual C++
public long TotalFileBytes { get; }
Public ReadOnly Property TotalFileBytes As Long
public:
property long long TotalFileBytes {
    long long get ();
}
Value
The total number of uncompressed bytes to be processed among all files.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


TotalFiles Property

TotalFiles Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressEventArgs ► TotalFiles
Gets the total number of files to be processed. Valid for all message types.
Declaration Syntax
C# Visual Basic Visual C++
public int TotalFiles { get; }
Public ReadOnly Property TotalFiles As Integer
public:
property int TotalFiles {
    int get ();
}
Value
The total number of files to be processed that are known so far.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ArchiveProgressType Enumeration

ArchiveProgressType Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveProgressType
The type of progress event.
Declaration Syntax
C# Visual Basic Visual C++
public enum ArchiveProgressType
Public Enumeration ArchiveProgressType
public enum class ArchiveProgressType
Members
Member | Description
StartFile | Status message before beginning the packing or unpacking an individual file.
PartialFile | Status message (possibly reported multiple times) during the process of packing or unpacking a file.
FinishFile | Status message after completion of the packing or unpacking an individual file.
StartArchive | Status message before beginning the packing or unpacking an archive.
PartialArchive | Status message (possibly reported multiple times) during the process of packing or unpacking an archiv.
FinishArchive | Status message after completion of the packing or unpacking of an archive.
Remarks

PACKING EXAMPLE: The following sequence of events might be received when extracting a simple archive file with 2 files.

Message Type | Description
StartArchive | Begin extracting archive
StartFile | Begin extracting first file
PartialFile | Extracting first file
PartialFile | Extracting first file
FinishFile | Finished extracting first file
StartFile | Begin extracting second file
PartialFile | Extracting second file
FinishFile | Finished extracting second file
FinishArchive | Finished extracting archive

UNPACKING EXAMPLE: Packing 3 files into 2 archive chunks, where the second file is continued to the second archive chunk.

Message Type | Description
StartFile | Begin compressing first file
FinishFile | Finished compressing first file
StartFile | Begin compressing second file
PartialFile | Compressing second file
PartialFile | Compressing second file
FinishFile | Finished compressing second file
StartArchive | Begin writing first archive
PartialArchive | Writing first archive
FinishArchive | Finished writing first archive
StartFile | Begin compressing third file
PartialFile | Compressing third file
FinishFile | Finished compressing third file
StartArchive | Begin writing second archive
PartialArchive | Writing second archive
FinishArchive | Finished writing second archive

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


BasicUnpackStreamContext Class

BasicUnpackStreamContext Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► BasicUnpackStreamContext
Stream context used to extract a single file from an archive into a memory stream.
Declaration Syntax
C# Visual Basic Visual C++
public class BasicUnpackStreamContext : IUnpackStreamContext
Public Class BasicUnpackStreamContext _
    Implements IUnpackStreamContext
public ref class BasicUnpackStreamContext : IUnpackStreamContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BasicUnpackStreamContext(Stream) | Creates a new BasicExtractStreamContext that reads from the specified archive stream.
 | CloseArchiveReadStream(Int32, String, Stream) | Does *not* close the stream. The archive stream should be managed by the code that invokes the archive extraction.
 | CloseFileWriteStream(String, Stream, FileAttributes, DateTime) | Does *not* close the file stream. The file stream is saved in memory so it can be read later.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileStream | Gets the stream for the extracted file, or null if no file was extracted.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OpenArchiveReadStream(Int32, String, CompressionEngine) | Opens the archive stream for reading. Returns a DuplicateStream instance, so the stream may be virtually opened multiple times.
 | OpenFileWriteStream(String, Int64, DateTime) | Opens a stream for writing extracted file bytes. The returned stream is a MemoryStream instance, so the file is extracted straight into memory.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BasicUnpackStreamContext

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


BasicUnpackStreamContext Constructor (archiveStream)

BasicUnpackStreamContext Constructor (archiveStream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► BasicUnpackStreamContext ► BasicUnpackStreamContext(Stream)
Creates a new BasicExtractStreamContext that reads from the specified archive stream.
Declaration Syntax
C# Visual Basic Visual C++
public BasicUnpackStreamContext(
    Stream archiveStream
)
Public Sub New ( _
    archiveStream As Stream _
)
public:
BasicUnpackStreamContext(
    Stream^ archiveStream
)
Parameters
archiveStream (Stream)
Archive stream to read from.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CloseArchiveReadStream Method (archiveNumber, archiveName, stream)

CloseArchiveReadStream Method (archiveNumber, archiveName, stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► BasicUnpackStreamContext ► CloseArchiveReadStream(Int32, String, Stream)
Does *not* close the stream. The archive stream should be managed by the code that invokes the archive extraction.
Declaration Syntax
C# Visual Basic Visual C++
public void CloseArchiveReadStream(
    int archiveNumber,
    string archiveName,
    Stream stream
)
Public Sub CloseArchiveReadStream ( _
    archiveNumber As Integer, _
    archiveName As String, _
    stream As Stream _
)
public:
virtual void CloseArchiveReadStream(
    int archiveNumber,
    String^ archiveName,
    Stream^ stream
) sealed
Parameters
archiveNumber (Int32)
The archive number of the stream to close.
archiveName (String)
The name of the archive being closed.
stream (Stream)
The stream being closed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CloseFileWriteStream Method (path, stream, attributes, lastWriteTime)

CloseFileWriteStream Method (path, stream, attributes, lastWriteTime)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► BasicUnpackStreamContext ► CloseFileWriteStream(String, Stream, FileAttributes, DateTime)
Does *not* close the file stream. The file stream is saved in memory so it can be read later.
Declaration Syntax
C# Visual Basic Visual C++
public void CloseFileWriteStream(
    string path,
    Stream stream,
    FileAttributes attributes,
    DateTime lastWriteTime
)
Public Sub CloseFileWriteStream ( _
    path As String, _
    stream As Stream, _
    attributes As FileAttributes, _
    lastWriteTime As DateTime _
)
public:
virtual void CloseFileWriteStream(
    String^ path,
    Stream^ stream,
    FileAttributes attributes,
    DateTime lastWriteTime
) sealed
Parameters
path (String)
Path of the file within the archive.
stream (Stream)
The file stream to be closed.
attributes (FileAttributes)
The attributes of the extracted file.
lastWriteTime (DateTime)
The last write time of the file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


FileStream Property

FileStream Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► BasicUnpackStreamContext ► FileStream
Gets the stream for the extracted file, or null if no file was extracted.
Declaration Syntax
C# Visual Basic Visual C++
public Stream FileStream { get; }
Public ReadOnly Property FileStream As Stream
public:
property Stream^ FileStream {
    Stream^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenArchiveReadStream Method (archiveNumber, archiveName, compressionEngine)

OpenArchiveReadStream Method (archiveNumber, archiveName, compressionEngine)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► BasicUnpackStreamContext ► OpenArchiveReadStream(Int32, String, CompressionEngine)
Opens the archive stream for reading. Returns a DuplicateStream instance, so the stream may be virtually opened multiple times.
Declaration Syntax
C# Visual Basic Visual C++
public Stream OpenArchiveReadStream(
    int archiveNumber,
    string archiveName,
    CompressionEngine compressionEngine
)
Public Function OpenArchiveReadStream ( _
    archiveNumber As Integer, _
    archiveName As String, _
    compressionEngine As CompressionEngine _
) As Stream
public:
virtual Stream^ OpenArchiveReadStream(
    int archiveNumber,
    String^ archiveName,
    CompressionEngine^ compressionEngine
) sealed
Parameters
archiveNumber (Int32)
The archive number to open (ignored; 0 is assumed).
archiveName (String)
The name of the archive being opened.
compressionEngine (CompressionEngine)
Instance of the compression engine doing the operations.
Return Value
A stream from which archive bytes are read.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenFileWriteStream Method (path, fileSize, lastWriteTime)

OpenFileWriteStream Method (path, fileSize, lastWriteTime)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► BasicUnpackStreamContext ► OpenFileWriteStream(String, Int64, DateTime)
Opens a stream for writing extracted file bytes. The returned stream is a MemoryStream instance, so the file is extracted straight into memory.
Declaration Syntax
C# Visual Basic Visual C++
public Stream OpenFileWriteStream(
    string path,
    long fileSize,
    DateTime lastWriteTime
)
Public Function OpenFileWriteStream ( _
    path As String, _
    fileSize As Long, _
    lastWriteTime As DateTime _
) As Stream
public:
virtual Stream^ OpenFileWriteStream(
    String^ path,
    long long fileSize,
    DateTime lastWriteTime
) sealed
Parameters
path (String)
Path of the file within the archive.
fileSize (Int64)
The uncompressed size of the file to be extracted.
lastWriteTime (DateTime)
The last write time of the file.
Return Value
A stream where extracted file bytes are to be written.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CargoStream Class

CargoStream Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream
Wraps a source stream and carries additional items that are disposed when the stream is closed.
Declaration Syntax
C# Visual Basic Visual C++
public class CargoStream : Stream
Public Class CargoStream _
    Inherits Stream
public ref class CargoStream : public Stream
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CargoStream(Stream, array<IDisposable>[]()[]) | Creates a new a cargo stream.
 | BeginRead(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead | Gets a value indicating whether the source stream supports reading. (Overrides Stream.CanRead.)
 | CanSeek | Gets a value indicating whether the source stream supports seeking. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Gets a value indicating whether the source stream supports writing. (Overrides Stream.CanWrite.)
 | Cargo | Gets the list of additional items that are disposed when the stream is closed. The order of the list is the order in which the items are disposed. The contents can be modified any time.
 | Close()()() | Closes the source stream and also closes the additional objects that are carried. (Overrides Stream.Close()()().)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()() | Flushes the source stream. (Overrides Stream.Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | Gets the length of the source stream. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Gets or sets the position of the source stream. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[], Int32, Int32) | Reads from the source stream. (Overrides Stream.Read(array<Byte>[]()[], Int32, Int32).)
 | ReadByte()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Changes the position of the source stream. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Sets the length of the source stream. (Overrides Stream.SetLength(Int64).)
 | Source | Gets the source stream of the cargo stream.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Write(array<Byte>[]()[], Int32, Int32) | Writes to the source stream. (Overrides Stream.Write(array<Byte>[]()[], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | CargoStream

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CargoStream Constructor (source, cargo)

CargoStream Constructor (source, cargo)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► CargoStream(Stream, array<IDisposable>[]()[])
Creates a new a cargo stream.
Declaration Syntax
C# Visual Basic Visual C++
public CargoStream(
    Stream source,
    params IDisposable[] cargo
)
Public Sub New ( _
    source As Stream, _
    ParamArray cargo As IDisposable() _
)
public:
CargoStream(
    Stream^ source,
    ... array<IDisposable^>^ cargo
)
Parameters
source (Stream)
source of the stream
cargo (array< IDisposable >[]()[])
List of additional items that are disposed when the stream is closed. The order of the list is the order in which the items are disposed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CanRead Property

CanRead Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► CanRead
Gets a value indicating whether the source stream supports reading.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
public:
virtual property bool CanRead {
    bool get () override;
}
Value
true if the stream supports reading; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CanSeek Property

CanSeek Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► CanSeek
Gets a value indicating whether the source stream supports seeking.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
public:
virtual property bool CanSeek {
    bool get () override;
}
Value
true if the stream supports seeking; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CanWrite Property

CanWrite Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► CanWrite
Gets a value indicating whether the source stream supports writing.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
public:
virtual property bool CanWrite {
    bool get () override;
}
Value
true if the stream supports writing; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Cargo Property

Cargo Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► Cargo
Gets the list of additional items that are disposed when the stream is closed. The order of the list is the order in which the items are disposed. The contents can be modified any time.
Declaration Syntax
C# Visual Basic Visual C++
public IList<IDisposable> Cargo { get; }
Public ReadOnly Property Cargo As IList(Of IDisposable)
public:
property IList<IDisposable^>^ Cargo {
    IList<IDisposable^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Close Method

Close Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► Close()()()
Closes the source stream and also closes the additional objects that are carried.
Declaration Syntax
C# Visual Basic Visual C++
public override void Close()
Public Overrides Sub Close
public:
virtual void Close() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Flush Method

Flush Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► Flush()()()
Flushes the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Flush()
Public Overrides Sub Flush
public:
virtual void Flush() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Length Property

Length Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► Length
Gets the length of the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
public:
virtual property long long Length {
    long long get () override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Position Property

Position Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► Position
Gets or sets the position of the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override long Position { get; set; }
Public Overrides Property Position As Long
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► Read(array<Byte>[]()[], Int32, Int32)
Reads from the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the source.
offset (Int32)
The zero-based byte offset in buffer at which to begin storing the data read from the stream.
count (Int32)
The maximum number of bytes to be read from the stream.
Return Value
The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Seek Method (offset, origin)

Seek Method (offset, origin)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► Seek(Int64, SeekOrigin)
Changes the position of the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek ( _
    offset As Long, _
    origin As SeekOrigin _
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
Parameters
offset (Int64)
A byte offset relative to the origin parameter.
origin (SeekOrigin)
A value of type SeekOrigin indicating the reference point used to obtain the new position.
Return Value
The new position within the stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


SetLength Method (value)

SetLength Method (value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► SetLength(Int64)
Sets the length of the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void SetLength(
    long value
)
Public Overrides Sub SetLength ( _
    value As Long _
)
public:
virtual void SetLength(
    long long value
) override
Parameters
value (Int64)
The desired length of the stream in bytes.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Source Property

Source Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► Source
Gets the source stream of the cargo stream.
Declaration Syntax
C# Visual Basic Visual C++
public Stream Source { get; }
Public ReadOnly Property Source As Stream
public:
property Stream^ Source {
    Stream^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► Write(array<Byte>[]()[], Int32, Int32)
Writes to the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
An array of bytes. This method copies count bytes from buffer to the stream.
offset (Int32)
The zero-based byte offset in buffer at which to begin copying bytes to the stream.
count (Int32)
The number of bytes to be written to the stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CompressionEngine Class

CompressionEngine Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine
Base class for an engine capable of packing and unpacking a particular compressed file format.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class CompressionEngine : IDisposable
Public MustInherit Class CompressionEngine _
    Implements IDisposable
public ref class CompressionEngine abstract : IDisposable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompressionEngine()()() | Creates a new instance of the compression engine base class.
 | CompressionLevel | Compression level to use when compressing files.
 | DateTimeToDosDateAndTime(DateTime, Int16%, Int16%) | Compresion utility function for converting a DateTime structure to old-style date and time values.
 | Dispose()()() | Disposes of resources allocated by the compression engine.
 | Dispose(Boolean) | Disposes of resources allocated by the compression engine.
 | DosDateAndTimeToDateTime(Int16, Int16, DateTime%) | Compresion utility function for converting old-style date and time values to a DateTime structure.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Disposes the compression engine. (Overrides Object.Finalize()()().)
 | FindArchiveOffset(Stream) | Gets the offset of an archive that is positioned 0 or more bytes from the start of the Stream.
 | GetFileInfo(Stream) | Gets information about all files in an archive stream.
 | GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Gets information about files in an archive or archive chain.
 | GetFiles(Stream) | Gets the list of files in an archive Stream.
 | GetFiles(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Gets the list of files in an archive or archive chain.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsArchive(Stream) | Checks whether a Stream begins with a header that indicates it is a valid archive.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnProgress(ArchiveProgressEventArgs) | Called by sublcasses to distribute a packing or unpacking progress event to listeners.
 | Pack(IPackStreamContext, IEnumerable<(Of <(String>)>)) | Creates an archive.
 | Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64) | Creates an archive or chain of archives.
 | Progress | Occurs when the compression engine reports progress in packing or unpacking an archive.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unpack(Stream, String) | Reads a single file from an archive stream.
 | Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Extracts files from an archive or archive chain.
 | UseTempFiles | Gets or sets a flag indicating whether temporary files are created and used during compression.
Inheritance Hierarchy
Object
 | CompressionEngine
 |  | CabEngine
 |  | ZipEngine

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CompressionEngine Constructor

CompressionEngine Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► CompressionEngine()()()
Creates a new instance of the compression engine base class.
Declaration Syntax
C# Visual Basic Visual C++
protected CompressionEngine()
Protected Sub New
protected:
CompressionEngine()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CompressionLevel Property

CompressionLevel Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► CompressionLevel
Compression level to use when compressing files.
Declaration Syntax
C# Visual Basic Visual C++
public CompressionLevel CompressionLevel { get; set; }
Public Property CompressionLevel As CompressionLevel
public:
property CompressionLevel CompressionLevel {
    CompressionLevel get ();
    void set (CompressionLevel value);
}
Value
A compression level ranging from minimum to maximum compression, or no compression.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


DateTimeToDosDateAndTime Method (dateTime, dosDate, dosTime)

DateTimeToDosDateAndTime Method (dateTime, dosDate, dosTime)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► DateTimeToDosDateAndTime(DateTime, Int16%, Int16%)
Compresion utility function for converting a DateTime structure to old-style date and time values.
Declaration Syntax
C# Visual Basic Visual C++
public static void DateTimeToDosDateAndTime(
    DateTime dateTime,
    out short dosDate,
    out short dosTime
)
Public Shared Sub DateTimeToDosDateAndTime ( _
    dateTime As DateTime, _
    <OutAttribute> ByRef dosDate As Short, _
    <OutAttribute> ByRef dosTime As Short _
)
public:
static void DateTimeToDosDateAndTime(
    DateTime dateTime,
    [OutAttribute] short% dosDate,
    [OutAttribute] short% dosTime
)
Parameters
dateTime (DateTime)
dosDate ( Int16 %)
dosTime ( Int16 %)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Disposes of resources allocated by the compression engine.
 | Dispose(Boolean) | Disposes of resources allocated by the compression engine.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► Dispose()()()
Disposes of resources allocated by the compression engine.
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method (disposing)

Dispose Method (disposing)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► Dispose(Boolean)
Disposes of resources allocated by the compression engine.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
)
Parameters
disposing (Boolean)
If true, the method has been called directly or indirectly by a user's code, so managed and unmanaged resources will be disposed. If false, the method has been called by the runtime from inside the finalizer, and only unmanaged resources will be disposed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


DosDateAndTimeToDateTime Method (dosDate, dosTime, dateTime)

DosDateAndTimeToDateTime Method (dosDate, dosTime, dateTime)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► DosDateAndTimeToDateTime(Int16, Int16, DateTime%)
Compresion utility function for converting old-style date and time values to a DateTime structure.
Declaration Syntax
C# Visual Basic Visual C++
public static void DosDateAndTimeToDateTime(
    short dosDate,
    short dosTime,
    out DateTime dateTime
)
Public Shared Sub DosDateAndTimeToDateTime ( _
    dosDate As Short, _
    dosTime As Short, _
    <OutAttribute> ByRef dateTime As DateTime _
)
public:
static void DosDateAndTimeToDateTime(
    short dosDate,
    short dosTime,
    [OutAttribute] DateTime% dateTime
)
Parameters
dosDate (Int16)
dosTime (Int16)
dateTime ( DateTime %)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Finalize Method

Finalize Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► Finalize()()()
Disposes the compression engine.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


FindArchiveOffset Method (stream)

FindArchiveOffset Method (stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► FindArchiveOffset(Stream)
Gets the offset of an archive that is positioned 0 or more bytes from the start of the Stream.
Declaration Syntax
C# Visual Basic Visual C++
public virtual long FindArchiveOffset(
    Stream stream
)
Public Overridable Function FindArchiveOffset ( _
    stream As Stream _
) As Long
public:
virtual long long FindArchiveOffset(
    Stream^ stream
)
Parameters
stream (Stream)
A stream for reading the archive.
Return Value
The offset in bytes of the archive, or -1 if no archive is found in the Stream.
Remarks
The archive must begin on a 4-byte boundary.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetFileInfo Method

GetFileInfo Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► GetFileInfo()()()
Members
Icon | Member | Description
 | GetFileInfo(Stream) | Gets information about all files in an archive stream.
 | GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Gets information about files in an archive or archive chain.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetFileInfo Method (streamContext, fileFilter)

GetFileInfo Method (streamContext, fileFilter)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>))
Gets information about files in an archive or archive chain.
Declaration Syntax
C# Visual Basic Visual C++
public abstract IList<ArchiveFileInfo> GetFileInfo(
    IUnpackStreamContext streamContext,
    Predicate<string> fileFilter
)
Public MustOverride Function GetFileInfo ( _
    streamContext As IUnpackStreamContext, _
    fileFilter As Predicate(Of String) _
) As IList(Of ArchiveFileInfo)
public:
virtual IList<ArchiveFileInfo^>^ GetFileInfo(
    IUnpackStreamContext^ streamContext,
    Predicate<String^>^ fileFilter
) abstract
Parameters
streamContext (IUnpackStreamContext)
A context interface to handle opening and closing of archive and file streams.
fileFilter (Predicate <(Of <( String >)>))
A predicate that can determine which files to process, optional.
Return Value
Information about files in the archive stream.
Remarks
The fileFilter predicate takes an internal file path and returns true to include the file or false to exclude it.
Exceptions
Exception | Condition
ArchiveException | The archive provided by the stream context is not valid.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetFileInfo Method (stream)

GetFileInfo Method (stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► GetFileInfo(Stream)
Gets information about all files in an archive stream.
Declaration Syntax
C# Visual Basic Visual C++
public IList<ArchiveFileInfo> GetFileInfo(
    Stream stream
)
Public Function GetFileInfo ( _
    stream As Stream _
) As IList(Of ArchiveFileInfo)
public:
IList<ArchiveFileInfo^>^ GetFileInfo(
    Stream^ stream
)
Parameters
stream (Stream)
A stream for reading the archive.
Return Value
Information about all files in the archive stream.
Exceptions
Exception | Condition
ArchiveException | The stream is not a valid archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method

GetFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► GetFiles()()()
Members
Icon | Member | Description
 | GetFiles(Stream) | Gets the list of files in an archive Stream.
 | GetFiles(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Gets the list of files in an archive or archive chain.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method (streamContext, fileFilter)

GetFiles Method (streamContext, fileFilter)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► GetFiles(IUnpackStreamContext, Predicate<(Of <(String>)>))
Gets the list of files in an archive or archive chain.
Declaration Syntax
C# Visual Basic Visual C++
public IList<string> GetFiles(
    IUnpackStreamContext streamContext,
    Predicate<string> fileFilter
)
Public Function GetFiles ( _
    streamContext As IUnpackStreamContext, _
    fileFilter As Predicate(Of String) _
) As IList(Of String)
public:
IList<String^>^ GetFiles(
    IUnpackStreamContext^ streamContext,
    Predicate<String^>^ fileFilter
)
Parameters
streamContext (IUnpackStreamContext)
A context interface to handle opening and closing of archive and file streams.
fileFilter (Predicate <(Of <( String >)>))
A predicate that can determine which files to process, optional.
Return Value
An array containing the names of all files contained in the archive or archive chain.
Remarks
The fileFilter predicate takes an internal file path and returns true to include the file or false to exclude it.
Exceptions
Exception | Condition
ArchiveException | The archive provided by the stream context is not valid.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method (stream)

GetFiles Method (stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► GetFiles(Stream)
Gets the list of files in an archive Stream.
Declaration Syntax
C# Visual Basic Visual C++
public IList<string> GetFiles(
    Stream stream
)
Public Function GetFiles ( _
    stream As Stream _
) As IList(Of String)
public:
IList<String^>^ GetFiles(
    Stream^ stream
)
Parameters
stream (Stream)
A stream for reading the archive.
Return Value
A list of the paths of all files contained in the archive.
Exceptions
Exception | Condition
ArchiveException | The stream is not a valid archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


IsArchive Method (stream)

IsArchive Method (stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► IsArchive(Stream)
Checks whether a Stream begins with a header that indicates it is a valid archive.
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool IsArchive(
    Stream stream
)
Public MustOverride Function IsArchive ( _
    stream As Stream _
) As Boolean
public:
virtual bool IsArchive(
    Stream^ stream
) abstract
Parameters
stream (Stream)
Stream for reading the archive file.
Return Value
True if the stream is a valid archive (with no offset); false otherwise.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OnProgress Method (e)

OnProgress Method (e)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► OnProgress(ArchiveProgressEventArgs)
Called by sublcasses to distribute a packing or unpacking progress event to listeners.
Declaration Syntax
C# Visual Basic Visual C++
protected void OnProgress(
    ArchiveProgressEventArgs e
)
Protected Sub OnProgress ( _
    e As ArchiveProgressEventArgs _
)
protected:
void OnProgress(
    ArchiveProgressEventArgs^ e
)
Parameters
e (ArchiveProgressEventArgs)
Event details.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Pack Method

Pack Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► Pack()()()
Members
Icon | Member | Description
 | Pack(IPackStreamContext, IEnumerable<(Of <(String>)>)) | Creates an archive.
 | Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64) | Creates an archive or chain of archives.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Pack Method (streamContext, files)

Pack Method (streamContext, files)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► Pack(IPackStreamContext, IEnumerable<(Of <(String>)>))
Creates an archive.
Declaration Syntax
C# Visual Basic Visual C++
public void Pack(
    IPackStreamContext streamContext,
    IEnumerable<string> files
)
Public Sub Pack ( _
    streamContext As IPackStreamContext, _
    files As IEnumerable(Of String) _
)
public:
void Pack(
    IPackStreamContext^ streamContext,
    IEnumerable<String^>^ files
)
Parameters
streamContext (IPackStreamContext)
A context interface to handle opening and closing of archive and file streams.
files (IEnumerable <(Of <( String >)>))
The paths of the files in the archive (not external file paths).
Remarks
The stream context implementation may provide a mapping from the file paths within the archive to the external file paths.
Exceptions
Exception | Condition
ArchiveException | The archive could not be created.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Pack Method (streamContext, files, maxArchiveSize)

Pack Method (streamContext, files, maxArchiveSize)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64)
Creates an archive or chain of archives.
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Pack(
    IPackStreamContext streamContext,
    IEnumerable<string> files,
    long maxArchiveSize
)
Public MustOverride Sub Pack ( _
    streamContext As IPackStreamContext, _
    files As IEnumerable(Of String), _
    maxArchiveSize As Long _
)
public:
virtual void Pack(
    IPackStreamContext^ streamContext,
    IEnumerable<String^>^ files,
    long long maxArchiveSize
) abstract
Parameters
streamContext (IPackStreamContext)
A context interface to handle opening and closing of archive and file streams.
files (IEnumerable <(Of <( String >)>))
The paths of the files in the archive (not external file paths).
maxArchiveSize (Int64)
The maximum number of bytes for one archive before the contents are chained to the next archive, or zero for unlimited archive size.
Remarks
The stream context implementation may provide a mapping from the file paths within the archive to the external file paths.
Exceptions
Exception | Condition
ArchiveException | The archive could not be created.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Progress Event

Progress Event
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► Progress
Occurs when the compression engine reports progress in packing or unpacking an archive.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<ArchiveProgressEventArgs> Progress
Public Event Progress As EventHandler(Of ArchiveProgressEventArgs)
public:
 event EventHandler<ArchiveProgressEventArgs^>^ Progress {
    void add (EventHandler<ArchiveProgressEventArgs^>^ value);
    void remove (EventHandler<ArchiveProgressEventArgs^>^ value);
}
See Also
ArchiveProgressType

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Unpack Method

Unpack Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► Unpack()()()
Members
Icon | Member | Description
 | Unpack(Stream, String) | Reads a single file from an archive stream.
 | Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Extracts files from an archive or archive chain.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Unpack Method (streamContext, fileFilter)

Unpack Method (streamContext, fileFilter)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>))
Extracts files from an archive or archive chain.
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Unpack(
    IUnpackStreamContext streamContext,
    Predicate<string> fileFilter
)
Public MustOverride Sub Unpack ( _
    streamContext As IUnpackStreamContext, _
    fileFilter As Predicate(Of String) _
)
public:
virtual void Unpack(
    IUnpackStreamContext^ streamContext,
    Predicate<String^>^ fileFilter
) abstract
Parameters
streamContext (IUnpackStreamContext)
A context interface to handle opening and closing of archive and file streams.
fileFilter (Predicate <(Of <( String >)>))
An optional predicate that can determine which files to process.
Remarks
The fileFilter predicate takes an internal file path and returns true to include the file or false to exclude it.
Exceptions
Exception | Condition
ArchiveException | The archive provided by the stream context is not valid.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Unpack Method (stream, path)

Unpack Method (stream, path)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► Unpack(Stream, String)
Reads a single file from an archive stream.
Declaration Syntax
C# Visual Basic Visual C++
public Stream Unpack(
    Stream stream,
    string path
)
Public Function Unpack ( _
    stream As Stream, _
    path As String _
) As Stream
public:
Stream^ Unpack(
    Stream^ stream,
    String^ path
)
Parameters
stream (Stream)
A stream for reading the archive.
path (String)
The path of the file within the archive (not the external file path).
Return Value
A stream for reading the extracted file, or null if the file does not exist in the archive.
Remarks
The entire extracted file is cached in memory, so this method requires enough free memory to hold the file.
Exceptions
Exception | Condition
ArchiveException | The stream is not a valid archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


UseTempFiles Property

UseTempFiles Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionEngine ► UseTempFiles
Gets or sets a flag indicating whether temporary files are created and used during compression.
Declaration Syntax
C# Visual Basic Visual C++
public bool UseTempFiles { get; set; }
Public Property UseTempFiles As Boolean
public:
property bool UseTempFiles {
    bool get ();
    void set (bool value);
}
Value
True if temporary files are used; false if compression is done entirely in-memory.
Remarks
The value of this property is true by default. Using temporary files can greatly reduce the memory requirement of compression, especially when compressing large archives. However, setting this property to false may yield slightly better performance when creating small archives. Or it may be necessary if the process does not have sufficient privileges to create temporary files.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CompressionLevel Enumeration

CompressionLevel Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CompressionLevel
Specifies the compression level ranging from minimum compresion to maximum compression, or no compression at all.
Declaration Syntax
C# Visual Basic Visual C++
public enum CompressionLevel
Public Enumeration CompressionLevel
public enum class CompressionLevel
Members
Member | Description
None | Do not compress files, only store.
Min | Minimum compression; fastest.
Normal | A compromize between speed and compression efficiency.
Max | Maximum compression; slowest.
Remarks
Although only four values are enumerated, any integral value between Min and Max can also be used.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


DuplicateStream Class

DuplicateStream Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream
Duplicates a source stream by maintaining a separate position.
Declaration Syntax
C# Visual Basic Visual C++
public class DuplicateStream : Stream
Public Class DuplicateStream _
    Inherits Stream
public ref class DuplicateStream : public Stream
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DuplicateStream(Stream) | Creates a new duplicate of a stream.
 | BeginRead(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead | Gets a value indicating whether the source stream supports reading. (Overrides Stream.CanRead.)
 | CanSeek | Gets a value indicating whether the source stream supports seeking. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Gets a value indicating whether the source stream supports writing. (Overrides Stream.CanWrite.)
 | Close()()() | Closes the underlying stream, effectively closing ALL duplicates. (Overrides Stream.Close()()().)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()() | Flushes the source stream. (Overrides Stream.Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | Gets the length of the source stream. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OriginalStream(Stream) | Retrieves the original stream from a possible duplicate stream.
 | Position | Gets or sets the position of the current stream, ignoring the position of the source stream. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[], Int32, Int32) | Reads from the source stream while maintaining a separate position and not impacting the source stream's position. (Overrides Stream.Read(array<Byte>[]()[], Int32, Int32).)
 | ReadByte()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Changes the position of this stream without impacting the source stream's position. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Sets the length of the source stream. (Overrides Stream.SetLength(Int64).)
 | Source | Gets the original stream that was used to create the duplicate.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Write(array<Byte>[]()[], Int32, Int32) | Writes to the source stream while maintaining a separate position and not impacting the source stream's position. (Overrides Stream.Write(array<Byte>[]()[], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks
WARNING: duplicate streams are not thread-safe with respect to each other or the original stream. If multiple threads use duplicate copies of the same stream, they must synchronize for any operations.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | DuplicateStream

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


DuplicateStream Constructor (source)

DuplicateStream Constructor (source)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► DuplicateStream(Stream)
Creates a new duplicate of a stream.
Declaration Syntax
C# Visual Basic Visual C++
public DuplicateStream(
    Stream source
)
Public Sub New ( _
    source As Stream _
)
public:
DuplicateStream(
    Stream^ source
)
Parameters
source (Stream)
source of the duplicate

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CanRead Property

CanRead Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► CanRead
Gets a value indicating whether the source stream supports reading.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
public:
virtual property bool CanRead {
    bool get () override;
}
Value
true if the stream supports reading; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CanSeek Property

CanSeek Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► CanSeek
Gets a value indicating whether the source stream supports seeking.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
public:
virtual property bool CanSeek {
    bool get () override;
}
Value
true if the stream supports seeking; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CanWrite Property

CanWrite Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► CanWrite
Gets a value indicating whether the source stream supports writing.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
public:
virtual property bool CanWrite {
    bool get () override;
}
Value
true if the stream supports writing; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Close Method

Close Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► Close()()()
Closes the underlying stream, effectively closing ALL duplicates.
Declaration Syntax
C# Visual Basic Visual C++
public override void Close()
Public Overrides Sub Close
public:
virtual void Close() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Flush Method

Flush Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► Flush()()()
Flushes the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Flush()
Public Overrides Sub Flush
public:
virtual void Flush() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Length Property

Length Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► Length
Gets the length of the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
public:
virtual property long long Length {
    long long get () override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OriginalStream Method (stream)

OriginalStream Method (stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► OriginalStream(Stream)
Retrieves the original stream from a possible duplicate stream.
Declaration Syntax
C# Visual Basic Visual C++
public static Stream OriginalStream(
    Stream stream
)
Public Shared Function OriginalStream ( _
    stream As Stream _
) As Stream
public:
static Stream^ OriginalStream(
    Stream^ stream
)
Parameters
stream (Stream)
Possible duplicate stream.
Return Value
If the stream is a DuplicateStream, returns the duplicate's source; otherwise returns the same stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Position Property

Position Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► Position
Gets or sets the position of the current stream, ignoring the position of the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override long Position { get; set; }
Public Overrides Property Position As Long
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► Read(array<Byte>[]()[], Int32, Int32)
Reads from the source stream while maintaining a separate position and not impacting the source stream's position.
Declaration Syntax
C# Visual Basic Visual C++
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset (Int32)
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count (Int32)
The maximum number of bytes to be read from the current stream.
Return Value
The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Seek Method (offset, origin)

Seek Method (offset, origin)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► Seek(Int64, SeekOrigin)
Changes the position of this stream without impacting the source stream's position.
Declaration Syntax
C# Visual Basic Visual C++
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek ( _
    offset As Long, _
    origin As SeekOrigin _
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
Parameters
offset (Int64)
A byte offset relative to the origin parameter.
origin (SeekOrigin)
A value of type SeekOrigin indicating the reference point used to obtain the new position.
Return Value
The new position within the current stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


SetLength Method (value)

SetLength Method (value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► SetLength(Int64)
Sets the length of the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void SetLength(
    long value
)
Public Overrides Sub SetLength ( _
    value As Long _
)
public:
virtual void SetLength(
    long long value
) override
Parameters
value (Int64)
The desired length of the stream in bytes.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Source Property

Source Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► Source
Gets the original stream that was used to create the duplicate.
Declaration Syntax
C# Visual Basic Visual C++
public Stream Source { get; }
Public ReadOnly Property Source As Stream
public:
property Stream^ Source {
    Stream^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► Write(array<Byte>[]()[], Int32, Int32)
Writes to the source stream while maintaining a separate position and not impacting the source stream's position.
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
An array of bytes. This method copies count bytes from buffer to the current stream.
offset (Int32)
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count (Int32)
The number of bytes to be written to the current stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


IPackStreamContext Interface

IPackStreamContext Interface
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► IPackStreamContext
This interface provides the methods necessary for the CompressionEngine to open and close streams for archives and files. The implementor of this interface can use any kind of logic to determine what kind of streams to open and where.
Declaration Syntax
C# Visual Basic Visual C++
public interface IPackStreamContext
Public Interface IPackStreamContext
public interface class IPackStreamContext
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CloseArchiveWriteStream(Int32, String, Stream) | Closes a stream where an archive package was written.
 | CloseFileReadStream(String, Stream) | Closes a stream that has been used to read a file.
 | GetArchiveName(Int32) | Gets the name of the archive with a specified number.
 | GetOption(String, array<Object>[]()[]) | Gets extended parameter information specific to the compression format being used.
 | OpenArchiveWriteStream(Int32, String, Boolean, CompressionEngine) | Opens a stream for writing an archive package.
 | OpenFileReadStream(String, FileAttributes%, DateTime%) | Opens a stream to read a file that is to be included in an archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CloseArchiveWriteStream Method (archiveNumber, archiveName, stream)

CloseArchiveWriteStream Method (archiveNumber, archiveName, stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► IPackStreamContext ► CloseArchiveWriteStream(Int32, String, Stream)
Closes a stream where an archive package was written.
Declaration Syntax
C# Visual Basic Visual C++
void CloseArchiveWriteStream(
    int archiveNumber,
    string archiveName,
    Stream stream
)
Sub CloseArchiveWriteStream ( _
    archiveNumber As Integer, _
    archiveName As String, _
    stream As Stream _
)
void CloseArchiveWriteStream(
    int archiveNumber,
    String^ archiveName,
    Stream^ stream
)
Parameters
archiveNumber (Int32)
The 0-based index of the archive within the chain.
archiveName (String)
The name of the archive that was previously returned by GetArchiveName(Int32).
stream (Stream)
A stream that was previously returned by OpenArchiveWriteStream(Int32, String, Boolean, CompressionEngine) and is now ready to be closed.
Remarks
If there is another archive package in the chain, then after this stream is closed a new stream will be opened.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CloseFileReadStream Method (path, stream)

CloseFileReadStream Method (path, stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► IPackStreamContext ► CloseFileReadStream(String, Stream)
Closes a stream that has been used to read a file.
Declaration Syntax
C# Visual Basic Visual C++
void CloseFileReadStream(
    string path,
    Stream stream
)
Sub CloseFileReadStream ( _
    path As String, _
    stream As Stream _
)
void CloseFileReadStream(
    String^ path,
    Stream^ stream
)
Parameters
path (String)
The path of the file within the archive; the same as the path provided when the stream was opened.
stream (Stream)
A stream that was previously returned by OpenFileReadStream(String, FileAttributes%, DateTime%) and is now ready to be closed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetArchiveName Method (archiveNumber)

GetArchiveName Method (archiveNumber)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► IPackStreamContext ► GetArchiveName(Int32)
Gets the name of the archive with a specified number.
Declaration Syntax
C# Visual Basic Visual C++
string GetArchiveName(
    int archiveNumber
)
Function GetArchiveName ( _
    archiveNumber As Integer _
) As String
String^ GetArchiveName(
    int archiveNumber
)
Parameters
archiveNumber (Int32)
The 0-based index of the archive within the chain.
Return Value
The name of the requested archive. May be an empty string for non-chained archives, but may never be null.
Remarks
The archive name is the name stored within the archive, used for identification of the archive especially among archive chains. That name is often, but not necessarily the same as the filename of the archive package.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


GetOption Method (optionName, parameters)

GetOption Method (optionName, parameters)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► IPackStreamContext ► GetOption(String, array<Object>[]()[])
Gets extended parameter information specific to the compression format being used.
Declaration Syntax
C# Visual Basic Visual C++
Object GetOption(
    string optionName,
    Object[] parameters
)
Function GetOption ( _
    optionName As String, _
    parameters As Object() _
) As Object
Object^ GetOption(
    String^ optionName,
    array<Object^>^ parameters
)
Parameters
optionName (String)
Name of the option being requested.
parameters (array< Object >[]()[])
Parameters for the option; for per-file options, the first parameter is typically the internal file path.
Return Value
Option value, or null to use the default behavior.
Remarks
This method provides a way to set uncommon options during packaging, or a way to handle aspects of compression formats not supported by the base library.

For example, this may be used by the zip compression library to specify different compression methods/levels on a per-file basis.

The available option names, parameters, and expected return values should be documented by each compression library.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenArchiveWriteStream Method (archiveNumber, archiveName, truncate, compressionEngine)

OpenArchiveWriteStream Method (archiveNumber, archiveName, truncate, compressionEngine)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► IPackStreamContext ► OpenArchiveWriteStream(Int32, String, Boolean, CompressionEngine)
Opens a stream for writing an archive package.
Declaration Syntax
C# Visual Basic Visual C++
Stream OpenArchiveWriteStream(
    int archiveNumber,
    string archiveName,
    bool truncate,
    CompressionEngine compressionEngine
)
Function OpenArchiveWriteStream ( _
    archiveNumber As Integer, _
    archiveName As String, _
    truncate As Boolean, _
    compressionEngine As CompressionEngine _
) As Stream
Stream^ OpenArchiveWriteStream(
    int archiveNumber,
    String^ archiveName,
    bool truncate,
    CompressionEngine^ compressionEngine
)
Parameters
archiveNumber (Int32)
The 0-based index of the archive within the chain.
archiveName (String)
The name of the archive that was returned by GetArchiveName(Int32).
truncate (Boolean)
True if the stream should be truncated when opened (if it already exists); false if an existing stream is being re-opened for writing additional data.
compressionEngine (CompressionEngine)
Instance of the compression engine doing the operations.
Return Value
A writable Stream where the compressed archive bytes will be written, or null to cancel the archive creation.
Remarks
If this method returns null, the archive engine will throw a FileNotFoundException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenFileReadStream Method (path, attributes, lastWriteTime)

OpenFileReadStream Method (path, attributes, lastWriteTime)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► IPackStreamContext ► OpenFileReadStream(String, FileAttributes%, DateTime%)
Opens a stream to read a file that is to be included in an archive.
Declaration Syntax
C# Visual Basic Visual C++
Stream OpenFileReadStream(
    string path,
    out FileAttributes attributes,
    out DateTime lastWriteTime
)
Function OpenFileReadStream ( _
    path As String, _
    <OutAttribute> ByRef attributes As FileAttributes, _
    <OutAttribute> ByRef lastWriteTime As DateTime _
) As Stream
Stream^ OpenFileReadStream(
    String^ path,
    [OutAttribute] FileAttributes% attributes,
    [OutAttribute] DateTime% lastWriteTime
)
Parameters
path (String)
The path of the file within the archive. This is often, but not necessarily, the same as the relative path of the file outside the archive.
attributes ( FileAttributes %)
Returned attributes of the opened file, to be stored in the archive.
lastWriteTime ( DateTime %)
Returned last-modified time of the opened file, to be stored in the archive.
Return Value
A readable Stream where the file bytes will be read from before they are compressed, or null to skip inclusion of the file and continue to the next file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


IUnpackStreamContext Interface

IUnpackStreamContext Interface
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► IUnpackStreamContext
This interface provides the methods necessary for the CompressionEngine to open and close streams for archives and files. The implementor of this interface can use any kind of logic to determine what kind of streams to open and where
Declaration Syntax
C# Visual Basic Visual C++
public interface IUnpackStreamContext
Public Interface IUnpackStreamContext
public interface class IUnpackStreamContext
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CloseArchiveReadStream(Int32, String, Stream) | Closes a stream where an archive package was read.
 | CloseFileWriteStream(String, Stream, FileAttributes, DateTime) | Closes a stream where an extracted file was written.
 | OpenArchiveReadStream(Int32, String, CompressionEngine) | Opens the archive stream for reading.
 | OpenFileWriteStream(String, Int64, DateTime) | Opens a stream for writing extracted file bytes.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CloseArchiveReadStream Method (archiveNumber, archiveName, stream)

CloseArchiveReadStream Method (archiveNumber, archiveName, stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► IUnpackStreamContext ► CloseArchiveReadStream(Int32, String, Stream)
Closes a stream where an archive package was read.
Declaration Syntax
C# Visual Basic Visual C++
void CloseArchiveReadStream(
    int archiveNumber,
    string archiveName,
    Stream stream
)
Sub CloseArchiveReadStream ( _
    archiveNumber As Integer, _
    archiveName As String, _
    stream As Stream _
)
void CloseArchiveReadStream(
    int archiveNumber,
    String^ archiveName,
    Stream^ stream
)
Parameters
archiveNumber (Int32)
The archive number of the stream to close.
archiveName (String)
The name of the archive being closed.
stream (Stream)
The stream that was previously returned by OpenArchiveReadStream(Int32, String, CompressionEngine) and is now ready to be closed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CloseFileWriteStream Method (path, stream, attributes, lastWriteTime)

CloseFileWriteStream Method (path, stream, attributes, lastWriteTime)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► IUnpackStreamContext ► CloseFileWriteStream(String, Stream, FileAttributes, DateTime)
Closes a stream where an extracted file was written.
Declaration Syntax
C# Visual Basic Visual C++
void CloseFileWriteStream(
    string path,
    Stream stream,
    FileAttributes attributes,
    DateTime lastWriteTime
)
Sub CloseFileWriteStream ( _
    path As String, _
    stream As Stream, _
    attributes As FileAttributes, _
    lastWriteTime As DateTime _
)
void CloseFileWriteStream(
    String^ path,
    Stream^ stream,
    FileAttributes attributes,
    DateTime lastWriteTime
)
Parameters
path (String)
The path of the file within the archive.
stream (Stream)
The stream that was previously returned by OpenFileWriteStream(String, Int64, DateTime) and is now ready to be closed.
attributes (FileAttributes)
The attributes of the extracted file.
lastWriteTime (DateTime)
The last write time of the file.
Remarks
The implementor may wish to apply the attributes and date to the newly-extracted file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenArchiveReadStream Method (archiveNumber, archiveName, compressionEngine)

OpenArchiveReadStream Method (archiveNumber, archiveName, compressionEngine)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► IUnpackStreamContext ► OpenArchiveReadStream(Int32, String, CompressionEngine)
Opens the archive stream for reading.
Declaration Syntax
C# Visual Basic Visual C++
Stream OpenArchiveReadStream(
    int archiveNumber,
    string archiveName,
    CompressionEngine compressionEngine
)
Function OpenArchiveReadStream ( _
    archiveNumber As Integer, _
    archiveName As String, _
    compressionEngine As CompressionEngine _
) As Stream
Stream^ OpenArchiveReadStream(
    int archiveNumber,
    String^ archiveName,
    CompressionEngine^ compressionEngine
)
Parameters
archiveNumber (Int32)
The zero-based index of the archive to open.
archiveName (String)
The name of the archive being opened.
compressionEngine (CompressionEngine)
Instance of the compression engine doing the operations.
Return Value
A stream from which archive bytes are read, or null to cancel extraction of the archive.
Remarks
When the first archive in a chain is opened, the name is not yet known, so the provided value will be an empty string. When opening further archives, the provided value is the next-archive name stored in the previous archive. This name is often, but not necessarily, the same as the filename of the archive package to be opened.

If this method returns null, the archive engine will throw a FileNotFoundException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OpenFileWriteStream Method (path, fileSize, lastWriteTime)

OpenFileWriteStream Method (path, fileSize, lastWriteTime)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► IUnpackStreamContext ► OpenFileWriteStream(String, Int64, DateTime)
Opens a stream for writing extracted file bytes.
Declaration Syntax
C# Visual Basic Visual C++
Stream OpenFileWriteStream(
    string path,
    long fileSize,
    DateTime lastWriteTime
)
Function OpenFileWriteStream ( _
    path As String, _
    fileSize As Long, _
    lastWriteTime As DateTime _
) As Stream
Stream^ OpenFileWriteStream(
    String^ path,
    long long fileSize,
    DateTime lastWriteTime
)
Parameters
path (String)
The path of the file within the archive. This is often, but not necessarily, the same as the relative path of the file outside the archive.
fileSize (Int64)
The uncompressed size of the file to be extracted.
lastWriteTime (DateTime)
The last write time of the file to be extracted.
Return Value
A stream where extracted file bytes are to be written, or null to skip extraction of the file and continue to the next file.
Remarks
The implementor may use the path, size and date information to dynamically decide whether or not the file should be extracted.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OffsetStream Class

OffsetStream Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream
Wraps a source stream and offsets all read/write/seek calls by a given value.
Declaration Syntax
C# Visual Basic Visual C++
public class OffsetStream : Stream
Public Class OffsetStream _
    Inherits Stream
public ref class OffsetStream : public Stream
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OffsetStream(Stream, Int64) | Creates a new OffsetStream instance from a source stream and using a specified offset.
 | BeginRead(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead | Gets a value indicating whether the source stream supports reading. (Overrides Stream.CanRead.)
 | CanSeek | Gets a value indicating whether the source stream supports seeking. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Gets a value indicating whether the source stream supports writing. (Overrides Stream.CanWrite.)
 | Close()()() | Closes the underlying stream. (Overrides Stream.Close()()().)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()() | Flushes the source stream. (Overrides Stream.Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | Gets the effective length of the stream, which is equal to the length of the source stream minus the offset. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Offset | Gets the number of bytes to offset all calls before redirecting to the underlying stream.
 | Position | Gets or sets the effective position of the stream, which is equal to the position of the source stream minus the offset. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[], Int32, Int32) | Reads a sequence of bytes from the source stream and advances the position within the stream by the number of bytes read. (Overrides Stream.Read(array<Byte>[]()[], Int32, Int32).)
 | ReadByte()()() | Reads a byte from the stream and advances the position within the source stream by one byte, or returns -1 if at the end of the stream. (Overrides Stream.ReadByte()()().)
 | ReadTimeout | Gets or sets a value that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Sets the position within the current stream, which is equal to the position within the source stream minus the offset. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Sets the effective length of the stream, which is equal to the length of the source stream minus the offset. (Overrides Stream.SetLength(Int64).)
 | Source | Gets the underlying stream that this OffsetStream calls into.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Write(array<Byte>[]()[], Int32, Int32) | Writes a sequence of bytes to the source stream and advances the current position within this stream by the number of bytes written. (Overrides Stream.Write(array<Byte>[]()[], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the source stream and advances the position within the stream by one byte. (Overrides Stream.WriteByte(Byte).)
 | WriteTimeout | Gets or sets a value that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks
This class is used to trick archive an packing or unpacking process into reading or writing at an offset into a file, primarily for self-extracting packages.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | OffsetStream

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


OffsetStream Constructor (source, offset)

OffsetStream Constructor (source, offset)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► OffsetStream(Stream, Int64)
Creates a new OffsetStream instance from a source stream and using a specified offset.
Declaration Syntax
C# Visual Basic Visual C++
public OffsetStream(
    Stream source,
    long offset
)
Public Sub New ( _
    source As Stream, _
    offset As Long _
)
public:
OffsetStream(
    Stream^ source,
    long long offset
)
Parameters
source (Stream)
Underlying stream for which all calls will be offset.
offset (Int64)
Positive or negative number of bytes to offset.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CanRead Property

CanRead Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► CanRead
Gets a value indicating whether the source stream supports reading.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
public:
virtual property bool CanRead {
    bool get () override;
}
Value
true if the stream supports reading; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CanSeek Property

CanSeek Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► CanSeek
Gets a value indicating whether the source stream supports seeking.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
public:
virtual property bool CanSeek {
    bool get () override;
}
Value
true if the stream supports seeking; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


CanWrite Property

CanWrite Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► CanWrite
Gets a value indicating whether the source stream supports writing.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
public:
virtual property bool CanWrite {
    bool get () override;
}
Value
true if the stream supports writing; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Close Method

Close Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► Close()()()
Closes the underlying stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Close()
Public Overrides Sub Close
public:
virtual void Close() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Flush Method

Flush Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► Flush()()()
Flushes the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Flush()
Public Overrides Sub Flush
public:
virtual void Flush() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Length Property

Length Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► Length
Gets the effective length of the stream, which is equal to the length of the source stream minus the offset.
Declaration Syntax
C# Visual Basic Visual C++
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
public:
virtual property long long Length {
    long long get () override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Offset Property

Offset Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► Offset
Gets the number of bytes to offset all calls before redirecting to the underlying stream.
Declaration Syntax
C# Visual Basic Visual C++
public long Offset { get; }
Public ReadOnly Property Offset As Long
public:
property long long Offset {
    long long get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Position Property

Position Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► Position
Gets or sets the effective position of the stream, which is equal to the position of the source stream minus the offset.
Declaration Syntax
C# Visual Basic Visual C++
public override long Position { get; set; }
Public Overrides Property Position As Long
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► Read(array<Byte>[]()[], Int32, Int32)
Reads a sequence of bytes from the source stream and advances the position within the stream by the number of bytes read.
Declaration Syntax
C# Visual Basic Visual C++
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset (Int32)
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count (Int32)
The maximum number of bytes to be read from the current stream.
Return Value
The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


ReadByte Method

ReadByte Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► ReadByte()()()
Reads a byte from the stream and advances the position within the source stream by one byte, or returns -1 if at the end of the stream.
Declaration Syntax
C# Visual Basic Visual C++
public override int ReadByte()
Public Overrides Function ReadByte As Integer
public:
virtual int ReadByte() override
Return Value
The unsigned byte cast to an Int32, or -1 if at the end of the stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Seek Method (offset, origin)

Seek Method (offset, origin)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► Seek(Int64, SeekOrigin)
Sets the position within the current stream, which is equal to the position within the source stream minus the offset.
Declaration Syntax
C# Visual Basic Visual C++
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek ( _
    offset As Long, _
    origin As SeekOrigin _
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
Parameters
offset (Int64)
A byte offset relative to the origin parameter.
origin (SeekOrigin)
A value of type SeekOrigin indicating the reference point used to obtain the new position.
Return Value
The new position within the current stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


SetLength Method (value)

SetLength Method (value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► SetLength(Int64)
Sets the effective length of the stream, which is equal to the length of the source stream minus the offset.
Declaration Syntax
C# Visual Basic Visual C++
public override void SetLength(
    long value
)
Public Overrides Sub SetLength ( _
    value As Long _
)
public:
virtual void SetLength(
    long long value
) override
Parameters
value (Int64)
The desired length of the current stream in bytes.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Source Property

Source Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► Source
Gets the underlying stream that this OffsetStream calls into.
Declaration Syntax
C# Visual Basic Visual C++
public Stream Source { get; }
Public ReadOnly Property Source As Stream
public:
property Stream^ Source {
    Stream^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► Write(array<Byte>[]()[], Int32, Int32)
Writes a sequence of bytes to the source stream and advances the current position within this stream by the number of bytes written.
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
An array of bytes. This method copies count bytes from buffer to the current stream.
offset (Int32)
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count (Int32)
The number of bytes to be written to the current stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


WriteByte Method (value)

WriteByte Method (value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► WriteByte(Byte)
Writes a byte to the current position in the source stream and advances the position within the stream by one byte.
Declaration Syntax
C# Visual Basic Visual C++
public override void WriteByte(
    byte value
)
Public Overrides Sub WriteByte ( _
    value As Byte _
)
public:
virtual void WriteByte(
    unsigned char value
) override
Parameters
value (Byte)
The byte to write to the stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Microsoft.Deployment.Compression.Cab Namespace

Microsoft.Deployment.Compression.Cab Namespace
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab
Implements cabinet archive packing and unpacking.
Declaration Syntax
C# Visual Basic Visual C++
namespace Microsoft.Deployment.Compression.Cab
Namespace Microsoft.Deployment.Compression.Cab
namespace Microsoft.Deployment.Compression.Cab
Types
All Types Classes
Icon | Type | Description
 | CabEngine | Engine capable of packing and unpacking archives in the cabinet format.
 | CabException | Exception class for cabinet operations.
 | CabFileInfo | Object representing a compressed file within a cabinet package; provides operations for getting the file properties and extracting the file.
 | CabInfo | Object representing a cabinet file on disk; provides access to file-based operations on the cabinet file.


CabEngine Class

CabEngine Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabEngine
Engine capable of packing and unpacking archives in the cabinet format.
Declaration Syntax
C# Visual Basic Visual C++
public class CabEngine : CompressionEngine
Public Class CabEngine _
    Inherits CompressionEngine
public ref class CabEngine : public CompressionEngine
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CabEngine()()() | Creates a new instance of the cabinet engine.
 | CompressionLevel | Compression level to use when compressing files. (Inherited from CompressionEngine.)
 | Dispose(Boolean) | Disposes of resources allocated by the cabinet engine. (Overrides CompressionEngine.Dispose(Boolean).)
 | Dispose()()() | Disposes of resources allocated by the compression engine. (Inherited from CompressionEngine.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Disposes the compression engine. (Inherited from CompressionEngine.)
 | FindArchiveOffset(Stream) | Gets the offset of an archive that is positioned 0 or more bytes from the start of the Stream. (Inherited from CompressionEngine.)
 | GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Gets information about files in a cabinet or cabinet chain. (Overrides CompressionEngine.GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>)).)
 | GetFileInfo(Stream) | Gets information about all files in an archive stream. (Inherited from CompressionEngine.)
 | GetFiles(Stream) | Gets the list of files in an archive Stream. (Inherited from CompressionEngine.)
 | GetFiles(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Gets the list of files in an archive or archive chain. (Inherited from CompressionEngine.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsArchive(Stream) | Checks whether a Stream begins with a header that indicates it is a valid cabinet file. (Overrides CompressionEngine.IsArchive(Stream).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnProgress(ArchiveProgressEventArgs) | Called by sublcasses to distribute a packing or unpacking progress event to listeners. (Inherited from CompressionEngine.)
 | Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64) | Creates a cabinet or chain of cabinets. (Overrides CompressionEngine.Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64).)
 | Pack(IPackStreamContext, IEnumerable<(Of <(String>)>)) | Creates an archive. (Inherited from CompressionEngine.)
 | Progress | Occurs when the compression engine reports progress in packing or unpacking an archive. (Inherited from CompressionEngine.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Extracts files from a cabinet or cabinet chain. (Overrides CompressionEngine.Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>)).)
 | Unpack(Stream, String) | Reads a single file from an archive stream. (Inherited from CompressionEngine.)
 | UseTempFiles | Gets or sets a flag indicating whether temporary files are created and used during compression. (Inherited from CompressionEngine.)
Inheritance Hierarchy
Object
 | CompressionEngine
 |  | CabEngine

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabEngine Constructor

CabEngine Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabEngine ► CabEngine()()()
Creates a new instance of the cabinet engine.
Declaration Syntax
C# Visual Basic Visual C++
public CabEngine()
Public Sub New
public:
CabEngine()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method (disposing)

Dispose Method (disposing)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabEngine ► Dispose(Boolean)
Disposes of resources allocated by the cabinet engine.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
If true, the method has been called directly or indirectly by a user's code, so managed and unmanaged resources will be disposed. If false, the method has been called by the runtime from inside the finalizer, and only unmanaged resources will be disposed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


GetFileInfo Method (streamContext, fileFilter)

GetFileInfo Method (streamContext, fileFilter)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabEngine ► GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>))
Gets information about files in a cabinet or cabinet chain.
Declaration Syntax
C# Visual Basic Visual C++
public override IList<ArchiveFileInfo> GetFileInfo(
    IUnpackStreamContext streamContext,
    Predicate<string> fileFilter
)
Public Overrides Function GetFileInfo ( _
    streamContext As IUnpackStreamContext, _
    fileFilter As Predicate(Of String) _
) As IList(Of ArchiveFileInfo)
public:
virtual IList<ArchiveFileInfo^>^ GetFileInfo(
    IUnpackStreamContext^ streamContext,
    Predicate<String^>^ fileFilter
) override
Parameters
streamContext (IUnpackStreamContext)
A context interface to handle opening and closing of cabinet and file streams.
fileFilter (Predicate <(Of <( String >)>))
A predicate that can determine which files to process, optional.
Return Value
Information about files in the cabinet stream.
Remarks
The fileFilter predicate takes an internal file path and returns true to include the file or false to exclude it.
Exceptions
Exception | Condition
ArchiveException | The cabinet provided by the stream context is not valid.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


IsArchive Method (stream)

IsArchive Method (stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabEngine ► IsArchive(Stream)
Checks whether a Stream begins with a header that indicates it is a valid cabinet file.
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsArchive(
    Stream stream
)
Public Overrides Function IsArchive ( _
    stream As Stream _
) As Boolean
public:
virtual bool IsArchive(
    Stream^ stream
) override
Parameters
stream (Stream)
Stream for reading the cabinet file.
Return Value
True if the stream is a valid cabinet file (with no offset); false otherwise.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Pack Method (streamContext, files, maxArchiveSize)

Pack Method (streamContext, files, maxArchiveSize)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabEngine ► Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64)
Creates a cabinet or chain of cabinets.
Declaration Syntax
C# Visual Basic Visual C++
public override void Pack(
    IPackStreamContext streamContext,
    IEnumerable<string> files,
    long maxArchiveSize
)
Public Overrides Sub Pack ( _
    streamContext As IPackStreamContext, _
    files As IEnumerable(Of String), _
    maxArchiveSize As Long _
)
public:
virtual void Pack(
    IPackStreamContext^ streamContext,
    IEnumerable<String^>^ files,
    long long maxArchiveSize
) override
Parameters
streamContext (IPackStreamContext)
A context interface to handle opening and closing of cabinet and file streams.
files (IEnumerable <(Of <( String >)>))
The paths of the files in the archive (not external file paths).
maxArchiveSize (Int64)
The maximum number of bytes for one cabinet before the contents are chained to the next cabinet, or zero for unlimited cabinet size.
Remarks
The stream context implementation may provide a mapping from the file paths within the cabinet to the external file paths.

Smaller folder sizes can make it more efficient to extract individual files out of large cabinet packages.

Exceptions
Exception | Condition
ArchiveException | The cabinet could not be created.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Unpack Method (streamContext, fileFilter)

Unpack Method (streamContext, fileFilter)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabEngine ► Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>))
Extracts files from a cabinet or cabinet chain.
Declaration Syntax
C# Visual Basic Visual C++
public override void Unpack(
    IUnpackStreamContext streamContext,
    Predicate<string> fileFilter
)
Public Overrides Sub Unpack ( _
    streamContext As IUnpackStreamContext, _
    fileFilter As Predicate(Of String) _
)
public:
virtual void Unpack(
    IUnpackStreamContext^ streamContext,
    Predicate<String^>^ fileFilter
) override
Parameters
streamContext (IUnpackStreamContext)
A context interface to handle opening and closing of cabinet and file streams.
fileFilter (Predicate <(Of <( String >)>))
An optional predicate that can determine which files to process.
Remarks
The fileFilter predicate takes an internal file path and returns true to include the file or false to exclude it.
Exceptions
Exception | Condition
ArchiveException | The cabinet provided by the stream context is not valid.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabException Class

CabException Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabException
Exception class for cabinet operations.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CabException : ArchiveException
<SerializableAttribute> _
Public Class CabException _
    Inherits ArchiveException
[SerializableAttribute]
public ref class CabException : public ArchiveException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CabException(String, Exception) | Creates a new CabException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | CabException(String) | Creates a new CabException with a specified error message.
 | CabException()()() | Creates a new CabException.
 | CabException(SerializationInfo, StreamingContext) | Initializes a new instance of the CabException class with serialized data.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Error | Gets the FCI or FDI cabinet engine error number.
 | ErrorCode | Gets the Win32 error code.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo with information about the exception. (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SystemException
 |  |  | IOException
 |  |  |  | ArchiveException
 |  |  |  |  | CabException

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabException Constructor

CabException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabException ► CabException()()()
Members
Icon | Member | Description
 | CabException(String, Exception) | Creates a new CabException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | CabException(String) | Creates a new CabException with a specified error message.
 | CabException()()() | Creates a new CabException.
 | CabException(SerializationInfo, StreamingContext) | Initializes a new instance of the CabException class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabException Constructor

CabException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabException ► CabException()()()
Creates a new CabException.
Declaration Syntax
C# Visual Basic Visual C++
public CabException()
Public Sub New
public:
CabException()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabException Constructor (info, context)

CabException Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabException ► CabException(SerializationInfo, StreamingContext)
Initializes a new instance of the CabException class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected CabException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CabException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabException Constructor (message)

CabException Constructor (message)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabException ► CabException(String)
Creates a new CabException with a specified error message.
Declaration Syntax
C# Visual Basic Visual C++
public CabException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
CabException(
    String^ message
)
Parameters
message (String)
The message that describes the error.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabException Constructor (message, innerException)

CabException Constructor (message, innerException)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabException ► CabException(String, Exception)
Creates a new CabException with a specified error message and a reference to the inner exception that is the cause of this exception.
Declaration Syntax
C# Visual Basic Visual C++
public CabException(
    string message,
    Exception innerException
)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
public:
CabException(
    String^ message,
    Exception^ innerException
)
Parameters
message (String)
The message that describes the error.
innerException (Exception)
The exception that is the cause of the current exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Error Property

Error Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabException ► Error
Gets the FCI or FDI cabinet engine error number.
Declaration Syntax
C# Visual Basic Visual C++
public int Error { get; }
Public ReadOnly Property Error As Integer
public:
property int Error {
    int get ();
}
Value
A cabinet engine error number, or 0 if the exception was not related to a cabinet engine error number.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


ErrorCode Property

ErrorCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabException ► ErrorCode
Gets the Win32 error code.
Declaration Syntax
C# Visual Basic Visual C++
public int ErrorCode { get; }
Public ReadOnly Property ErrorCode As Integer
public:
property int ErrorCode {
    int get ();
}
Value
A Win32 error code, or 0 if the exception was not related to a Win32 error.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabException ► GetObjectData(SerializationInfo, StreamingContext)
Sets the SerializationInfo with information about the exception.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabFileInfo Class

CabFileInfo Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabFileInfo
Object representing a compressed file within a cabinet package; provides operations for getting the file properties and extracting the file.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CabFileInfo : ArchiveFileInfo
<SerializableAttribute> _
Public Class CabFileInfo _
    Inherits ArchiveFileInfo
[SerializableAttribute]
public ref class CabFileInfo : public ArchiveFileInfo
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CabFileInfo(CabInfo, String) | Creates a new CabinetFileInfo object representing a file within a cabinet in a specified path.
 | CabFileInfo(SerializationInfo, StreamingContext) | Initializes a new instance of the CabinetFileInfo class with serialized data.
 | Archive | Gets or sets the archive that contains this file. (Inherited from ArchiveFileInfo.)
 | ArchiveName | Gets the full path of the archive that contains this file. (Inherited from ArchiveFileInfo.)
 | ArchiveNumber | Gets the number of the archive where this file starts. (Inherited from ArchiveFileInfo.)
 | Attributes | Gets the attributes of the file. (Inherited from ArchiveFileInfo.)
 | Cabinet | Gets or sets the cabinet that contains this file.
 | CabinetFolderNumber | Gets the number of the folder containing this file.
 | CabinetName | Gets the full path of the cabinet that contains this file.
 | CopyTo(String) | Extracts the file. (Inherited from ArchiveFileInfo.)
 | CopyTo(String, Boolean) | Extracts the file, optionally overwriting any existing file. (Inherited from ArchiveFileInfo.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreationTime | Gets or sets the creation time of the current FileSystemInfo object. (Inherited from FileSystemInfo.)
 | CreationTimeUtc | Gets or sets the creation time, in coordinated universal time (UTC), of the current FileSystemInfo object. (Inherited from FileSystemInfo.)
 | Delete()()() | Deletes the file. NOT SUPPORTED. (Inherited from ArchiveFileInfo.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists | Checks if the file exists within the archive. (Inherited from ArchiveFileInfo.)
 | Extension | Gets the string representing the extension part of the file. (Inherited from FileSystemInfo.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets the full path to the file. (Inherited from ArchiveFileInfo.)
 | FullPath | Represents the fully qualified path of the directory or file. (Inherited from FileSystemInfo.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo with information about the archive. (Overrides ArchiveFileInfo.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LastAccessTime | Gets or sets the time the current file or directory was last accessed. (Inherited from FileSystemInfo.)
 | LastAccessTimeUtc | Gets or sets the time, in coordinated universal time (UTC), that the current file or directory was last accessed. (Inherited from FileSystemInfo.)
 | LastWriteTime | Gets the last modification time of the file. (Inherited from ArchiveFileInfo.)
 | LastWriteTimeUtc | Gets or sets the time, in coordinated universal time (UTC), when the current file or directory was last written to. (Inherited from FileSystemInfo.)
 | Length | Gets the uncompressed size of the file. (Inherited from ArchiveFileInfo.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the file. (Inherited from ArchiveFileInfo.)
 | OpenRead()()() | Opens the archive file for reading without actually extracting the file to disk. (Inherited from ArchiveFileInfo.)
 | OpenText()()() | Opens the archive file reading text with UTF-8 encoding without actually extracting the file to disk. (Inherited from ArchiveFileInfo.)
 | OriginalPath | The path originally specified by the user, whether relative or absolute. (Inherited from FileSystemInfo.)
 | Path | Gets the internal path of the file in the archive. (Inherited from ArchiveFileInfo.)
 | Refresh(ArchiveFileInfo) | Refreshes the information in this object with new data retrieved from an archive. (Overrides ArchiveFileInfo.Refresh(ArchiveFileInfo).)
 | Refresh()()() | Refreshes the attributes and other cached information about the file, by re-reading the information from the archive. (Inherited from ArchiveFileInfo.)
 | ToString()()() | Gets the full path to the file. (Inherited from ArchiveFileInfo.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | FileSystemInfo
 |  |  | ArchiveFileInfo
 |  |  |  | CabFileInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabFileInfo Constructor

CabFileInfo Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabFileInfo ► CabFileInfo()()()
Members
Icon | Member | Description
 | CabFileInfo(CabInfo, String) | Creates a new CabinetFileInfo object representing a file within a cabinet in a specified path.
 | CabFileInfo(SerializationInfo, StreamingContext) | Initializes a new instance of the CabinetFileInfo class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabFileInfo Constructor (cabinetInfo, filePath)

CabFileInfo Constructor (cabinetInfo, filePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabFileInfo ► CabFileInfo(CabInfo, String)
Creates a new CabinetFileInfo object representing a file within a cabinet in a specified path.
Declaration Syntax
C# Visual Basic Visual C++
public CabFileInfo(
    CabInfo cabinetInfo,
    string filePath
)
Public Sub New ( _
    cabinetInfo As CabInfo, _
    filePath As String _
)
public:
CabFileInfo(
    CabInfo^ cabinetInfo,
    String^ filePath
)
Parameters
cabinetInfo (CabInfo)
An object representing the cabinet containing the file.
filePath (String)
The path to the file within the cabinet. Usually, this is a simple file name, but if the cabinet contains a directory structure this may include the directory.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabFileInfo Constructor (info, context)

CabFileInfo Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabFileInfo ► CabFileInfo(SerializationInfo, StreamingContext)
Initializes a new instance of the CabinetFileInfo class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected CabFileInfo(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CabFileInfo(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Cabinet Property

Cabinet Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabFileInfo ► Cabinet
Gets or sets the cabinet that contains this file.
Declaration Syntax
C# Visual Basic Visual C++
public CabInfo Cabinet { get; }
Public ReadOnly Property Cabinet As CabInfo
public:
property CabInfo^ Cabinet {
    CabInfo^ get ();
}
Value
The CabinetInfo instance that retrieved this file information -- this may be null if the CabinetFileInfo object was returned directly from a stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabinetFolderNumber Property

CabinetFolderNumber Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabFileInfo ► CabinetFolderNumber
Gets the number of the folder containing this file.
Declaration Syntax
C# Visual Basic Visual C++
public int CabinetFolderNumber { get; }
Public ReadOnly Property CabinetFolderNumber As Integer
public:
property int CabinetFolderNumber {
    int get ();
}
Value
The number of the cabinet folder containing this file.
Remarks
A single folder or the first folder of a cabinet (or chain of cabinets) is numbered 0.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabinetName Property

CabinetName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabFileInfo ► CabinetName
Gets the full path of the cabinet that contains this file.
Declaration Syntax
C# Visual Basic Visual C++
public string CabinetName { get; }
Public ReadOnly Property CabinetName As String
public:
property String^ CabinetName {
    String^ get ();
}
Value
The full path of the cabinet that contains this file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabFileInfo ► GetObjectData(SerializationInfo, StreamingContext)
Sets the SerializationInfo with information about the archive.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Refresh Method (newFileInfo)

Refresh Method (newFileInfo)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabFileInfo ► Refresh(ArchiveFileInfo)
Refreshes the information in this object with new data retrieved from an archive.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Refresh(
    ArchiveFileInfo newFileInfo
)
Protected Overrides Sub Refresh ( _
    newFileInfo As ArchiveFileInfo _
)
protected:
virtual void Refresh(
    ArchiveFileInfo^ newFileInfo
) override
Parameters
newFileInfo (ArchiveFileInfo)
Fresh instance for the same file just read from the archive.
Remarks
This implementation refreshes the CabinetFolderNumber.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabInfo Class

CabInfo Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo
Object representing a cabinet file on disk; provides access to file-based operations on the cabinet file.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CabInfo : ArchiveInfo
<SerializableAttribute> _
Public Class CabInfo _
    Inherits ArchiveInfo
[SerializableAttribute]
public ref class CabInfo : public ArchiveInfo
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CabInfo(String) | Creates a new CabinetInfo object representing a cabinet file in a specified path.
 | CabInfo(SerializationInfo, StreamingContext) | Initializes a new instance of the CabinetInfo class with serialized data.
 | Attributes | Gets or sets the FileAttributes of the current FileSystemInfo. (Inherited from FileSystemInfo.)
 | CopyTo(String) | Copies an existing archive to another location. (Inherited from ArchiveInfo.)
 | CopyTo(String, Boolean) | Copies an existing archive to another location, optionally overwriting the destination file. (Inherited from ArchiveInfo.)
 | CreateCompressionEngine()()() | Creates a compression engine that does the low-level work for this object. (Overrides ArchiveInfo.CreateCompressionEngine()()().)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreationTime | Gets or sets the creation time of the current FileSystemInfo object. (Inherited from FileSystemInfo.)
 | CreationTimeUtc | Gets or sets the creation time, in coordinated universal time (UTC), of the current FileSystemInfo object. (Inherited from FileSystemInfo.)
 | Delete()()() | Deletes the archive. (Inherited from ArchiveInfo.)
 | Directory | Gets the directory that contains the archive. (Inherited from ArchiveInfo.)
 | DirectoryName | Gets the full path of the directory that contains the archive. (Inherited from ArchiveInfo.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists | Checks if the archive exists. (Inherited from ArchiveInfo.)
 | Extension | Gets the string representing the extension part of the file. (Inherited from FileSystemInfo.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets the full path of the directory or file. (Inherited from FileSystemInfo.)
 | FullPath | Represents the fully qualified path of the directory or file. (Inherited from FileSystemInfo.)
 | GetFiles()()() | Gets information about the files contained in the archive.
 | GetFiles(String) | Gets information about the certain files contained in the archive file.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo object with the file name and additional exception information. (Inherited from FileSystemInfo.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsValid()()() | Checks if the archive contains a valid archive header. (Inherited from ArchiveInfo.)
 | LastAccessTime | Gets or sets the time the current file or directory was last accessed. (Inherited from FileSystemInfo.)
 | LastAccessTimeUtc | Gets or sets the time, in coordinated universal time (UTC), that the current file or directory was last accessed. (Inherited from FileSystemInfo.)
 | LastWriteTime | Gets or sets the time when the current file or directory was last written to. (Inherited from FileSystemInfo.)
 | LastWriteTimeUtc | Gets or sets the time, in coordinated universal time (UTC), when the current file or directory was last written to. (Inherited from FileSystemInfo.)
 | Length | Gets the size of the archive. (Inherited from ArchiveInfo.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveTo(String) | Moves an existing archive to another location. (Inherited from ArchiveInfo.)
 | Name | Gets the file name of the archive. (Inherited from ArchiveInfo.)
 | OpenRead(String) | Opens a file inside the archive for reading without actually extracting the file to disk. (Inherited from ArchiveInfo.)
 | OpenText(String) | Opens a file inside the archive for reading text with UTF-8 encoding without actually extracting the file to disk. (Inherited from ArchiveInfo.)
 | OriginalPath | The path originally specified by the user, whether relative or absolute. (Inherited from FileSystemInfo.)
 | Pack(String) | Compresses all files in a directory into the archive. Does not include subdirectories. (Inherited from ArchiveInfo.)
 | Pack(String, Boolean, CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses all files in a directory into the archive, optionally including subdirectories. (Inherited from ArchiveInfo.)
 | PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive. (Inherited from ArchiveInfo.)
 | PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive. (Inherited from ArchiveInfo.)
 | PackFileSet(String, IDictionary<(Of <(String, String>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive. (Inherited from ArchiveInfo.)
 | PackFileSet(String, IDictionary<(Of <(String, String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive. (Inherited from ArchiveInfo.)
 | Refresh()()() | Refreshes the state of the object. (Inherited from FileSystemInfo.)
 | ToString()()() | Gets the full path of the archive. (Inherited from ArchiveInfo.)
 | Unpack(String) | Extracts all files from an archive to a destination directory. (Inherited from ArchiveInfo.)
 | Unpack(String, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts all files from an archive to a destination directory, optionally extracting only newer files. (Inherited from ArchiveInfo.)
 | UnpackFile(String, String) | Extracts a single file from the archive. (Inherited from ArchiveInfo.)
 | UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>)) | Extracts multiple files from the archive. (Inherited from ArchiveInfo.)
 | UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>), EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts multiple files from the archive, optionally extracting only newer files. (Inherited from ArchiveInfo.)
 | UnpackFileSet(IDictionary<(Of <(String, String>)>), String) | Extracts multiple files from the archive. (Inherited from ArchiveInfo.)
 | UnpackFileSet(IDictionary<(Of <(String, String>)>), String, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts multiple files from the archive. (Inherited from ArchiveInfo.)
Remarks
Generally, the methods on this class are much easier to use than the stream-based interfaces provided by the CabEngine class.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | FileSystemInfo
 |  |  | ArchiveInfo
 |  |  |  | CabInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabInfo Constructor

CabInfo Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► CabInfo()()()
Members
Icon | Member | Description
 | CabInfo(String) | Creates a new CabinetInfo object representing a cabinet file in a specified path.
 | CabInfo(SerializationInfo, StreamingContext) | Initializes a new instance of the CabinetInfo class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabInfo Constructor (info, context)

CabInfo Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► CabInfo(SerializationInfo, StreamingContext)
Initializes a new instance of the CabinetInfo class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected CabInfo(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CabInfo(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CabInfo Constructor (path)

CabInfo Constructor (path)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► CabInfo(String)
Creates a new CabinetInfo object representing a cabinet file in a specified path.
Declaration Syntax
C# Visual Basic Visual C++
public CabInfo(
    string path
)
Public Sub New ( _
    path As String _
)
public:
CabInfo(
    String^ path
)
Parameters
path (String)
The path to the cabinet file. When creating a cabinet file, this file does not necessarily exist yet.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CreateCompressionEngine Method

CreateCompressionEngine Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► CreateCompressionEngine()()()
Creates a compression engine that does the low-level work for this object.
Declaration Syntax
C# Visual Basic Visual C++
protected override CompressionEngine CreateCompressionEngine()
Protected Overrides Function CreateCompressionEngine As CompressionEngine
protected:
virtual CompressionEngine^ CreateCompressionEngine() override
Return Value
A new CabEngine instance.
Remarks
Each instance will be Dispose()()()d immediately after use.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method

GetFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► GetFiles()()()
Members
Icon | Member | Description
 | GetFiles()()() | Gets information about the files contained in the archive.
 | GetFiles(String) | Gets information about the certain files contained in the archive file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method

GetFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► GetFiles()()()
Gets information about the files contained in the archive.
Declaration Syntax
C# Visual Basic Visual C++
public IList<CabFileInfo> GetFiles()
Public Function GetFiles As IList(Of CabFileInfo)
public:
IList<CabFileInfo^>^ GetFiles()
Return Value
A list of CabFileInfo objects, each containing information about a file in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method (searchPattern)

GetFiles Method (searchPattern)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► GetFiles(String)
Gets information about the certain files contained in the archive file.
Declaration Syntax
C# Visual Basic Visual C++
public IList<CabFileInfo> GetFiles(
    string searchPattern
)
Public Function GetFiles ( _
    searchPattern As String _
) As IList(Of CabFileInfo)
public:
IList<CabFileInfo^>^ GetFiles(
    String^ searchPattern
)
Parameters
searchPattern (String)
The search string, such as "*.txt".
Return Value
A list of CabFileInfo objects, each containing information about a file in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Microsoft.Deployment.Compression.Zip Namespace

Microsoft.Deployment.Compression.Zip Namespace
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip
Implements zip archive packing and unpacking.
Declaration Syntax
C# Visual Basic Visual C++
namespace Microsoft.Deployment.Compression.Zip
Namespace Microsoft.Deployment.Compression.Zip
namespace Microsoft.Deployment.Compression.Zip
Types
All Types Classes Enumerations
Icon | Type | Description
 | CrcStream | Wraps a source stream and calcaluates a CRC over all bytes that are read or written.
 | ZipCompressionMethod | Identifies the compression method or "algorithm" used for a single file within a zip archive.
 | ZipEngine | Engine capable of packing and unpacking archives in the zip format.
 | ZipException | Exception class for zip operations.
 | ZipFileInfo | Object representing a compressed file within a zip package; provides operations for getting the file properties and extracting the file.
 | ZipInfo | Object representing a zip file on disk; provides access to file-based operations on the zip file.


CrcStream Class

CrcStream Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream
Wraps a source stream and calcaluates a CRC over all bytes that are read or written.
Declaration Syntax
C# Visual Basic Visual C++
public class CrcStream : Stream
Public Class CrcStream _
    Inherits Stream
public ref class CrcStream : public Stream
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrcStream(Stream) | Creates a new CrcStream instance from a source stream.
 | BeginRead(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead | Gets a value indicating whether the source stream supports reading. (Overrides Stream.CanRead.)
 | CanSeek | Gets a value indicating whether the source stream supports seeking. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Gets a value indicating whether the source stream supports writing. (Overrides Stream.CanWrite.)
 | Close()()() | Closes the underlying stream. (Overrides Stream.Close()()().)
 | Crc | Gets the current CRC over all bytes that have been read or written since this instance was created.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()() | Flushes the source stream. (Overrides Stream.Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | Gets the length of the source stream. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Gets or sets the position of the source stream. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[], Int32, Int32) | Reads a sequence of bytes from the source stream and advances the position within the stream by the number of bytes read. (Overrides Stream.Read(array<Byte>[]()[], Int32, Int32).)
 | ReadByte()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Sets the position within the source stream. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Sets the length of the source stream. (Overrides Stream.SetLength(Int64).)
 | Source | Gets the underlying stream that this stream reads from or writes to.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Write(array<Byte>[]()[], Int32, Int32) | Writes a sequence of bytes to the source stream and advances the current position within this stream by the number of bytes written. (Overrides Stream.Write(array<Byte>[]()[], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks
The CRC algorithm matches that used in the standard ZIP file format.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | CrcStream

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


CrcStream Constructor (source)

CrcStream Constructor (source)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► CrcStream(Stream)
Creates a new CrcStream instance from a source stream.
Declaration Syntax
C# Visual Basic Visual C++
public CrcStream(
    Stream source
)
Public Sub New ( _
    source As Stream _
)
public:
CrcStream(
    Stream^ source
)
Parameters
source (Stream)
Underlying stream where bytes will be read from or written to.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


CanRead Property

CanRead Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► CanRead
Gets a value indicating whether the source stream supports reading.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
public:
virtual property bool CanRead {
    bool get () override;
}
Value
true if the stream supports reading; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


CanSeek Property

CanSeek Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► CanSeek
Gets a value indicating whether the source stream supports seeking.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
public:
virtual property bool CanSeek {
    bool get () override;
}
Value
true if the stream supports seeking; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


CanWrite Property

CanWrite Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► CanWrite
Gets a value indicating whether the source stream supports writing.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
public:
virtual property bool CanWrite {
    bool get () override;
}
Value
true if the stream supports writing; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Close Method

Close Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► Close()()()
Closes the underlying stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Close()
Public Overrides Sub Close
public:
virtual void Close() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Crc Property

Crc Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► Crc
Gets the current CRC over all bytes that have been read or written since this instance was created.
Declaration Syntax
C# Visual Basic Visual C++
public uint Crc { get; }
Public ReadOnly Property Crc As UInteger
public:
property unsigned int Crc {
    unsigned int get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Flush Method

Flush Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► Flush()()()
Flushes the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Flush()
Public Overrides Sub Flush
public:
virtual void Flush() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Length Property

Length Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► Length
Gets the length of the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
public:
virtual property long long Length {
    long long get () override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Position Property

Position Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► Position
Gets or sets the position of the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override long Position { get; set; }
Public Overrides Property Position As Long
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► Read(array<Byte>[]()[], Int32, Int32)
Reads a sequence of bytes from the source stream and advances the position within the stream by the number of bytes read.
Declaration Syntax
C# Visual Basic Visual C++
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset (Int32)
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count (Int32)
The maximum number of bytes to be read from the current stream.
Return Value
The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Seek Method (offset, origin)

Seek Method (offset, origin)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► Seek(Int64, SeekOrigin)
Sets the position within the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek ( _
    offset As Long, _
    origin As SeekOrigin _
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
Parameters
offset (Int64)
A byte offset relative to the origin parameter.
origin (SeekOrigin)
A value of type SeekOrigin indicating the reference point used to obtain the new position.
Return Value
The new position within the source stream.
Remarks
Note the CRC is only calculated over bytes that are actually read or written, so any bytes skipped by seeking will not contribute to the CRC.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


SetLength Method (value)

SetLength Method (value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► SetLength(Int64)
Sets the length of the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void SetLength(
    long value
)
Public Overrides Sub SetLength ( _
    value As Long _
)
public:
virtual void SetLength(
    long long value
) override
Parameters
value (Int64)
The desired length of the stream in bytes.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Source Property

Source Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► Source
Gets the underlying stream that this stream reads from or writes to.
Declaration Syntax
C# Visual Basic Visual C++
public Stream Source { get; }
Public ReadOnly Property Source As Stream
public:
property Stream^ Source {
    Stream^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► Write(array<Byte>[]()[], Int32, Int32)
Writes a sequence of bytes to the source stream and advances the current position within this stream by the number of bytes written.
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
An array of bytes. This method copies count bytes from buffer to the current stream.
offset (Int32)
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count (Int32)
The number of bytes to be written to the current stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipCompressionMethod Enumeration

ZipCompressionMethod Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipCompressionMethod
Identifies the compression method or "algorithm" used for a single file within a zip archive.
Declaration Syntax
C# Visual Basic Visual C++
public enum ZipCompressionMethod
Public Enumeration ZipCompressionMethod
public enum class ZipCompressionMethod
Members
Member | Description
Store | The file is stored (no compression)
Shrink | The file is Shrunk
Reduce1 | The file is Reduced with compression factor 1
Reduce2 | The file is Reduced with compression factor 2
Reduce3 | The file is Reduced with compression factor 3
Reduce4 | The file is Reduced with compression factor 4
Implode | The file is Imploded
Deflate | The file is Deflated; the most common and widely-compatible form of zip compression.
Deflate64 | The file is Deflated using the enhanced Deflate64 method.
BZip2 | The file is compressed using the BZIP2 algorithm.
Lzma | The file is compressed using the LZMA algorithm.
Ppmd | The file is compressed using the PPMd algorithm.
Remarks
Proprietary zip implementations may define additional compression methods outside of those included here.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipEngine Class

ZipEngine Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine
Engine capable of packing and unpacking archives in the zip format.
Declaration Syntax
C# Visual Basic Visual C++
public class ZipEngine : CompressionEngine
Public Class ZipEngine _
    Inherits CompressionEngine
public ref class ZipEngine : public CompressionEngine
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZipEngine()()() | Creates a new instance of the zip engine.
 | ArchiveComment | Gets the comment from the last-examined archive, or sets the comment to be added to any created archives.
 | CompressionLevel | Compression level to use when compressing files. (Inherited from CompressionEngine.)
 | Dispose()()() | Disposes of resources allocated by the compression engine. (Inherited from CompressionEngine.)
 | Dispose(Boolean) | Disposes of resources allocated by the compression engine. (Inherited from CompressionEngine.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Disposes the compression engine. (Inherited from CompressionEngine.)
 | FindArchiveOffset(Stream) | Gets the offset of an archive that is positioned 0 or more bytes from the start of the Stream. (Overrides CompressionEngine.FindArchiveOffset(Stream).)
 | GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Gets information about files in a zip archive or archive chain. (Overrides CompressionEngine.GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>)).)
 | GetFileInfo(Stream) | Gets information about all files in an archive stream. (Inherited from CompressionEngine.)
 | GetFiles(Stream) | Gets the list of files in an archive Stream. (Inherited from CompressionEngine.)
 | GetFiles(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Gets the list of files in an archive or archive chain. (Inherited from CompressionEngine.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsArchive(Stream) | Checks whether a Stream begins with a header that indicates it is a valid archive file. (Overrides CompressionEngine.IsArchive(Stream).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnProgress(ArchiveProgressEventArgs) | Called by sublcasses to distribute a packing or unpacking progress event to listeners. (Inherited from CompressionEngine.)
 | Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64) | Creates a zip archive or chain of zip archives. (Overrides CompressionEngine.Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64).)
 | Pack(IPackStreamContext, IEnumerable<(Of <(String>)>)) | Creates an archive. (Inherited from CompressionEngine.)
 | Progress | Occurs when the compression engine reports progress in packing or unpacking an archive. (Inherited from CompressionEngine.)
 | RegisterCompressionStreamCreator(ZipCompressionMethod, CompressionMode, Converter<(Of <(Stream, Stream>)>)) | Registers a delegate that can create a warpper stream for compressing or uncompressing the data of a source stream.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Extracts files from a zip archive or archive chain. (Overrides CompressionEngine.Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>)).)
 | Unpack(Stream, String) | Reads a single file from an archive stream. (Inherited from CompressionEngine.)
 | UseTempFiles | Gets or sets a flag indicating whether temporary files are created and used during compression. (Inherited from CompressionEngine.)
Inheritance Hierarchy
Object
 | CompressionEngine
 |  | ZipEngine

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipEngine Constructor

ZipEngine Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► ZipEngine()()()
Creates a new instance of the zip engine.
Declaration Syntax
C# Visual Basic Visual C++
public ZipEngine()
Public Sub New
public:
ZipEngine()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ArchiveComment Property

ArchiveComment Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► ArchiveComment
Gets the comment from the last-examined archive, or sets the comment to be added to any created archives.
Declaration Syntax
C# Visual Basic Visual C++
public string ArchiveComment { get; set; }
Public Property ArchiveComment As String
public:
property String^ ArchiveComment {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


FindArchiveOffset Method (stream)

FindArchiveOffset Method (stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► FindArchiveOffset(Stream)
Gets the offset of an archive that is positioned 0 or more bytes from the start of the Stream.
Declaration Syntax
C# Visual Basic Visual C++
public override long FindArchiveOffset(
    Stream stream
)
Public Overrides Function FindArchiveOffset ( _
    stream As Stream _
) As Long
public:
virtual long long FindArchiveOffset(
    Stream^ stream
) override
Parameters
stream (Stream)
A stream for reading the archive.
Return Value
The offset in bytes of the archive, or -1 if no archive is found in the Stream.
Remarks
The archive must begin on a 4-byte boundary.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


GetFileInfo Method (streamContext, fileFilter)

GetFileInfo Method (streamContext, fileFilter)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>))
Gets information about files in a zip archive or archive chain.
Declaration Syntax
C# Visual Basic Visual C++
public override IList<ArchiveFileInfo> GetFileInfo(
    IUnpackStreamContext streamContext,
    Predicate<string> fileFilter
)
Public Overrides Function GetFileInfo ( _
    streamContext As IUnpackStreamContext, _
    fileFilter As Predicate(Of String) _
) As IList(Of ArchiveFileInfo)
public:
virtual IList<ArchiveFileInfo^>^ GetFileInfo(
    IUnpackStreamContext^ streamContext,
    Predicate<String^>^ fileFilter
) override
Parameters
streamContext (IUnpackStreamContext)
A context interface to handle opening and closing of archive and file streams.
fileFilter (Predicate <(Of <( String >)>))
A predicate that can determine which files to process, optional.
Return Value
Information about files in the archive stream.
Remarks
The fileFilter predicate takes an internal file path and returns true to include the file or false to exclude it.
Exceptions
Exception | Condition
ArchiveException | The archive provided by the stream context is not valid.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


IsArchive Method (stream)

IsArchive Method (stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► IsArchive(Stream)
Checks whether a Stream begins with a header that indicates it is a valid archive file.
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsArchive(
    Stream stream
)
Public Overrides Function IsArchive ( _
    stream As Stream _
) As Boolean
public:
virtual bool IsArchive(
    Stream^ stream
) override
Parameters
stream (Stream)
Stream for reading the archive file.
Return Value
True if the stream is a valid zip archive (with no offset); false otherwise.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Pack Method (streamContext, files, maxArchiveSize)

Pack Method (streamContext, files, maxArchiveSize)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64)
Creates a zip archive or chain of zip archives.
Declaration Syntax
C# Visual Basic Visual C++
public override void Pack(
    IPackStreamContext streamContext,
    IEnumerable<string> files,
    long maxArchiveSize
)
Public Overrides Sub Pack ( _
    streamContext As IPackStreamContext, _
    files As IEnumerable(Of String), _
    maxArchiveSize As Long _
)
public:
virtual void Pack(
    IPackStreamContext^ streamContext,
    IEnumerable<String^>^ files,
    long long maxArchiveSize
) override
Parameters
streamContext (IPackStreamContext)
A context interface to handle opening and closing of archive and file streams.
files (IEnumerable <(Of <( String >)>))
An array of file lists. Each list is compressed into one stream in the archive.
maxArchiveSize (Int64)
The maximum number of bytes for one archive before the contents are chained to the next archive, or zero for unlimited archive size.
Remarks
The stream context implementation may provide a mapping from the file paths within the archive to the external file paths.
Exceptions
Exception | Condition
ArchiveException | The archive could not be created.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


RegisterCompressionStreamCreator Method (compressionMethod, compressionMode, creator)

RegisterCompressionStreamCreator Method (compressionMethod, compressionMode, creator)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► RegisterCompressionStreamCreator(ZipCompressionMethod, CompressionMode, Converter<(Of <(Stream, Stream>)>))
Registers a delegate that can create a warpper stream for compressing or uncompressing the data of a source stream.
Declaration Syntax
C# Visual Basic Visual C++
public static void RegisterCompressionStreamCreator(
    ZipCompressionMethod compressionMethod,
    CompressionMode compressionMode,
    Converter<Stream, Stream> creator
)
Public Shared Sub RegisterCompressionStreamCreator ( _
    compressionMethod As ZipCompressionMethod, _
    compressionMode As CompressionMode, _
    creator As Converter(Of Stream, Stream) _
)
public:
static void RegisterCompressionStreamCreator(
    ZipCompressionMethod compressionMethod,
    CompressionMode compressionMode,
    Converter<Stream^, Stream^>^ creator
)
Parameters
compressionMethod (ZipCompressionMethod)
Compression method being registered.
compressionMode (CompressionMode)
Indicates registration for ether compress or decompress mode.
creator (Converter <(Of <( Stream, Stream >)>))
Delegate being registered.
Remarks
For compression, the delegate accepts a stream that writes to the archive and returns a wrapper stream that compresses bytes as they are written. For decompression, the delegate accepts a stream that reads from the archive and returns a wrapper stream that decompresses bytes as they are read. This wrapper stream model follows the design used by System.IO.Compression.DeflateStream, and indeed that class is used to implement the Deflate compression method by default.

To unregister a delegate, call this method again and pass null for the delegate parameter.

Examples
When the ZipEngine class is initialized, the Deflate compression method is automatically registered like this:
CopyC#
ZipEngine.RegisterCompressionStreamCreator(
    ZipCompressionMethod.Deflate,
    CompressionMode.Compress,
    delegate(Stream stream) {
        return new DeflateStream(stream, CompressionMode.Compress, true);
    });
ZipEngine.RegisterCompressionStreamCreator(
    ZipCompressionMethod.Deflate,
    CompressionMode.Decompress,
    delegate(Stream stream) {
        return new DeflateStream(stream, CompressionMode.Decompress, true);
    });

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Unpack Method (streamContext, fileFilter)

Unpack Method (streamContext, fileFilter)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>))
Extracts files from a zip archive or archive chain.
Declaration Syntax
C# Visual Basic Visual C++
public override void Unpack(
    IUnpackStreamContext streamContext,
    Predicate<string> fileFilter
)
Public Overrides Sub Unpack ( _
    streamContext As IUnpackStreamContext, _
    fileFilter As Predicate(Of String) _
)
public:
virtual void Unpack(
    IUnpackStreamContext^ streamContext,
    Predicate<String^>^ fileFilter
) override
Parameters
streamContext (IUnpackStreamContext)
A context interface to handle opening and closing of archive and file streams.
fileFilter (Predicate <(Of <( String >)>))
An optional predicate that can determine which files to process.
Remarks
The fileFilter predicate takes an internal file path and returns true to include the file or false to exclude it.
Exceptions
Exception | Condition
ArchiveException | The archive provided by the stream context is not valid.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipException Class

ZipException Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipException
Exception class for zip operations.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ZipException : ArchiveException
<SerializableAttribute> _
Public Class ZipException _
    Inherits ArchiveException
[SerializableAttribute]
public ref class ZipException : public ArchiveException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZipException(String, Exception) | Creates a new ZipException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | ZipException(String) | Creates a new ZipException with a specified error message.
 | ZipException()()() | Creates a new ZipException.
 | ZipException(SerializationInfo, StreamingContext) | Initializes a new instance of the ZipException class with serialized data.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo with information about the exception. (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SystemException
 |  |  | IOException
 |  |  |  | ArchiveException
 |  |  |  |  | ZipException

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipException Constructor

ZipException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipException ► ZipException()()()
Members
Icon | Member | Description
 | ZipException(String, Exception) | Creates a new ZipException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | ZipException(String) | Creates a new ZipException with a specified error message.
 | ZipException()()() | Creates a new ZipException.
 | ZipException(SerializationInfo, StreamingContext) | Initializes a new instance of the ZipException class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipException Constructor

ZipException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipException ► ZipException()()()
Creates a new ZipException.
Declaration Syntax
C# Visual Basic Visual C++
public ZipException()
Public Sub New
public:
ZipException()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipException Constructor (info, context)

ZipException Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipException ► ZipException(SerializationInfo, StreamingContext)
Initializes a new instance of the ZipException class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected ZipException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ZipException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipException Constructor (message)

ZipException Constructor (message)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipException ► ZipException(String)
Creates a new ZipException with a specified error message.
Declaration Syntax
C# Visual Basic Visual C++
public ZipException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
ZipException(
    String^ message
)
Parameters
message (String)
The message that describes the error.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipException Constructor (message, innerException)

ZipException Constructor (message, innerException)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipException ► ZipException(String, Exception)
Creates a new ZipException with a specified error message and a reference to the inner exception that is the cause of this exception.
Declaration Syntax
C# Visual Basic Visual C++
public ZipException(
    string message,
    Exception innerException
)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
public:
ZipException(
    String^ message,
    Exception^ innerException
)
Parameters
message (String)
The message that describes the error.
innerException (Exception)
The exception that is the cause of the current exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipException ► GetObjectData(SerializationInfo, StreamingContext)
Sets the SerializationInfo with information about the exception.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipFileInfo Class

ZipFileInfo Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipFileInfo
Object representing a compressed file within a zip package; provides operations for getting the file properties and extracting the file.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ZipFileInfo : ArchiveFileInfo
<SerializableAttribute> _
Public Class ZipFileInfo _
    Inherits ArchiveFileInfo
[SerializableAttribute]
public ref class ZipFileInfo : public ArchiveFileInfo
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZipFileInfo(ZipInfo, String) | Creates a new ZipFileInfo object representing a file within a zip in a specified path.
 | ZipFileInfo(SerializationInfo, StreamingContext) | Initializes a new instance of the ZipFileInfo class with serialized data.
 | Archive | Gets or sets the archive that contains this file. (Inherited from ArchiveFileInfo.)
 | ArchiveName | Gets the full path of the archive that contains this file. (Inherited from ArchiveFileInfo.)
 | ArchiveNumber | Gets the number of the archive where this file starts. (Inherited from ArchiveFileInfo.)
 | Attributes | Gets the attributes of the file. (Inherited from ArchiveFileInfo.)
 | CompressedLength | Gets the compressed size of the file in bytes.
 | CompressionMethod | Gets the method used to compress this file.
 | CopyTo(String) | Extracts the file. (Inherited from ArchiveFileInfo.)
 | CopyTo(String, Boolean) | Extracts the file, optionally overwriting any existing file. (Inherited from ArchiveFileInfo.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreationTime | Gets or sets the creation time of the current FileSystemInfo object. (Inherited from FileSystemInfo.)
 | CreationTimeUtc | Gets or sets the creation time, in coordinated universal time (UTC), of the current FileSystemInfo object. (Inherited from FileSystemInfo.)
 | Delete()()() | Deletes the file. NOT SUPPORTED. (Inherited from ArchiveFileInfo.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists | Checks if the file exists within the archive. (Inherited from ArchiveFileInfo.)
 | Extension | Gets the string representing the extension part of the file. (Inherited from FileSystemInfo.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets the full path to the file. (Inherited from ArchiveFileInfo.)
 | FullPath | Represents the fully qualified path of the directory or file. (Inherited from FileSystemInfo.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo with information about the archive. (Overrides ArchiveFileInfo.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LastAccessTime | Gets or sets the time the current file or directory was last accessed. (Inherited from FileSystemInfo.)
 | LastAccessTimeUtc | Gets or sets the time, in coordinated universal time (UTC), that the current file or directory was last accessed. (Inherited from FileSystemInfo.)
 | LastWriteTime | Gets the last modification time of the file. (Inherited from ArchiveFileInfo.)
 | LastWriteTimeUtc | Gets or sets the time, in coordinated universal time (UTC), when the current file or directory was last written to. (Inherited from FileSystemInfo.)
 | Length | Gets the uncompressed size of the file. (Inherited from ArchiveFileInfo.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the file. (Inherited from ArchiveFileInfo.)
 | OpenRead()()() | Opens the archive file for reading without actually extracting the file to disk. (Inherited from ArchiveFileInfo.)
 | OpenText()()() | Opens the archive file reading text with UTF-8 encoding without actually extracting the file to disk. (Inherited from ArchiveFileInfo.)
 | OriginalPath | The path originally specified by the user, whether relative or absolute. (Inherited from FileSystemInfo.)
 | Path | Gets the internal path of the file in the archive. (Inherited from ArchiveFileInfo.)
 | Refresh()()() | Refreshes the attributes and other cached information about the file, by re-reading the information from the archive. (Inherited from ArchiveFileInfo.)
 | Refresh(ArchiveFileInfo) | Refreshes the information in this object with new data retrieved from an archive. (Inherited from ArchiveFileInfo.)
 | ToString()()() | Gets the full path to the file. (Inherited from ArchiveFileInfo.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | FileSystemInfo
 |  |  | ArchiveFileInfo
 |  |  |  | ZipFileInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipFileInfo Constructor

ZipFileInfo Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipFileInfo ► ZipFileInfo()()()
Members
Icon | Member | Description
 | ZipFileInfo(ZipInfo, String) | Creates a new ZipFileInfo object representing a file within a zip in a specified path.
 | ZipFileInfo(SerializationInfo, StreamingContext) | Initializes a new instance of the ZipFileInfo class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipFileInfo Constructor (zipInfo, filePath)

ZipFileInfo Constructor (zipInfo, filePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipFileInfo ► ZipFileInfo(ZipInfo, String)
Creates a new ZipFileInfo object representing a file within a zip in a specified path.
Declaration Syntax
C# Visual Basic Visual C++
public ZipFileInfo(
    ZipInfo zipInfo,
    string filePath
)
Public Sub New ( _
    zipInfo As ZipInfo, _
    filePath As String _
)
public:
ZipFileInfo(
    ZipInfo^ zipInfo,
    String^ filePath
)
Parameters
zipInfo (ZipInfo)
An object representing the zip archive containing the file.
filePath (String)
The path to the file within the zip archive. Usually, this is a simple file name, but if the zip archive contains a directory structure this may include the directory.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipFileInfo Constructor (info, context)

ZipFileInfo Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipFileInfo ► ZipFileInfo(SerializationInfo, StreamingContext)
Initializes a new instance of the ZipFileInfo class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected ZipFileInfo(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ZipFileInfo(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


CompressedLength Property

CompressedLength Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipFileInfo ► CompressedLength
Gets the compressed size of the file in bytes.
Declaration Syntax
C# Visual Basic Visual C++
public long CompressedLength { get; }
Public ReadOnly Property CompressedLength As Long
public:
property long long CompressedLength {
    long long get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


CompressionMethod Property

CompressionMethod Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipFileInfo ► CompressionMethod
Gets the method used to compress this file.
Declaration Syntax
C# Visual Basic Visual C++
public ZipCompressionMethod CompressionMethod { get; }
Public ReadOnly Property CompressionMethod As ZipCompressionMethod
public:
property ZipCompressionMethod CompressionMethod {
    ZipCompressionMethod get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipFileInfo ► GetObjectData(SerializationInfo, StreamingContext)
Sets the SerializationInfo with information about the archive.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipInfo Class

ZipInfo Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo
Object representing a zip file on disk; provides access to file-based operations on the zip file.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ZipInfo : ArchiveInfo
<SerializableAttribute> _
Public Class ZipInfo _
    Inherits ArchiveInfo
[SerializableAttribute]
public ref class ZipInfo : public ArchiveInfo
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZipInfo(String) | Creates a new CabinetInfo object representing a zip file in a specified path.
 | ZipInfo(SerializationInfo, StreamingContext) | Initializes a new instance of the CabinetInfo class with serialized data.
 | Attributes | Gets or sets the FileAttributes of the current FileSystemInfo. (Inherited from FileSystemInfo.)
 | CopyTo(String) | Copies an existing archive to another location. (Inherited from ArchiveInfo.)
 | CopyTo(String, Boolean) | Copies an existing archive to another location, optionally overwriting the destination file. (Inherited from ArchiveInfo.)
 | CreateCompressionEngine()()() | Creates a compression engine that does the low-level work for this object. (Overrides ArchiveInfo.CreateCompressionEngine()()().)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreationTime | Gets or sets the creation time of the current FileSystemInfo object. (Inherited from FileSystemInfo.)
 | CreationTimeUtc | Gets or sets the creation time, in coordinated universal time (UTC), of the current FileSystemInfo object. (Inherited from FileSystemInfo.)
 | Delete()()() | Deletes the archive. (Inherited from ArchiveInfo.)
 | Directory | Gets the directory that contains the archive. (Inherited from ArchiveInfo.)
 | DirectoryName | Gets the full path of the directory that contains the archive. (Inherited from ArchiveInfo.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists | Checks if the archive exists. (Inherited from ArchiveInfo.)
 | Extension | Gets the string representing the extension part of the file. (Inherited from FileSystemInfo.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FullName | Gets the full path of the directory or file. (Inherited from FileSystemInfo.)
 | FullPath | Represents the fully qualified path of the directory or file. (Inherited from FileSystemInfo.)
 | GetFiles()()() | Gets information about the files contained in the archive.
 | GetFiles(String) | Gets information about the certain files contained in the archive file.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo object with the file name and additional exception information. (Inherited from FileSystemInfo.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsValid()()() | Checks if the archive contains a valid archive header. (Inherited from ArchiveInfo.)
 | LastAccessTime | Gets or sets the time the current file or directory was last accessed. (Inherited from FileSystemInfo.)
 | LastAccessTimeUtc | Gets or sets the time, in coordinated universal time (UTC), that the current file or directory was last accessed. (Inherited from FileSystemInfo.)
 | LastWriteTime | Gets or sets the time when the current file or directory was last written to. (Inherited from FileSystemInfo.)
 | LastWriteTimeUtc | Gets or sets the time, in coordinated universal time (UTC), when the current file or directory was last written to. (Inherited from FileSystemInfo.)
 | Length | Gets the size of the archive. (Inherited from ArchiveInfo.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveTo(String) | Moves an existing archive to another location. (Inherited from ArchiveInfo.)
 | Name | Gets the file name of the archive. (Inherited from ArchiveInfo.)
 | OpenRead(String) | Opens a file inside the archive for reading without actually extracting the file to disk. (Inherited from ArchiveInfo.)
 | OpenText(String) | Opens a file inside the archive for reading text with UTF-8 encoding without actually extracting the file to disk. (Inherited from ArchiveInfo.)
 | OriginalPath | The path originally specified by the user, whether relative or absolute. (Inherited from FileSystemInfo.)
 | Pack(String) | Compresses all files in a directory into the archive. Does not include subdirectories. (Inherited from ArchiveInfo.)
 | Pack(String, Boolean, CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses all files in a directory into the archive, optionally including subdirectories. (Inherited from ArchiveInfo.)
 | PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive. (Inherited from ArchiveInfo.)
 | PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive. (Inherited from ArchiveInfo.)
 | PackFileSet(String, IDictionary<(Of <(String, String>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive. (Inherited from ArchiveInfo.)
 | PackFileSet(String, IDictionary<(Of <(String, String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive. (Inherited from ArchiveInfo.)
 | Refresh()()() | Refreshes the state of the object. (Inherited from FileSystemInfo.)
 | ToString()()() | Gets the full path of the archive. (Inherited from ArchiveInfo.)
 | Unpack(String) | Extracts all files from an archive to a destination directory. (Inherited from ArchiveInfo.)
 | Unpack(String, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts all files from an archive to a destination directory, optionally extracting only newer files. (Inherited from ArchiveInfo.)
 | UnpackFile(String, String) | Extracts a single file from the archive. (Inherited from ArchiveInfo.)
 | UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>)) | Extracts multiple files from the archive. (Inherited from ArchiveInfo.)
 | UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>), EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts multiple files from the archive, optionally extracting only newer files. (Inherited from ArchiveInfo.)
 | UnpackFileSet(IDictionary<(Of <(String, String>)>), String) | Extracts multiple files from the archive. (Inherited from ArchiveInfo.)
 | UnpackFileSet(IDictionary<(Of <(String, String>)>), String, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts multiple files from the archive. (Inherited from ArchiveInfo.)
Remarks
Generally, the methods on this class are much easier to use than the stream-based interfaces provided by the ZipEngine class.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | FileSystemInfo
 |  |  | ArchiveInfo
 |  |  |  | ZipInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipInfo Constructor

ZipInfo Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► ZipInfo()()()
Members
Icon | Member | Description
 | ZipInfo(String) | Creates a new CabinetInfo object representing a zip file in a specified path.
 | ZipInfo(SerializationInfo, StreamingContext) | Initializes a new instance of the CabinetInfo class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipInfo Constructor (info, context)

ZipInfo Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► ZipInfo(SerializationInfo, StreamingContext)
Initializes a new instance of the CabinetInfo class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected ZipInfo(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ZipInfo(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


ZipInfo Constructor (path)

ZipInfo Constructor (path)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► ZipInfo(String)
Creates a new CabinetInfo object representing a zip file in a specified path.
Declaration Syntax
C# Visual Basic Visual C++
public ZipInfo(
    string path
)
Public Sub New ( _
    path As String _
)
public:
ZipInfo(
    String^ path
)
Parameters
path (String)
The path to the zip file. When creating a zip file, this file does not necessarily exist yet.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


CreateCompressionEngine Method

CreateCompressionEngine Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► CreateCompressionEngine()()()
Creates a compression engine that does the low-level work for this object.
Declaration Syntax
C# Visual Basic Visual C++
protected override CompressionEngine CreateCompressionEngine()
Protected Overrides Function CreateCompressionEngine As CompressionEngine
protected:
virtual CompressionEngine^ CreateCompressionEngine() override
Return Value
A new ZipEngine instance.
Remarks
Each instance will be Dispose()()()d immediately after use.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method

GetFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► GetFiles()()()
Members
Icon | Member | Description
 | GetFiles()()() | Gets information about the files contained in the archive.
 | GetFiles(String) | Gets information about the certain files contained in the archive file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method

GetFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► GetFiles()()()
Gets information about the files contained in the archive.
Declaration Syntax
C# Visual Basic Visual C++
public IList<ZipFileInfo> GetFiles()
Public Function GetFiles As IList(Of ZipFileInfo)
public:
IList<ZipFileInfo^>^ GetFiles()
Return Value
A list of ZipFileInfo objects, each containing information about a file in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method (searchPattern)

GetFiles Method (searchPattern)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► GetFiles(String)
Gets information about the certain files contained in the archive file.
Declaration Syntax
C# Visual Basic Visual C++
public IList<ZipFileInfo> GetFiles(
    string searchPattern
)
Public Function GetFiles ( _
    searchPattern As String _
) As IList(Of ZipFileInfo)
public:
IList<ZipFileInfo^>^ GetFiles(
    String^ searchPattern
)
Parameters
searchPattern (String)
The search string, such as "*.txt".
Return Value
A list of ZipFileInfo objects, each containing information about a file in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Microsoft.Deployment.Resources Namespace

Microsoft.Deployment.Resources Namespace
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources
Classes for reading and writing resource data in executable files.
Declaration Syntax
C# Visual Basic Visual C++
namespace Microsoft.Deployment.Resources
Namespace Microsoft.Deployment.Resources
namespace Microsoft.Deployment.Resources
Types
All Types Classes Enumerations
Icon | Type | Description
 | Resource | Represents a Win32 resource which can be loaded from and saved to a PE file.
 | ResourceCollection | Allows reading and editing of resource data in a Win32 PE file.
 | ResourceType | Represents either a standard integer resource type or a custom resource type name.
 | VersionBuildTypes | Identifies build types of a versioned file.
 | VersionFileSubtype | Identifies the sub-type of a versioned file.
 | VersionFileType | Identifies the type of a versioned file.
 | VersionResource | A subclass of Resource which provides specific methods for manipulating the resource data.
 | VersionStringTable | Represents a string table of a file version resource.


Resource Class

Resource Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► Resource
Represents a Win32 resource which can be loaded from and saved to a PE file.
Declaration Syntax
C# Visual Basic Visual C++
public class Resource
Public Class Resource
public ref class Resource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Resource(ResourceType, String, Int32) | Creates a new Resource object without any data. The data can be later loaded from a file.
 | Resource(ResourceType, String, Int32, array<Byte>[]()[]) | Creates a new Resource object with data. The data can be later saved to a file.
 | Data | Gets or sets the raw data of the resource.
 | Equals(Object) | Tests if type, name, and locale of this Resource object match another Resource object. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Gets a hash code for this Resource object. (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Load(String) | Loads the resource data from a file. The file is searched for a resource with matching type, name, and locale.
 | Locale | Gets or sets the locale of the resource.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name of the resource. For a numeric resource identifier, the decimal number is prefixed with a "#".
 | ResourceType | Gets or sets the type of the resource. This may be one of the ResourceType constants or a user-defined type name.
 | Save(String) | Saves the resource to a file. Any existing resource data with matching type, name, and locale is overwritten.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Resource
 |  | VersionResource

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Resource Constructor

Resource Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► Resource ► Resource()()()
Members
Icon | Member | Description
 | Resource(ResourceType, String, Int32) | Creates a new Resource object without any data. The data can be later loaded from a file.
 | Resource(ResourceType, String, Int32, array<Byte>[]()[]) | Creates a new Resource object with data. The data can be later saved to a file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Resource Constructor (type, name, locale)

Resource Constructor (type, name, locale)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► Resource ► Resource(ResourceType, String, Int32)
Creates a new Resource object without any data. The data can be later loaded from a file.
Declaration Syntax
C# Visual Basic Visual C++
public Resource(
    ResourceType type,
    string name,
    int locale
)
Public Sub New ( _
    type As ResourceType, _
    name As String, _
    locale As Integer _
)
public:
Resource(
    ResourceType^ type,
    String^ name,
    int locale
)
Parameters
type (ResourceType)
Type of the resource; may be one of the ResourceType constants or a user-defined type.
name (String)
Name of the resource. For a numeric resource identifier, prefix the decimal number with a "#".
locale (Int32)
Locale of the resource

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Resource Constructor (type, name, locale, data)

Resource Constructor (type, name, locale, data)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► Resource ► Resource(ResourceType, String, Int32, array<Byte>[]()[])
Creates a new Resource object with data. The data can be later saved to a file.
Declaration Syntax
C# Visual Basic Visual C++
public Resource(
    ResourceType type,
    string name,
    int locale,
    byte[] data
)
Public Sub New ( _
    type As ResourceType, _
    name As String, _
    locale As Integer, _
    data As Byte() _
)
public:
Resource(
    ResourceType^ type,
    String^ name,
    int locale,
    array<unsigned char>^ data
)
Parameters
type (ResourceType)
Type of the resource; may be one of the ResourceType constants or a user-defined type.
name (String)
Name of the resource. For a numeric resource identifier, prefix the decimal number with a "#".
locale (Int32)
Locale of the resource
data (array< Byte >[]()[])
Raw resource data

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Data Property

Data Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► Resource ► Data
Gets or sets the raw data of the resource.
Declaration Syntax
C# Visual Basic Visual C++
public virtual byte[] Data { get; set; }
Public Overridable Property Data As Byte()
public:
virtual property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Equals Method (obj)

Equals Method (obj)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► Resource ► Equals(Object)
Tests if type, name, and locale of this Resource object match another Resource object.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
Resource object to be compared
Return Value
True if the objects represent the same resource; false otherwise.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


GetHashCode Method

GetHashCode Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► Resource ► GetHashCode()()()
Gets a hash code for this Resource object.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
Hash code generated from the resource type, name, and locale.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Load Method (file)

Load Method (file)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► Resource ► Load(String)
Loads the resource data from a file. The file is searched for a resource with matching type, name, and locale.
Declaration Syntax
C# Visual Basic Visual C++
public void Load(
    string file
)
Public Sub Load ( _
    file As String _
)
public:
void Load(
    String^ file
)
Parameters
file (String)
Win32 PE file containing the resource

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Locale Property

Locale Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► Resource ► Locale
Gets or sets the locale of the resource.
Declaration Syntax
C# Visual Basic Visual C++
public int Locale { get; set; }
Public Property Locale As Integer
public:
property int Locale {
    int get ();
    void set (int value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Name Property

Name Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► Resource ► Name
Gets or sets the name of the resource. For a numeric resource identifier, the decimal number is prefixed with a "#".
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


ResourceType Property

ResourceType Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► Resource ► ResourceType
Gets or sets the type of the resource. This may be one of the ResourceType constants or a user-defined type name.
Declaration Syntax
C# Visual Basic Visual C++
public ResourceType ResourceType { get; set; }
Public Property ResourceType As ResourceType
public:
property ResourceType^ ResourceType {
    ResourceType^ get ();
    void set (ResourceType^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Save Method (file)

Save Method (file)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► Resource ► Save(String)
Saves the resource to a file. Any existing resource data with matching type, name, and locale is overwritten.
Declaration Syntax
C# Visual Basic Visual C++
public void Save(
    string file
)
Public Sub Save ( _
    file As String _
)
public:
void Save(
    String^ file
)
Parameters
file (String)
Win32 PE file to contain the resource

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


ResourceCollection Class

ResourceCollection Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection
Allows reading and editing of resource data in a Win32 PE file.
Declaration Syntax
C# Visual Basic Visual C++
public class ResourceCollection : ICollection<Resource>,
    IEnumerable<Resource>, IEnumerable
Public Class ResourceCollection _
    Implements ICollection(Of Resource), IEnumerable(Of Resource),  _
    IEnumerable
public ref class ResourceCollection : ICollection<Resource^>,
    IEnumerable<Resource^>, IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResourceCollection()()() | Creates a new, empty ResourceCollection.
 | Add(Resource) | Adds a new item to the collection.
 | Clear()()() | Removes all resources from the collection.
 | Contains(Resource) | Tests if the collection contains an item.
 | CopyTo(array<Resource>[]()[], Int32) | Copies the collection into an array.
 | Count | Gets the number of resources in the collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(String) | Locates all resources in a file, including all resource types and languages. For each located resource, a Resource instance (or subclass) is added to the collection.
 | Find(String, ResourceType) | Locates all resources in a file of a given type, including all languages. For each located resource, a Resource instance (or subclass) is added to the collection.
 | Find(String, ResourceType, String) | Locates all resources in a file of a given type and language. For each located resource, a Resource instance (or subclass) is added to the collection.
 | GetEnumerator()()() | Gets an enumerator over all resources in the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(Resource) | Gets the index of an item in the collection.
 | Insert(Int32, Resource) | Inserts a item into the collection.
 | Item[([(Int32])]) | Gets or sets the element at the specified index.
 | Load(String) | For all resources in the collection, loads their data from a resource file.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(Resource) | Removes an item to the collection.
 | Save(String) | For all resources in the collection, saves their data to a resource file.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
To use this class:
  1. Create a new ResourceCollection
  2. Locate resources for the collection by calling one of the Find(String) methods
  3. Load data of one or more Resources from a file by calling the Load(String) method of the Resource class, or load them all at once (more efficient) with the Load(String) method of the ResourceCollection.
  4. Read and/or edit data of the individual Resource objects using the methods on that class.
  5. Save data of one or more Resources to a file by calling the Save(String) method of the Resource class, or save them all at once (more efficient) with the Save(String) method of the ResourceCollection.
Inheritance Hierarchy
Object
ResourceCollection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


ResourceCollection Constructor

ResourceCollection Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► ResourceCollection()()()
Creates a new, empty ResourceCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ResourceCollection()
Public Sub New
public:
ResourceCollection()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Add Method (item)

Add Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Add(Resource)
Adds a new item to the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    Resource item
)
Public Sub Add ( _
    item As Resource _
)
public:
virtual void Add(
    Resource^ item
) sealed
Parameters
item (Resource)
The Resource to add.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Clear Method

Clear Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Clear()()()
Removes all resources from the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Contains Method (item)

Contains Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Contains(Resource)
Tests if the collection contains an item.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Resource item
)
Public Function Contains ( _
    item As Resource _
) As Boolean
public:
virtual bool Contains(
    Resource^ item
) sealed
Parameters
item (Resource)
The Resource to search for.
Return Value
true if the item is found; false otherwise

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► CopyTo(array<Resource>[]()[], Int32)
Copies the collection into an array.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Resource[] array,
    int arrayIndex
)
Public Sub CopyTo ( _
    array As Resource(), _
    arrayIndex As Integer _
)
public:
virtual void CopyTo(
    array<Resource^>^ array,
    int arrayIndex
) sealed
Parameters
array (array< Resource >[]()[])
The array to copy into.
arrayIndex (Int32)
The starting index in the destination array.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Count Property

Count Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Count
Gets the number of resources in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Find Method

Find Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Find()()()
Members
Icon | Member | Description
 | Find(String) | Locates all resources in a file, including all resource types and languages. For each located resource, a Resource instance (or subclass) is added to the collection.
 | Find(String, ResourceType) | Locates all resources in a file of a given type, including all languages. For each located resource, a Resource instance (or subclass) is added to the collection.
 | Find(String, ResourceType, String) | Locates all resources in a file of a given type and language. For each located resource, a Resource instance (or subclass) is added to the collection.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Find Method (resFile)

Find Method (resFile)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Find(String)
Locates all resources in a file, including all resource types and languages. For each located resource, a Resource instance (or subclass) is added to the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Find(
    string resFile
)
Public Sub Find ( _
    resFile As String _
)
public:
void Find(
    String^ resFile
)
Parameters
resFile (String)
The file to be searched for resources.
Exceptions
Exception | Condition
IOException | resources could not be read from the file

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Find Method (resFile, type)

Find Method (resFile, type)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Find(String, ResourceType)
Locates all resources in a file of a given type, including all languages. For each located resource, a Resource instance (or subclass) is added to the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Find(
    string resFile,
    ResourceType type
)
Public Sub Find ( _
    resFile As String, _
    type As ResourceType _
)
public:
void Find(
    String^ resFile,
    ResourceType^ type
)
Parameters
resFile (String)
The file to be searched for resources.
type (ResourceType)
The type of resource to search for; may be one of the ResourceType constants or a user-defined type.
Exceptions
Exception | Condition
IOException | resources could not be read from the file

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Find Method (resFile, type, name)

Find Method (resFile, type, name)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Find(String, ResourceType, String)
Locates all resources in a file of a given type and language. For each located resource, a Resource instance (or subclass) is added to the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Find(
    string resFile,
    ResourceType type,
    string name
)
Public Sub Find ( _
    resFile As String, _
    type As ResourceType, _
    name As String _
)
public:
void Find(
    String^ resFile,
    ResourceType^ type,
    String^ name
)
Parameters
resFile (String)
The file to be searched for resources.
type (ResourceType)
The type of resource to search for; may be one of the ResourceType constants or a user-defined type.
name (String)
The name of the resource to search for.
Exceptions
Exception | Condition
IOException | resources could not be read from the file

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► GetEnumerator()()()
Gets an enumerator over all resources in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<Resource> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Resource)
public:
virtual IEnumerator<Resource^>^ GetEnumerator() sealed
Return Value

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


IndexOf Method (item)

IndexOf Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► IndexOf(Resource)
Gets the index of an item in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Resource item
)
Public Function IndexOf ( _
    item As Resource _
) As Integer
public:
int IndexOf(
    Resource^ item
)
Parameters
item (Resource)
The Resource to search for.
Return Value
The index of the item, or -1 if not found.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Insert Method (index, item)

Insert Method (index, item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Insert(Int32, Resource)
Inserts a item into the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    Resource item
)
Public Sub Insert ( _
    index As Integer, _
    item As Resource _
)
public:
void Insert(
    int index,
    Resource^ item
)
Parameters
index (Int32)
The insertion index.
item (Resource)
The Resource to insert.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Item Property (index)

Item Property (index)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Item[([(Int32])])
Gets or sets the element at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
public Resource this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As Resource
public:
property Resource^ default[int index] {
    Resource^ get (int index);
    void set (int index, Resource^ value);
}
Parameters
index (Int32)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Load Method (file)

Load Method (file)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Load(String)
For all resources in the collection, loads their data from a resource file.
Declaration Syntax
C# Visual Basic Visual C++
public void Load(
    string file
)
Public Sub Load ( _
    file As String _
)
public:
void Load(
    String^ file
)
Parameters
file (String)
The file from which resources are loaded.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Remove Method (item)

Remove Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Remove(Resource)
Removes an item to the collection.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    Resource item
)
Public Function Remove ( _
    item As Resource _
) As Boolean
public:
virtual bool Remove(
    Resource^ item
) sealed
Parameters
item (Resource)
The Resource to remove.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Save Method (file)

Save Method (file)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceCollection ► Save(String)
For all resources in the collection, saves their data to a resource file.
Declaration Syntax
C# Visual Basic Visual C++
public void Save(
    string file
)
Public Sub Save ( _
    file As String _
)
public:
void Save(
    String^ file
)
Parameters
file (String)
The file to which resources are saved.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


ResourceType Class

ResourceType Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType
Represents either a standard integer resource type or a custom resource type name.
Declaration Syntax
C# Visual Basic Visual C++
public class ResourceType
Public Class ResourceType
public ref class ResourceType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ResourceType(String) | Creates a new resource type from a string resource name.
 | ResourceType(Int32) | Creates a new integer resource type.
 | Accelerator |
 | AniCursor |
 | AniIcon |
 | Bitmap |
 | Cursor |
 | Dialog |
 | DialogInclude |
 | Equals(Object) | Tests whether one resource type equals another object. (Overrides Object.Equals(Object).)
 | Equals(ResourceType) | Tests whether one resource type equals another.
 | Explicit(ResourceType) | Explicitly converts a ResourceType to a string.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Font |
 | FontDir |
 | GetHashCode()()() | Gets a hash code suitable for using the resource type as a dictionary key. (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GroupCursor |
 | GroupIcon |
 | Html |
 | Icon |
 | Implicit(String) | Implicitly converts a string to a ResourceType.
 | IntegerValue | Gets the integer value of the resource type, or -1 if the resource type is not an integer.
 | IsInteger | Gets a flag indicating whether the resource type is an integer type.
 | Manifest |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Menu |
 | MessageTable |
 | None |
 | PlugPlay |
 | RCData |
 | String |
 | ToString()()() | Gets a string representation of the resource type. (Overrides Object.ToString()()().)
 | Version |
 | Vxd |
Inheritance Hierarchy
Object
ResourceType

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


ResourceType Constructor

ResourceType Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► ResourceType()()()
Members
Icon | Member | Description
 | ResourceType(String) | Creates a new resource type from a string resource name.
 | ResourceType(Int32) | Creates a new integer resource type.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


ResourceType Constructor (resourceType)

ResourceType Constructor (resourceType)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► ResourceType(Int32)
Creates a new integer resource type.
Declaration Syntax
C# Visual Basic Visual C++
public ResourceType(
    int resourceType
)
Public Sub New ( _
    resourceType As Integer _
)
public:
ResourceType(
    int resourceType
)
Parameters
resourceType (Int32)
Integer value of a well-known resource type.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


ResourceType Constructor (resourceType)

ResourceType Constructor (resourceType)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► ResourceType(String)
Creates a new resource type from a string resource name.
Declaration Syntax
C# Visual Basic Visual C++
public ResourceType(
    string resourceType
)
Public Sub New ( _
    resourceType As String _
)
public:
ResourceType(
    String^ resourceType
)
Parameters
resourceType (String)
String resource name, or an integer resource type prefixed by a #.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Accelerator Property

Accelerator Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Accelerator
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType Accelerator { get; }
Public Shared ReadOnly Property Accelerator As ResourceType
public:
static property ResourceType^ Accelerator {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


AniCursor Property

AniCursor Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► AniCursor
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType AniCursor { get; }
Public Shared ReadOnly Property AniCursor As ResourceType
public:
static property ResourceType^ AniCursor {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


AniIcon Property

AniIcon Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► AniIcon
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType AniIcon { get; }
Public Shared ReadOnly Property AniIcon As ResourceType
public:
static property ResourceType^ AniIcon {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Bitmap Property

Bitmap Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Bitmap
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType Bitmap { get; }
Public Shared ReadOnly Property Bitmap As ResourceType
public:
static property ResourceType^ Bitmap {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Cursor Property

Cursor Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Cursor
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType Cursor { get; }
Public Shared ReadOnly Property Cursor As ResourceType
public:
static property ResourceType^ Cursor {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Dialog Property

Dialog Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Dialog
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType Dialog { get; }
Public Shared ReadOnly Property Dialog As ResourceType
public:
static property ResourceType^ Dialog {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


DialogInclude Property

DialogInclude Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► DialogInclude
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType DialogInclude { get; }
Public Shared ReadOnly Property DialogInclude As ResourceType
public:
static property ResourceType^ DialogInclude {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Equals Method

Equals Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Equals()()()
Members
Icon | Member | Description
 | Equals(Object) | Tests whether one resource type equals another object. (Overrides Object.Equals(Object).)
 | Equals(ResourceType) | Tests whether one resource type equals another.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Equals Method (otherType)

Equals Method (otherType)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Equals(ResourceType)
Tests whether one resource type equals another.
Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    ResourceType otherType
)
Public Function Equals ( _
    otherType As ResourceType _
) As Boolean
public:
bool Equals(
    ResourceType^ otherType
)
Parameters
otherType (ResourceType)
Other resource type.
Return Value
True if equal, else false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Equals Method (obj)

Equals Method (obj)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Equals(Object)
Tests whether one resource type equals another object.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
Other object.
Return Value
True if equal, else false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Explicit Operator

Explicit Operator
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Explicit(ResourceType)
Explicitly converts a ResourceType to a string.
Declaration Syntax
C# Visual Basic Visual C++
public static explicit operator string (
    ResourceType resourceType
)
Public Shared Narrowing Operator CType ( _
    resourceType As ResourceType _
) As String
static explicit operator String^ (
    ResourceType^ resourceType
)
Parameters
resourceType (ResourceType)
ResourceType object to convert.
Return Value
The resource type string.
Remarks
Unlike ToString()()(), this conversion does not return the common name of well-known integer resource types. Therefore, the returned string is suitable for passing directly to Win32 resource APIs that accept resource type strings.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Font Property

Font Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Font
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType Font { get; }
Public Shared ReadOnly Property Font As ResourceType
public:
static property ResourceType^ Font {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


FontDir Property

FontDir Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► FontDir
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType FontDir { get; }
Public Shared ReadOnly Property FontDir As ResourceType
public:
static property ResourceType^ FontDir {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


GetHashCode Method

GetHashCode Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► GetHashCode()()()
Gets a hash code suitable for using the resource type as a dictionary key.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
Hash code based on the resource type string.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


GroupCursor Property

GroupCursor Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► GroupCursor
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType GroupCursor { get; }
Public Shared ReadOnly Property GroupCursor As ResourceType
public:
static property ResourceType^ GroupCursor {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


GroupIcon Property

GroupIcon Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► GroupIcon
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType GroupIcon { get; }
Public Shared ReadOnly Property GroupIcon As ResourceType
public:
static property ResourceType^ GroupIcon {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Html Property

Html Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Html
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType Html { get; }
Public Shared ReadOnly Property Html As ResourceType
public:
static property ResourceType^ Html {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Icon Property

Icon Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Icon
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType Icon { get; }
Public Shared ReadOnly Property Icon As ResourceType
public:
static property ResourceType^ Icon {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Implicit Operator

Implicit Operator
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Implicit(String)
Implicitly converts a string to a ResourceType.
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator ResourceType (
    string resourceType
)
Public Shared Widening Operator CType ( _
    resourceType As String _
) As ResourceType
static implicit operator ResourceType^ (
    String^ resourceType
)
Parameters
resourceType (String)
String resource type to convert.
Return Value
ResourceType object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


IntegerValue Property

IntegerValue Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► IntegerValue
Gets the integer value of the resource type, or -1 if the resource type is not an integer.
Declaration Syntax
C# Visual Basic Visual C++
public int IntegerValue { get; }
Public ReadOnly Property IntegerValue As Integer
public:
property int IntegerValue {
    int get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


IsInteger Property

IsInteger Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► IsInteger
Gets a flag indicating whether the resource type is an integer type.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInteger { get; }
Public ReadOnly Property IsInteger As Boolean
public:
property bool IsInteger {
    bool get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Manifest Property

Manifest Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Manifest
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType Manifest { get; }
Public Shared ReadOnly Property Manifest As ResourceType
public:
static property ResourceType^ Manifest {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Menu Property

Menu Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Menu
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType Menu { get; }
Public Shared ReadOnly Property Menu As ResourceType
public:
static property ResourceType^ Menu {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


MessageTable Property

MessageTable Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► MessageTable
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType MessageTable { get; }
Public Shared ReadOnly Property MessageTable As ResourceType
public:
static property ResourceType^ MessageTable {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


None Property

None Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► None
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType None { get; }
Public Shared ReadOnly Property None As ResourceType
public:
static property ResourceType^ None {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


PlugPlay Property

PlugPlay Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► PlugPlay
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType PlugPlay { get; }
Public Shared ReadOnly Property PlugPlay As ResourceType
public:
static property ResourceType^ PlugPlay {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


RCData Property

RCData Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► RCData
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType RCData { get; }
Public Shared ReadOnly Property RCData As ResourceType
public:
static property ResourceType^ RCData {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


String Property

String Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► String
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType String { get; }
Public Shared ReadOnly Property String As ResourceType
public:
static property ResourceType^ String {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


ToString Method

ToString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► ToString()()()
Gets a string representation of the resource type.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The custom resource name, or the name of a well-known resource type.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Version Property

Version Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Version
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType Version { get; }
Public Shared ReadOnly Property Version As ResourceType
public:
static property ResourceType^ Version {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Vxd Property

Vxd Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► ResourceType ► Vxd
Declaration Syntax
C# Visual Basic Visual C++
public static ResourceType Vxd { get; }
Public Shared ReadOnly Property Vxd As ResourceType
public:
static property ResourceType^ Vxd {
    ResourceType^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


VersionBuildTypes Enumeration

VersionBuildTypes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionBuildTypes
Identifies build types of a versioned file.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum VersionBuildTypes
<FlagsAttribute> _
Public Enumeration VersionBuildTypes
[FlagsAttribute]
public enum class VersionBuildTypes
Members
Member | Description
None |
Debug |
Prerelease |
Patched |
PrivateBuild |
InfoInferred |
SpecialBuild |

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


VersionFileSubtype Enumeration

VersionFileSubtype Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionFileSubtype
Identifies the sub-type of a versioned file.
Declaration Syntax
C# Visual Basic Visual C++
public enum VersionFileSubtype
Public Enumeration VersionFileSubtype
public enum class VersionFileSubtype
Members
Member | Description
Unknown |
PrinterDriver |
KeyboardDriver |
LanguageDriver |
DisplayDriver |
MouseDriver |
NetworkDriver |
SystemDriver |
InstallableDriver |
SoundDriver |
CommDriver |
InputMethodDriver |
VersionedPrinterDriver |
RasterFont |
VectorFont |
TrueTypeFont |

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


VersionFileType Enumeration

VersionFileType Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionFileType
Identifies the type of a versioned file.
Declaration Syntax
C# Visual Basic Visual C++
public enum VersionFileType
Public Enumeration VersionFileType
public enum class VersionFileType
Members
Member | Description
Unknown |
Application |
Dll |
Driver |
Font |
VirtualDevice |
StaticLibrary |

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


VersionResource Class

VersionResource Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource
A subclass of Resource which provides specific methods for manipulating the resource data.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class VersionResource : Resource, ICollection<VersionStringTable>,
    IEnumerable<VersionStringTable>, IEnumerable
Public NotInheritable Class VersionResource _
    Inherits Resource _
    Implements ICollection(Of VersionStringTable), IEnumerable(Of VersionStringTable),  _
    IEnumerable
public ref class VersionResource sealed : public Resource,
    ICollection<VersionStringTable^>, IEnumerable<VersionStringTable^>, IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VersionResource(String, Int32) | Creates a new VersionResource object without any data. The data can be later loaded from a file.
 | VersionResource(String, Int32, array<Byte>[]()[]) | Creates a new VersionResource object with data. The data can be later saved to a file.
 | Add(Int32) | Adds a new version string table for a locale.
 | BuildTypes | Gets or sets a bitmask that specifies the build types of the file.
 | Clear()()() | Removes all string tables from the version resource.
 | Contains(Int32) | Checks if a version string table exists for a given locale.
 | CopyTo(array<VersionStringTable>[]()[], Int32) | Copies the version string tables to an array, starting at a particular array index.
 | Count | Gets the number string tables in the version resource.
 | Data | Gets or sets the raw data of the resource. The data is in the format of the VS_VERSIONINFO structure. (Overrides Resource.Data.)
 | Equals(Object) | Tests if type, name, and locale of this Resource object match another Resource object. (Inherited from Resource.)
 | FileSubtype | Gets or sets the specific type of the file.
 | FileType | Gets or sets the general type of the file.
 | FileVersion | Gets or sets the binary locale-independent file version of the version resource.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Gets an enumerator that can iterate over the version string tables in the collection.
 | GetHashCode()()() | Gets a hash code for this Resource object. (Inherited from Resource.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Int32])]) | Gets the string table for a specific locale, or null if there is no table for that locale.
 | Load(String) | Loads the resource data from a file. The file is searched for a resource with matching type, name, and locale. (Inherited from Resource.)
 | Locale | Gets or sets the locale of the resource. (Inherited from Resource.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name of the resource. For a numeric resource identifier, the decimal number is prefixed with a "#". (Inherited from Resource.)
 | ProductVersion | Gets or sets the binary locale-independent product version of the version resource.
 | Remove(Int32) | Removes a version string table for a locale.
 | ResourceType | Gets or sets the type of the resource. This may be one of the ResourceType constants or a user-defined type name. (Inherited from Resource.)
 | Save(String) | Saves the resource to a file. Any existing resource data with matching type, name, and locale is overwritten. (Inherited from Resource.)
 | Timestamp | Gets or sets the binary creation date and time.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
The resource is of type Version (RT_VERSION).
Inheritance Hierarchy
Object
 | Resource
 |  | VersionResource

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


VersionResource Constructor

VersionResource Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► VersionResource()()()
Members
Icon | Member | Description
 | VersionResource(String, Int32) | Creates a new VersionResource object without any data. The data can be later loaded from a file.
 | VersionResource(String, Int32, array<Byte>[]()[]) | Creates a new VersionResource object with data. The data can be later saved to a file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


VersionResource Constructor (name, locale)

VersionResource Constructor (name, locale)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► VersionResource(String, Int32)
Creates a new VersionResource object without any data. The data can be later loaded from a file.
Declaration Syntax
C# Visual Basic Visual C++
public VersionResource(
    string name,
    int locale
)
Public Sub New ( _
    name As String, _
    locale As Integer _
)
public:
VersionResource(
    String^ name,
    int locale
)
Parameters
name (String)
Name of the resource. For a numeric resource identifier, prefix the decimal number with a "#".
locale (Int32)
Locale of the resource

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


VersionResource Constructor (name, locale, data)

VersionResource Constructor (name, locale, data)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► VersionResource(String, Int32, array<Byte>[]()[])
Creates a new VersionResource object with data. The data can be later saved to a file.
Declaration Syntax
C# Visual Basic Visual C++
public VersionResource(
    string name,
    int locale,
    byte[] data
)
Public Sub New ( _
    name As String, _
    locale As Integer, _
    data As Byte() _
)
public:
VersionResource(
    String^ name,
    int locale,
    array<unsigned char>^ data
)
Parameters
name (String)
Name of the resource. For a numeric resource identifier, prefix the decimal number with a "#".
locale (Int32)
Locale of the resource
data (array< Byte >[]()[])
Raw resource data

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Add Method (locale)

Add Method (locale)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► Add(Int32)
Adds a new version string table for a locale.
Declaration Syntax
C# Visual Basic Visual C++
public VersionStringTable Add(
    int locale
)
Public Function Add ( _
    locale As Integer _
) As VersionStringTable
public:
VersionStringTable^ Add(
    int locale
)
Parameters
locale (Int32)
Locale of the table
Return Value
The new string table, or the existing table if the locale already existed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


BuildTypes Property

BuildTypes Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► BuildTypes
Gets or sets a bitmask that specifies the build types of the file.
Declaration Syntax
C# Visual Basic Visual C++
public VersionBuildTypes BuildTypes { get; set; }
Public Property BuildTypes As VersionBuildTypes
public:
property VersionBuildTypes BuildTypes {
    VersionBuildTypes get ();
    void set (VersionBuildTypes value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Clear Method

Clear Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► Clear()()()
Removes all string tables from the version resource.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Contains Method (locale)

Contains Method (locale)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► Contains(Int32)
Checks if a version string table exists for a given locale.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    int locale
)
Public Function Contains ( _
    locale As Integer _
) As Boolean
public:
bool Contains(
    int locale
)
Parameters
locale (Int32)
Locale to search for
Return Value
True if a string table was found for the locale; false otherwise.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► CopyTo(array<VersionStringTable>[]()[], Int32)
Copies the version string tables to an array, starting at a particular array index.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    VersionStringTable[] array,
    int arrayIndex
)
Public Sub CopyTo ( _
    array As VersionStringTable(), _
    arrayIndex As Integer _
)
public:
virtual void CopyTo(
    array<VersionStringTable^>^ array,
    int arrayIndex
) sealed
Parameters
array (array< VersionStringTable >[]()[])
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
arrayIndex (Int32)
The zero-based index in array at which copying begins.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Count Property

Count Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► Count
Gets the number string tables in the version resource.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Data Property

Data Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► Data
Gets or sets the raw data of the resource. The data is in the format of the VS_VERSIONINFO structure.
Declaration Syntax
C# Visual Basic Visual C++
public override byte[] Data { get; set; }
Public Overrides Property Data As Byte()
public:
virtual property array<unsigned char>^ Data {
    array<unsigned char>^ get () override;
    void set (array<unsigned char>^ value) override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


FileSubtype Property

FileSubtype Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► FileSubtype
Gets or sets the specific type of the file.
Declaration Syntax
C# Visual Basic Visual C++
public VersionFileSubtype FileSubtype { get; set; }
Public Property FileSubtype As VersionFileSubtype
public:
property VersionFileSubtype FileSubtype {
    VersionFileSubtype get ();
    void set (VersionFileSubtype value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


FileType Property

FileType Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► FileType
Gets or sets the general type of the file.
Declaration Syntax
C# Visual Basic Visual C++
public VersionFileType FileType { get; set; }
Public Property FileType As VersionFileType
public:
property VersionFileType FileType {
    VersionFileType get ();
    void set (VersionFileType value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


FileVersion Property

FileVersion Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► FileVersion
Gets or sets the binary locale-independent file version of the version resource.
Declaration Syntax
C# Visual Basic Visual C++
public Version FileVersion { get; set; }
Public Property FileVersion As Version
public:
property Version^ FileVersion {
    Version^ get ();
    void set (Version^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► GetEnumerator()()()
Gets an enumerator that can iterate over the version string tables in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<VersionStringTable> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of VersionStringTable)
public:
virtual IEnumerator<VersionStringTable^>^ GetEnumerator() sealed
Return Value
An enumerator that returns VersionStringTable objects.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Item Property (locale)

Item Property (locale)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► Item[([(Int32])])
Gets the string table for a specific locale, or null if there is no table for that locale.
Declaration Syntax
C# Visual Basic Visual C++
public VersionStringTable this[
    int locale
] { get; }
Public ReadOnly Default Property Item ( _
    locale As Integer _
) As VersionStringTable
public:
property VersionStringTable^ default[int locale] {
    VersionStringTable^ get (int locale);
}
Parameters
locale (Int32)
See Also
Add(Int32)
Remove(Int32)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


ProductVersion Property

ProductVersion Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► ProductVersion
Gets or sets the binary locale-independent product version of the version resource.
Declaration Syntax
C# Visual Basic Visual C++
public Version ProductVersion { get; set; }
Public Property ProductVersion As Version
public:
property Version^ ProductVersion {
    Version^ get ();
    void set (Version^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Remove Method (locale)

Remove Method (locale)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► Remove(Int32)
Removes a version string table for a locale.
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    int locale
)
Public Sub Remove ( _
    locale As Integer _
)
public:
void Remove(
    int locale
)
Parameters
locale (Int32)
Locale of the table

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Timestamp Property

Timestamp Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionResource ► Timestamp
Gets or sets the binary creation date and time.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


VersionStringTable Class

VersionStringTable Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionStringTable
Represents a string table of a file version resource.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class VersionStringTable : IDictionary<string, string>,
    ICollection<KeyValuePair<string, string>>, IEnumerable<KeyValuePair<string, string>>,
    IEnumerable
Public NotInheritable Class VersionStringTable _
    Implements IDictionary(Of String, String),  _
    ICollection(Of KeyValuePair(Of String, String)), IEnumerable(Of KeyValuePair(Of String, String)),  _
    IEnumerable
public ref class VersionStringTable sealed : IDictionary<String^, String^>,
    ICollection<KeyValuePair<String^, String^>>, IEnumerable<KeyValuePair<String^, String^>>,
    IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clear()()() | Removes all strings from the string table.
 | Count | Gets the number of strings in the table.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Gets an enumeration over all strings in the table.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets or sets a string value.
 | Keys | Gets a collection of all the names of the strings in the table.
 | Locale | Gets the locale (LCID) of the string table.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Values | Gets a collection of all the values in the table.
Inheritance Hierarchy
Object
VersionStringTable

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Clear Method

Clear Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionStringTable ► Clear()()()
Removes all strings from the string table.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Count Property

Count Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionStringTable ► Count
Gets the number of strings in the table.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionStringTable ► GetEnumerator()()()
Gets an enumeration over all strings in the table.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<KeyValuePair<string, string>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, String))
public:
virtual IEnumerator<KeyValuePair<String^, String^>>^ GetEnumerator() sealed
Return Value
Enumeration of string name and value pairs

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Item Property (key)

Item Property (key)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionStringTable ► Item[([(String])])
Gets or sets a string value.
Declaration Syntax
C# Visual Basic Visual C++
public string this[
    string key
] { get; set; }
Public Default Property Item ( _
    key As String _
) As String
public:
virtual property String^ default[String^ key] {
    String^ get (String^ key) sealed;
    void set (String^ key, String^ value) sealed;
}
Parameters
key (String)
Name of the string.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Keys Property

Keys Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionStringTable ► Keys
Gets a collection of all the names of the strings in the table.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<string> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of String)
public:
virtual property ICollection<String^>^ Keys {
    ICollection<String^>^ get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Locale Property

Locale Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionStringTable ► Locale
Gets the locale (LCID) of the string table.
Declaration Syntax
C# Visual Basic Visual C++
public int Locale { get; set; }
Public Property Locale As Integer
public:
property int Locale {
    int get ();
    void set (int value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Values Property

Values Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Resources ► VersionStringTable ► Values
Gets a collection of all the values in the table.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<string> Values { get; }
Public ReadOnly Property Values As ICollection(Of String)
public:
virtual property ICollection<String^>^ Values {
    ICollection<String^>^ get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Resources (Module: Microsoft.Deployment.Resources) Version: 3.0.0.0 (3.0.5419.0)


Microsoft.Deployment.WindowsInstaller Namespace

Microsoft.Deployment.WindowsInstaller Namespace
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller
Complete class library for the Windows Installer APIs.
Declaration Syntax
C# Visual Basic Visual C++
namespace Microsoft.Deployment.WindowsInstaller
Namespace Microsoft.Deployment.WindowsInstaller
namespace Microsoft.Deployment.WindowsInstaller
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
 | ActionResult | Specifies a return status value for custom actions.
 | BadQuerySyntaxException | A bad SQL query string was passed to OpenView(String, array<Object>[]()[]) or Execute(String, array<Object>[]()[]).
 | ColumnCollection | Collection of column information related to a TableInfo or View.
 | ColumnInfo | Defines a single column of a table in an installer database.
 | ComponentAttributes | Available values for the Attributes column of the Component table.
 | ComponentInfo | Provides access to information about a component within the context of an installation session.
 | ComponentInfoCollection | Accessor for information about components within the context of an installation session.
 | ComponentInstallation | Represents an instance of a registered component.
 | ControlAttributes | Defines flags for the Attributes column of the Control table.
 | CustomActionAttribute | Marks a method as a custom action entry point.
 | CustomActionData | Contains a collection of key-value pairs suitable for passing between immediate and deferred/rollback/commit custom actions.
 | CustomActionTypes | Defines flags for the Type column of the CustomAction table.
 | Database | Accesses a Windows Installer database.
 | DatabaseOpenMode | Specifies the open mode for a Database.
 | DialogAttributes | Defines flags for the Attributes column of the Dialog table.
 | ExternalUIHandler | Defines a callback function that the installer calls for progress notification and error messages.
 | ExternalUIRecordHandler | [MSI 3.1] Defines a callback function that the installer calls for record-based progress notification and error messages.
 | FeatureAttributes | Available values for the Attributes column of the Feature table.
 | FeatureInfo | Provides access to information about a feature within the context of an installation session.
 | FeatureInfoCollection | Accessor for information about features within the context of an installation session.
 | FeatureInstallation | Represents an instance of a feature of an installed product.
 | FileAttributes | Available values for the Attributes column of the File table.
 | IEmbeddedUI | [MSI 4.5] Interface for an embedded external user interface for an installation.
 | InapplicablePatchHandler | Receives an exception from DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler, String, UserContexts) indicating the reason a particular patch is not applicable to a product.
 | IniFileAction | Defines values for the Action column of the IniFile and RemoveIniFile tables.
 | Installation | Subclasses of this abstract class represent a unique instance of a registered product or patch installation.
 | InstallationPart | Subclasses of this abstract class represent an instance of a registered feature or component.
 | InstallCanceledException | User Canceled the installation.
 | InstallCost | Represents a per-drive disk space cost for an installation.
 | Installer | Provides static methods for installing and configuring products and patches.
 | InstallerException | Base class for Windows Installer exceptions.
 | InstallerHandle | Base class for Windows Installer handle types (Database, View, Record, SummaryInfo).
 | InstallLogModes | Log modes available for EnableLog(InstallLogModes, String) and SetExternalUI(ExternalUIHandler, InstallLogModes).
 | InstallMessage | Type of message to be processed by Message(InstallMessage, Record), ExternalUIHandler, or ExternalUIRecordHandler.
 | InstallMode | Specifies the install mode for ProvideComponent(String, String, String, InstallMode) or ProvideQualifiedComponent(String, String, InstallMode, String).
 | InstallRunMode | Specifies the run mode for GetMode(InstallRunMode).
 | InstallState | Installed state of a Component or Feature.
 | InstallType | Specifies the type of installation for ApplyPatch(String, String, InstallType, String).
 | InstallUIOptions | Level of the installation user interface, specified with SetInternalUI(InstallUIOptions).
 | InvalidHandleException | A method was called on an invalid installer handle. The handle may have been already closed.
 | LocatorTypes | Defines values for the Type column of the CompLocator, IniLocator, and RegLocator tables.
 | MediaDisk | Represents a media disk source of a product or a patch.
 | MergeException | A failure occurred when executing Merge(Database, String). The exception may contain details about the merge conflict.
 | MessageResult | Specifies a return status value for message handlers. These values are returned by Message(InstallMessage, Record), ExternalUIHandler, and ProcessMessage(InstallMessage, Record, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton).
 | PatchInstallation | The Patch object represents a unique instance of a patch that has been registered or applied.
 | PatchStates | Specifies the different patch states for GetPatches(String, String, String, UserContexts, PatchStates).
 | ProductInstallation | Represents a unique instance of a product that is either advertised, installed or unknown.
 | ComponentInstallation..::.Qualifier | Holds data about a component qualifier.
 | Record | The Record object is a container for holding and transferring a variable number of values. Fields within the record are numerically indexed and can contain strings, integers, streams, and null values. Record fields are indexed starting with 1. Field 0 is a special format field.
 | RegistryRoot | Defines values for the Root column of the Registry, RemoveRegistry, and RegLocator tables.
 | ReinstallModes | Specifies the reinstall mode for ReinstallFeature(String, String, ReinstallModes) or ReinstallProduct(String, ReinstallModes).
 | RemoveFileModes | Defines values for the InstallMode column of the RemoveFile table.
 | ServiceAttributes | Defines values for the ServiceType, StartType, and ErrorControl columns of the ServiceInstall table.
 | ServiceControlEvents | Defines values for the Event column of the ServiceControl table.
 | Session | The Session object controls the installation process. It opens the install database, which contains the installation tables and data.
 | ShortcutTarget | Holds information about the target of a shortcut file.
 | SourceList | A list of sources for an installed product or patch.
 | SourceMediaList | A list of source media for an installed product or patch.
 | SummaryInfo | Provides access to summary information of a Windows Installer database.
 | TableCollection | Contains information about all the tables in a Windows Installer database.
 | TableInfo | Defines a table in an installation database.
 | TextStyles | Defines values for the StyleBits column of the TextStyle table.
 | Transaction | [MSI 4.5] Handle to a multi-session install transaction.
 | TransactionAttributes | Attributes for Transaction methods.
 | TransformErrors | Transform error conditions available for CreateTransformSummaryInfo(Database, String, TransformErrors, TransformValidations) or ApplyTransform(String, TransformErrors).
 | TransformValidations | Transform validation flags available for CreateTransformSummaryInfo(Database, String, TransformErrors, TransformValidations).
 | UpgradeAttributes | Defines values for the Attributes column of the Upgrade table.
 | FeatureInstallation..::.UsageData | Holds data about the usage of a feature.
 | UserContexts | Specifies the installation context for ProductInstallations, PatchInstallationes, and DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler, String, UserContexts)
 | ValidationError | Defines the type of error encountered by the Validate(Record), ValidateNew(Record), or ValidateFields(Record) methods of the View class.
 | ValidationErrorInfo | Contains specific information about an error encountered by the Validate(Record), ValidateNew(Record), or ValidateFields(Record) methods of the View class.
 | View | A View represents a result set obtained when processing a query using the OpenView(String, array<Object>[]()[]) method of a Database. Before any data can be transferred, the query must be executed using the Execute(Record) method, passing to it all replaceable parameters designated within the SQL query string.
 | ViewModifyMode | Specifies the modify mode for Modify(ViewModifyMode, Record).


ActionResult Enumeration

ActionResult Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ActionResult
Specifies a return status value for custom actions.
Declaration Syntax
C# Visual Basic Visual C++
public enum ActionResult
Public Enumeration ActionResult
public enum class ActionResult
Members
Member | Description
Success | Action completed successfully.
SkipRemainingActions | Skip remaining actions, not an error.
UserExit | User terminated prematurely.
Failure | Unrecoverable error or unhandled exception occurred.
NotExecuted | Action not executed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


BadQuerySyntaxException Class

BadQuerySyntaxException Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► BadQuerySyntaxException
A bad SQL query string was passed to OpenView(String, array<Object>[]()[]) or Execute(String, array<Object>[]()[]).
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class BadQuerySyntaxException : InstallerException
<SerializableAttribute> _
Public Class BadQuerySyntaxException _
    Inherits InstallerException
[SerializableAttribute]
public ref class BadQuerySyntaxException : public InstallerException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BadQuerySyntaxException(String, Exception) | Creates a new BadQuerySyntaxException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | BadQuerySyntaxException(String) | Creates a new BadQuerySyntaxException with a specified error message.
 | BadQuerySyntaxException()()() | Creates a new BadQuerySyntaxException.
 | BadQuerySyntaxException(SerializationInfo, StreamingContext) | Initializes a new instance of the BadQuerySyntaxException class with serialized data.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorCode | Gets the system error code that resulted in this exception, or 0 if not applicable. (Inherited from InstallerException.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetErrorRecord()()() | Gets extended information about the error, or null if no further information is available. (Inherited from InstallerException.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo with information about the exception. (Inherited from InstallerException.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the exception. This message may contain detailed formatted error data if it was available. (Inherited from InstallerException.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SystemException
 |  |  | InstallerException
 |  |  |  | BadQuerySyntaxException

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


BadQuerySyntaxException Constructor

BadQuerySyntaxException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► BadQuerySyntaxException ► BadQuerySyntaxException()()()
Members
Icon | Member | Description
 | BadQuerySyntaxException(String, Exception) | Creates a new BadQuerySyntaxException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | BadQuerySyntaxException(String) | Creates a new BadQuerySyntaxException with a specified error message.
 | BadQuerySyntaxException()()() | Creates a new BadQuerySyntaxException.
 | BadQuerySyntaxException(SerializationInfo, StreamingContext) | Initializes a new instance of the BadQuerySyntaxException class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


BadQuerySyntaxException Constructor

BadQuerySyntaxException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► BadQuerySyntaxException ► BadQuerySyntaxException()()()
Creates a new BadQuerySyntaxException.
Declaration Syntax
C# Visual Basic Visual C++
public BadQuerySyntaxException()
Public Sub New
public:
BadQuerySyntaxException()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


BadQuerySyntaxException Constructor (info, context)

BadQuerySyntaxException Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► BadQuerySyntaxException ► BadQuerySyntaxException(SerializationInfo, StreamingContext)
Initializes a new instance of the BadQuerySyntaxException class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected BadQuerySyntaxException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
BadQuerySyntaxException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


BadQuerySyntaxException Constructor (msg)

BadQuerySyntaxException Constructor (msg)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► BadQuerySyntaxException ► BadQuerySyntaxException(String)
Creates a new BadQuerySyntaxException with a specified error message.
Declaration Syntax
C# Visual Basic Visual C++
public BadQuerySyntaxException(
    string msg
)
Public Sub New ( _
    msg As String _
)
public:
BadQuerySyntaxException(
    String^ msg
)
Parameters
msg (String)
The message that describes the error.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


BadQuerySyntaxException Constructor (msg, innerException)

BadQuerySyntaxException Constructor (msg, innerException)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► BadQuerySyntaxException ► BadQuerySyntaxException(String, Exception)
Creates a new BadQuerySyntaxException with a specified error message and a reference to the inner exception that is the cause of this exception.
Declaration Syntax
C# Visual Basic Visual C++
public BadQuerySyntaxException(
    string msg,
    Exception innerException
)
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
public:
BadQuerySyntaxException(
    String^ msg,
    Exception^ innerException
)
Parameters
msg (String)
The message that describes the error.
innerException (Exception)
The exception that is the cause of the current exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ColumnCollection Class

ColumnCollection Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection
Collection of column information related to a TableInfo or View.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ColumnCollection : ICollection<ColumnInfo>,
    IEnumerable<ColumnInfo>, IEnumerable
Public NotInheritable Class ColumnCollection _
    Implements ICollection(Of ColumnInfo), IEnumerable(Of ColumnInfo),  _
    IEnumerable
public ref class ColumnCollection sealed : ICollection<ColumnInfo^>,
    IEnumerable<ColumnInfo^>, IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ColumnCollection(ICollection<(Of <(ColumnInfo>)>)) | Creates a new ColumnCollection based on a specified list of columns.
 | Add(ColumnInfo) | Not supported because the collection is read-only.
 | Clear()()() | Not supported because the collection is read-only.
 | Contains(String) | Checks if a column with a given name exists in the collection.
 | CopyTo(array<ColumnInfo>[]()[], Int32) | Copies the columns from this collection into an array.
 | Count | Gets the number of columns in the collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatString | Gets a string suitable for printing all the values of a record containing these columns.
 | GetEnumerator()()() | Gets an enumerator over the columns in the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(String) | Gets the index of a column within the collection.
 | IsReadOnly | Gets a boolean value indicating whether the collection is read-only. A ColumnCollection is read-only if it is associated with a View or a read-only Database.
 | Item[([(Int32])]) | Gets information about a specific column in the collection.
 | Item[([(String])]) | Gets information about a specific column in the collection.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ColumnCollection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ColumnCollection Constructor (columns)

ColumnCollection Constructor (columns)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► ColumnCollection(ICollection<(Of <(ColumnInfo>)>))
Creates a new ColumnCollection based on a specified list of columns.
Declaration Syntax
C# Visual Basic Visual C++
public ColumnCollection(
    ICollection<ColumnInfo> columns
)
Public Sub New ( _
    columns As ICollection(Of ColumnInfo) _
)
public:
ColumnCollection(
    ICollection<ColumnInfo^>^ columns
)
Parameters
columns (ICollection <(Of <( ColumnInfo >)>))
columns to be added to the new collection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Add Method (item)

Add Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► Add(ColumnInfo)
Not supported because the collection is read-only.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    ColumnInfo item
)
Public Sub Add ( _
    item As ColumnInfo _
)
public:
virtual void Add(
    ColumnInfo^ item
) sealed
Parameters
item (ColumnInfo)
information about the column being added
Exceptions
Exception | Condition
InvalidOperationException | the collection is read-only

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Clear Method

Clear Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► Clear()()()
Not supported because the collection is read-only.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
Exceptions
Exception | Condition
InvalidOperationException | the collection is read-only

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Contains Method (columnName)

Contains Method (columnName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► Contains(String)
Checks if a column with a given name exists in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string columnName
)
Public Function Contains ( _
    columnName As String _
) As Boolean
public:
bool Contains(
    String^ columnName
)
Parameters
columnName (String)
case-sensitive name of the column to look for
Return Value
true if the column exists in the collection, false otherwise

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► CopyTo(array<ColumnInfo>[]()[], Int32)
Copies the columns from this collection into an array.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ColumnInfo[] array,
    int arrayIndex
)
Public Sub CopyTo ( _
    array As ColumnInfo(), _
    arrayIndex As Integer _
)
public:
virtual void CopyTo(
    array<ColumnInfo^>^ array,
    int arrayIndex
) sealed
Parameters
array (array< ColumnInfo >[]()[])
destination array to be filed
arrayIndex (Int32)
offset into the destination array where copying begins

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Count Property

Count Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► Count
Gets the number of columns in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}
Value
number of columns in the collection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FormatString Property

FormatString Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► FormatString
Gets a string suitable for printing all the values of a record containing these columns.
Declaration Syntax
C# Visual Basic Visual C++
public string FormatString { get; }
Public ReadOnly Property FormatString As String
public:
property String^ FormatString {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► GetEnumerator()()()
Gets an enumerator over the columns in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<ColumnInfo> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of ColumnInfo)
public:
virtual IEnumerator<ColumnInfo^>^ GetEnumerator() sealed
Return Value
An enumerator of ColumnInfo objects.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IndexOf Method (columnName)

IndexOf Method (columnName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► IndexOf(String)
Gets the index of a column within the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    string columnName
)
Public Function IndexOf ( _
    columnName As String _
) As Integer
public:
int IndexOf(
    String^ columnName
)
Parameters
columnName (String)
case-sensitive name of the column to look for
Return Value
0-based index of the column, or -1 if not found

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsReadOnly Property

IsReadOnly Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► IsReadOnly
Gets a boolean value indicating whether the collection is read-only. A ColumnCollection is read-only if it is associated with a View or a read-only Database.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
Value
read-only status of the collection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property

Item Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets information about a specific column in the collection.
 | Item[([(String])]) | Gets information about a specific column in the collection.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (columnIndex)

Item Property (columnIndex)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► Item[([(Int32])])
Gets information about a specific column in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public ColumnInfo this[
    int columnIndex
] { get; }
Public ReadOnly Default Property Item ( _
    columnIndex As Integer _
) As ColumnInfo
public:
property ColumnInfo^ default[int columnIndex] {
    ColumnInfo^ get (int columnIndex);
}
Parameters
columnIndex (Int32)
1-based index into the column collection
Exceptions
Exception | Condition
ArgumentOutOfRangeException | columnIndex is less than 1 or greater than the number of columns in the collection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (columnName)

Item Property (columnName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnCollection ► Item[([(String])])
Gets information about a specific column in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public ColumnInfo this[
    string columnName
] { get; }
Public ReadOnly Default Property Item ( _
    columnName As String _
) As ColumnInfo
public:
property ColumnInfo^ default[String^ columnName] {
    ColumnInfo^ get (String^ columnName);
}
Parameters
columnName (String)
case-sensitive name of a column collection
Exceptions
Exception | Condition
ArgumentOutOfRangeException | columnName does not exist in the collection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ColumnInfo Class

ColumnInfo Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo
Defines a single column of a table in an installer database.
Declaration Syntax
C# Visual Basic Visual C++
public class ColumnInfo
Public Class ColumnInfo
public ref class ColumnInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ColumnInfo(String, String) | Creates a new ColumnInfo object from a column definition.
 | ColumnInfo(String, Type, Int32, Boolean) | Creates a new ColumnInfo object from a list of parameters.
 | ColumnInfo(String, Type, Int32, Boolean, Boolean, Boolean) | Creates a new ColumnInfo object from a list of parameters.
 | ColumnDefinitionString | Gets a short string defining the type and size of the column.
 | DBType | Gets the type of the column as a System.Data.DbType. This is one of the following: Int16, Int32, String, or Binary
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLocalizable | Gets a value indicating whether the column is a string column that is localizable.
 | IsRequired | Gets a value indicating whether the column must be non-null when inserting a record.
 | IsTemporary | Gets a value indicating whether the column is temporary. Temporary columns are not persisted when the database is saved to disk.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the column.
 | Size | Gets the size of the column.
 | SqlCreateString | Gets an SQL fragment that can be used to create this column within a CREATE TABLE statement.
 | ToString()()() | Gets the name of the column. (Overrides Object.ToString()()().)
 | Type | Gets the type of the column as a System.Type. This is one of the following: Int16, Int32, String, or Stream
Remarks
Once created, a ColumnInfo object is immutable.
Inheritance Hierarchy
Object
ColumnInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ColumnInfo Constructor

ColumnInfo Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► ColumnInfo()()()
Members
Icon | Member | Description
 | ColumnInfo(String, String) | Creates a new ColumnInfo object from a column definition.
 | ColumnInfo(String, Type, Int32, Boolean) | Creates a new ColumnInfo object from a list of parameters.
 | ColumnInfo(String, Type, Int32, Boolean, Boolean, Boolean) | Creates a new ColumnInfo object from a list of parameters.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ColumnInfo Constructor (name, columnDefinition)

ColumnInfo Constructor (name, columnDefinition)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► ColumnInfo(String, String)
Creates a new ColumnInfo object from a column definition.
Declaration Syntax
C# Visual Basic Visual C++
public ColumnInfo(
    string name,
    string columnDefinition
)
Public Sub New ( _
    name As String, _
    columnDefinition As String _
)
public:
ColumnInfo(
    String^ name,
    String^ columnDefinition
)
Parameters
name (String)
name of the column
columnDefinition (String)
column definition string
See Also
ColumnDefinitionString

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ColumnInfo Constructor (name, type, size, isRequired)

ColumnInfo Constructor (name, type, size, isRequired)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► ColumnInfo(String, Type, Int32, Boolean)
Creates a new ColumnInfo object from a list of parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ColumnInfo(
    string name,
    Type type,
    int size,
    bool isRequired
)
Public Sub New ( _
    name As String, _
    type As Type, _
    size As Integer, _
    isRequired As Boolean _
)
public:
ColumnInfo(
    String^ name,
    Type^ type,
    int size,
    bool isRequired
)
Parameters
name (String)
name of the column
type (Type)
type of the column; must be one of the following: Int16, Int32, String, or Stream
size (Int32)
the maximum number of characters for String columns; ignored for other column types
isRequired (Boolean)
true if the column is required to have a non-null value

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ColumnInfo Constructor (name, type, size, isRequired, isTemporary, isLocalizable)

ColumnInfo Constructor (name, type, size, isRequired, isTemporary, isLocalizable)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► ColumnInfo(String, Type, Int32, Boolean, Boolean, Boolean)
Creates a new ColumnInfo object from a list of parameters.
Declaration Syntax
C# Visual Basic Visual C++
public ColumnInfo(
    string name,
    Type type,
    int size,
    bool isRequired,
    bool isTemporary,
    bool isLocalizable
)
Public Sub New ( _
    name As String, _
    type As Type, _
    size As Integer, _
    isRequired As Boolean, _
    isTemporary As Boolean, _
    isLocalizable As Boolean _
)
public:
ColumnInfo(
    String^ name,
    Type^ type,
    int size,
    bool isRequired,
    bool isTemporary,
    bool isLocalizable
)
Parameters
name (String)
name of the column
type (Type)
type of the column; must be one of the following: Int16, Int32, String, or Stream
size (Int32)
the maximum number of characters for String columns; ignored for other column types
isRequired (Boolean)
true if the column is required to have a non-null value
isTemporary (Boolean)
true to if the column is only in-memory and not persisted with the database
isLocalizable (Boolean)
for String columns, indicates the column is localizable; ignored for other column types

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ColumnDefinitionString Property

ColumnDefinitionString Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► ColumnDefinitionString
Gets a short string defining the type and size of the column.
Declaration Syntax
C# Visual Basic Visual C++
public string ColumnDefinitionString { get; }
Public ReadOnly Property ColumnDefinitionString As String
public:
property String^ ColumnDefinitionString {
    String^ get ();
}
Value
The definition string consists of a single letter representing the data type followed by the width of the column (in characters when applicable, bytes otherwise). A width of zero designates an unbounded width (for example, long text fields and streams). An uppercase letter indicates that null values are allowed in the column.
Remarks

s? - String, variable length (?=1-255) s0 - String, variable length i2 - Short integer i4 - Long integer v0 - Binary Stream g? - Temporary string (?=0-255) j? - Temporary integer (?=0,1,2,4) l? - Localizable string, variable length (?=1-255) l0 - Localizable string, variable length

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DBType Property

DBType Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► DBType
Gets the type of the column as a System.Data.DbType. This is one of the following: Int16, Int32, String, or Binary
Declaration Syntax
C# Visual Basic Visual C++
public DbType DBType { get; }
Public ReadOnly Property DBType As DbType
public:
property DbType DBType {
    DbType get ();
}
Value
equivalent DbType of the column

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsLocalizable Property

IsLocalizable Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► IsLocalizable
Gets a value indicating whether the column is a string column that is localizable.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLocalizable { get; }
Public ReadOnly Property IsLocalizable As Boolean
public:
property bool IsLocalizable {
    bool get ();
}
Value
localizable status of the column

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsRequired Property

IsRequired Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► IsRequired
Gets a value indicating whether the column must be non-null when inserting a record.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsRequired { get; }
Public ReadOnly Property IsRequired As Boolean
public:
property bool IsRequired {
    bool get ();
}
Value
required status of the column

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsTemporary Property

IsTemporary Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► IsTemporary
Gets a value indicating whether the column is temporary. Temporary columns are not persisted when the database is saved to disk.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTemporary { get; }
Public ReadOnly Property IsTemporary As Boolean
public:
property bool IsTemporary {
    bool get ();
}
Value
temporary status of the column

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Name Property

Name Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► Name
Gets the name of the column.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}
Value
name of the column

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Size Property

Size Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► Size
Gets the size of the column.
Declaration Syntax
C# Visual Basic Visual C++
public int Size { get; }
Public ReadOnly Property Size As Integer
public:
property int Size {
    int get ();
}
Value
The size of integer columns this is either 2 or 4. For string columns this is the maximum recommended length of the string, or 0 for unlimited length. For stream columns, 0 is returned.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SqlCreateString Property

SqlCreateString Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► SqlCreateString
Gets an SQL fragment that can be used to create this column within a CREATE TABLE statement.
Declaration Syntax
C# Visual Basic Visual C++
public string SqlCreateString { get; }
Public ReadOnly Property SqlCreateString As String
public:
property String^ SqlCreateString {
    String^ get ();
}
Value
SQL fragment to be used for creating the column
Remarks

Examples:

  • LONG
  • SHORT TEMPORARY
  • CHAR(0) LOCALIZABLE
  • CHAR(72) NOT NULL LOCALIZABLE
  • OBJECT

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ToString Method

ToString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► ToString()()()
Gets the name of the column.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
Name of the column.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Type Property

Type Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ColumnInfo ► Type
Gets the type of the column as a System.Type. This is one of the following: Int16, Int32, String, or Stream
Declaration Syntax
C# Visual Basic Visual C++
public Type Type { get; }
Public ReadOnly Property Type As Type
public:
property Type^ Type {
    Type^ get ();
}
Value
type of the column

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ComponentAttributes Enumeration

ComponentAttributes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentAttributes
Available values for the Attributes column of the Component table.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum ComponentAttributes
<FlagsAttribute> _
Public Enumeration ComponentAttributes
[FlagsAttribute]
public enum class ComponentAttributes
Members
Member | Description
None | Local only - Component cannot be run from source.
SourceOnly | Component can only be run from source.
Optional | Component can run locally or from source.
RegistryKeyPath | If this bit is set, the value in the KeyPath column is used as a key into the Registry table.
SharedDllRefCount | If this bit is set, the installer increments the reference count in the shared DLL registry of the component's key file. If this bit is not set, the installer increments the reference count only if the reference count already exists.
Permanent | If this bit is set, the installer does not remove the component during an uninstall. The installer registers an extra system client for the component in the Windows Installer registry settings.
OdbcDataSource | If this bit is set, the value in the KeyPath column is a key into the ODBCDataSource table.
Transitive | If this bit is set, the installer reevaluates the value of the statement in the Condition column upon a reinstall. If the value was previously False and has changed to true, the installer installs the component. If the value was previously true and has changed to false, the installer removes the component even if the component has other products as clients.
NeverOverwrite | If this bit is set, the installer does not install or reinstall the component if a key path file or a key path registry entry for the component already exists. The application does register itself as a client of the component.
SixtyFourBit | Set this bit to mark this as a 64-bit component. This attribute facilitates the installation of packages that include both 32-bit and 64-bit components. If this bit is not set, the component is registered as a 32-bit component.
DisableRegistryReflection | Set this bit to disable registry reflection on all existing and new registry keys affected by this component.
UninstallOnSupersedence | [MSI 4.5] Set this bit for a component in a patch package to prevent leaving orphan components on the computer.
Shared | [MSI 4.5] If a component is marked with this attribute value in at least one package installed on the system, the installer treats the component as marked in all packages. If a package that shares the marked component is uninstalled, Windows Installer 4.5 can continue to share the highest version of the component on the system, even if that highest version was installed by the package that is being uninstalled.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ComponentInfo Class

ComponentInfo Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInfo
Provides access to information about a component within the context of an installation session.
Declaration Syntax
C# Visual Basic Visual C++
public class ComponentInfo
Public Class ComponentInfo
public ref class ComponentInfo
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CurrentState | Gets the current install state of the designated Component.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCost(InstallState) | Gets disk space per drive required to install a component.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the component (primary key in the Component table).
 | RequestState | Gets or sets the action state of the designated Component.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ComponentInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CurrentState Property

CurrentState Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInfo ► CurrentState
Gets the current install state of the designated Component.
Declaration Syntax
C# Visual Basic Visual C++
public InstallState CurrentState { get; }
Public ReadOnly Property CurrentState As InstallState
public:
property InstallState CurrentState {
    InstallState get ();
}
Remarks

Win32 MSI API: MsiGetComponentState

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
ArgumentException | an unknown Component was requested

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetCost Method (installState)

GetCost Method (installState)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInfo ► GetCost(InstallState)
Gets disk space per drive required to install a component.
Declaration Syntax
C# Visual Basic Visual C++
public IList<InstallCost> GetCost(
    InstallState installState
)
Public Function GetCost ( _
    installState As InstallState _
) As IList(Of InstallCost)
public:
IList<InstallCost>^ GetCost(
    InstallState installState
)
Parameters
installState (InstallState)
Requested component state
Return Value
A list of InstallCost structures, specifying the cost for each drive for the component
Remarks

Win32 MSI API: MsiEnumComponentCosts

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Name Property

Name Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInfo ► Name
Gets the name of the component (primary key in the Component table).
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


RequestState Property

RequestState Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInfo ► RequestState
Gets or sets the action state of the designated Component.
Declaration Syntax
C# Visual Basic Visual C++
public InstallState RequestState { get; set; }
Public Property RequestState As InstallState
public:
property InstallState RequestState {
    InstallState get ();
    void set (InstallState value);
}
Remarks

Win32 MSI APIs: MsiGetComponentState, MsiSetComponentState

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
ArgumentException | an unknown Component was requested
InstallCanceledException | the user exited the installation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ComponentInfoCollection Class

ComponentInfoCollection Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInfoCollection
Accessor for information about components within the context of an installation session.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ComponentInfoCollection : ICollection<ComponentInfo>,
    IEnumerable<ComponentInfo>, IEnumerable
Public NotInheritable Class ComponentInfoCollection _
    Implements ICollection(Of ComponentInfo), IEnumerable(Of ComponentInfo),  _
    IEnumerable
public ref class ComponentInfoCollection sealed : ICollection<ComponentInfo^>,
    IEnumerable<ComponentInfo^>, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Contains(String) | Checks if the collection contains a component.
 | CopyTo(array<ComponentInfo>[]()[], Int32) | Copies the features into an array.
 | Count | Gets the number of components defined for the product.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Enumerates the components in the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets information about a component within the context of an installation session.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ComponentInfoCollection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Contains Method (component)

Contains Method (component)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInfoCollection ► Contains(String)
Checks if the collection contains a component.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string component
)
Public Function Contains ( _
    component As String _
) As Boolean
public:
bool Contains(
    String^ component
)
Parameters
component (String)
name of the component
Return Value
true if the component is in the collection, else false

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInfoCollection ► CopyTo(array<ComponentInfo>[]()[], Int32)
Copies the features into an array.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ComponentInfo[] array,
    int arrayIndex
)
Public Sub CopyTo ( _
    array As ComponentInfo(), _
    arrayIndex As Integer _
)
public:
virtual void CopyTo(
    array<ComponentInfo^>^ array,
    int arrayIndex
) sealed
Parameters
array (array< ComponentInfo >[]()[])
array that receives the features
arrayIndex (Int32)
offset into the array

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Count Property

Count Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInfoCollection ► Count
Gets the number of components defined for the product.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInfoCollection ► GetEnumerator()()()
Enumerates the components in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<ComponentInfo> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of ComponentInfo)
public:
virtual IEnumerator<ComponentInfo^>^ GetEnumerator() sealed
Return Value
an enumerator over all features in the collection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (component)

Item Property (component)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInfoCollection ► Item[([(String])])
Gets information about a component within the context of an installation session.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInfo this[
    string component
] { get; }
Public ReadOnly Default Property Item ( _
    component As String _
) As ComponentInfo
public:
property ComponentInfo^ default[String^ component] {
    ComponentInfo^ get (String^ component);
}
Parameters
component (String)
name of the component
Return Value
component object

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ComponentInstallation Class

ComponentInstallation Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation
Represents an instance of a registered component.
Declaration Syntax
C# Visual Basic Visual C++
public class ComponentInstallation : InstallationPart
Public Class ComponentInstallation _
    Inherits InstallationPart
public ref class ComponentInstallation : public InstallationPart
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComponentInstallation(String) | Creates a new ComponentInstallation, automatically detecting the product that the component is a part of.
 | ComponentInstallation(String, String) | Creates a new ComponentInstallation for a component installed by a specific product.
 | AllComponents | Gets the set of installed components for all products.
 | ClientProducts | Gets all client products of a specified component.
 | ComponentCode | Gets the component code (GUID) of the component.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Gets the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
 | Product | Gets the product that this item is a part of. (Inherited from InstallationPart.)
 | Qualifiers | Gets the set of registered qualifiers for the component.
 | State | Gets the installed state of a component. (Overrides InstallationPart.State.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | InstallationPart
 |  | ComponentInstallation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ComponentInstallation Constructor

ComponentInstallation Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation ► ComponentInstallation()()()
Members
Icon | Member | Description
 | ComponentInstallation(String) | Creates a new ComponentInstallation, automatically detecting the product that the component is a part of.
 | ComponentInstallation(String, String) | Creates a new ComponentInstallation for a component installed by a specific product.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ComponentInstallation Constructor (componentCode)

ComponentInstallation Constructor (componentCode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation ► ComponentInstallation(String)
Creates a new ComponentInstallation, automatically detecting the product that the component is a part of.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInstallation(
    string componentCode
)
Public Sub New ( _
    componentCode As String _
)
public:
ComponentInstallation(
    String^ componentCode
)
Parameters
componentCode (String)
component GUID
Remarks

Win32 MSI API: MsiGetProductCode

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ComponentInstallation Constructor (componentCode, productCode)

ComponentInstallation Constructor (componentCode, productCode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation ► ComponentInstallation(String, String)
Creates a new ComponentInstallation for a component installed by a specific product.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInstallation(
    string componentCode,
    string productCode
)
Public Sub New ( _
    componentCode As String, _
    productCode As String _
)
public:
ComponentInstallation(
    String^ componentCode,
    String^ productCode
)
Parameters
componentCode (String)
component GUID
productCode (String)
ProductCode GUID

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AllComponents Property

AllComponents Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation ► AllComponents
Gets the set of installed components for all products.
Declaration Syntax
C# Visual Basic Visual C++
public static IEnumerable<ComponentInstallation> AllComponents { get; }
Public Shared ReadOnly Property AllComponents As IEnumerable(Of ComponentInstallation)
public:
static property IEnumerable<ComponentInstallation^>^ AllComponents {
    IEnumerable<ComponentInstallation^>^ get ();
}
Remarks

Win32 MSI API: MsiEnumComponents

Exceptions
Exception | Condition
InstallerException | The installer configuration data is corrupt

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ClientProducts Property

ClientProducts Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation ► ClientProducts
Gets all client products of a specified component.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<ProductInstallation> ClientProducts { get; }
Public ReadOnly Property ClientProducts As IEnumerable(Of ProductInstallation)
public:
property IEnumerable<ProductInstallation^>^ ClientProducts {
    IEnumerable<ProductInstallation^>^ get ();
}
Return Value
enumeration over all client products of the component
Remarks

Because clients are not ordered, any new component has an arbitrary index. This means that the property may return clients in any order.

Win32 MSI API: MsiEnumClients

Exceptions
Exception | Condition
InstallerException | The installer configuration data is corrupt

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ComponentCode Property

ComponentCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation ► ComponentCode
Gets the component code (GUID) of the component.
Declaration Syntax
C# Visual Basic Visual C++
public string ComponentCode { get; }
Public ReadOnly Property ComponentCode As String
public:
property String^ ComponentCode {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Path Property

Path Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation ► Path
Gets the full path to an installed component. If the key path for the component is a registry key then the registry key is returned.
Declaration Syntax
C# Visual Basic Visual C++
public string Path { get; }
Public ReadOnly Property Path As String
public:
property String^ Path {
    String^ get ();
}
Return Value
The file or registry keypath to the component, or null if the component is not available.
Remarks

If the component is a registry key, the registry roots are represented numerically. For example, a registry path of "HKEY_CURRENT_USER\SOFTWARE\Microsoft" would be returned as "01:\SOFTWARE\Microsoft". The registry roots returned are defined as follows: HKEY_CLASSES_ROOT=00, HKEY_CURRENT_USER=01, HKEY_LOCAL_MACHINE=02, HKEY_USERS=03, HKEY_PERFORMANCE_DATA=04

Win32 MSI APIs: MsiGetComponentPath, MsiLocateComponent

Exceptions
Exception | Condition
ArgumentException | An unknown product or component was specified
InstallerException | The installer configuration data is corrupt

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Qualifiers Property

Qualifiers Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation ► Qualifiers
Gets the set of registered qualifiers for the component.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<ComponentInstallation..::.Qualifier> Qualifiers { get; }
Public ReadOnly Property Qualifiers As IEnumerable(Of ComponentInstallation..::.Qualifier)
public:
property IEnumerable<ComponentInstallation..::.Qualifier>^ Qualifiers {
    IEnumerable<ComponentInstallation..::.Qualifier>^ get ();
}
Return Value
Enumeration of the qulifiers for the component.
Remarks

Because qualifiers are not ordered, any new qualifier has an arbitrary index, meaning the function can return qualifiers in any order.

Win32 MSI API: MsiEnumComponentQualifiers

Exceptions
Exception | Condition
InstallerException | The installer configuration data is corrupt

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


State Property

State Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation ► State
Gets the installed state of a component.
Declaration Syntax
C# Visual Basic Visual C++
public override InstallState State { get; }
Public Overrides ReadOnly Property State As InstallState
public:
virtual property InstallState State {
    InstallState get () override;
}
Return Value
the installed state of the component, or InstallState.Unknown if this component is not part of a product
Remarks

Win32 MSI API: MsiGetComponentPath

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ComponentInstallation.Qualifier Structure

ComponentInstallation..::.Qualifier Structure
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation ► ComponentInstallation..::.Qualifier
Holds data about a component qualifier.
Declaration Syntax
C# Visual Basic Visual C++
public struct Qualifier
Public Structure Qualifier
public value class Qualifier
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Data | Gets the qualifier data.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | QualifierCode | Gets the qualifier code.
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Remarks

Win32 MSI API: MsiEnumComponentQualifiers

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Data Property

Data Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation..::.Qualifier ► Data
Gets the qualifier data.
Declaration Syntax
C# Visual Basic Visual C++
public string Data { get; }
Public ReadOnly Property Data As String
public:
property String^ Data {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


QualifierCode Property

QualifierCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ComponentInstallation..::.Qualifier ► QualifierCode
Gets the qualifier code.
Declaration Syntax
C# Visual Basic Visual C++
public string QualifierCode { get; }
Public ReadOnly Property QualifierCode As String
public:
property String^ QualifierCode {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ControlAttributes Enumeration

ControlAttributes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ControlAttributes
Defines flags for the Attributes column of the Control table.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum ControlAttributes
<FlagsAttribute> _
Public Enumeration ControlAttributes
[FlagsAttribute]
public enum class ControlAttributes
Members
Member | Description
Visible | If this bit is set, the control is visible on the dialog box.
Enabled | specifies if the given control is enabled or disabled. Most controls appear gray when disabled.
Sunken | If this bit is set, the control is displayed with a sunken, three dimensional look.
Indirect | The Indirect control attribute specifies whether the value displayed or changed by this control is referenced indirectly.
Integer | If this bit is set on a control, the associated property specified in the Property column of the Control table is an integer.
RightToLeftReadingOrder | If this bit is set the text in the control is displayed in a right-to-left reading order.
RightAligned | If this style bit is set, text in the control is aligned to the right.
LeftScroll | If this bit is set, the scroll bar is located on the left side of the control, otherwise it is on the right.
Bidirectional | This is a combination of the RightToLeftReadingOrder, RightAligned, and LeftScroll attributes.
Transparent | If this bit is set on a text control, the control is displayed transparently with the background showing through the control where there are no characters.
NoPrefix | If this bit is set on a text control, the occurrence of the character "&" in a text string is displayed as itself.
NoWrap | If this bit is set the text in the control is displayed on a single line.
FormatSize | If this bit is set for a text control, the control will automatically attempt to format the displayed text as a number representing a count of bytes.
UsersLanguage | If this bit is set, fonts are created using the user's default UI code page. Otherwise it is created using the database code page.
Multiline | If this bit is set on an Edit control, the installer creates a multiple line edit control with a vertical scroll bar.
PasswordInput | This attribute creates an edit control for entering passwords. The control displays each character as an asterisk (*) as they are typed into the control.
Progress95 | If this bit is set on a ProgressBar control, the bar is drawn as a series of small rectangles in Microsoft Windows 95-style. Otherwise it is drawn as a single continuous rectangle.
RemovableVolume | If this bit is set, the control shows removable volumes.
FixedVolume | If this bit is set, the control shows fixed internal hard drives.
RemoteVolume | If this bit is set, the control shows remote volumes.
CdromVolume | If this bit is set, the control shows CD-ROM volumes.
RamDiskVolume | If this bit is set, the control shows RAM disk volumes.
FloppyVolume | If this bit is set, the control shows floppy volumes.
ShowRollbackCost | Specifies whether or not the rollback backup files are included in the costs displayed by the VolumeCostList control.
Sorted | If this bit is set, the items listed in the control are displayed in a specified order. Otherwise, items are displayed in alphabetical order.
ComboList | If this bit is set on a combo box, the edit field is replaced by a static text field. This prevents a user from entering a new value and requires the user to choose only one of the predefined values.
PushLike | If this bit is set on a check box or a radio button group, the button is drawn with the appearance of a push button, but its logic stays the same.
Bitmap | If this bit is set, the text in the control is replaced by a bitmap image. The Text column in the Control table is a foreign key into the Binary table.
Icon | If this bit is set, text is replaced by an icon image and the Text column in the Control table is a foreign key into the Binary table.
FixedSize | If this bit is set, the picture is cropped or centered in the control without changing its shape or size.
IconSize16 | Specifies which size of the icon image to load. If none of the bits are set, the first image is loaded.
IconSize32 | Specifies which size of the icon image to load. If none of the bits are set, the first image is loaded.
IconSize48 | Specifies which size of the icon image to load. If none of the bits are set, the first image is loaded.
ElevationShield | If this bit is set, and the installation is not yet running with elevated privileges, the control is created with a UAC icon.
HasBorder | If this bit is set, the RadioButtonGroup has text and a border displayed around it.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CustomActionAttribute Class

CustomActionAttribute Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionAttribute
Marks a method as a custom action entry point.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CustomActionAttribute : Attribute
<SerializableAttribute> _
Public NotInheritable Class CustomActionAttribute _
    Inherits Attribute
[SerializableAttribute]
public ref class CustomActionAttribute sealed : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomActionAttribute()()() | Marks a method as a custom action entry point.
 | CustomActionAttribute(String) | Marks a method as a custom action entry point.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name of the custom action entrypoint. A null value defaults to the name of the method.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Remarks

A custom action method must be defined as public and static, take a single Session object as a parameter, and return an ActionResult enumeration value.

Inheritance Hierarchy
Object
 | Attribute
 |  | CustomActionAttribute

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CustomActionAttribute Constructor

CustomActionAttribute Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionAttribute ► CustomActionAttribute()()()
Members
Icon | Member | Description
 | CustomActionAttribute()()() | Marks a method as a custom action entry point.
 | CustomActionAttribute(String) | Marks a method as a custom action entry point.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CustomActionAttribute Constructor

CustomActionAttribute Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionAttribute ► CustomActionAttribute()()()
Marks a method as a custom action entry point.
Declaration Syntax
C# Visual Basic Visual C++
public CustomActionAttribute()
Public Sub New
public:
CustomActionAttribute()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CustomActionAttribute Constructor (name)

CustomActionAttribute Constructor (name)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionAttribute ► CustomActionAttribute(String)
Marks a method as a custom action entry point.
Declaration Syntax
C# Visual Basic Visual C++
public CustomActionAttribute(
    string name
)
Public Sub New ( _
    name As String _
)
public:
CustomActionAttribute(
    String^ name
)
Parameters
name (String)
Name of the function to be exported, defaults to the name of this method

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Name Property

Name Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionAttribute ► Name
Gets or sets the name of the custom action entrypoint. A null value defaults to the name of the method.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}
Value
name of the custom action entrypoint, or null if none was specified

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CustomActionData Class

CustomActionData Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData
Contains a collection of key-value pairs suitable for passing between immediate and deferred/rollback/commit custom actions.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class CustomActionData : IDictionary<string, string>,
    ICollection<KeyValuePair<string, string>>, IEnumerable<KeyValuePair<string, string>>,
    IEnumerable
Public NotInheritable Class CustomActionData _
    Implements IDictionary(Of String, String),  _
    ICollection(Of KeyValuePair(Of String, String)), IEnumerable(Of KeyValuePair(Of String, String)),  _
    IEnumerable
public ref class CustomActionData sealed : IDictionary<String^, String^>,
    ICollection<KeyValuePair<String^, String^>>, IEnumerable<KeyValuePair<String^, String^>>,
    IEnumerable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomActionData()()() | Creates a new empty custom action data object.
 | CustomActionData(String) | Reconstructs a custom action data object from data that was previously persisted in a string.
 | Add(String, String) | Adds a key and value to the data collection.
 | Add(KeyValuePair<(Of <(String, String>)>)) | Adds an item with key and value to the data collection.
 | AddObject<(Of <(T>)>)(String, T) | Adds a value to the data collection, using XML serialization to persist the object as a string.
 | Clear()()() | Removes all items from the data.
 | Contains(KeyValuePair<(Of <(String, String>)>)) | Determines whether the data contains a specified item.
 | ContainsKey(String) | Determines whether the data contains an item with the specified key.
 | CopyTo(array<KeyValuePair<(Of <(String, String>)>)>[]()[], Int32) | Copies the data to an array, starting at a particular array index.
 | Count | Gets the number of items in the data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObject<(Of <(T>)>)(String) | Gets a value from the data collection, using XML serialization to load the object from a string.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsReadOnly | Gets a value indicating whether the data is read-only.
 | Item[([(String])]) | Gets or sets a data value with a specified key.
 | Keys | Gets a collection object containing all the keys of the data.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PropertyName | "CustomActionData" literal property name.
 | Remove(String) | Removes the item with the specified key from the data.
 | Remove(KeyValuePair<(Of <(String, String>)>)) | Removes an item from the data.
 | ToString()()() | Gets a string representation of the data suitable for persisting in a property. (Overrides Object.ToString()()().)
 | TryGetValue(String, String%) | Gets the value with the specified key.
 | Values | Gets a collection containing all the values of the data.
Remarks
Call the ToString()()() method to get a string suitable for storing in a property and reconstructing the custom action data later.
Inheritance Hierarchy
Object
CustomActionData
See Also
CustomActionData
DoAction(String, CustomActionData)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CustomActionData Constructor

CustomActionData Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► CustomActionData()()()
Members
Icon | Member | Description
 | CustomActionData()()() | Creates a new empty custom action data object.
 | CustomActionData(String) | Reconstructs a custom action data object from data that was previously persisted in a string.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CustomActionData Constructor

CustomActionData Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► CustomActionData()()()
Creates a new empty custom action data object.
Declaration Syntax
C# Visual Basic Visual C++
public CustomActionData()
Public Sub New
public:
CustomActionData()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CustomActionData Constructor (keyValueList)

CustomActionData Constructor (keyValueList)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► CustomActionData(String)
Reconstructs a custom action data object from data that was previously persisted in a string.
Declaration Syntax
C# Visual Basic Visual C++
public CustomActionData(
    string keyValueList
)
Public Sub New ( _
    keyValueList As String _
)
public:
CustomActionData(
    String^ keyValueList
)
Parameters
keyValueList (String)
Previous output from ToString()()().

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Add Method

Add Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► Add()()()
Members
Icon | Member | Description
 | Add(String, String) | Adds a key and value to the data collection.
 | Add(KeyValuePair<(Of <(String, String>)>)) | Adds an item with key and value to the data collection.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Add Method (item)

Add Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► Add(KeyValuePair<(Of <(String, String>)>))
Adds an item with key and value to the data collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    KeyValuePair<string, string> item
)
Public Sub Add ( _
    item As KeyValuePair(Of String, String) _
)
public:
virtual void Add(
    KeyValuePair<String^, String^> item
) sealed
Parameters
item (KeyValuePair <(Of <( String, String >)>))
Case-sensitive data key, with a data value that may be null.
Exceptions
Exception | Condition
ArgumentException | the key does not consist solely of letters, numbers, and the period, underscore, and space characters.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Add Method (key, value)

Add Method (key, value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► Add(String, String)
Adds a key and value to the data collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string key,
    string value
)
Public Sub Add ( _
    key As String, _
    value As String _
)
public:
virtual void Add(
    String^ key,
    String^ value
) sealed
Parameters
key (String)
Case-sensitive data key.
value (String)
Data value (may be null).
Exceptions
Exception | Condition
ArgumentException | the key does not consist solely of letters, numbers, and the period, underscore, and space characters.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AddObject Method (key, value)

AddObject<(Of <(T>)>) Method (key, value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► AddObject<(Of <(T>)>)(String, T)
Adds a value to the data collection, using XML serialization to persist the object as a string.
Declaration Syntax
C# Visual Basic Visual C++
public void AddObject<T>(
    string key,
    T value
)
Public Sub AddObject(Of T) ( _
    key As String, _
    value As T _
)
public:
generic<typename T>
void AddObject(
    String^ key,
    T value
)
Generic Template Parameters
T
Parameters
key (String)
Case-sensitive data key.
value (T)
Data value (may be null).
Exceptions
Exception | Condition
ArgumentException | the key does not consist solely of letters, numbers, and the period, underscore, and space characters.
NotSupportedException | The value type does not support XML serialization.
InvalidOperationException | The value could not be serialized.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Clear Method

Clear Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► Clear()()()
Removes all items from the data.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Contains Method (item)

Contains Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► Contains(KeyValuePair<(Of <(String, String>)>))
Determines whether the data contains a specified item.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    KeyValuePair<string, string> item
)
Public Function Contains ( _
    item As KeyValuePair(Of String, String) _
) As Boolean
public:
virtual bool Contains(
    KeyValuePair<String^, String^> item
) sealed
Parameters
item (KeyValuePair <(Of <( String, String >)>))
The data item to locate.
Return Value
true if the data contains the item; otherwise, false

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ContainsKey Method (key)

ContainsKey Method (key)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► ContainsKey(String)
Determines whether the data contains an item with the specified key.
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsKey(
    string key
)
Public Function ContainsKey ( _
    key As String _
) As Boolean
public:
virtual bool ContainsKey(
    String^ key
) sealed
Parameters
key (String)
Case-sensitive data key.
Return Value
true if the data contains an item with the key; otherwise, false

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► CopyTo(array<KeyValuePair<(Of <(String, String>)>)>[]()[], Int32)
Copies the data to an array, starting at a particular array index.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    KeyValuePair<string, string>[] array,
    int arrayIndex
)
Public Sub CopyTo ( _
    array As KeyValuePair(Of String, String)(), _
    arrayIndex As Integer _
)
public:
virtual void CopyTo(
    array<KeyValuePair<String^, String^>>^ array,
    int arrayIndex
) sealed
Parameters
array (array< KeyValuePair <(Of <( String, String >)>) >[]()[])
Destination array.
arrayIndex (Int32)
Index in the array at which copying begins.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Count Property

Count Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► Count
Gets the number of items in the data.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► GetEnumerator()()()
Returns an enumerator that iterates through the collection.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<KeyValuePair<string, string>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, String))
public:
virtual IEnumerator<KeyValuePair<String^, String^>>^ GetEnumerator() sealed
Return Value
An enumerator that can be used to iterate through the collection.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetObject Method (key)

GetObject<(Of <(T>)>) Method (key)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► GetObject<(Of <(T>)>)(String)
Gets a value from the data collection, using XML serialization to load the object from a string.
Declaration Syntax
C# Visual Basic Visual C++
public T GetObject<T>(
    string key
)
Public Function GetObject(Of T) ( _
    key As String _
) As T
public:
generic<typename T>
T GetObject(
    String^ key
)
Generic Template Parameters
T
Parameters
key (String)
Case-sensitive data key.
Exceptions
Exception | Condition
InvalidOperationException | The value could not be deserialized.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsReadOnly Property

IsReadOnly Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► IsReadOnly
Gets a value indicating whether the data is read-only.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (key)

Item Property (key)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► Item[([(String])])
Gets or sets a data value with a specified key.
Declaration Syntax
C# Visual Basic Visual C++
public string this[
    string key
] { get; set; }
Public Default Property Item ( _
    key As String _
) As String
public:
virtual property String^ default[String^ key] {
    String^ get (String^ key) sealed;
    void set (String^ key, String^ value) sealed;
}
Parameters
key (String)
Case-sensitive data key.
Exceptions
Exception | Condition
ArgumentException | the key does not consist solely of letters, numbers, and the period, underscore, and space characters.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Keys Property

Keys Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► Keys
Gets a collection object containing all the keys of the data.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<string> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of String)
public:
virtual property ICollection<String^>^ Keys {
    ICollection<String^>^ get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


PropertyName Field

PropertyName Field
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► PropertyName
"CustomActionData" literal property name.
Declaration Syntax
C# Visual Basic Visual C++
public const string PropertyName
Public Const PropertyName As String
public:
literal String^ PropertyName

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Remove Method

Remove Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► Remove()()()
Members
Icon | Member | Description
 | Remove(String) | Removes the item with the specified key from the data.
 | Remove(KeyValuePair<(Of <(String, String>)>)) | Removes an item from the data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Remove Method (item)

Remove Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► Remove(KeyValuePair<(Of <(String, String>)>))
Removes an item from the data.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    KeyValuePair<string, string> item
)
Public Function Remove ( _
    item As KeyValuePair(Of String, String) _
) As Boolean
public:
virtual bool Remove(
    KeyValuePair<String^, String^> item
) sealed
Parameters
item (KeyValuePair <(Of <( String, String >)>))
The item to remove.
Return Value
true if the item was successfully removed from the data; false if the item was not found

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Remove Method (key)

Remove Method (key)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► Remove(String)
Removes the item with the specified key from the data.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string key
)
Public Function Remove ( _
    key As String _
) As Boolean
public:
virtual bool Remove(
    String^ key
) sealed
Parameters
key (String)
Case-sensitive data key.
Return Value
true if the item was successfully removed from the data; false if an item with the specified key was not found

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ToString Method

ToString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► ToString()()()
Gets a string representation of the data suitable for persisting in a property.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
Data string in the form "Key1=Value1;Key2=Value2"

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


TryGetValue Method (key, value)

TryGetValue Method (key, value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► TryGetValue(String, String%)
Gets the value with the specified key.
Declaration Syntax
C# Visual Basic Visual C++
public bool TryGetValue(
    string key,
    out string value
)
Public Function TryGetValue ( _
    key As String, _
    <OutAttribute> ByRef value As String _
) As Boolean
public:
virtual bool TryGetValue(
    String^ key,
    [OutAttribute] String^% value
) sealed
Parameters
key (String)
Case-sensitive data key.
value ( String %)
Value associated with the specified key, or null if an item with the specified key was not found
Return Value
true if the data contains an item with the specified key; otherwise, false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Values Property

Values Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionData ► Values
Gets a collection containing all the values of the data.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<string> Values { get; }
Public ReadOnly Property Values As ICollection(Of String)
public:
virtual property ICollection<String^>^ Values {
    ICollection<String^>^ get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CustomActionTypes Enumeration

CustomActionTypes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► CustomActionTypes
Defines flags for the Type column of the CustomAction table.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum CustomActionTypes
<FlagsAttribute> _
Public Enumeration CustomActionTypes
[FlagsAttribute]
public enum class CustomActionTypes
Members
Member | Description
None | Unspecified custom action type.
Dll | Target = entry point name
Exe | Target = command line args
TextData | Target = text string to be formatted and set into property
JScript | Target = entry point name, null if none to call
VBScript | Target = entry point name, null if none to call
Install | Target = property list for nested engine initialization
SourceFile | Source = File.File, file part of installation
Directory | Source = Directory.Directory, folder containing existing file
Property | Source = Property.Property, full path to executable
Continue | Ignore action return status, continue running
Async | Run asynchronously
FirstSequence | Skip if UI sequence already run
OncePerProcess | Skip if UI sequence already run in same process
ClientRepeat | Run on client only if UI already run on client
InScript | Queue for execution within script
Rollback | In conjunction with InScript: queue in Rollback script
Commit | In conjunction with InScript: run Commit ops from script on success
NoImpersonate | No impersonation, run in system context
TSAware | Impersonate for per-machine installs on TS machines
SixtyFourBitScript | Script requires 64bit process
HideTarget | Don't record the contents of the Target field in the log file
PatchUninstall | The custom action runs only when a patch is being uninstalled

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Database Class

Database Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database
Accesses a Windows Installer database.
Declaration Syntax
C# Visual Basic Visual C++
public class Database : InstallerHandle
Public Class Database _
    Inherits InstallerHandle
public ref class Database : public InstallerHandle
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Database(String) | Opens an existing database in read-only mode.
 | Database(String, String) | Opens an existing database with another database as output.
 | Database(String, DatabaseOpenMode) | Opens an existing database or creates a new one.
 | Database(IntPtr, Boolean, String, DatabaseOpenMode) | Creates a new database from an MSI handle.
 | ApplyTransform(String) | Apply a transform to the database, suppressing any error conditions specified by the transform's summary information.
 | ApplyTransform(String, TransformErrors) | Apply a transform to the database, specifying error conditions to suppress.
 | Close()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | CodePage | Gets or sets the code page of the Database.
 | Commit()()() | Finalizes the persistent form of the database. All persistent data is written to the writeable database, and no temporary columns or rows are written.
 | CountRows(String) | Gets the count of all rows in the table.
 | CountRows(String, String) | Gets the count of all rows in the table that satisfy a given condition.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateRecord(Int32) | Creates a new record object with the requested number of fields.
 | CreateTransformSummaryInfo(Database, String, TransformErrors, TransformValidations) | Creates and populates the summary information stream of an existing transform file, and fills in the properties with the base and reference ProductCode and ProductVersion.
 | DeleteOnClose(String) | Schedules a file or directory for deletion after the database handle is closed.
 | Dispose(Boolean) | Closes the database handle. After closing a handle, further method calls may throw InvalidHandleException. (Overrides InstallerHandle.Dispose(Boolean).)
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Equals(Object) | Tests whether this handle object is equal to another handle object. Two handle objects are equal if their types are the same and their native integer handles are the same. (Inherited from InstallerHandle.)
 | Execute(String, array<Object>[]()[]) | Executes the query specified by a SQL string. The query may not be a SELECT statement.
 | Execute(String, Record) | Executes the query specified by a SQL string. The query may not be a SELECT statement.
 | ExecuteIntegerQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as integers.
 | ExecuteIntegerQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as integers.
 | ExecuteQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results.
 | ExecuteQuery(String, Record) | Executes the specified SQL SELECT query and returns all results.
 | ExecuteScalar(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns a single result.
 | ExecuteScalar(String, Record) | Executes the specified SQL SELECT query and returns a single result.
 | ExecuteStringQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as strings.
 | ExecuteStringQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as strings.
 | Export(String, String) | Copies the structure and data from a specified table to a text archive file.
 | ExportAll(String) | Exports all database tables, streams, and summary information to archive files.
 | FilePath | Gets the file path the Database was originally opened from, or null if not known.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromHandle(IntPtr, Boolean) | Creates a new Database object from an integer database handle.
 | GenerateTransform(Database, String) | Creates a transform that, when applied to the object database, results in the reference database.
 | GetHashCode()()() | Gets a hash value for the handle object. (Inherited from InstallerHandle.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets the native integer handle. (Inherited from InstallerHandle.)
 | Import(String) | Imports a database table from a text archive file, dropping any existing table.
 | ImportAll(String) | Imports all database tables, streams, and summary information from archive files.
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsClosed | Checks if the handle is closed. When closed, method calls on the handle object may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | IsColumnPersistent(String, String) | Checks whether a table contains a persistent column with a given name.
 | IsReadOnly | Gets a boolean value indicating whether this database was opened in read-only mode.
 | IsTablePersistent(String) | Checks whether a table exists and is persistent in the database.
 | IsTransformValid(String) | Checks whether a transform is valid for this Database, according to its validation data and flags.
 | IsTransformValid(SummaryInfo) | Checks whether a transform is valid for this Database, according to its SummaryInfo data.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(Database, String) | Merges another database with this database.
 | Merge(Database) | Merges another database with this database.
 | OpenMode | Gets the open mode for the database.
 | OpenView(String, array<Object>[]()[]) | Gets a View object representing the query specified by a SQL string.
 | SummaryInfo | Gets the SummaryInfo object for this database that can be used to examine and modify properties to the summary information stream.
 | Tables | Gets the collection of tables in the Database.
 | ToString()()() | Returns the file path of this database, or the handle value if a file path was not specified. (Overrides Object.ToString()()().)
 | ViewTransform(String) | Apply a transform to the database, recording the changes in the "_TransformView" table.
Remarks

The Commit()()() method must be called before the Database is closed to write out all persistent changes. If the Commit method is not called, the installer performs an implicit rollback upon object destruction.

The client can use the following procedure for data access:

  1. Obtain a Database object using one of the Database constructors.
  2. Initiate a query using a SQL string by calling the OpenView(String, array<Object>[]()[]) method of the Database.
  3. Set query parameters in a Record and execute the database query by calling the Execute(Record) method of the View. This produces a result that can be fetched or updated.
  4. Call the Fetch()()() method of the View repeatedly to return Records.
  5. Update database rows of a Record object obtained by the Fetch method using one of the Modify(ViewModifyMode, Record) methods of the View.
  6. Release the query and any unfetched records by calling the Close()()() method of the View.
  7. Persist any database updates by calling the Commit method of the Database.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | InstallerHandle
 |  |  | Database
 |  |  |  | QDatabase
 |  |  |  | InstallPackage
 |  |  |  | PatchPackage

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Database Constructor

Database Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Database()()()
Members
Icon | Member | Description
 | Database(String) | Opens an existing database in read-only mode.
 | Database(String, String) | Opens an existing database with another database as output.
 | Database(String, DatabaseOpenMode) | Opens an existing database or creates a new one.
 | Database(IntPtr, Boolean, String, DatabaseOpenMode) | Creates a new database from an MSI handle.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Database Constructor (handle, ownsHandle, filePath, openMode)

Database Constructor (handle, ownsHandle, filePath, openMode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Database(IntPtr, Boolean, String, DatabaseOpenMode)
Creates a new database from an MSI handle.
Declaration Syntax
C# Visual Basic Visual C++
protected Database(
    IntPtr handle,
    bool ownsHandle,
    string filePath,
    DatabaseOpenMode openMode
)
Protected Sub New ( _
    handle As IntPtr, _
    ownsHandle As Boolean, _
    filePath As String, _
    openMode As DatabaseOpenMode _
)
protected:
Database(
    IntPtr handle,
    bool ownsHandle,
    String^ filePath,
    DatabaseOpenMode openMode
)
Parameters
handle (IntPtr)
Native MSI database handle.
ownsHandle (Boolean)
True if the handle should be closed when the database object is disposed
filePath (String)
Path of the database file, if known
openMode (DatabaseOpenMode)
Mode the handle was originally opened in

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Database Constructor (filePath)

Database Constructor (filePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Database(String)
Opens an existing database in read-only mode.
Declaration Syntax
C# Visual Basic Visual C++
public Database(
    string filePath
)
Public Sub New ( _
    filePath As String _
)
public:
Database(
    String^ filePath
)
Parameters
filePath (String)
Path to the database file.
Remarks

Because this constructor initiates database access, it cannot be used with a running installation.

The Database object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Win32 MSI API: MsiOpenDatabase

Exceptions
Exception | Condition
InstallerException | the database could not be created/opened

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Database Constructor (filePath, mode)

Database Constructor (filePath, mode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Database(String, DatabaseOpenMode)
Opens an existing database or creates a new one.
Declaration Syntax
C# Visual Basic Visual C++
public Database(
    string filePath,
    DatabaseOpenMode mode
)
Public Sub New ( _
    filePath As String, _
    mode As DatabaseOpenMode _
)
public:
Database(
    String^ filePath,
    DatabaseOpenMode mode
)
Parameters
filePath (String)
Path to the database file. If an empty string is supplied, a temporary database is created that is not persisted.
mode (DatabaseOpenMode)
Open mode for the database
Remarks

Because this constructor initiates database access, it cannot be used with a running installation.

The database object should be Close()()()d after use. The finalizer will close the handle if it is still open, however due to the nondeterministic nature of finalization it is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

A database opened in CreateDirect or Direct mode will be automatically commited when it is closed. However a database opened in Create or Transact mode must have the Commit()()() method called before it is closed, otherwise no changes will be persisted.

Win32 MSI API: MsiOpenDatabase

Exceptions
Exception | Condition
InstallerException | the database could not be created/opened

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Database Constructor (filePath, outputPath)

Database Constructor (filePath, outputPath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Database(String, String)
Opens an existing database with another database as output.
Declaration Syntax
C# Visual Basic Visual C++
public Database(
    string filePath,
    string outputPath
)
Public Sub New ( _
    filePath As String, _
    outputPath As String _
)
public:
Database(
    String^ filePath,
    String^ outputPath
)
Parameters
filePath (String)
Path to the database to be read.
outputPath (String)
Open mode for the database
Return Value
Database object representing the created or opened database
Remarks

When a database is opened as the output of another database, the summary information stream of the output database is actually a read-only mirror of the original database and thus cannot be changed. Additionally, it is not persisted with the database. To create or modify the summary information for the output database it must be closed and re-opened.

The Database object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

The database is opened in CreateDirect mode, and will be automatically commited when it is closed.

Win32 MSI API: MsiOpenDatabase

Exceptions
Exception | Condition
InstallerException | the database could not be created/opened

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ApplyTransform Method

ApplyTransform Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ApplyTransform()()()
Members
Icon | Member | Description
 | ApplyTransform(String) | Apply a transform to the database, suppressing any error conditions specified by the transform's summary information.
 | ApplyTransform(String, TransformErrors) | Apply a transform to the database, specifying error conditions to suppress.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ApplyTransform Method (transformFile)

ApplyTransform Method (transformFile)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ApplyTransform(String)
Apply a transform to the database, suppressing any error conditions specified by the transform's summary information.
Declaration Syntax
C# Visual Basic Visual C++
public void ApplyTransform(
    string transformFile
)
Public Sub ApplyTransform ( _
    transformFile As String _
)
public:
void ApplyTransform(
    String^ transformFile
)
Parameters
transformFile (String)
Path to the transform file
Remarks

Win32 MSI API: MsiDatabaseApplyTransform

Exceptions
Exception | Condition
InstallerException | the transform could not be applied
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ApplyTransform Method (transformFile, errorConditionsToSuppress)

ApplyTransform Method (transformFile, errorConditionsToSuppress)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ApplyTransform(String, TransformErrors)
Apply a transform to the database, specifying error conditions to suppress.
Declaration Syntax
C# Visual Basic Visual C++
public void ApplyTransform(
    string transformFile,
    TransformErrors errorConditionsToSuppress
)
Public Sub ApplyTransform ( _
    transformFile As String, _
    errorConditionsToSuppress As TransformErrors _
)
public:
void ApplyTransform(
    String^ transformFile,
    TransformErrors errorConditionsToSuppress
)
Parameters
transformFile (String)
Path to the transform file
errorConditionsToSuppress (TransformErrors)
Error conditions that are to be suppressed
Remarks

Win32 MSI API: MsiDatabaseApplyTransform

Exceptions
Exception | Condition
InstallerException | the transform could not be applied
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CodePage Property

CodePage Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► CodePage
Gets or sets the code page of the Database.
Declaration Syntax
C# Visual Basic Visual C++
public int CodePage { get; set; }
Public Property CodePage As Integer
public:
property int CodePage {
    int get ();
    void set (int value);
}
Remarks

Getting or setting the code page is a slow operation because it involves an export or import of the codepage data to/from a temporary file.

Exceptions
Exception | Condition
IOException | error exporting/importing the codepage data
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Commit Method

Commit Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Commit()()()
Finalizes the persistent form of the database. All persistent data is written to the writeable database, and no temporary columns or rows are written.
Declaration Syntax
C# Visual Basic Visual C++
public void Commit()
Public Sub Commit
public:
void Commit()
Remarks

For a database open in ReadOnly mode, this method has no effect.

For a database open in CreateDirect or Direct mode, it is not necessary to call this method because the database will be automatically committed when it is closed. However this method may be called at any time to persist the current state of tables loaded into memory.

For a database open in Create or Transact mode, no changes will be persisted until this method is called. If the database object is closed without calling this method, the database file remains unmodified.

Win32 MSI API: MsiDatabaseCommit

Exceptions
Exception | Condition
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CountRows Method

CountRows Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► CountRows()()()
Members
Icon | Member | Description
 | CountRows(String) | Gets the count of all rows in the table.
 | CountRows(String, String) | Gets the count of all rows in the table that satisfy a given condition.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CountRows Method (table)

CountRows Method (table)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► CountRows(String)
Gets the count of all rows in the table.
Declaration Syntax
C# Visual Basic Visual C++
public int CountRows(
    string table
)
Public Function CountRows ( _
    table As String _
) As Integer
public:
int CountRows(
    String^ table
)
Parameters
table (String)
Name of the table whose rows are to be counted
Return Value
The count of all rows in the table
Exceptions
Exception | Condition
InstallerException | the View could not be executed
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CountRows Method (table, where)

CountRows Method (table, where)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► CountRows(String, String)
Gets the count of all rows in the table that satisfy a given condition.
Declaration Syntax
C# Visual Basic Visual C++
public int CountRows(
    string table,
    string where
)
Public Function CountRows ( _
    table As String, _
    where As String _
) As Integer
public:
int CountRows(
    String^ table,
    String^ where
)
Parameters
table (String)
Name of the table whose rows are to be counted
where (String)
Conditional expression, such as could be placed on the end of a SQL WHERE clause
Return Value
The count of all rows in the table satisfying the condition
Exceptions
Exception | Condition
BadQuerySyntaxException | the SQL WHERE syntax is invalid
InstallerException | the View could not be executed
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CreateRecord Method (fieldCount)

CreateRecord Method (fieldCount)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► CreateRecord(Int32)
Creates a new record object with the requested number of fields.
Declaration Syntax
C# Visual Basic Visual C++
public Record CreateRecord(
    int fieldCount
)
Public Function CreateRecord ( _
    fieldCount As Integer _
) As Record
public:
Record^ CreateRecord(
    int fieldCount
)
Parameters
fieldCount (Int32)
Required number of fields, which may be 0. The maximum number of fields in a record is limited to 65535.
Return Value
A new record object that can be used with the database.
Remarks

This method is equivalent to directly calling the Record constructor in all cases outside of a custom action context. When in a custom action session, this method allows creation of a record that can work with a database other than the session database.

The Record object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Win32 MSI API: MsiCreateRecord

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CreateTransformSummaryInfo Method (referenceDatabase, transformFile, errors, validations)

CreateTransformSummaryInfo Method (referenceDatabase, transformFile, errors, validations)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► CreateTransformSummaryInfo(Database, String, TransformErrors, TransformValidations)
Creates and populates the summary information stream of an existing transform file, and fills in the properties with the base and reference ProductCode and ProductVersion.
Declaration Syntax
C# Visual Basic Visual C++
public void CreateTransformSummaryInfo(
    Database referenceDatabase,
    string transformFile,
    TransformErrors errors,
    TransformValidations validations
)
Public Sub CreateTransformSummaryInfo ( _
    referenceDatabase As Database, _
    transformFile As String, _
    errors As TransformErrors, _
    validations As TransformValidations _
)
public:
void CreateTransformSummaryInfo(
    Database^ referenceDatabase,
    String^ transformFile,
    TransformErrors errors,
    TransformValidations validations
)
Parameters
referenceDatabase (Database)
Database that does not include the changes
transformFile (String)
Name of the generated transform file
errors (TransformErrors)
Error conditions that should be suppressed when the transform is applied
validations (TransformValidations)
Defines which properties should be validated to verify that this transform can be applied to a database.
Remarks

Win32 MSI API: MsiCreateTransformSummaryInfo

Exceptions
Exception | Condition
InstallerException | the transform summary info could not be generated
InvalidHandleException | a Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DeleteOnClose Method (path)

DeleteOnClose Method (path)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► DeleteOnClose(String)
Schedules a file or directory for deletion after the database handle is closed.
Declaration Syntax
C# Visual Basic Visual C++
public void DeleteOnClose(
    string path
)
Public Sub DeleteOnClose ( _
    path As String _
)
public:
void DeleteOnClose(
    String^ path
)
Parameters
path (String)
File or directory path to be deleted. All files and subdirectories under a directory are deleted.
Remarks

Once an item is scheduled, it cannot be unscheduled.

The items cannot be deleted if the Database object is auto-disposed by the garbage collector; the handle must be explicitly closed.

Files which are read-only or otherwise locked cannot be deleted, but they will not cause an exception to be thrown.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method (disposing)

Dispose Method (disposing)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Dispose(Boolean)
Closes the database handle. After closing a handle, further method calls may throw InvalidHandleException.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
If true, the method has been called directly or indirectly by a user's code, so managed and unmanaged resources will be disposed. If false, only unmanaged resources will be disposed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Execute Method

Execute Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Execute()()()
Members
Icon | Member | Description
 | Execute(String, array<Object>[]()[]) | Executes the query specified by a SQL string. The query may not be a SELECT statement.
 | Execute(String, Record) | Executes the query specified by a SQL string. The query may not be a SELECT statement.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Execute Method (sql, record)

Execute Method (sql, record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Execute(String, Record)
Executes the query specified by a SQL string. The query may not be a SELECT statement.
Declaration Syntax
C# Visual Basic Visual C++
public void Execute(
    string sql,
    Record record
)
Public Sub Execute ( _
    sql As String, _
    record As Record _
)
public:
void Execute(
    String^ sql,
    Record^ record
)
Parameters
sql (String)
SQL query string
record (Record)
Optional Record object containing the values that replace the parameter tokens (?) in the SQL query.
Remarks

Win32 MSI APIs: MsiDatabaseOpenView, MsiViewExecute

Exceptions
Exception | Condition
BadQuerySyntaxException | the SQL syntax is invalid
InstallerException | the View could not be executed
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Execute Method (sqlFormat, args)

Execute Method (sqlFormat, args)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Execute(String, array<Object>[]()[])
Executes the query specified by a SQL string. The query may not be a SELECT statement.
Declaration Syntax
C# Visual Basic Visual C++
public void Execute(
    string sqlFormat,
    params Object[] args
)
Public Sub Execute ( _
    sqlFormat As String, _
    ParamArray args As Object() _
)
public:
void Execute(
    String^ sqlFormat,
    ... array<Object^>^ args
)
Parameters
sqlFormat (String)
SQL query string, which may contain format items
args (array< Object >[]()[])
Zero or more objects to format
Remarks

The sqlFormat parameter is formatted using Format(String, array<Object>[]()[]).

Win32 MSI APIs: MsiDatabaseOpenView, MsiViewExecute

Exceptions
Exception | Condition
BadQuerySyntaxException | the SQL syntax is invalid
InstallerException | the View could not be executed
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExecuteIntegerQuery Method

ExecuteIntegerQuery Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExecuteIntegerQuery()()()
Members
Icon | Member | Description
 | ExecuteIntegerQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as integers.
 | ExecuteIntegerQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as integers.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExecuteIntegerQuery Method (sql, record)

ExecuteIntegerQuery Method (sql, record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExecuteIntegerQuery(String, Record)
Executes the specified SQL SELECT query and returns all results as integers.
Declaration Syntax
C# Visual Basic Visual C++
public IList<int> ExecuteIntegerQuery(
    string sql,
    Record record
)
Public Function ExecuteIntegerQuery ( _
    sql As String, _
    record As Record _
) As IList(Of Integer)
public:
IList<int>^ ExecuteIntegerQuery(
    String^ sql,
    Record^ record
)
Parameters
sql (String)
SQL SELECT query string
record (Record)
Optional Record object containing the values that replace the parameter tokens (?) in the SQL query.
Return Value
All results combined into an array
Remarks

Multiple rows columns will be collapsed into a single one-dimensional list.

Win32 MSI APIs: MsiDatabaseOpenView, MsiViewExecute, MsiViewFetch

Exceptions
Exception | Condition
BadQuerySyntaxException | the SQL syntax is invalid
InstallerException | the View could not be executed
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExecuteIntegerQuery Method (sqlFormat, args)

ExecuteIntegerQuery Method (sqlFormat, args)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExecuteIntegerQuery(String, array<Object>[]()[])
Executes the specified SQL SELECT query and returns all results as integers.
Declaration Syntax
C# Visual Basic Visual C++
public IList<int> ExecuteIntegerQuery(
    string sqlFormat,
    params Object[] args
)
Public Function ExecuteIntegerQuery ( _
    sqlFormat As String, _
    ParamArray args As Object() _
) As IList(Of Integer)
public:
IList<int>^ ExecuteIntegerQuery(
    String^ sqlFormat,
    ... array<Object^>^ args
)
Parameters
sqlFormat (String)
SQL query string, which may contain format items
args (array< Object >[]()[])
Zero or more objects to format
Return Value
All results combined into an array
Remarks

The sqlFormat parameter is formatted using Format(String, array<Object>[]()[]).

Multiple rows columns will be collapsed into a single one-dimensional list.

Win32 MSI APIs: MsiDatabaseOpenView, MsiViewExecute, MsiViewFetch

Exceptions
Exception | Condition
BadQuerySyntaxException | the SQL syntax is invalid
InstallerException | the View could not be executed
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExecuteQuery Method

ExecuteQuery Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExecuteQuery()()()
Members
Icon | Member | Description
 | ExecuteQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results.
 | ExecuteQuery(String, Record) | Executes the specified SQL SELECT query and returns all results.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExecuteQuery Method (sql, record)

ExecuteQuery Method (sql, record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExecuteQuery(String, Record)
Executes the specified SQL SELECT query and returns all results.
Declaration Syntax
C# Visual Basic Visual C++
public IList ExecuteQuery(
    string sql,
    Record record
)
Public Function ExecuteQuery ( _
    sql As String, _
    record As Record _
) As IList
public:
IList^ ExecuteQuery(
    String^ sql,
    Record^ record
)
Parameters
sql (String)
SQL SELECT query string
record (Record)
Optional Record object containing the values that replace the parameter tokens (?) in the SQL query.
Return Value
All results combined into an array
Remarks

Multiple rows columns will be collapsed into a single one-dimensional list.

Win32 MSI APIs: MsiDatabaseOpenView, MsiViewExecute, MsiViewFetch

Exceptions
Exception | Condition
BadQuerySyntaxException | the SQL syntax is invalid
InstallerException | the View could not be executed
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExecuteQuery Method (sqlFormat, args)

ExecuteQuery Method (sqlFormat, args)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExecuteQuery(String, array<Object>[]()[])
Executes the specified SQL SELECT query and returns all results.
Declaration Syntax
C# Visual Basic Visual C++
public IList ExecuteQuery(
    string sqlFormat,
    params Object[] args
)
Public Function ExecuteQuery ( _
    sqlFormat As String, _
    ParamArray args As Object() _
) As IList
public:
IList^ ExecuteQuery(
    String^ sqlFormat,
    ... array<Object^>^ args
)
Parameters
sqlFormat (String)
SQL query string, which may contain format items
args (array< Object >[]()[])
Zero or more objects to format
Return Value
All results combined into an array
Remarks

The sqlFormat parameter is formatted using Format(String, array<Object>[]()[]).

Multiple rows columns will be collapsed into a single one-dimensional list.

Win32 MSI APIs: MsiDatabaseOpenView, MsiViewExecute, MsiViewFetch

Exceptions
Exception | Condition
BadQuerySyntaxException | the SQL syntax is invalid
InstallerException | the View could not be executed
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExecuteScalar Method

ExecuteScalar Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns a single result.
 | ExecuteScalar(String, Record) | Executes the specified SQL SELECT query and returns a single result.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExecuteScalar Method (sql, record)

ExecuteScalar Method (sql, record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExecuteScalar(String, Record)
Executes the specified SQL SELECT query and returns a single result.
Declaration Syntax
C# Visual Basic Visual C++
public Object ExecuteScalar(
    string sql,
    Record record
)
Public Function ExecuteScalar ( _
    sql As String, _
    record As Record _
) As Object
public:
Object^ ExecuteScalar(
    String^ sql,
    Record^ record
)
Parameters
sql (String)
SQL SELECT query string
record (Record)
Optional Record object containing the values that replace the parameter tokens (?) in the SQL query.
Return Value
First field of the first result
Remarks

Win32 MSI APIs: MsiDatabaseOpenView, MsiViewExecute, MsiViewFetch

Exceptions
Exception | Condition
BadQuerySyntaxException | the SQL syntax is invalid
InstallerException | the View could not be executed or the query returned 0 results
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExecuteScalar Method (sqlFormat, args)

ExecuteScalar Method (sqlFormat, args)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExecuteScalar(String, array<Object>[]()[])
Executes the specified SQL SELECT query and returns a single result.
Declaration Syntax
C# Visual Basic Visual C++
public Object ExecuteScalar(
    string sqlFormat,
    params Object[] args
)
Public Function ExecuteScalar ( _
    sqlFormat As String, _
    ParamArray args As Object() _
) As Object
public:
Object^ ExecuteScalar(
    String^ sqlFormat,
    ... array<Object^>^ args
)
Parameters
sqlFormat (String)
SQL query string, which may contain format items
args (array< Object >[]()[])
Zero or more objects to format
Return Value
First field of the first result
Remarks

The sqlFormat parameter is formatted using Format(String, array<Object>[]()[]).

Win32 MSI APIs: MsiDatabaseOpenView, MsiViewExecute, MsiViewFetch

Exceptions
Exception | Condition
BadQuerySyntaxException | the SQL syntax is invalid
InstallerException | the View could not be executed or the query returned 0 results
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExecuteStringQuery Method

ExecuteStringQuery Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExecuteStringQuery()()()
Members
Icon | Member | Description
 | ExecuteStringQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as strings.
 | ExecuteStringQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as strings.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExecuteStringQuery Method (sql, record)

ExecuteStringQuery Method (sql, record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExecuteStringQuery(String, Record)
Executes the specified SQL SELECT query and returns all results as strings.
Declaration Syntax
C# Visual Basic Visual C++
public IList<string> ExecuteStringQuery(
    string sql,
    Record record
)
Public Function ExecuteStringQuery ( _
    sql As String, _
    record As Record _
) As IList(Of String)
public:
IList<String^>^ ExecuteStringQuery(
    String^ sql,
    Record^ record
)
Parameters
sql (String)
SQL SELECT query string
record (Record)
Optional Record object containing the values that replace the parameter tokens (?) in the SQL query.
Return Value
All results combined into an array
Remarks

Multiple rows columns will be collapsed into a single on-dimensional list.

Win32 MSI APIs: MsiDatabaseOpenView, MsiViewExecute, MsiViewFetch

Exceptions
Exception | Condition
BadQuerySyntaxException | the SQL syntax is invalid
InstallerException | the View could not be executed
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExecuteStringQuery Method (sqlFormat, args)

ExecuteStringQuery Method (sqlFormat, args)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExecuteStringQuery(String, array<Object>[]()[])
Executes the specified SQL SELECT query and returns all results as strings.
Declaration Syntax
C# Visual Basic Visual C++
public IList<string> ExecuteStringQuery(
    string sqlFormat,
    params Object[] args
)
Public Function ExecuteStringQuery ( _
    sqlFormat As String, _
    ParamArray args As Object() _
) As IList(Of String)
public:
IList<String^>^ ExecuteStringQuery(
    String^ sqlFormat,
    ... array<Object^>^ args
)
Parameters
sqlFormat (String)
SQL query string, which may contain format items
args (array< Object >[]()[])
Zero or more objects to format
Return Value
All results combined into an array
Remarks

The sqlFormat parameter is formatted using Format(String, array<Object>[]()[]).

Multiple rows columns will be collapsed into a single on-dimensional list.

Win32 MSI APIs: MsiDatabaseOpenView, MsiViewExecute, MsiViewFetch

Exceptions
Exception | Condition
BadQuerySyntaxException | the SQL syntax is invalid
InstallerException | the View could not be executed
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Export Method (table, exportFilePath)

Export Method (table, exportFilePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Export(String, String)
Copies the structure and data from a specified table to a text archive file.
Declaration Syntax
C# Visual Basic Visual C++
public void Export(
    string table,
    string exportFilePath
)
Public Sub Export ( _
    table As String, _
    exportFilePath As String _
)
public:
void Export(
    String^ table,
    String^ exportFilePath
)
Parameters
table (String)
Name of the table to be exported
exportFilePath (String)
Path to the file to be created
Remarks

Win32 MSI API: MsiDatabaseExport

Exceptions
Exception | Condition
FileNotFoundException | the file path is invalid
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExportAll Method (directoryPath)

ExportAll Method (directoryPath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ExportAll(String)
Exports all database tables, streams, and summary information to archive files.
Declaration Syntax
C# Visual Basic Visual C++
public void ExportAll(
    string directoryPath
)
Public Sub ExportAll ( _
    directoryPath As String _
)
public:
void ExportAll(
    String^ directoryPath
)
Parameters
directoryPath (String)
Path to the directory where archive files will be created
Remarks

The directory will be created if it does not already exist.

Win32 MSI API: MsiDatabaseExport

Exceptions
Exception | Condition
FileNotFoundException | the directory path is invalid
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FilePath Property

FilePath Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► FilePath
Gets the file path the Database was originally opened from, or null if not known.
Declaration Syntax
C# Visual Basic Visual C++
public string FilePath { get; }
Public ReadOnly Property FilePath As String
public:
property String^ FilePath {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FromHandle Method (handle, ownsHandle)

FromHandle Method (handle, ownsHandle)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► FromHandle(IntPtr, Boolean)
Creates a new Database object from an integer database handle.
Declaration Syntax
C# Visual Basic Visual C++
public static Database FromHandle(
    IntPtr handle,
    bool ownsHandle
)
Public Shared Function FromHandle ( _
    handle As IntPtr, _
    ownsHandle As Boolean _
) As Database
public:
static Database^ FromHandle(
    IntPtr handle,
    bool ownsHandle
)
Parameters
handle (IntPtr)
Integer database handle
ownsHandle (Boolean)
true to close the handle when this object is disposed
Remarks

This method is only provided for interop purposes. A Database object should normally be obtained from Database or a public Database constructor.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GenerateTransform Method (referenceDatabase, transformFile)

GenerateTransform Method (referenceDatabase, transformFile)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► GenerateTransform(Database, String)
Creates a transform that, when applied to the object database, results in the reference database.
Declaration Syntax
C# Visual Basic Visual C++
public bool GenerateTransform(
    Database referenceDatabase,
    string transformFile
)
Public Function GenerateTransform ( _
    referenceDatabase As Database, _
    transformFile As String _
) As Boolean
public:
bool GenerateTransform(
    Database^ referenceDatabase,
    String^ transformFile
)
Parameters
referenceDatabase (Database)
Database that does not include the changes
transformFile (String)
Name of the generated transform file, or null to only check whether or not the two database are identical
Return Value
true if a transform is generated, or false if a transform is not generated because there are no differences between the two databases.
Remarks

A transform can add non-primary key columns to the end of a table. A transform cannot be created that adds primary key columns to a table. A transform cannot be created that changes the order, names, or definitions of columns.

If the transform is to be applied during an installation you must use the CreateTransformSummaryInfo(Database, String, TransformErrors, TransformValidations) method to populate the summary information stream.

Win32 MSI API: MsiDatabaseGenerateTransform

Exceptions
Exception | Condition
InstallerException | the transform could not be generated
InvalidHandleException | a Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Import Method (importFilePath)

Import Method (importFilePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Import(String)
Imports a database table from a text archive file, dropping any existing table.
Declaration Syntax
C# Visual Basic Visual C++
public void Import(
    string importFilePath
)
Public Sub Import ( _
    importFilePath As String _
)
public:
void Import(
    String^ importFilePath
)
Parameters
importFilePath (String)
Path to the file to be imported. The table name is specified within the file.
Remarks

Win32 MSI API: MsiDatabaseImport

Exceptions
Exception | Condition
FileNotFoundException | the file path is invalid
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ImportAll Method (directoryPath)

ImportAll Method (directoryPath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ImportAll(String)
Imports all database tables, streams, and summary information from archive files.
Declaration Syntax
C# Visual Basic Visual C++
public void ImportAll(
    string directoryPath
)
Public Sub ImportAll ( _
    directoryPath As String _
)
public:
void ImportAll(
    String^ directoryPath
)
Parameters
directoryPath (String)
Path to the directory from which archive files will be imported
Remarks

Win32 MSI API: MsiDatabaseImport

Exceptions
Exception | Condition
FileNotFoundException | the directory path is invalid
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsColumnPersistent Method (table, column)

IsColumnPersistent Method (table, column)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► IsColumnPersistent(String, String)
Checks whether a table contains a persistent column with a given name.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsColumnPersistent(
    string table,
    string column
)
Public Function IsColumnPersistent ( _
    table As String, _
    column As String _
) As Boolean
public:
bool IsColumnPersistent(
    String^ table,
    String^ column
)
Parameters
table (String)
The table to the checked
column (String)
The name of the column to be checked
Return Value
true if the column exists in the table; false if the column is temporary or does not exist.
Remarks

To check whether a column exists regardless of persistence, use Contains(String).

Exceptions
Exception | Condition
InstallerException | the View could not be executed
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsReadOnly Property

IsReadOnly Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► IsReadOnly
Gets a boolean value indicating whether this database was opened in read-only mode.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
public:
property bool IsReadOnly {
    bool get ();
}
Remarks

Win32 MSI API: MsiGetDatabaseState

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsTablePersistent Method (table)

IsTablePersistent Method (table)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► IsTablePersistent(String)
Checks whether a table exists and is persistent in the database.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTablePersistent(
    string table
)
Public Function IsTablePersistent ( _
    table As String _
) As Boolean
public:
bool IsTablePersistent(
    String^ table
)
Parameters
table (String)
The table to the checked
Return Value
true if the table exists and is persistent in the database; false otherwise
Remarks

To check whether a table exists regardless of persistence, use Contains(String).

Win32 MSI API: MsiDatabaseIsTablePersistent

Exceptions
Exception | Condition
ArgumentException | the table is unknown
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsTransformValid Method

IsTransformValid Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► IsTransformValid()()()
Members
Icon | Member | Description
 | IsTransformValid(String) | Checks whether a transform is valid for this Database, according to its validation data and flags.
 | IsTransformValid(SummaryInfo) | Checks whether a transform is valid for this Database, according to its SummaryInfo data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsTransformValid Method (transformSummaryInfo)

IsTransformValid Method (transformSummaryInfo)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► IsTransformValid(SummaryInfo)
Checks whether a transform is valid for this Database, according to its SummaryInfo data.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTransformValid(
    SummaryInfo transformSummaryInfo
)
Public Function IsTransformValid ( _
    transformSummaryInfo As SummaryInfo _
) As Boolean
public:
bool IsTransformValid(
    SummaryInfo^ transformSummaryInfo
)
Parameters
transformSummaryInfo (SummaryInfo)
SummaryInfo data of a transform file
Return Value
true if the transform can be validly applied to this Database; false otherwise
Exceptions
Exception | Condition
InstallerException | error processing summary info
InvalidHandleException | the Database or SummaryInfo handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsTransformValid Method (transformFile)

IsTransformValid Method (transformFile)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► IsTransformValid(String)
Checks whether a transform is valid for this Database, according to its validation data and flags.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTransformValid(
    string transformFile
)
Public Function IsTransformValid ( _
    transformFile As String _
) As Boolean
public:
bool IsTransformValid(
    String^ transformFile
)
Parameters
transformFile (String)
Path to the transform file
Return Value
true if the transform can be validly applied to this Database; false otherwise
Exceptions
Exception | Condition
InstallerException | the transform could not be applied
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Merge Method

Merge Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Merge()()()
Members
Icon | Member | Description
 | Merge(Database, String) | Merges another database with this database.
 | Merge(Database) | Merges another database with this database.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Merge Method (otherDatabase)

Merge Method (otherDatabase)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Merge(Database)
Merges another database with this database.
Declaration Syntax
C# Visual Basic Visual C++
public void Merge(
    Database otherDatabase
)
Public Sub Merge ( _
    otherDatabase As Database _
)
public:
void Merge(
    Database^ otherDatabase
)
Parameters
otherDatabase (Database)
The database to be merged into this database
Remarks

MsiDatabaseMerge does not copy over embedded cabinet files or embedded transforms from the reference database into the target database. Embedded data streams that are listed in the Binary table or Icon table are copied from the reference database to the target database. Storage embedded in the reference database are not copied to the target database.

The Merge method merges the data of two databases. These databases must have the same codepage. The merge fails if any tables or rows in the databases conflict. A conflict exists if the data in any row in the first database differs from the data in the corresponding row of the second database. Corresponding rows are in the same table of both databases and have the same primary key in both databases. The tables of non-conflicting databases must have the same number of primary keys, same number of columns, same column types, same column names, and the same data in rows with identical primary keys. Temporary columns however don't matter in the column count and corresponding tables can have a different number of temporary columns without creating conflict as long as the persistent columns match.

If the number, type, or name of columns in corresponding tables are different, the schema of the two databases are incompatible and the installer will stop processing tables and the merge fails. The installer checks that the two databases have the same schema before checking for row merge conflicts. If the schemas are incompatible, the databases have be modified.

Win32 MSI API: MsiDatabaseMerge

Exceptions
Exception | Condition
MergeException | merge failed due to a schema difference or data conflict
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Merge Method (otherDatabase, errorTable)

Merge Method (otherDatabase, errorTable)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Merge(Database, String)
Merges another database with this database.
Declaration Syntax
C# Visual Basic Visual C++
public void Merge(
    Database otherDatabase,
    string errorTable
)
Public Sub Merge ( _
    otherDatabase As Database, _
    errorTable As String _
)
public:
void Merge(
    Database^ otherDatabase,
    String^ errorTable
)
Parameters
otherDatabase (Database)
The database to be merged into this database
errorTable (String)
Optional name of table to contain the names of the tables containing merge conflicts, the number of conflicting rows within the table, and a reference to the table with the merge conflict.
Remarks

Merge does not copy over embedded cabinet files or embedded transforms from the reference database into the target database. Embedded data streams that are listed in the Binary table or Icon table are copied from the reference database to the target database. Storage embedded in the reference database are not copied to the target database.

The Merge method merges the data of two databases. These databases must have the same codepage. The merge fails if any tables or rows in the databases conflict. A conflict exists if the data in any row in the first database differs from the data in the corresponding row of the second database. Corresponding rows are in the same table of both databases and have the same primary key in both databases. The tables of non-conflicting databases must have the same number of primary keys, same number of columns, same column types, same column names, and the same data in rows with identical primary keys. Temporary columns however don't matter in the column count and corresponding tables can have a different number of temporary columns without creating conflict as long as the persistent columns match.

If the number, type, or name of columns in corresponding tables are different, the schema of the two databases are incompatible and the installer will stop processing tables and the merge fails. The installer checks that the two databases have the same schema before checking for row merge conflicts. If the schemas are incompatible, the databases have be modified.

If the data in particular rows differ, this is a row merge conflict, the merge fails and creates a new table with the specified name. The first column of this table is the name of the table having the conflict. The second column gives the number of rows in the table having the conflict.

Win32 MSI API: MsiDatabaseMerge

Exceptions
Exception | Condition
MergeException | merge failed due to a schema difference or data conflict
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


OpenMode Property

OpenMode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► OpenMode
Gets the open mode for the database.
Declaration Syntax
C# Visual Basic Visual C++
public DatabaseOpenMode OpenMode { get; }
Public ReadOnly Property OpenMode As DatabaseOpenMode
public:
property DatabaseOpenMode OpenMode {
    DatabaseOpenMode get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


OpenView Method (sqlFormat, args)

OpenView Method (sqlFormat, args)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► OpenView(String, array<Object>[]()[])
Gets a View object representing the query specified by a SQL string.
Declaration Syntax
C# Visual Basic Visual C++
public View OpenView(
    string sqlFormat,
    params Object[] args
)
Public Function OpenView ( _
    sqlFormat As String, _
    ParamArray args As Object() _
) As View
public:
View^ OpenView(
    String^ sqlFormat,
    ... array<Object^>^ args
)
Parameters
sqlFormat (String)
SQL query string, which may contain format items
args (array< Object >[]()[])
Zero or more objects to format
Return Value
A View object representing the query specified by a SQL string
Remarks

The sqlFormat parameter is formatted using Format(String, array<Object>[]()[]).

The View object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Win32 MSI API: MsiDatabaseOpenView

Exceptions
Exception | Condition
BadQuerySyntaxException | the SQL syntax is invalid
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SummaryInfo Property

SummaryInfo Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► SummaryInfo
Gets the SummaryInfo object for this database that can be used to examine and modify properties to the summary information stream.
Declaration Syntax
C# Visual Basic Visual C++
public SummaryInfo SummaryInfo { get; }
Public ReadOnly Property SummaryInfo As SummaryInfo
public:
property SummaryInfo^ SummaryInfo {
    SummaryInfo^ get ();
}
Remarks

The object returned from this property does not need to be explicitly persisted or closed. Any modifications will be automatically saved when the database is committed.

Win32 MSI API: MsiGetSummaryInformation

Exceptions
Exception | Condition
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Tables Property

Tables Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Tables
Gets the collection of tables in the Database.
Declaration Syntax
C# Visual Basic Visual C++
public TableCollection Tables { get; }
Public ReadOnly Property Tables As TableCollection
public:
property TableCollection^ Tables {
    TableCollection^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ToString Method

ToString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ToString()()()
Returns the file path of this database, or the handle value if a file path was not specified.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ViewTransform Method (transformFile)

ViewTransform Method (transformFile)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► ViewTransform(String)
Apply a transform to the database, recording the changes in the "_TransformView" table.
Declaration Syntax
C# Visual Basic Visual C++
public void ViewTransform(
    string transformFile
)
Public Sub ViewTransform ( _
    transformFile As String _
)
public:
void ViewTransform(
    String^ transformFile
)
Parameters
transformFile (String)
Path to the transform file
Remarks

Win32 MSI API: MsiDatabaseApplyTransform

Exceptions
Exception | Condition
InstallerException | the transform could not be applied
InvalidHandleException | the Database handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DatabaseOpenMode Enumeration

DatabaseOpenMode Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► DatabaseOpenMode
Specifies the open mode for a Database.
Declaration Syntax
C# Visual Basic Visual C++
public enum DatabaseOpenMode
Public Enumeration DatabaseOpenMode
public enum class DatabaseOpenMode
Members
Member | Description
ReadOnly | Open a database read-only, no persistent changes.
Transact | Open a database read/write in transaction mode.
Direct | Open a database direct read/write without transaction.
Create | Create a new database, transact mode read/write.
CreateDirect | Create a new database, direct mode read/write.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DialogAttributes Enumeration

DialogAttributes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► DialogAttributes
Defines flags for the Attributes column of the Dialog table.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum DialogAttributes
<FlagsAttribute> _
Public Enumeration DialogAttributes
[FlagsAttribute]
public enum class DialogAttributes
Members
Member | Description
Visible | If this bit is set, the dialog is originally created as visible, otherwise it is hidden.
Modal | If this bit is set, the dialog box is modal, other dialogs of the same application cannot be put on top of it, and the dialog keeps the control while it is running.
Minimize | If this bit is set, the dialog box can be minimized. This bit is ignored for modal dialog boxes, which cannot be minimized.
SysModal | If this style bit is set, the dialog box will stop all other applications and no other applications can take the focus.
KeepModeless | If this bit is set, the other dialogs stay alive when this dialog box is created.
TrackDiskSpace | If this bit is set, the dialog box periodically calls the installer. If the property changes, it notifies the controls on the dialog.
UseCustomPalette | If this bit is set, the pictures on the dialog box are created with the custom palette (one per dialog received from the first control created).
RightToLeftReadingOrder | If this style bit is set the text in the dialog box is displayed in right-to-left-reading order.
RightAligned | If this style bit is set, the text is aligned on the right side of the dialog box.
LeftScroll | If this style bit is set, the scroll bar is located on the left side of the dialog box.
Bidirectional | This is a combination of the RightToLeftReadingOrder, RightAligned, and the LeftScroll dialog style bits.
Error | If this bit is set, the dialog box is an error dialog.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExternalUIHandler Delegate

ExternalUIHandler Delegate
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ExternalUIHandler
Defines a callback function that the installer calls for progress notification and error messages.
Declaration Syntax
C# Visual Basic Visual C++
public delegate MessageResult ExternalUIHandler(
    InstallMessage messageType,
    string message,
    MessageBoxButtons buttons,
    MessageBoxIcon icon,
    MessageBoxDefaultButton defaultButton
)
Public Delegate Function ExternalUIHandler ( _
    messageType As InstallMessage, _
    message As String, _
    buttons As MessageBoxButtons, _
    icon As MessageBoxIcon, _
    defaultButton As MessageBoxDefaultButton _
) As MessageResult
public delegate MessageResult ExternalUIHandler(
    InstallMessage messageType,
    String^ message,
    MessageBoxButtons buttons,
    MessageBoxIcon icon,
    MessageBoxDefaultButton defaultButton
)
Parameters
messageType (InstallMessage)
message (String)
buttons (MessageBoxButtons)
icon (MessageBoxIcon)
defaultButton (MessageBoxDefaultButton)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExternalUIRecordHandler Delegate

ExternalUIRecordHandler Delegate
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ExternalUIRecordHandler
[MSI 3.1] Defines a callback function that the installer calls for record-based progress notification and error messages.
Declaration Syntax
C# Visual Basic Visual C++
public delegate MessageResult ExternalUIRecordHandler(
    InstallMessage messageType,
    Record messageRecord,
    MessageBoxButtons buttons,
    MessageBoxIcon icon,
    MessageBoxDefaultButton defaultButton
)
Public Delegate Function ExternalUIRecordHandler ( _
    messageType As InstallMessage, _
    messageRecord As Record, _
    buttons As MessageBoxButtons, _
    icon As MessageBoxIcon, _
    defaultButton As MessageBoxDefaultButton _
) As MessageResult
public delegate MessageResult ExternalUIRecordHandler(
    InstallMessage messageType,
    Record^ messageRecord,
    MessageBoxButtons buttons,
    MessageBoxIcon icon,
    MessageBoxDefaultButton defaultButton
)
Parameters
messageType (InstallMessage)
messageRecord (Record)
buttons (MessageBoxButtons)
icon (MessageBoxIcon)
defaultButton (MessageBoxDefaultButton)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FeatureAttributes Enumeration

FeatureAttributes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureAttributes
Available values for the Attributes column of the Feature table.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum FeatureAttributes
<FlagsAttribute> _
Public Enumeration FeatureAttributes
[FlagsAttribute]
public enum class FeatureAttributes
Members
Member | Description
None | Favor local - Components of this feature that are not marked for installation from source are installed locally.
FavorSource | Components of this feature not marked for local installation are installed to run from the source CD-ROM or server.
FollowParent | Set this attribute and the state of the feature is the same as the state of the feature's parent. You cannot use this option if the feature is located at the root of a feature tree.
FavorAdvertise | Set this attribute and the feature state is Advertise.
DisallowAdvertise | Set this attribute to prevent the feature from being advertised.
UIDisallowAbsent | Set this attribute and the user interface does not display an option to change the feature state to Absent. Setting this attribute forces the feature to the installation state, whether or not the feature is visible in the UI.
NoUnsupportedAdvertise | Set this attribute and advertising is disabled for the feature if the operating system shell does not support Windows Installer descriptors.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FeatureInfo Class

FeatureInfo Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfo
Provides access to information about a feature within the context of an installation session.
Declaration Syntax
C# Visual Basic Visual C++
public class FeatureInfo
Public Class FeatureInfo
public ref class FeatureInfo
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Attributes | Gets or sets the attributes of the feature.
 | CurrentState | Gets the current install state of the feature.
 | Description | Gets the description of the feature.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCost(Boolean, Boolean, InstallState) | Calculates the disk space required by the feature and its selected children and parent features.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the feature (primary key in the Feature table).
 | RequestState | Gets or sets the action state of the feature.
 | Title | Gets the title of the feature.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidStates | Gets a list of valid installation states for the feature.
Inheritance Hierarchy
Object
FeatureInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Attributes Property

Attributes Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfo ► Attributes
Gets or sets the attributes of the feature.
Declaration Syntax
C# Visual Basic Visual C++
public FeatureAttributes Attributes { get; set; }
Public Property Attributes As FeatureAttributes
public:
property FeatureAttributes Attributes {
    FeatureAttributes get ();
    void set (FeatureAttributes value);
}
Remarks

Win32 MSI APIs: MsiGetFeatureInfo, MsiSetFeatureAttributes

Since the lpAttributes paramter of MsiGetFeatureInfo does not contain an equivalent flag for UIDisallowAbsent, this flag will not be retrieved.

Since the dwAttributes parameter of MsiSetFeatureAttributes does not contain an equivalent flag for UIDisallowAbsent, the presence of this flag will be ignored.

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
ArgumentException | an unknown feature was requested

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CurrentState Property

CurrentState Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfo ► CurrentState
Gets the current install state of the feature.
Declaration Syntax
C# Visual Basic Visual C++
public InstallState CurrentState { get; }
Public ReadOnly Property CurrentState As InstallState
public:
property InstallState CurrentState {
    InstallState get ();
}
Remarks

Win32 MSI API: MsiGetFeatureState

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
ArgumentException | an unknown feature was requested

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Description Property

Description Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfo ► Description
Gets the description of the feature.
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; }
Public ReadOnly Property Description As String
public:
property String^ Description {
    String^ get ();
}
Remarks

Win32 MSI API: MsiGetFeatureInfo

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
ArgumentException | an unknown feature was requested

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetCost Method (includeParents, includeChildren, installState)

GetCost Method (includeParents, includeChildren, installState)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfo ► GetCost(Boolean, Boolean, InstallState)
Calculates the disk space required by the feature and its selected children and parent features.
Declaration Syntax
C# Visual Basic Visual C++
public long GetCost(
    bool includeParents,
    bool includeChildren,
    InstallState installState
)
Public Function GetCost ( _
    includeParents As Boolean, _
    includeChildren As Boolean, _
    installState As InstallState _
) As Long
public:
long long GetCost(
    bool includeParents,
    bool includeChildren,
    InstallState installState
)
Parameters
includeParents (Boolean)
If true, the parent features are included in the cost.
includeChildren (Boolean)
If true, the child features are included in the cost.
installState (InstallState)
Specifies the installation state.
Return Value
The disk space requirement in bytes.
Remarks

Win32 MSI API: MsiGetFeatureCost

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Name Property

Name Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfo ► Name
Gets the name of the feature (primary key in the Feature table).
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


RequestState Property

RequestState Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfo ► RequestState
Gets or sets the action state of the feature.
Declaration Syntax
C# Visual Basic Visual C++
public InstallState RequestState { get; set; }
Public Property RequestState As InstallState
public:
property InstallState RequestState {
    InstallState get ();
    void set (InstallState value);
}
Remarks

When changing the feature action, the action state of all the Components linked to the changed Feature records are also updated appropriately, based on the new feature Select state. All Features can be configured at once by specifying the keyword ALL instead of a specific feature name.

Win32 MSI APIs: MsiGetFeatureState, MsiSetFeatureState

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
ArgumentException | an unknown feature was requested

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Title Property

Title Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfo ► Title
Gets the title of the feature.
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; }
Public ReadOnly Property Title As String
public:
property String^ Title {
    String^ get ();
}
Remarks

Win32 MSI API: MsiGetFeatureInfo

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
ArgumentException | an unknown feature was requested

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ValidStates Property

ValidStates Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfo ► ValidStates
Gets a list of valid installation states for the feature.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<InstallState> ValidStates { get; }
Public ReadOnly Property ValidStates As ICollection(Of InstallState)
public:
property ICollection<InstallState>^ ValidStates {
    ICollection<InstallState>^ get ();
}
Remarks

Win32 MSI API: MsiGetFeatureValidStates

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
ArgumentException | an unknown feature was requested

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FeatureInfoCollection Class

FeatureInfoCollection Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfoCollection
Accessor for information about features within the context of an installation session.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class FeatureInfoCollection : ICollection<FeatureInfo>,
    IEnumerable<FeatureInfo>, IEnumerable
Public NotInheritable Class FeatureInfoCollection _
    Implements ICollection(Of FeatureInfo), IEnumerable(Of FeatureInfo),  _
    IEnumerable
public ref class FeatureInfoCollection sealed : ICollection<FeatureInfo^>,
    IEnumerable<FeatureInfo^>, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Contains(String) | Checks if the collection contains a feature.
 | CopyTo(array<FeatureInfo>[]()[], Int32) | Copies the features into an array.
 | Count | Gets the number of features defined for the product.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Enumerates the features in the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets information about a feature within the context of an installation session.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FeatureInfoCollection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Contains Method (feature)

Contains Method (feature)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfoCollection ► Contains(String)
Checks if the collection contains a feature.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string feature
)
Public Function Contains ( _
    feature As String _
) As Boolean
public:
bool Contains(
    String^ feature
)
Parameters
feature (String)
name of the feature
Return Value
true if the feature is in the collection, else false

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfoCollection ► CopyTo(array<FeatureInfo>[]()[], Int32)
Copies the features into an array.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    FeatureInfo[] array,
    int arrayIndex
)
Public Sub CopyTo ( _
    array As FeatureInfo(), _
    arrayIndex As Integer _
)
public:
virtual void CopyTo(
    array<FeatureInfo^>^ array,
    int arrayIndex
) sealed
Parameters
array (array< FeatureInfo >[]()[])
array that receives the features
arrayIndex (Int32)
offset into the array

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Count Property

Count Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfoCollection ► Count
Gets the number of features defined for the product.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfoCollection ► GetEnumerator()()()
Enumerates the features in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<FeatureInfo> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of FeatureInfo)
public:
virtual IEnumerator<FeatureInfo^>^ GetEnumerator() sealed
Return Value
an enumerator over all features in the collection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (feature)

Item Property (feature)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInfoCollection ► Item[([(String])])
Gets information about a feature within the context of an installation session.
Declaration Syntax
C# Visual Basic Visual C++
public FeatureInfo this[
    string feature
] { get; }
Public ReadOnly Default Property Item ( _
    feature As String _
) As FeatureInfo
public:
property FeatureInfo^ default[String^ feature] {
    FeatureInfo^ get (String^ feature);
}
Parameters
feature (String)
name of the feature
Return Value
feature object

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FeatureInstallation Class

FeatureInstallation Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInstallation
Represents an instance of a feature of an installed product.
Declaration Syntax
C# Visual Basic Visual C++
public class FeatureInstallation : InstallationPart
Public Class FeatureInstallation _
    Inherits InstallationPart
public ref class FeatureInstallation : public InstallationPart
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeatureInstallation(String, String) | Creates a new FeatureInstallation instance for a feature of a product.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FeatureName | Gets the name of the feature.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | Gets the parent of the feature, or null if the feature has no parent (it is a root feature).
 | Product | Gets the product that this item is a part of. (Inherited from InstallationPart.)
 | State | Gets the installed state of the feature. (Overrides InstallationPart.State.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Usage | Gets the usage metrics for the feature.
Inheritance Hierarchy
Object
 | InstallationPart
 |  | FeatureInstallation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FeatureInstallation Constructor (featureName, productCode)

FeatureInstallation Constructor (featureName, productCode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInstallation ► FeatureInstallation(String, String)
Creates a new FeatureInstallation instance for a feature of a product.
Declaration Syntax
C# Visual Basic Visual C++
public FeatureInstallation(
    string featureName,
    string productCode
)
Public Sub New ( _
    featureName As String, _
    productCode As String _
)
public:
FeatureInstallation(
    String^ featureName,
    String^ productCode
)
Parameters
featureName (String)
feature name
productCode (String)
ProductCode GUID

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FeatureName Property

FeatureName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInstallation ► FeatureName
Gets the name of the feature.
Declaration Syntax
C# Visual Basic Visual C++
public string FeatureName { get; }
Public ReadOnly Property FeatureName As String
public:
property String^ FeatureName {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Parent Property

Parent Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInstallation ► Parent
Gets the parent of the feature, or null if the feature has no parent (it is a root feature).
Declaration Syntax
C# Visual Basic Visual C++
public FeatureInstallation Parent { get; }
Public ReadOnly Property Parent As FeatureInstallation
public:
property FeatureInstallation^ Parent {
    FeatureInstallation^ get ();
}
Remarks
Invocation of this property may be slightly costly for products with many features, because it involves an enumeration of all the features in the product.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


State Property

State Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInstallation ► State
Gets the installed state of the feature.
Declaration Syntax
C# Visual Basic Visual C++
public override InstallState State { get; }
Public Overrides ReadOnly Property State As InstallState
public:
virtual property InstallState State {
    InstallState get () override;
}
Remarks

Win32 MSI API: MsiQueryFeatureState

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Usage Property

Usage Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInstallation ► Usage
Gets the usage metrics for the feature.
Declaration Syntax
C# Visual Basic Visual C++
public FeatureInstallation..::.UsageData Usage { get; }
Public ReadOnly Property Usage As FeatureInstallation..::.UsageData
public:
property FeatureInstallation..::.UsageData Usage {
    FeatureInstallation..::.UsageData get ();
}
Remarks

If no usage metrics are recorded, the UseCount value is 0.

Win32 MSI API: MsiGetFeatureUsage

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FeatureInstallation.UsageData Structure

FeatureInstallation..::.UsageData Structure
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInstallation ► FeatureInstallation..::.UsageData
Holds data about the usage of a feature.
Declaration Syntax
C# Visual Basic Visual C++
public struct UsageData
Public Structure UsageData
public value class UsageData
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LastUsedDate | Gets the date the feature was last used.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | UseCount | Gets count of the number of times the feature has been used.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


LastUsedDate Property

LastUsedDate Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInstallation..::.UsageData ► LastUsedDate
Gets the date the feature was last used.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastUsedDate { get; }
Public ReadOnly Property LastUsedDate As DateTime
public:
property DateTime LastUsedDate {
    DateTime get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


UseCount Property

UseCount Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FeatureInstallation..::.UsageData ► UseCount
Gets count of the number of times the feature has been used.
Declaration Syntax
C# Visual Basic Visual C++
public int UseCount { get; }
Public ReadOnly Property UseCount As Integer
public:
property int UseCount {
    int get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FileAttributes Enumeration

FileAttributes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► FileAttributes
Available values for the Attributes column of the File table.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum FileAttributes
<FlagsAttribute> _
Public Enumeration FileAttributes
[FlagsAttribute]
public enum class FileAttributes
Members
Member | Description
None | No attributes.
ReadOnly | Read-only.
Hidden | Hidden.
System | System.
Vital | The file is vital for the proper operation of the component to which it belongs.
Checksum | The file contains a valid checksum. A checksum is required to repair a file that has become corrupted.
PatchAdded | This bit must only be added by a patch and if the file is being added by the patch.
NonCompressed | The file's source type is uncompressed. If set, ignore the WordCount summary information property. If neither Noncompressed nor Compressed are set, the compression state of the file is specified by the WordCount summary information property. Do not set both Noncompressed and Compressed.
Compressed | The file's source type is compressed. If set, ignore the WordCount summary information property. If neither Noncompressed or Compressed are set, the compression state of the file is specified by the WordCount summary information property. Do not set both Noncompressed and Compressed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IEmbeddedUI Interface

IEmbeddedUI Interface
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► IEmbeddedUI
[MSI 4.5] Interface for an embedded external user interface for an installation.
Declaration Syntax
C# Visual Basic Visual C++
public interface IEmbeddedUI
Public Interface IEmbeddedUI
public interface class IEmbeddedUI
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Initialize(Session, String, InstallUIOptions%) | Initializes the embedded UI.
 | ProcessMessage(InstallMessage, Record, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton) | Processes information and progress messages sent to the user interface.
 | Shutdown()()() | Shuts down the embedded UI at the end of the installation.
Remarks
Classes which implement this interface must have a public constructor that takes no parameters.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Initialize Method (session, resourcePath, internalUILevel)

Initialize Method (session, resourcePath, internalUILevel)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► IEmbeddedUI ► Initialize(Session, String, InstallUIOptions%)
Initializes the embedded UI.
Declaration Syntax
C# Visual Basic Visual C++
bool Initialize(
    Session session,
    string resourcePath,
    ref InstallUIOptions internalUILevel
)
Function Initialize ( _
    session As Session, _
    resourcePath As String, _
    ByRef internalUILevel As InstallUIOptions _
) As Boolean
bool Initialize(
    Session^ session,
    String^ resourcePath,
    InstallUIOptions% internalUILevel
)
Parameters
session (Session)
Handle to the installer which can be used to get and set properties. The handle is only valid for the duration of this method call.
resourcePath (String)
Path to the directory that contains all the files from the MsiEmbeddedUI table.
internalUILevel ( InstallUIOptions %)
On entry, contains the current UI level for the installation. After this method returns, the installer resets the UI level to the returned value of this parameter.
Return Value
True if the embedded UI was successfully initialized; false if the installation should continue without the embedded UI.
Remarks

Win32 MSI API: InitializeEmbeddedUI

Exceptions
Exception | Condition
InstallCanceledException | The installation was canceled by the user.
InstallerException | The embedded UI failed to initialize and causes the installation to fail.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProcessMessage Method (messageType, messageRecord, buttons, icon, defaultButton)

ProcessMessage Method (messageType, messageRecord, buttons, icon, defaultButton)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► IEmbeddedUI ► ProcessMessage(InstallMessage, Record, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton)
Processes information and progress messages sent to the user interface.
Declaration Syntax
C# Visual Basic Visual C++
MessageResult ProcessMessage(
    InstallMessage messageType,
    Record messageRecord,
    MessageBoxButtons buttons,
    MessageBoxIcon icon,
    MessageBoxDefaultButton defaultButton
)
Function ProcessMessage ( _
    messageType As InstallMessage, _
    messageRecord As Record, _
    buttons As MessageBoxButtons, _
    icon As MessageBoxIcon, _
    defaultButton As MessageBoxDefaultButton _
) As MessageResult
MessageResult ProcessMessage(
    InstallMessage messageType,
    Record^ messageRecord,
    MessageBoxButtons buttons,
    MessageBoxIcon icon,
    MessageBoxDefaultButton defaultButton
)
Parameters
messageType (InstallMessage)
Message type.
messageRecord (Record)
Record that contains message data.
buttons (MessageBoxButtons)
Message box buttons.
icon (MessageBoxIcon)
Message box icon.
defaultButton (MessageBoxDefaultButton)
Message box default button.
Return Value
Result of processing the message.
Remarks

Win32 MSI API: EmbeddedUIHandler

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Shutdown Method

Shutdown Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► IEmbeddedUI ► Shutdown()()()
Shuts down the embedded UI at the end of the installation.
Declaration Syntax
C# Visual Basic Visual C++
void Shutdown()
Sub Shutdown
void Shutdown()
Remarks
If the installation was canceled during initialization, this method will not be called. If the installation was canceled or failed at any later point, this method will be called at the end.

Win32 MSI API: ShutdownEmbeddedUI

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InapplicablePatchHandler Delegate

InapplicablePatchHandler Delegate
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InapplicablePatchHandler
Receives an exception from DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler, String, UserContexts) indicating the reason a particular patch is not applicable to a product.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void InapplicablePatchHandler(
    string patch,
    Exception exception
)
Public Delegate Sub InapplicablePatchHandler ( _
    patch As String, _
    exception As Exception _
)
public delegate void InapplicablePatchHandler(
    String^ patch,
    Exception^ exception
)
Parameters
patch (String)
MSP file path, XML file path, or XML blob that was passed to DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler, String, UserContexts)
exception (Exception)
exception indicating the reason the patch is not applicable
Remarks

If exception is an InstallerException or subclass, then its ErrorCode and Message properties will indicate a more specific reason the patch was not applicable.

The exception could also be a FileNotFoundException if the patch string was a file path.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IniFileAction Enumeration

IniFileAction Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► IniFileAction
Defines values for the Action column of the IniFile and RemoveIniFile tables.
Declaration Syntax
C# Visual Basic Visual C++
public enum IniFileAction
Public Enumeration IniFileAction
public enum class IniFileAction
Members
Member | Description
AddLine | Creates or updates a .ini entry.
CreateLine | Creates a .ini entry only if the entry does not already exist.
RemoveLine | Deletes .ini entry.
AddTag | Creates a new entry or appends a new comma-separated value to an existing entry.
RemoveTag | Deletes a tag from a .ini entry.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Installation Class

Installation Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installation
Subclasses of this abstract class represent a unique instance of a registered product or patch installation.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class Installation
Public MustInherit Class Installation
public ref class Installation abstract
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Context | Gets the user context of this product or patch installation.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsInstalled | Gets a value indicating whether this product or patch is installed on the current system.
 | Item[([(String])]) | Gets a property about the product or patch installation.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SourceList | Gets the source list of this product or patch installation.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserSid | Gets the user security identifier (SID) under which this product or patch installation is available.
Inheritance Hierarchy
Object
 | Installation
 |  | PatchInstallation
 |  | ProductInstallation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Context Property

Context Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installation ► Context
Gets the user context of this product or patch installation.
Declaration Syntax
C# Visual Basic Visual C++
public UserContexts Context { get; }
Public ReadOnly Property Context As UserContexts
public:
property UserContexts Context {
    UserContexts get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsInstalled Property

IsInstalled Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installation ► IsInstalled
Gets a value indicating whether this product or patch is installed on the current system.
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool IsInstalled { get; }
Public MustOverride ReadOnly Property IsInstalled As Boolean
public:
virtual property bool IsInstalled {
    bool get () abstract;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (propertyName)

Item Property (propertyName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installation ► Item[([(String])])
Gets a property about the product or patch installation.
Declaration Syntax
C# Visual Basic Visual C++
public abstract string this[
    string propertyName
] { get; }
Public MustOverride ReadOnly Default Property Item ( _
    propertyName As String _
) As String
public:
virtual property String^ default[String^ propertyName] {
    String^ get (String^ propertyName) abstract;
}
Parameters
propertyName (String)
Name of the property being retrieved.
Return Value

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SourceList Property

SourceList Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installation ► SourceList
Gets the source list of this product or patch installation.
Declaration Syntax
C# Visual Basic Visual C++
public virtual SourceList SourceList { get; }
Public Overridable ReadOnly Property SourceList As SourceList
public:
virtual property SourceList^ SourceList {
    SourceList^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


UserSid Property

UserSid Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installation ► UserSid
Gets the user security identifier (SID) under which this product or patch installation is available.
Declaration Syntax
C# Visual Basic Visual C++
public string UserSid { get; }
Public ReadOnly Property UserSid As String
public:
property String^ UserSid {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallationPart Class

InstallationPart Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallationPart
Subclasses of this abstract class represent an instance of a registered feature or component.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class InstallationPart
Public MustInherit Class InstallationPart
public ref class InstallationPart abstract
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Product | Gets the product that this item is a part of.
 | State | Gets the current installation state of the item.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | InstallationPart
 |  | ComponentInstallation
 |  | FeatureInstallation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Product Property

Product Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallationPart ► Product
Gets the product that this item is a part of.
Declaration Syntax
C# Visual Basic Visual C++
public ProductInstallation Product { get; }
Public ReadOnly Property Product As ProductInstallation
public:
property ProductInstallation^ Product {
    ProductInstallation^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


State Property

State Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallationPart ► State
Gets the current installation state of the item.
Declaration Syntax
C# Visual Basic Visual C++
public abstract InstallState State { get; }
Public MustOverride ReadOnly Property State As InstallState
public:
virtual property InstallState State {
    InstallState get () abstract;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallCanceledException Class

InstallCanceledException Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallCanceledException
User Canceled the installation.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class InstallCanceledException : InstallerException
<SerializableAttribute> _
Public Class InstallCanceledException _
    Inherits InstallerException
[SerializableAttribute]
public ref class InstallCanceledException : public InstallerException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstallCanceledException(String, Exception) | Creates a new InstallCanceledException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | InstallCanceledException(String) | Creates a new InstallCanceledException with a specified error message.
 | InstallCanceledException()()() | Creates a new InstallCanceledException.
 | InstallCanceledException(SerializationInfo, StreamingContext) | Initializes a new instance of the InstallCanceledException class with serialized data.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorCode | Gets the system error code that resulted in this exception, or 0 if not applicable. (Inherited from InstallerException.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetErrorRecord()()() | Gets extended information about the error, or null if no further information is available. (Inherited from InstallerException.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo with information about the exception. (Inherited from InstallerException.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the exception. This message may contain detailed formatted error data if it was available. (Inherited from InstallerException.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SystemException
 |  |  | InstallerException
 |  |  |  | InstallCanceledException

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallCanceledException Constructor

InstallCanceledException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallCanceledException ► InstallCanceledException()()()
Members
Icon | Member | Description
 | InstallCanceledException(String, Exception) | Creates a new InstallCanceledException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | InstallCanceledException(String) | Creates a new InstallCanceledException with a specified error message.
 | InstallCanceledException()()() | Creates a new InstallCanceledException.
 | InstallCanceledException(SerializationInfo, StreamingContext) | Initializes a new instance of the InstallCanceledException class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallCanceledException Constructor

InstallCanceledException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallCanceledException ► InstallCanceledException()()()
Creates a new InstallCanceledException.
Declaration Syntax
C# Visual Basic Visual C++
public InstallCanceledException()
Public Sub New
public:
InstallCanceledException()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallCanceledException Constructor (info, context)

InstallCanceledException Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallCanceledException ► InstallCanceledException(SerializationInfo, StreamingContext)
Initializes a new instance of the InstallCanceledException class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected InstallCanceledException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
InstallCanceledException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallCanceledException Constructor (msg)

InstallCanceledException Constructor (msg)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallCanceledException ► InstallCanceledException(String)
Creates a new InstallCanceledException with a specified error message.
Declaration Syntax
C# Visual Basic Visual C++
public InstallCanceledException(
    string msg
)
Public Sub New ( _
    msg As String _
)
public:
InstallCanceledException(
    String^ msg
)
Parameters
msg (String)
The message that describes the error.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallCanceledException Constructor (msg, innerException)

InstallCanceledException Constructor (msg, innerException)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallCanceledException ► InstallCanceledException(String, Exception)
Creates a new InstallCanceledException with a specified error message and a reference to the inner exception that is the cause of this exception.
Declaration Syntax
C# Visual Basic Visual C++
public InstallCanceledException(
    string msg,
    Exception innerException
)
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
public:
InstallCanceledException(
    String^ msg,
    Exception^ innerException
)
Parameters
msg (String)
The message that describes the error.
innerException (Exception)
The exception that is the cause of the current exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallCost Structure

InstallCost Structure
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallCost
Represents a per-drive disk space cost for an installation.
Declaration Syntax
C# Visual Basic Visual C++
public struct InstallCost
Public Structure InstallCost
public value class InstallCost
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Cost | The installation cost on this drive, as a number of bytes.
 | DriveName | The name of the drive this cost data applies to.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TempCost | The temporary disk space required on this drive, as a number of bytes.
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Cost Property

Cost Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallCost ► Cost
The installation cost on this drive, as a number of bytes.
Declaration Syntax
C# Visual Basic Visual C++
public long Cost { get; }
Public ReadOnly Property Cost As Long
public:
property long long Cost {
    long long get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DriveName Property

DriveName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallCost ► DriveName
The name of the drive this cost data applies to.
Declaration Syntax
C# Visual Basic Visual C++
public string DriveName { get; }
Public ReadOnly Property DriveName As String
public:
property String^ DriveName {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


TempCost Property

TempCost Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallCost ► TempCost
The temporary disk space required on this drive, as a number of bytes.
Declaration Syntax
C# Visual Basic Visual C++
public long TempCost { get; }
Public ReadOnly Property TempCost As Long
public:
property long long TempCost {
    long long get ();
}
Remarks

This temporary space requirement is space needed only for the duration of the installation, over the final footprint on disk.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Installer Class

Installer Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer
Provides static methods for installing and configuring products and patches.
Declaration Syntax
C# Visual Basic Visual C++
public static class Installer
Public NotInheritable Class Installer
public ref class Installer abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AdvertiseProduct(String, Boolean, String, Int32) | Advertises a product to the local computer.
 | AdvertiseScript(String, Int32, Boolean) | Copies an advertise script file to the local computer.
 | ApplyMultiplePatches(IList<(Of <(String>)>), String, String) | Applies one or more patches to products that are eligible to receive the patch. For each product listed by the patch package as eligible to receive the patch, ApplyPatch invokes an installation and sets the PATCH property to the path of the patch package.
 | ApplyPatch(String, String) | For each product listed by the patch package as eligible to receive the patch, ApplyPatch invokes an installation and sets the PATCH property to the path of the patch package.
 | ApplyPatch(String, String, InstallType, String) | For each product listed by the patch package as eligible to receive the patch, ApplyPatch invokes an installation and sets the PATCH property to the path of the patch package.
 | ConfigureFeature(String, String, InstallState) | Configures the installed state for a product feature.
 | ConfigureProduct(String, Int32, InstallState, String) | Installs or uninstalls a product.
 | DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler) | Determines which patches apply to a specified product MSI and in what sequence.
 | DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler, String, UserContexts) | Determines which patches apply to a specified product and in what sequence. If the product is installed, this method accounts for patches that have already been applied to the product and accounts for obsolete and superceded patches.
 | EnableLog(InstallLogModes, String) | Enables logging of the selected message type for all subsequent install sessions in the current process space.
 | EnableLog(InstallLogModes, String, Boolean, Boolean) | Enables logging of the selected message type for all subsequent install sessions in the current process space.
 | ExtractPatchXmlData(String) | Extracts information from a patch that can be used to determine whether the patch applies on a target system. The method returns an XML string that can be provided to DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler, String, UserContexts) instead of the full patch file.
 | GenerateAdvertiseScript(String, String, String, Int32) | Generates an advertise script. The method enables the installer to write to a script the registry and shortcut information used to assign or publish a product.
 | GenerateAdvertiseScript(String, String, String, Int32, ProcessorArchitecture, Boolean) | Generates an advertise script. The method enables the installer to write to a script the registry and shortcut information used to assign or publish a product.
 | GetErrorMessage(Int32) | Gets a Windows Installer error message in the system default language.
 | GetErrorMessage(Int32, CultureInfo) | Gets a Windows Installer error message in a specified language.
 | GetErrorMessage(Record) | Gets a formatted Windows Installer error message in the system default language.
 | GetErrorMessage(Record, CultureInfo) | Gets a formatted Windows Installer error message in a specified language.
 | GetFileHash(String, array<Int32>[]()[]) | Gets a 128-bit hash of the specified file.
 | GetFileLanguage(String) | Gets the language string of the path specified using the format that the installer expects to find them in in the database.
 | GetFileVersion(String) | Gets the version string of the path specified using the format that the installer expects to find it in in the database.
 | GetPatchFileList(String, IList<(Of <(String>)>)) | [MSI 4.0] Gets the list of files that can be updated by one or more patches.
 | GetProductInfoFromScript(String) | Gets product information for an installer script file.
 | GetShortcutTarget(String) | Examines a shortcut and returns its product, feature name, and component if available.
 | InstallMissingComponent(String, String, InstallState) | Installs files that are unexpectedly missing.
 | InstallMissingFile(String, String) | Installs files that are unexpectedly missing.
 | InstallProduct(String, String) | Opens an installer package and initializes an install session.
 | NotifySidChange(String, String) | [MSI 3.1] Migrates a user's application configuration data to a new SID.
 | OpenPackage(String, Boolean) | Opens an installer package for use with functions that access the product database and install engine, returning an Session object.
 | OpenPackage(Database, Boolean) | Opens an installer package for use with functions that access the product database and install engine, returning an Session object.
 | OpenProduct(String) | Opens an installer package for an installed product using the product code.
 | ProcessAdvertiseScript(String, String, Boolean, Boolean) | Processes an advertise script file into the specified locations.
 | ProvideAssembly(String, String, InstallMode, Boolean) | Gets the full path to a Windows Installer component containing an assembly. This method prompts for a source and increments the usage count for the feature.
 | ProvideComponent(String, String, String, InstallMode) | Gets the full component path, performing any necessary installation. This method prompts for source if necessary and increments the usage count for the feature.
 | ProvideQualifiedComponent(String, String, InstallMode, String) | Gets the full component path for a qualified component that is published by a product and performs any necessary installation. This method prompts for source if necessary and increments the usage count for the feature.
 | RebootInitiated | Indicates whether a system reboot has been initiated after running an installation or configuration operation.
 | RebootRequired | Indicates whether a system reboot is required after running an installation or configuration operation.
 | ReinstallFeature(String, String, ReinstallModes) | Reinstalls a feature.
 | ReinstallProduct(String, ReinstallModes) | Reinstalls a product.
 | RemovePatches(IList<(Of <(String>)>), String, String) | Removes one or more patches from a single product. To remove a patch from multiple products, RemovePatches must be called for each product.
 | SetExternalUI(ExternalUIHandler, InstallLogModes) | Enables an external user-interface handler. This external UI handler is called before the normal internal user-interface handler. The external UI handler has the option to suppress the internal UI by returning a non-zero value to indicate that it has handled the messages.
 | SetExternalUI(ExternalUIRecordHandler, InstallLogModes) | [MSI 3.1] Enables a record-based external user-interface handler. This external UI handler is called before the normal internal user-interface handler. The external UI handler has the option to suppress the internal UI by returning a non-zero value to indicate that it has handled the messages.
 | SetInternalUI(InstallUIOptions, IntPtr%) | Enables the installer's internal user interface. Then this user interface is used for all subsequent calls to user-interface-generating installer functions in this process.
 | SetInternalUI(InstallUIOptions) | Enables the installer's internal user interface. Then this user interface is used for all subsequent calls to user-interface-generating installer functions in this process. The owner of the user interface does not change.
 | UseFeature(String, String, InstallMode) | increments the usage count for a particular feature and returns the installation state for that feature. This method should be used to indicate an application's intent to use a feature.
 | VerifyPackage(String) | Verifies that the given file is an installation package.
 | Version | Gets the current version of the installer.
Inheritance Hierarchy
Object
Installer

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AdvertiseProduct Method (packagePath, perUser, transforms, locale)

AdvertiseProduct Method (packagePath, perUser, transforms, locale)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► AdvertiseProduct(String, Boolean, String, Int32)
Advertises a product to the local computer.
Declaration Syntax
C# Visual Basic Visual C++
public static void AdvertiseProduct(
    string packagePath,
    bool perUser,
    string transforms,
    int locale
)
Public Shared Sub AdvertiseProduct ( _
    packagePath As String, _
    perUser As Boolean, _
    transforms As String, _
    locale As Integer _
)
public:
static void AdvertiseProduct(
    String^ packagePath,
    bool perUser,
    String^ transforms,
    int locale
)
Parameters
packagePath (String)
Path to the package of the product being advertised
perUser (Boolean)
True if the product is user-assigned; false if it is machine-assigned.
transforms (String)
Semi-colon delimited list of transforms to be applied. This parameter may be null.
locale (Int32)
The language to use if the source supports multiple languages
Remarks

Win32 MSI APIs: MsiAdvertiseProduct, MsiAdvertiseProductEx

Exceptions
Exception | Condition
FileNotFoundException | the specified package file does not exist
See Also
GenerateAdvertiseScript(String, String, String, Int32, ProcessorArchitecture, Boolean)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AdvertiseScript Method (scriptFile, flags, removeItems)

AdvertiseScript Method (scriptFile, flags, removeItems)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► AdvertiseScript(String, Int32, Boolean)
Copies an advertise script file to the local computer.
Declaration Syntax
C# Visual Basic Visual C++
public static void AdvertiseScript(
    string scriptFile,
    int flags,
    bool removeItems
)
Public Shared Sub AdvertiseScript ( _
    scriptFile As String, _
    flags As Integer, _
    removeItems As Boolean _
)
public:
static void AdvertiseScript(
    String^ scriptFile,
    int flags,
    bool removeItems
)
Parameters
scriptFile (String)
Path to a script file generated by GenerateAdvertiseScript(String, String, String, Int32, ProcessorArchitecture, Boolean)
flags (Int32)
Flags controlling advertisement
removeItems (Boolean)
True if specified items are to be removed instead of being created
Remarks

The process calling this function must be running under the LocalSystem account. To advertise an application for per-user installation to a targeted user, the thread that calls this function must impersonate the targeted user. If the thread calling this function is not impersonating a targeted user, the application is advertised to all users for installation with elevated privileges.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ApplyMultiplePatches Method (patchPackages, productCode, commandLine)

ApplyMultiplePatches Method (patchPackages, productCode, commandLine)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ApplyMultiplePatches(IList<(Of <(String>)>), String, String)
Applies one or more patches to products that are eligible to receive the patch. For each product listed by the patch package as eligible to receive the patch, ApplyPatch invokes an installation and sets the PATCH property to the path of the patch package.
Declaration Syntax
C# Visual Basic Visual C++
public static void ApplyMultiplePatches(
    IList<string> patchPackages,
    string productCode,
    string commandLine
)
Public Shared Sub ApplyMultiplePatches ( _
    patchPackages As IList(Of String), _
    productCode As String, _
    commandLine As String _
)
public:
static void ApplyMultiplePatches(
    IList<String^>^ patchPackages,
    String^ productCode,
    String^ commandLine
)
Parameters
patchPackages (IList <(Of <( String >)>))
The set of patch packages to be applied. Each item is the full path to an MSP file.
productCode (String)
Provides the ProductCode of the product being patched. If this parameter is null, the patches are applied to all products that are eligible to receive these patches.
commandLine (String)
optional command line property settings
Remarks

Win32 MSI API: MsiApplyMultiplePatches

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ApplyPatch Method

ApplyPatch Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ApplyPatch()()()
Members
Icon | Member | Description
 | ApplyPatch(String, String) | For each product listed by the patch package as eligible to receive the patch, ApplyPatch invokes an installation and sets the PATCH property to the path of the patch package.
 | ApplyPatch(String, String, InstallType, String) | For each product listed by the patch package as eligible to receive the patch, ApplyPatch invokes an installation and sets the PATCH property to the path of the patch package.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ApplyPatch Method (patchPackage, commandLine)

ApplyPatch Method (patchPackage, commandLine)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ApplyPatch(String, String)
For each product listed by the patch package as eligible to receive the patch, ApplyPatch invokes an installation and sets the PATCH property to the path of the patch package.
Declaration Syntax
C# Visual Basic Visual C++
public static void ApplyPatch(
    string patchPackage,
    string commandLine
)
Public Shared Sub ApplyPatch ( _
    patchPackage As String, _
    commandLine As String _
)
public:
static void ApplyPatch(
    String^ patchPackage,
    String^ commandLine
)
Parameters
patchPackage (String)
path to the patch package
commandLine (String)
optional command line property settings
Remarks

The RebootRequired and RebootInitiated properties should be tested after calling this method.

Win32 MSI API: MsiApplyPatch

Exceptions
Exception | Condition
InstallerException | There was an error applying the patch

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ApplyPatch Method (patchPackage, installPackage, installType, commandLine)

ApplyPatch Method (patchPackage, installPackage, installType, commandLine)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ApplyPatch(String, String, InstallType, String)
For each product listed by the patch package as eligible to receive the patch, ApplyPatch invokes an installation and sets the PATCH property to the path of the patch package.
Declaration Syntax
C# Visual Basic Visual C++
public static void ApplyPatch(
    string patchPackage,
    string installPackage,
    InstallType installType,
    string commandLine
)
Public Shared Sub ApplyPatch ( _
    patchPackage As String, _
    installPackage As String, _
    installType As InstallType, _
    commandLine As String _
)
public:
static void ApplyPatch(
    String^ patchPackage,
    String^ installPackage,
    InstallType installType,
    String^ commandLine
)
Parameters
patchPackage (String)
path to the patch package
installPackage (String)
path to the product to be patched, if installType is set to NetworkImage
installType (InstallType)
type of installation to patch
commandLine (String)
optional command line property settings
Remarks

The RebootRequired and RebootInitiated properties should be tested after calling this method.

Win32 MSI API: MsiApplyPatch

Exceptions
Exception | Condition
InstallerException | There was an error applying the patch

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ConfigureFeature Method (productCode, feature, installState)

ConfigureFeature Method (productCode, feature, installState)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ConfigureFeature(String, String, InstallState)
Configures the installed state for a product feature.
Declaration Syntax
C# Visual Basic Visual C++
public static void ConfigureFeature(
    string productCode,
    string feature,
    InstallState installState
)
Public Shared Sub ConfigureFeature ( _
    productCode As String, _
    feature As String, _
    installState As InstallState _
)
public:
static void ConfigureFeature(
    String^ productCode,
    String^ feature,
    InstallState installState
)
Parameters
productCode (String)
Product code of the product to be configured.
feature (String)
Specifies the feature ID for the feature to be configured.
installState (InstallState)
Specifies the installation state for the feature.
Remarks

The RebootRequired and RebootInitiated properties should be tested after calling this method.

Win32 MSI API: MsiConfigureFeature

Exceptions
Exception | Condition
InstallerException | There was an error configuring the feature

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ConfigureProduct Method (productCode, installLevel, installState, commandLine)

ConfigureProduct Method (productCode, installLevel, installState, commandLine)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ConfigureProduct(String, Int32, InstallState, String)
Installs or uninstalls a product.
Declaration Syntax
C# Visual Basic Visual C++
public static void ConfigureProduct(
    string productCode,
    int installLevel,
    InstallState installState,
    string commandLine
)
Public Shared Sub ConfigureProduct ( _
    productCode As String, _
    installLevel As Integer, _
    installState As InstallState, _
    commandLine As String _
)
public:
static void ConfigureProduct(
    String^ productCode,
    int installLevel,
    InstallState installState,
    String^ commandLine
)
Parameters
productCode (String)
Product code of the product to be configured.
installLevel (Int32)
Specifies the default installation configuration of the product. The installLevel parameter is ignored and all features are installed if the installState parameter is set to any other value than Default. This parameter must be either 0 (install using authored feature levels), 65535 (install all features), or a value between 0 and 65535 to install a subset of available features.
installState (InstallState)
Specifies the installation state for the product.
commandLine (String)
Specifies the command line property settings. This should be a list of the format Property=Setting Property=Setting.
Remarks

This method displays the user interface with the current settings and log mode. You can change user interface settings with the SetInternalUI(InstallUIOptions) and SetExternalUI(ExternalUIHandler, InstallLogModes) functions. You can set the log mode with the EnableLog(InstallLogModes, String) function.

The RebootRequired and RebootInitiated properties should be tested after calling this method.

Win32 MSI APIs: MsiConfigureProduct, MsiConfigureProductEx

Exceptions
Exception | Condition
InstallerException | There was an error configuring the product

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DetermineApplicablePatches Method

DetermineApplicablePatches Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► DetermineApplicablePatches()()()
Members
Icon | Member | Description
 | DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler) | Determines which patches apply to a specified product MSI and in what sequence.
 | DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler, String, UserContexts) | Determines which patches apply to a specified product and in what sequence. If the product is installed, this method accounts for patches that have already been applied to the product and accounts for obsolete and superceded patches.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DetermineApplicablePatches Method (productPackage, patches, errorHandler)

DetermineApplicablePatches Method (productPackage, patches, errorHandler)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler)
Determines which patches apply to a specified product MSI and in what sequence.
Declaration Syntax
C# Visual Basic Visual C++
public static IList<string> DetermineApplicablePatches(
    string productPackage,
    string[] patches,
    InapplicablePatchHandler errorHandler
)
Public Shared Function DetermineApplicablePatches ( _
    productPackage As String, _
    patches As String(), _
    errorHandler As InapplicablePatchHandler _
) As IList(Of String)
public:
static IList<String^>^ DetermineApplicablePatches(
    String^ productPackage,
    array<String^>^ patches,
    InapplicablePatchHandler^ errorHandler
)
Parameters
productPackage (String)
Full path to an MSI file that is the target product for the set of patches.
patches (array< String >[]()[])
An array of strings specifying the patches to be checked. Each item may be the path to an MSP file, the path an XML file, or just an XML blob.
errorHandler (InapplicablePatchHandler)
Callback to be invoked for each inapplicable patch, reporting the reason the patch is not applicable. This value may be left null if that information is not desired.
Return Value
An array of selected patch strings from patches, indicating the set of applicable patches. The items are re-ordered to be in the best sequence.
Remarks

If an item in patches is a file path but does not end in .MSP or .XML, it is assumed to be an MSP file.

As this overload uses InstallContext.None, it does not consider the current state of the system.

Win32 MSI API: MsiDetermineApplicablePatches

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DetermineApplicablePatches Method (product, patches, errorHandler, userSid, context)

DetermineApplicablePatches Method (product, patches, errorHandler, userSid, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler, String, UserContexts)
Determines which patches apply to a specified product and in what sequence. If the product is installed, this method accounts for patches that have already been applied to the product and accounts for obsolete and superceded patches.
Declaration Syntax
C# Visual Basic Visual C++
public static IList<string> DetermineApplicablePatches(
    string product,
    string[] patches,
    InapplicablePatchHandler errorHandler,
    string userSid,
    UserContexts context
)
Public Shared Function DetermineApplicablePatches ( _
    product As String, _
    patches As String(), _
    errorHandler As InapplicablePatchHandler, _
    userSid As String, _
    context As UserContexts _
) As IList(Of String)
public:
static IList<String^>^ DetermineApplicablePatches(
    String^ product,
    array<String^>^ patches,
    InapplicablePatchHandler^ errorHandler,
    String^ userSid,
    UserContexts context
)
Parameters
product (String)
The product that is the target for the set of patches. This may be either a ProductCode (GUID) of a product that is currently installed, or the path to a an MSI file.
patches (array< String >[]()[])
An array of strings specifying the patches to be checked. Each item may be the path to an MSP file, the path an XML file, or just an XML blob.
errorHandler (InapplicablePatchHandler)
Callback to be invoked for each inapplicable patch, reporting the reason the patch is not applicable. This value may be left null if that information is not desired.
userSid (String)
Specifies a security identifier (SID) of a user. This parameter restricts the context of enumeration for this user account. This parameter cannot be the special SID strings s-1-1-0 (everyone) or s-1-5-18 (local system). If context is set to None or Machine, then userSid must be null. For the current user context, userSid can be null and context can be set to UserManaged or UserUnmanaged.
context (UserContexts)
Restricts the enumeration to per-user-unmanaged, per-user-managed, or per-machine context, or (if referring to an MSI) to no system context at all. This parameter can be Machine, UserManaged, UserUnmanaged, or None.
Return Value
An array of selected patch strings from patches, indicating the set of applicable patches. The items are re-ordered to be in the best sequence.
Remarks

If an item in patches is a file path but does not end in .MSP or .XML, it is assumed to be an MSP file.

Passing an InstallContext of None only analyzes the MSI file; it does not consider the current state of the system. You cannot use InstallContext.None with a ProductCode GUID.

Win32 MSI APIs: MsiDetermineApplicablePatches MsiDeterminePatchSequence

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


EnableLog Method

EnableLog Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► EnableLog()()()
Members
Icon | Member | Description
 | EnableLog(InstallLogModes, String) | Enables logging of the selected message type for all subsequent install sessions in the current process space.
 | EnableLog(InstallLogModes, String, Boolean, Boolean) | Enables logging of the selected message type for all subsequent install sessions in the current process space.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


EnableLog Method (logModes, logFile)

EnableLog Method (logModes, logFile)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► EnableLog(InstallLogModes, String)
Enables logging of the selected message type for all subsequent install sessions in the current process space.
Declaration Syntax
C# Visual Basic Visual C++
public static void EnableLog(
    InstallLogModes logModes,
    string logFile
)
Public Shared Sub EnableLog ( _
    logModes As InstallLogModes, _
    logFile As String _
)
public:
static void EnableLog(
    InstallLogModes logModes,
    String^ logFile
)
Parameters
logModes (InstallLogModes)
One or more mode flags specifying the type of messages to log
logFile (String)
Full path to the log file. A null path disables logging, in which case the logModes paraneter is ignored.
Remarks
This method takes effect on any new installation processes. Calling this method from within a custom action will not start logging for that installation.
Exceptions
Exception | Condition
ArgumentException | an invalid log mode was specified

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


EnableLog Method (logModes, logFile, append, flushEveryLine)

EnableLog Method (logModes, logFile, append, flushEveryLine)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► EnableLog(InstallLogModes, String, Boolean, Boolean)
Enables logging of the selected message type for all subsequent install sessions in the current process space.
Declaration Syntax
C# Visual Basic Visual C++
public static void EnableLog(
    InstallLogModes logModes,
    string logFile,
    bool append,
    bool flushEveryLine
)
Public Shared Sub EnableLog ( _
    logModes As InstallLogModes, _
    logFile As String, _
    append As Boolean, _
    flushEveryLine As Boolean _
)
public:
static void EnableLog(
    InstallLogModes logModes,
    String^ logFile,
    bool append,
    bool flushEveryLine
)
Parameters
logModes (InstallLogModes)
One or more mode flags specifying the type of messages to log
logFile (String)
Full path to the log file. A null path disables logging, in which case the logModes paraneter is ignored.
append (Boolean)
If true, the log lines will be appended to any existing file content. If false, the log file will be truncated if it exists. The default is false.
flushEveryLine (Boolean)
If true, the log will be flushed after every line. If false, the log will be flushed every 20 lines. The default is true.
Remarks

This method takes effect on any new installation processes. Calling this method from within a custom action will not start logging for that installation.

Win32 MSI API: MsiEnableLog

Exceptions
Exception | Condition
ArgumentException | an invalid log mode was specified

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ExtractPatchXmlData Method (patchPath)

ExtractPatchXmlData Method (patchPath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ExtractPatchXmlData(String)
Extracts information from a patch that can be used to determine whether the patch applies on a target system. The method returns an XML string that can be provided to DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler, String, UserContexts) instead of the full patch file.
Declaration Syntax
C# Visual Basic Visual C++
public static string ExtractPatchXmlData(
    string patchPath
)
Public Shared Function ExtractPatchXmlData ( _
    patchPath As String _
) As String
public:
static String^ ExtractPatchXmlData(
    String^ patchPath
)
Parameters
patchPath (String)
Full path to the patch being queried.
Return Value
XML string containing patch data.
Remarks

Win32 MSI API: MsiExtractPatchXMLData

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GenerateAdvertiseScript Method

GenerateAdvertiseScript Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GenerateAdvertiseScript()()()
Members
Icon | Member | Description
 | GenerateAdvertiseScript(String, String, String, Int32) | Generates an advertise script. The method enables the installer to write to a script the registry and shortcut information used to assign or publish a product.
 | GenerateAdvertiseScript(String, String, String, Int32, ProcessorArchitecture, Boolean) | Generates an advertise script. The method enables the installer to write to a script the registry and shortcut information used to assign or publish a product.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GenerateAdvertiseScript Method (packagePath, scriptFilePath, transforms, locale)

GenerateAdvertiseScript Method (packagePath, scriptFilePath, transforms, locale)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GenerateAdvertiseScript(String, String, String, Int32)
Generates an advertise script. The method enables the installer to write to a script the registry and shortcut information used to assign or publish a product.
Declaration Syntax
C# Visual Basic Visual C++
public static void GenerateAdvertiseScript(
    string packagePath,
    string scriptFilePath,
    string transforms,
    int locale
)
Public Shared Sub GenerateAdvertiseScript ( _
    packagePath As String, _
    scriptFilePath As String, _
    transforms As String, _
    locale As Integer _
)
public:
static void GenerateAdvertiseScript(
    String^ packagePath,
    String^ scriptFilePath,
    String^ transforms,
    int locale
)
Parameters
packagePath (String)
Path to the package of the product being advertised
scriptFilePath (String)
path to script file to be created with the advertise information
transforms (String)
Semi-colon delimited list of transforms to be applied. This parameter may be null.
locale (Int32)
The language to use if the source supports multiple languages
Remarks

Win32 MSI APIs: MsiAdvertiseProduct, MsiAdvertiseProductEx

Exceptions
Exception | Condition
FileNotFoundException | the specified package file does not exist
See Also
AdvertiseProduct(String, Boolean, String, Int32)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GenerateAdvertiseScript Method (packagePath, scriptFilePath, transforms, locale, processor, instance)

GenerateAdvertiseScript Method (packagePath, scriptFilePath, transforms, locale, processor, instance)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GenerateAdvertiseScript(String, String, String, Int32, ProcessorArchitecture, Boolean)
Generates an advertise script. The method enables the installer to write to a script the registry and shortcut information used to assign or publish a product.
Declaration Syntax
C# Visual Basic Visual C++
public static void GenerateAdvertiseScript(
    string packagePath,
    string scriptFilePath,
    string transforms,
    int locale,
    ProcessorArchitecture processor,
    bool instance
)
Public Shared Sub GenerateAdvertiseScript ( _
    packagePath As String, _
    scriptFilePath As String, _
    transforms As String, _
    locale As Integer, _
    processor As ProcessorArchitecture, _
    instance As Boolean _
)
public:
static void GenerateAdvertiseScript(
    String^ packagePath,
    String^ scriptFilePath,
    String^ transforms,
    int locale,
    ProcessorArchitecture processor,
    bool instance
)
Parameters
packagePath (String)
Path to the package of the product being advertised
scriptFilePath (String)
path to script file to be created with the advertise information
transforms (String)
Semi-colon delimited list of transforms to be applied. This parameter may be null.
locale (Int32)
The language to use if the source supports multiple languages
processor (ProcessorArchitecture)
Targeted processor architecture.
instance (Boolean)
True to install multiple instances through product code changing transform. Advertises a new instance of the product. Requires that the transforms parameter includes the instance transform that changes the product code.
Remarks

Win32 MSI APIs: MsiAdvertiseProduct, MsiAdvertiseProductEx

See Also
AdvertiseProduct(String, Boolean, String, Int32)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetErrorMessage Method

GetErrorMessage Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GetErrorMessage()()()
Members
Icon | Member | Description
 | GetErrorMessage(Int32) | Gets a Windows Installer error message in the system default language.
 | GetErrorMessage(Int32, CultureInfo) | Gets a Windows Installer error message in a specified language.
 | GetErrorMessage(Record) | Gets a formatted Windows Installer error message in the system default language.
 | GetErrorMessage(Record, CultureInfo) | Gets a formatted Windows Installer error message in a specified language.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetErrorMessage Method (errorRecord)

GetErrorMessage Method (errorRecord)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GetErrorMessage(Record)
Gets a formatted Windows Installer error message in the system default language.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetErrorMessage(
    Record errorRecord
)
Public Shared Function GetErrorMessage ( _
    errorRecord As Record _
) As String
public:
static String^ GetErrorMessage(
    Record^ errorRecord
)
Parameters
errorRecord (Record)
Error record containing the error number in the first field, and error-specific parameters in the other fields.
Return Value
The message string, or null if the error message is not found.
Remarks

Error numbers greater than 2000 refer to MSI "internal" errors, and are always returned in English.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetErrorMessage Method (errorRecord, culture)

GetErrorMessage Method (errorRecord, culture)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GetErrorMessage(Record, CultureInfo)
Gets a formatted Windows Installer error message in a specified language.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetErrorMessage(
    Record errorRecord,
    CultureInfo culture
)
Public Shared Function GetErrorMessage ( _
    errorRecord As Record, _
    culture As CultureInfo _
) As String
public:
static String^ GetErrorMessage(
    Record^ errorRecord,
    CultureInfo^ culture
)
Parameters
errorRecord (Record)
Error record containing the error number in the first field, and error-specific parameters in the other fields.
culture (CultureInfo)
The locale for the message.
Return Value
The message string, or null if the error message or locale is not found.
Remarks

Error numbers greater than 2000 refer to MSI "internal" errors, and are always returned in English.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetErrorMessage Method (errorNumber)

GetErrorMessage Method (errorNumber)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GetErrorMessage(Int32)
Gets a Windows Installer error message in the system default language.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetErrorMessage(
    int errorNumber
)
Public Shared Function GetErrorMessage ( _
    errorNumber As Integer _
) As String
public:
static String^ GetErrorMessage(
    int errorNumber
)
Parameters
errorNumber (Int32)
The error number.
Return Value
The message string, or null if the error message is not found.
Remarks

The returned string may have tokens such as [2] and [3] that are meant to be substituted with context-specific values.

Error numbers greater than 2000 refer to MSI "internal" errors, and are always returned in English.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetErrorMessage Method (errorNumber, culture)

GetErrorMessage Method (errorNumber, culture)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GetErrorMessage(Int32, CultureInfo)
Gets a Windows Installer error message in a specified language.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetErrorMessage(
    int errorNumber,
    CultureInfo culture
)
Public Shared Function GetErrorMessage ( _
    errorNumber As Integer, _
    culture As CultureInfo _
) As String
public:
static String^ GetErrorMessage(
    int errorNumber,
    CultureInfo^ culture
)
Parameters
errorNumber (Int32)
The error number.
culture (CultureInfo)
The locale for the message.
Return Value
The message string, or null if the error message or locale is not found.
Remarks

The returned string may have tokens such as [2] and [3] that are meant to be substituted with context-specific values.

Error numbers greater than 2000 refer to MSI "internal" errors, and are always returned in English.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetFileHash Method (path, hash)

GetFileHash Method (path, hash)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GetFileHash(String, array<Int32>[]()[])
Gets a 128-bit hash of the specified file.
Declaration Syntax
C# Visual Basic Visual C++
public static void GetFileHash(
    string path,
    int[] hash
)
Public Shared Sub GetFileHash ( _
    path As String, _
    hash As Integer() _
)
public:
static void GetFileHash(
    String^ path,
    array<int>^ hash
)
Parameters
path (String)
Path to the file
hash (array< Int32 >[]()[])
Integer array of length 4 which receives the four 32-bit parts of the hash value.
Remarks

Win32 MSI API: MsiGetFileHash

Exceptions
Exception | Condition
FileNotFoundException | the file does not exist or could not be read

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetFileLanguage Method (path)

GetFileLanguage Method (path)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GetFileLanguage(String)
Gets the language string of the path specified using the format that the installer expects to find them in in the database.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetFileLanguage(
    string path
)
Public Shared Function GetFileLanguage ( _
    path As String _
) As String
public:
static String^ GetFileLanguage(
    String^ path
)
Parameters
path (String)
Path to the file
Return Value
Language string in the form of a decimal language ID, or an empty string if the file does not contain a language ID
Remarks

Win32 MSI API: MsiGetFileVersion

Exceptions
Exception | Condition
FileNotFoundException | the file does not exist or could not be read

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetFileVersion Method (path)

GetFileVersion Method (path)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GetFileVersion(String)
Gets the version string of the path specified using the format that the installer expects to find it in in the database.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetFileVersion(
    string path
)
Public Shared Function GetFileVersion ( _
    path As String _
) As String
public:
static String^ GetFileVersion(
    String^ path
)
Parameters
path (String)
Path to the file
Return Value
Version string in the "#.#.#.#" format, or an empty string if the file does not contain version information
Remarks

Win32 MSI API: MsiGetFileVersion

Exceptions
Exception | Condition
FileNotFoundException | the file does not exist or could not be read

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetPatchFileList Method (productCode, patches)

GetPatchFileList Method (productCode, patches)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GetPatchFileList(String, IList<(Of <(String>)>))
[MSI 4.0] Gets the list of files that can be updated by one or more patches.
Declaration Syntax
C# Visual Basic Visual C++
public static IList<string> GetPatchFileList(
    string productCode,
    IList<string> patches
)
Public Shared Function GetPatchFileList ( _
    productCode As String, _
    patches As IList(Of String) _
) As IList(Of String)
public:
static IList<String^>^ GetPatchFileList(
    String^ productCode,
    IList<String^>^ patches
)
Parameters
productCode (String)
ProductCode (GUID) of the product which is the target of the patches
patches (IList <(Of <( String >)>))
list of file paths of one or more patches to be analyzed
Return Value
List of absolute paths of files that can be updated when the patches are applied on this system.
Remarks

Win32 MSI API: MsiGetPatchFileList

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetProductInfoFromScript Method (scriptFile)

GetProductInfoFromScript Method (scriptFile)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GetProductInfoFromScript(String)
Gets product information for an installer script file.
Declaration Syntax
C# Visual Basic Visual C++
public static ProductInstallation GetProductInfoFromScript(
    string scriptFile
)
Public Shared Function GetProductInfoFromScript ( _
    scriptFile As String _
) As ProductInstallation
public:
static ProductInstallation^ GetProductInfoFromScript(
    String^ scriptFile
)
Parameters
scriptFile (String)
Path to a script file generated by GenerateAdvertiseScript(String, String, String, Int32, ProcessorArchitecture, Boolean)
Return Value
ProductInstallation stub with advertise-related properties filled in.
Remarks

Only the following properties will be filled in in the returned object:

  • ProductCode
  • AdvertisedLanguage
  • AdvertisedVersion
  • AdvertisedProductName
  • AdvertisedPackageName
Other properties will be null.

Win32 MSI API: MsiGetProductInfoFromScript

Exceptions
Exception | Condition
ArgumentOutOfRangeException | An invalid product property was requested

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetShortcutTarget Method (shortcut)

GetShortcutTarget Method (shortcut)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► GetShortcutTarget(String)
Examines a shortcut and returns its product, feature name, and component if available.
Declaration Syntax
C# Visual Basic Visual C++
public static ShortcutTarget GetShortcutTarget(
    string shortcut
)
Public Shared Function GetShortcutTarget ( _
    shortcut As String _
) As ShortcutTarget
public:
static ShortcutTarget GetShortcutTarget(
    String^ shortcut
)
Parameters
shortcut (String)
Full path to a shortcut
Return Value
ShortcutTarget structure containing target product code, feature, and component code
Remarks

Win32 MSI API: MsiGetShortcutTarget

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallMissingComponent Method (product, component, installState)

InstallMissingComponent Method (product, component, installState)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► InstallMissingComponent(String, String, InstallState)
Installs files that are unexpectedly missing.
Declaration Syntax
C# Visual Basic Visual C++
public static void InstallMissingComponent(
    string product,
    string component,
    InstallState installState
)
Public Shared Sub InstallMissingComponent ( _
    product As String, _
    component As String, _
    installState As InstallState _
)
public:
static void InstallMissingComponent(
    String^ product,
    String^ component,
    InstallState installState
)
Parameters
product (String)
Product code for the product that owns the component to be installed
component (String)
Component to be installed
installState (InstallState)
Specifies the way the component should be installed.
Remarks

Win32 MSI API: MsiInstallMissingComponent

Exceptions
Exception | Condition
InstallCanceledException | the user exited the installation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallMissingFile Method (product, file)

InstallMissingFile Method (product, file)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► InstallMissingFile(String, String)
Installs files that are unexpectedly missing.
Declaration Syntax
C# Visual Basic Visual C++
public static void InstallMissingFile(
    string product,
    string file
)
Public Shared Sub InstallMissingFile ( _
    product As String, _
    file As String _
)
public:
static void InstallMissingFile(
    String^ product,
    String^ file
)
Parameters
product (String)
Product code for the product that owns the file to be installed
file (String)
File to be installed
Remarks

Win32 MSI API: MsiInstallMissingFile

Exceptions
Exception | Condition
InstallCanceledException | the user exited the installation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallProduct Method (packagePath, commandLine)

InstallProduct Method (packagePath, commandLine)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► InstallProduct(String, String)
Opens an installer package and initializes an install session.
Declaration Syntax
C# Visual Basic Visual C++
public static void InstallProduct(
    string packagePath,
    string commandLine
)
Public Shared Sub InstallProduct ( _
    packagePath As String, _
    commandLine As String _
)
public:
static void InstallProduct(
    String^ packagePath,
    String^ commandLine
)
Parameters
packagePath (String)
path to the patch package
commandLine (String)
command line property settings
Remarks

To completely remove a product, set REMOVE=ALL in .

This method displays the user interface with the current settings and log mode. You can change user interface settings with the SetInternalUI(InstallUIOptions) and SetExternalUI(ExternalUIHandler, InstallLogModes) functions. You can set the log mode with the EnableLog(InstallLogModes, String) function.

The RebootRequired and RebootInitiated properties should be tested after calling this method.

Win32 MSI API: MsiInstallProduct

Exceptions
Exception | Condition
InstallerException | There was an error installing the product

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


NotifySidChange Method (oldSid, newSid)

NotifySidChange Method (oldSid, newSid)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► NotifySidChange(String, String)
[MSI 3.1] Migrates a user's application configuration data to a new SID.
Declaration Syntax
C# Visual Basic Visual C++
public static void NotifySidChange(
    string oldSid,
    string newSid
)
Public Shared Sub NotifySidChange ( _
    oldSid As String, _
    newSid As String _
)
public:
static void NotifySidChange(
    String^ oldSid,
    String^ newSid
)
Parameters
oldSid (String)
Previous user SID that data is to be migrated from
newSid (String)
New user SID that data is to be migrated to
Remarks

Win32 MSI API: MsiNotifySidChange

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


OpenPackage Method

OpenPackage Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► OpenPackage()()()
Members
Icon | Member | Description
 | OpenPackage(String, Boolean) | Opens an installer package for use with functions that access the product database and install engine, returning an Session object.
 | OpenPackage(Database, Boolean) | Opens an installer package for use with functions that access the product database and install engine, returning an Session object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


OpenPackage Method (database, ignoreMachineState)

OpenPackage Method (database, ignoreMachineState)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► OpenPackage(Database, Boolean)
Opens an installer package for use with functions that access the product database and install engine, returning an Session object.
Declaration Syntax
C# Visual Basic Visual C++
public static Session OpenPackage(
    Database database,
    bool ignoreMachineState
)
Public Shared Function OpenPackage ( _
    database As Database, _
    ignoreMachineState As Boolean _
) As Session
public:
static Session^ OpenPackage(
    Database^ database,
    bool ignoreMachineState
)
Parameters
database (Database)
Database used to create the session
ignoreMachineState (Boolean)
Specifies whether or not the create a Session object that ignores the computer state and that is incapable of changing the current computer state. A value of false yields the normal behavior. A value of true creates a "safe" Session object that cannot change of the current machine state.
Return Value
A Session object allowing access to the product database and install engine
Remarks

Note that only one Session object can be opened by a single process. OpenPackage cannot be used in a custom action because the active installation is the only session allowed.

A "safe" Session object ignores the current computer state when opening the package and prevents changes to the current computer state.

The Session object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Win32 MSI APIs: MsiOpenPackage, MsiOpenPackageEx

Exceptions
Exception | Condition
InstallerException | The product could not be opened
InstallerException | The installer configuration data is corrupt

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


OpenPackage Method (packagePath, ignoreMachineState)

OpenPackage Method (packagePath, ignoreMachineState)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► OpenPackage(String, Boolean)
Opens an installer package for use with functions that access the product database and install engine, returning an Session object.
Declaration Syntax
C# Visual Basic Visual C++
public static Session OpenPackage(
    string packagePath,
    bool ignoreMachineState
)
Public Shared Function OpenPackage ( _
    packagePath As String, _
    ignoreMachineState As Boolean _
) As Session
public:
static Session^ OpenPackage(
    String^ packagePath,
    bool ignoreMachineState
)
Parameters
packagePath (String)
Path to the package
ignoreMachineState (Boolean)
Specifies whether or not the create a Session object that ignores the computer state and that is incapable of changing the current computer state. A value of false yields the normal behavior. A value of true creates a "safe" Session object that cannot change of the current machine state.
Return Value
A Session object allowing access to the product database and install engine
Remarks

Note that only one Session object can be opened by a single process. OpenPackage cannot be used in a custom action because the active installation is the only session allowed.

A "safe" Session object ignores the current computer state when opening the package and prevents changes to the current computer state.

The Session object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Win32 MSI APIs: MsiOpenPackage, MsiOpenPackageEx

Exceptions
Exception | Condition
InstallerException | The product could not be opened
InstallerException | The installer configuration data is corrupt

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


OpenProduct Method (productCode)

OpenProduct Method (productCode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► OpenProduct(String)
Opens an installer package for an installed product using the product code.
Declaration Syntax
C# Visual Basic Visual C++
public static Session OpenProduct(
    string productCode
)
Public Shared Function OpenProduct ( _
    productCode As String _
) As Session
public:
static Session^ OpenProduct(
    String^ productCode
)
Parameters
productCode (String)
Product code of the installed product
Return Value
A Session object allowing access to the product database and install engine, or null if the specified product is not installed.
Remarks

Note that only one Session object can be opened by a single process. OpenProduct cannot be used in a custom action because the active installation is the only session allowed.

The Session object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Win32 MSI API: MsiOpenProduct

Exceptions
Exception | Condition
ArgumentException | An unknown product was requested
InstallerException | The product could not be opened
InstallerException | The installer configuration data is corrupt

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProcessAdvertiseScript Method (scriptFile, iconFolder, shortcuts, removeItems)

ProcessAdvertiseScript Method (scriptFile, iconFolder, shortcuts, removeItems)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ProcessAdvertiseScript(String, String, Boolean, Boolean)
Processes an advertise script file into the specified locations.
Declaration Syntax
C# Visual Basic Visual C++
public static void ProcessAdvertiseScript(
    string scriptFile,
    string iconFolder,
    bool shortcuts,
    bool removeItems
)
Public Shared Sub ProcessAdvertiseScript ( _
    scriptFile As String, _
    iconFolder As String, _
    shortcuts As Boolean, _
    removeItems As Boolean _
)
public:
static void ProcessAdvertiseScript(
    String^ scriptFile,
    String^ iconFolder,
    bool shortcuts,
    bool removeItems
)
Parameters
scriptFile (String)
Path to a script file generated by GenerateAdvertiseScript(String, String, String, Int32, ProcessorArchitecture, Boolean)
iconFolder (String)
An optional path to a folder in which advertised icon files and transform files are located. If this parameter is null, no icon or transform files are written.
shortcuts (Boolean)
True if shortcuts should be created
removeItems (Boolean)
True if specified items are to be removed instead of created
Remarks

The process calling this function must be running under the LocalSystem account. To advertise an application for per-user installation to a targeted user, the thread that calls this function must impersonate the targeted user. If the thread calling this function is not impersonating a targeted user, the application is advertised to all users for installation with elevated privileges.

Win32 MSI API: MsiProcessAdvertiseScript

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProvideAssembly Method (assemblyName, appContext, installMode, isWin32Assembly)

ProvideAssembly Method (assemblyName, appContext, installMode, isWin32Assembly)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ProvideAssembly(String, String, InstallMode, Boolean)
Gets the full path to a Windows Installer component containing an assembly. This method prompts for a source and increments the usage count for the feature.
Declaration Syntax
C# Visual Basic Visual C++
public static string ProvideAssembly(
    string assemblyName,
    string appContext,
    InstallMode installMode,
    bool isWin32Assembly
)
Public Shared Function ProvideAssembly ( _
    assemblyName As String, _
    appContext As String, _
    installMode As InstallMode, _
    isWin32Assembly As Boolean _
) As String
public:
static String^ ProvideAssembly(
    String^ assemblyName,
    String^ appContext,
    InstallMode installMode,
    bool isWin32Assembly
)
Parameters
assemblyName (String)
Assembly name
appContext (String)
Set to null for global assemblies. For private assemblies, set to the full path of the application configuration file (.cfg file) or executable file (.exe) of the application to which the assembly has been made private.
installMode (InstallMode)
Installation mode; this can also include bits from ReinstallModes
isWin32Assembly (Boolean)
True if this is a Win32 assembly, false if it is a .NET assembly
Return Value
Path to the assembly
Remarks

Win32 MSI API: MsiProvideAssembly

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProvideComponent Method (product, feature, component, installMode)

ProvideComponent Method (product, feature, component, installMode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ProvideComponent(String, String, String, InstallMode)
Gets the full component path, performing any necessary installation. This method prompts for source if necessary and increments the usage count for the feature.
Declaration Syntax
C# Visual Basic Visual C++
public static string ProvideComponent(
    string product,
    string feature,
    string component,
    InstallMode installMode
)
Public Shared Function ProvideComponent ( _
    product As String, _
    feature As String, _
    component As String, _
    installMode As InstallMode _
) As String
public:
static String^ ProvideComponent(
    String^ product,
    String^ feature,
    String^ component,
    InstallMode installMode
)
Parameters
product (String)
Product code for the product that contains the feature with the necessary component
feature (String)
Feature ID of the feature with the necessary component
component (String)
Component code of the necessary component
installMode (InstallMode)
Installation mode; this can also include bits from ReinstallModes
Return Value
Path to the component
Remarks

Win32 MSI API: MsiProvideComponent

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProvideQualifiedComponent Method (component, qualifier, installMode, product)

ProvideQualifiedComponent Method (component, qualifier, installMode, product)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ProvideQualifiedComponent(String, String, InstallMode, String)
Gets the full component path for a qualified component that is published by a product and performs any necessary installation. This method prompts for source if necessary and increments the usage count for the feature.
Declaration Syntax
C# Visual Basic Visual C++
public static string ProvideQualifiedComponent(
    string component,
    string qualifier,
    InstallMode installMode,
    string product
)
Public Shared Function ProvideQualifiedComponent ( _
    component As String, _
    qualifier As String, _
    installMode As InstallMode, _
    product As String _
) As String
public:
static String^ ProvideQualifiedComponent(
    String^ component,
    String^ qualifier,
    InstallMode installMode,
    String^ product
)
Parameters
component (String)
Specifies the component ID for the requested component. This may not be the GUID for the component itself but rather a server that provides the correct functionality, as in the ComponentId column of the PublishComponent table.
qualifier (String)
Specifies a qualifier into a list of advertising components (from PublishComponent Table).
installMode (InstallMode)
Installation mode; this can also include bits from ReinstallModes
product (String)
Optional; specifies the product to match that has published the qualified component.
Return Value
Path to the component
Remarks

Win32 MSI APIs: MsiProvideQualifiedComponent MsiProvideQualifiedComponentEx

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


RebootInitiated Property

RebootInitiated Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► RebootInitiated
Indicates whether a system reboot has been initiated after running an installation or configuration operation.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RebootInitiated { get; }
Public Shared ReadOnly Property RebootInitiated As Boolean
public:
static property bool RebootInitiated {
    bool get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


RebootRequired Property

RebootRequired Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► RebootRequired
Indicates whether a system reboot is required after running an installation or configuration operation.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RebootRequired { get; }
Public Shared ReadOnly Property RebootRequired As Boolean
public:
static property bool RebootRequired {
    bool get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ReinstallFeature Method (product, feature, reinstallModes)

ReinstallFeature Method (product, feature, reinstallModes)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ReinstallFeature(String, String, ReinstallModes)
Reinstalls a feature.
Declaration Syntax
C# Visual Basic Visual C++
public static void ReinstallFeature(
    string product,
    string feature,
    ReinstallModes reinstallModes
)
Public Shared Sub ReinstallFeature ( _
    product As String, _
    feature As String, _
    reinstallModes As ReinstallModes _
)
public:
static void ReinstallFeature(
    String^ product,
    String^ feature,
    ReinstallModes reinstallModes
)
Parameters
product (String)
Product code for the product containing the feature to be reinstalled
feature (String)
Feature to be reinstalled
reinstallModes (ReinstallModes)
Reinstall modes
Remarks

Win32 MSI API: MsiReinstallFeature

Exceptions
Exception | Condition
InstallCanceledException | the user exited the installation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ReinstallProduct Method (product, reinstallModes)

ReinstallProduct Method (product, reinstallModes)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► ReinstallProduct(String, ReinstallModes)
Reinstalls a product.
Declaration Syntax
C# Visual Basic Visual C++
public static void ReinstallProduct(
    string product,
    ReinstallModes reinstallModes
)
Public Shared Sub ReinstallProduct ( _
    product As String, _
    reinstallModes As ReinstallModes _
)
public:
static void ReinstallProduct(
    String^ product,
    ReinstallModes reinstallModes
)
Parameters
product (String)
Product code for the product to be reinstalled
reinstallModes (ReinstallModes)
Reinstall modes
Remarks

Win32 MSI API: MsiReinstallProduct

Exceptions
Exception | Condition
InstallCanceledException | the user exited the installation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


RemovePatches Method (patches, productCode, commandLine)

RemovePatches Method (patches, productCode, commandLine)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► RemovePatches(IList<(Of <(String>)>), String, String)
Removes one or more patches from a single product. To remove a patch from multiple products, RemovePatches must be called for each product.
Declaration Syntax
C# Visual Basic Visual C++
public static void RemovePatches(
    IList<string> patches,
    string productCode,
    string commandLine
)
Public Shared Sub RemovePatches ( _
    patches As IList(Of String), _
    productCode As String, _
    commandLine As String _
)
public:
static void RemovePatches(
    IList<String^>^ patches,
    String^ productCode,
    String^ commandLine
)
Parameters
patches (IList <(Of <( String >)>))
List of patches to remove. Each patch can be specified by the GUID of the patch or the full path to the patch package.
productCode (String)
The ProductCode (GUID) of the product from which the patches are removed. This parameter cannot be null.
commandLine (String)
optional command line property settings
Remarks

The RebootRequired and RebootInitiated properties should be tested after calling this method.

Win32 MSI API: MsiRemovePatches

Exceptions
Exception | Condition
InstallerException | There was an error removing the patches

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetExternalUI Method

SetExternalUI Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► SetExternalUI()()()
Members
Icon | Member | Description
 | SetExternalUI(ExternalUIHandler, InstallLogModes) | Enables an external user-interface handler. This external UI handler is called before the normal internal user-interface handler. The external UI handler has the option to suppress the internal UI by returning a non-zero value to indicate that it has handled the messages.
 | SetExternalUI(ExternalUIRecordHandler, InstallLogModes) | [MSI 3.1] Enables a record-based external user-interface handler. This external UI handler is called before the normal internal user-interface handler. The external UI handler has the option to suppress the internal UI by returning a non-zero value to indicate that it has handled the messages.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetExternalUI Method (uiHandler, messageFilter)

SetExternalUI Method (uiHandler, messageFilter)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► SetExternalUI(ExternalUIHandler, InstallLogModes)
Enables an external user-interface handler. This external UI handler is called before the normal internal user-interface handler. The external UI handler has the option to suppress the internal UI by returning a non-zero value to indicate that it has handled the messages.
Declaration Syntax
C# Visual Basic Visual C++
public static ExternalUIHandler SetExternalUI(
    ExternalUIHandler uiHandler,
    InstallLogModes messageFilter
)
Public Shared Function SetExternalUI ( _
    uiHandler As ExternalUIHandler, _
    messageFilter As InstallLogModes _
) As ExternalUIHandler
public:
static ExternalUIHandler^ SetExternalUI(
    ExternalUIHandler^ uiHandler,
    InstallLogModes messageFilter
)
Parameters
uiHandler (ExternalUIHandler)
A callback delegate that handles the UI messages
messageFilter (InstallLogModes)
Specifies which messages to handle using the external message handler. If the external handler returns a non-zero result, then that message will not be sent to the UI, instead the message will be logged if logging has been enabled.
Return Value
The previously set external handler, or null if there was no previously set handler
Remarks

To restore the previous UI handler, a second call is made to SetExternalUI using the ExternalUIHandler returned by the first call to SetExternalUI and specifying None as the message filter.

The external user interface handler does not have full control over the external user interface unless SetInternalUI(InstallUIOptions) is called with the uiLevel parameter set to Silent. If SetInternalUI is not called, the internal user interface level defaults to Basic. As a result, any message not handled by the external user interface handler is handled by Windows Installer. The initial "Preparing to install..." dialog always appears even if the external user interface handler handles all messages.

SetExternalUI should only be called from a bootstrapping application. You cannot call it from a custom action

Win32 MSI API: MsiSetExternalUI

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetExternalUI Method (uiHandler, messageFilter)

SetExternalUI Method (uiHandler, messageFilter)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► SetExternalUI(ExternalUIRecordHandler, InstallLogModes)
[MSI 3.1] Enables a record-based external user-interface handler. This external UI handler is called before the normal internal user-interface handler. The external UI handler has the option to suppress the internal UI by returning a non-zero value to indicate that it has handled the messages.
Declaration Syntax
C# Visual Basic Visual C++
public static ExternalUIRecordHandler SetExternalUI(
    ExternalUIRecordHandler uiHandler,
    InstallLogModes messageFilter
)
Public Shared Function SetExternalUI ( _
    uiHandler As ExternalUIRecordHandler, _
    messageFilter As InstallLogModes _
) As ExternalUIRecordHandler
public:
static ExternalUIRecordHandler^ SetExternalUI(
    ExternalUIRecordHandler^ uiHandler,
    InstallLogModes messageFilter
)
Parameters
uiHandler (ExternalUIRecordHandler)
A callback delegate that handles the UI messages
messageFilter (InstallLogModes)
Specifies which messages to handle using the external message handler. If the external handler returns a non-zero result, then that message will not be sent to the UI, instead the message will be logged if logging has been enabled.
Return Value
The previously set external handler, or null if there was no previously set handler
Remarks

To restore the previous UI handler, a second call is made to SetExternalUI using the ExternalUIHandler returned by the first call to SetExternalUI and specifying None as the message filter.

The external user interface handler does not have full control over the external user interface unless SetInternalUI(InstallUIOptions) is called with the uiLevel parameter set to Silent. If SetInternalUI is not called, the internal user interface level defaults to Basic. As a result, any message not handled by the external user interface handler is handled by Windows Installer. The initial "Preparing to install..." dialog always appears even if the external user interface handler handles all messages.

SetExternalUI should only be called from a bootstrapping application. You cannot call it from a custom action

Win32 MSI API: MsiSetExternalUIRecord

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetInternalUI Method

SetInternalUI Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► SetInternalUI()()()
Members
Icon | Member | Description
 | SetInternalUI(InstallUIOptions, IntPtr%) | Enables the installer's internal user interface. Then this user interface is used for all subsequent calls to user-interface-generating installer functions in this process.
 | SetInternalUI(InstallUIOptions) | Enables the installer's internal user interface. Then this user interface is used for all subsequent calls to user-interface-generating installer functions in this process. The owner of the user interface does not change.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetInternalUI Method (uiOptions)

SetInternalUI Method (uiOptions)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► SetInternalUI(InstallUIOptions)
Enables the installer's internal user interface. Then this user interface is used for all subsequent calls to user-interface-generating installer functions in this process. The owner of the user interface does not change.
Declaration Syntax
C# Visual Basic Visual C++
public static InstallUIOptions SetInternalUI(
    InstallUIOptions uiOptions
)
Public Shared Function SetInternalUI ( _
    uiOptions As InstallUIOptions _
) As InstallUIOptions
public:
static InstallUIOptions SetInternalUI(
    InstallUIOptions uiOptions
)
Parameters
uiOptions (InstallUIOptions)
Specifies the level of complexity of the user interface
Return Value
The previous user interface level
Remarks

Win32 MSI API: MsiSetInternalUI

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetInternalUI Method (uiOptions, windowHandle)

SetInternalUI Method (uiOptions, windowHandle)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► SetInternalUI(InstallUIOptions, IntPtr%)
Enables the installer's internal user interface. Then this user interface is used for all subsequent calls to user-interface-generating installer functions in this process.
Declaration Syntax
C# Visual Basic Visual C++
public static InstallUIOptions SetInternalUI(
    InstallUIOptions uiOptions,
    ref IntPtr windowHandle
)
Public Shared Function SetInternalUI ( _
    uiOptions As InstallUIOptions, _
    ByRef windowHandle As IntPtr _
) As InstallUIOptions
public:
static InstallUIOptions SetInternalUI(
    InstallUIOptions uiOptions,
    IntPtr% windowHandle
)
Parameters
uiOptions (InstallUIOptions)
Specifies the level of complexity of the user interface
windowHandle ( IntPtr %)
Handle to a window, which becomes the owner of any user interface created. A pointer to the previous owner of the user interface is returned.
Return Value
The previous user interface level
Remarks

Win32 MSI API: MsiSetInternalUI

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


UseFeature Method (productCode, feature, installMode)

UseFeature Method (productCode, feature, installMode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► UseFeature(String, String, InstallMode)
increments the usage count for a particular feature and returns the installation state for that feature. This method should be used to indicate an application's intent to use a feature.
Declaration Syntax
C# Visual Basic Visual C++
public static InstallState UseFeature(
    string productCode,
    string feature,
    InstallMode installMode
)
Public Shared Function UseFeature ( _
    productCode As String, _
    feature As String, _
    installMode As InstallMode _
) As InstallState
public:
static InstallState UseFeature(
    String^ productCode,
    String^ feature,
    InstallMode installMode
)
Parameters
productCode (String)
The product code of the product.
feature (String)
The feature to be used.
installMode (InstallMode)
Must have the value NoDetection.
Return Value
The installed state of the feature.
Remarks

The UseFeature method should only be used on features known to be published. The application should determine the status of the feature by calling either the FeatureState method or Features method.

Win32 MSI APIs: MsiUseFeature, MsiUseFeatureEx

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


VerifyPackage Method (packagePath)

VerifyPackage Method (packagePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► VerifyPackage(String)
Verifies that the given file is an installation package.
Declaration Syntax
C# Visual Basic Visual C++
public static bool VerifyPackage(
    string packagePath
)
Public Shared Function VerifyPackage ( _
    packagePath As String _
) As Boolean
public:
static bool VerifyPackage(
    String^ packagePath
)
Parameters
packagePath (String)
Path to the package
Return Value
True if the file is an installation package; false otherwise.
Remarks

Win32 MSI API: MsiVerifyPackage

Exceptions
Exception | Condition
FileNotFoundException | the specified package file does not exist
InstallerException | the package file could not be opened

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Version Property

Version Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Installer ► Version
Gets the current version of the installer.
Declaration Syntax
C# Visual Basic Visual C++
public static Version Version { get; }
Public Shared ReadOnly Property Version As Version
public:
static property Version^ Version {
    Version^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallerException Class

InstallerException Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerException
Base class for Windows Installer exceptions.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class InstallerException : SystemException
<SerializableAttribute> _
Public Class InstallerException _
    Inherits SystemException
[SerializableAttribute]
public ref class InstallerException : public SystemException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstallerException(String, Exception) | Creates a new InstallerException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | InstallerException(String) | Creates a new InstallerException with a specified error message.
 | InstallerException()()() | Creates a new InstallerException.
 | InstallerException(SerializationInfo, StreamingContext) | Initializes a new instance of the InstallerException class with serialized data.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorCode | Gets the system error code that resulted in this exception, or 0 if not applicable.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetErrorRecord()()() | Gets extended information about the error, or null if no further information is available.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo with information about the exception. (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the exception. This message may contain detailed formatted error data if it was available. (Overrides Exception.Message.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SystemException
 |  |  | InstallerException
 |  |  |  | InstallCanceledException
 |  |  |  | BadQuerySyntaxException
 |  |  |  | InvalidHandleException
 |  |  |  | MergeException

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallerException Constructor

InstallerException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerException ► InstallerException()()()
Members
Icon | Member | Description
 | InstallerException(String, Exception) | Creates a new InstallerException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | InstallerException(String) | Creates a new InstallerException with a specified error message.
 | InstallerException()()() | Creates a new InstallerException.
 | InstallerException(SerializationInfo, StreamingContext) | Initializes a new instance of the InstallerException class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallerException Constructor

InstallerException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerException ► InstallerException()()()
Creates a new InstallerException.
Declaration Syntax
C# Visual Basic Visual C++
public InstallerException()
Public Sub New
public:
InstallerException()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallerException Constructor (info, context)

InstallerException Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerException ► InstallerException(SerializationInfo, StreamingContext)
Initializes a new instance of the InstallerException class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected InstallerException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
InstallerException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallerException Constructor (msg)

InstallerException Constructor (msg)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerException ► InstallerException(String)
Creates a new InstallerException with a specified error message.
Declaration Syntax
C# Visual Basic Visual C++
public InstallerException(
    string msg
)
Public Sub New ( _
    msg As String _
)
public:
InstallerException(
    String^ msg
)
Parameters
msg (String)
The message that describes the error.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallerException Constructor (msg, innerException)

InstallerException Constructor (msg, innerException)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerException ► InstallerException(String, Exception)
Creates a new InstallerException with a specified error message and a reference to the inner exception that is the cause of this exception.
Declaration Syntax
C# Visual Basic Visual C++
public InstallerException(
    string msg,
    Exception innerException
)
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
public:
InstallerException(
    String^ msg,
    Exception^ innerException
)
Parameters
msg (String)
The message that describes the error.
innerException (Exception)
The exception that is the cause of the current exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ErrorCode Property

ErrorCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerException ► ErrorCode
Gets the system error code that resulted in this exception, or 0 if not applicable.
Declaration Syntax
C# Visual Basic Visual C++
public int ErrorCode { get; }
Public ReadOnly Property ErrorCode As Integer
public:
property int ErrorCode {
    int get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetErrorRecord Method

GetErrorRecord Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerException ► GetErrorRecord()()()
Gets extended information about the error, or null if no further information is available.
Declaration Syntax
C# Visual Basic Visual C++
public Record GetErrorRecord()
Public Function GetErrorRecord As Record
public:
Record^ GetErrorRecord()
Return Value
A Record object. Field 1 of the Record contains the installer message code. Other fields contain data specific to the particular error.
Remarks

If the record is passed to Message(InstallMessage, Record), it is formatted by looking up the string in the current database. If there is no installation session, the format string may be obtained by a query on the Error table using the error code, followed by a call to ToString(String, IFormatProvider). Alternatively, the standard MSI message can by retrieved by calling the GetErrorMessage(Record, CultureInfo) method.

The following methods and properties may report extended error data:

  • Database (constructor)
  • Database.ApplyTransform(String, TransformErrors)
  • Database.Commit()()()
  • Database.Execute(String, array<Object>[]()[])
  • Database.ExecuteQuery(String, array<Object>[]()[])
  • Database.ExecuteIntegerQuery(String, array<Object>[]()[])
  • Database.ExecuteStringQuery(String, array<Object>[]()[])
  • Database.Export(String, String)
  • Database.ExportAll(String)
  • Database.GenerateTransform(Database, String)
  • Database.Import(String)
  • Database.ImportAll(String)
  • Database.Merge(Database, String)
  • Database.OpenView(String, array<Object>[]()[])
  • Database.SummaryInfo
  • Database.ViewTransform(String)
  • View.Assign(Record)
  • View.Delete(Record)
  • View.Execute(Record)
  • View.Insert(Record)
  • View.InsertTemporary(Record)
  • View.Merge(Record)
  • View.Modify(ViewModifyMode, Record)
  • View.Refresh(Record)
  • View.Replace(Record)
  • View.Seek(Record)
  • View.Update(Record)
  • View.Validate(Record)
  • View.ValidateFields(Record)
  • View.ValidateDelete(Record)
  • View.ValidateNew(Record)
  • SummaryInfo (constructor)
  • Record.SetStream(Int32, String)
  • Session.SetInstallLevel(Int32)
  • Session.GetSourcePath(String)
  • Session.GetTargetPath(String)
  • Session.SetTargetPath(String, String)
  • ComponentInfo.CurrentState
  • FeatureInfo.CurrentState
  • FeatureInfo.ValidStates
  • FeatureInfo.GetCost(Boolean, Boolean, InstallState)

The Record object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Win32 MSI API: MsiGetLastErrorRecord

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerException ► GetObjectData(SerializationInfo, StreamingContext)
Sets the SerializationInfo with information about the exception.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Message Property

Message Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerException ► Message
Gets a message that describes the exception. This message may contain detailed formatted error data if it was available.
Declaration Syntax
C# Visual Basic Visual C++
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
public:
virtual property String^ Message {
    String^ get () override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallerHandle Class

InstallerHandle Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerHandle
Base class for Windows Installer handle types (Database, View, Record, SummaryInfo).
Declaration Syntax
C# Visual Basic Visual C++
public abstract class InstallerHandle : MarshalByRefObject, IDisposable
Public MustInherit Class InstallerHandle _
    Inherits MarshalByRefObject _
    Implements IDisposable
public ref class InstallerHandle abstract : public MarshalByRefObject,
    IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstallerHandle(IntPtr, Boolean) | Constructs a handle object from a native integer handle.
 | Close()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.
 | Dispose(Boolean) | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.
 | Equals(Object) | Tests whether this handle object is equal to another handle object. Two handle objects are equal if their types are the same and their native integer handles are the same. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Gets a hash value for the handle object. (Overrides Object.GetHashCode()()().)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets the native integer handle.
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsClosed | Checks if the handle is closed. When closed, method calls on the handle object may throw an InvalidHandleException.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

These classes implement the IDisposable interface, because they hold unmanaged resources (MSI handles) that should be properly disposed when no longer needed.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | InstallerHandle
 |  |  | Database
 |  |  | Transaction
 |  |  | Record
 |  |  | Session
 |  |  | SummaryInfo
 |  |  | View

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallerHandle Constructor (handle, ownsHandle)

InstallerHandle Constructor (handle, ownsHandle)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerHandle ► InstallerHandle(IntPtr, Boolean)
Constructs a handle object from a native integer handle.
Declaration Syntax
C# Visual Basic Visual C++
protected InstallerHandle(
    IntPtr handle,
    bool ownsHandle
)
Protected Sub New ( _
    handle As IntPtr, _
    ownsHandle As Boolean _
)
protected:
InstallerHandle(
    IntPtr handle,
    bool ownsHandle
)
Parameters
handle (IntPtr)
Native integer handle.
ownsHandle (Boolean)
true to close the handle when this object is disposed or finalized

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Close Method

Close Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerHandle ► Close()()()
Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.
Declaration Syntax
C# Visual Basic Visual C++
public void Close()
Public Sub Close
public:
void Close()
Remarks

The finalizer of this class will NOT close the handle if it is still open, because finalization can run on a separate thread from the application, resulting in potential problems if handles are closed from that thread. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

This method is merely an alias for the Dispose()()() method.

Win32 MSI API: MsiCloseHandle

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerHandle ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.
 | Dispose(Boolean) | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerHandle ► Dispose()()()
Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
Remarks

The finalizer of this class will NOT close the handle if it is still open, because finalization can run on a separate thread from the application, resulting in potential problems if handles are closed from that thread. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Win32 MSI API: MsiCloseHandle

See Also
Close()()()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method (disposing)

Dispose Method (disposing)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerHandle ► Dispose(Boolean)
Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
)
Parameters
disposing (Boolean)
If true, the method has been called directly or indirectly by a user's code, so managed and unmanaged resources will be disposed. If false, the method has been called by the runtime from inside the finalizer, and only unmanaged resources will be disposed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Equals Method (obj)

Equals Method (obj)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerHandle ► Equals(Object)
Tests whether this handle object is equal to another handle object. Two handle objects are equal if their types are the same and their native integer handles are the same.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
The handle object to compare with the current handle object.
Return Value
true if the specified handle object is equal to the current handle object; otherwise false

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetHashCode Method

GetHashCode Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerHandle ► GetHashCode()()()
Gets a hash value for the handle object.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
A hash code for the handle object.
Remarks

The hash code is derived from the native integer handle.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Handle Property

Handle Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerHandle ► Handle
Gets the native integer handle.
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr Handle { get; }
Public ReadOnly Property Handle As IntPtr
public:
property IntPtr Handle {
    IntPtr get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsClosed Property

IsClosed Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerHandle ► IsClosed
Checks if the handle is closed. When closed, method calls on the handle object may throw an InvalidHandleException.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosed { get; }
Public ReadOnly Property IsClosed As Boolean
public:
property bool IsClosed {
    bool get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallLogModes Enumeration

InstallLogModes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallLogModes
Log modes available for EnableLog(InstallLogModes, String) and SetExternalUI(ExternalUIHandler, InstallLogModes).
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum InstallLogModes
<FlagsAttribute> _
Public Enumeration InstallLogModes
[FlagsAttribute]
public enum class InstallLogModes
Members
Member | Description
None | Disable logging.
FatalExit | Log out of memory or fatal exit information.
Error | Log error messages.
Warning | Log warning messages.
User | Log user requests.
Info | Log status messages that are not displayed.
ResolveSource | Log request to determine a valid source location.
OutOfDiskSpace | Log insufficient disk space error.
ActionStart | Log the start of installation actions.
ActionData | Log the data record for installation actions.
CommonData | Log parameters for user-interface initialization.
PropertyDump | Log the property values at termination.
Verbose | Sends large amounts of information to log file not generally useful to users. May be used for support.
ExtraDebug | Log extra debugging information.
LogOnlyOnError | Log only on error.
Progress | Log progress bar information. This message includes information on units so far and total number of units. See Message(InstallMessage, Record) for an explanation of the message format. This message is only sent to an external user interface and is not logged.
Initialize | If this is not a quiet installation, then the basic UI has been initialized. If this is a full UI installation, the Full UI is not yet initialized. This message is only sent to an external user interface and is not logged.
Terminate | If a full UI is being used, the full UI has ended. If this is not a quiet installation, the basic UI has not yet ended. This message is only sent to an external user interface and is not logged.
ShowDialog | Sent prior to display of the Full UI dialog. This message is only sent to an external user interface and is not logged.
FilesInUse | List of files in use that need to be replaced.
RMFilesInUse | [MSI 4.0] List of apps that the user can request Restart Manager to shut down and restart.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallMessage Enumeration

InstallMessage Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallMessage
Type of message to be processed by Message(InstallMessage, Record), ExternalUIHandler, or ExternalUIRecordHandler.
Declaration Syntax
C# Visual Basic Visual C++
public enum InstallMessage
Public Enumeration InstallMessage
public enum class InstallMessage
Members
Member | Description
FatalExit | Premature termination, possibly fatal OOM.
Error | Formatted error message.
Warning | Formatted warning message.
User | User request message.
Info | Informative message for log.
FilesInUse | List of files in use that need to be replaced.
ResolveSource | Request to determine a valid source location.
OutOfDiskSpace | Insufficient disk space message.
ActionStart | Start of action: action name & description.
ActionData | Formatted data associated with individual action item.
Progress | Progress gauge info: units so far, total.
CommonData | Product info for dialog: language Id, dialog caption.
Initialize | Sent prior to UI initialization, no string data.
Terminate | Sent after UI termination, no string data.
ShowDialog | Sent prior to display or authored dialog or wizard.
RMFilesInUse | [MSI 4.0] List of apps that the user can request Restart Manager to shut down and restart.
InstallStart | [MSI 4.5] Sent prior to install of a product.
InstallEnd | [MSI 4.5] Sent after install of a product.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallMode Enumeration

InstallMode Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallMode
Specifies the install mode for ProvideComponent(String, String, String, InstallMode) or ProvideQualifiedComponent(String, String, InstallMode, String).
Declaration Syntax
C# Visual Basic Visual C++
public enum InstallMode
Public Enumeration InstallMode
public enum class InstallMode
Members
Member | Description
NoSourceResolution | Provide the component only if the feature's installation state is Local.
NoDetection | Only check that the component is registered, without verifying that the key file of the component exists.
Existing | Provide the component only if the feature exists.
Default | Provide the component and perform any installation necessary to provide the component.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallRunMode Enumeration

InstallRunMode Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallRunMode
Specifies the run mode for GetMode(InstallRunMode).
Declaration Syntax
C# Visual Basic Visual C++
public enum InstallRunMode
Public Enumeration InstallRunMode
public enum class InstallRunMode
Members
Member | Description
Admin | The administrative mode is installing, or the product is installing.
Advertise | The advertisements are installing or the product is installing or updating.
Maintenance | An existing installation is being modified or there is a new installation.
RollbackEnabled | Rollback is enabled.
LogEnabled | The log file is active. It was enabled prior to the installation session.
Operations | Execute operations are spooling or they are in the determination phase.
RebootAtEnd | A reboot is necessary after a successful installation (settable).
RebootNow | A reboot is necessary to continue the installation (settable).
Cabinet | Files from cabinets and Media table files are installing.
SourceShortNames | The source LongFileNames is suppressed through the PID_MSISOURCE summary property.
TargetShortNames | The target LongFileNames is suppressed through the SHORTFILENAMES property.
Windows9x | The operating system is Windows 95, Windows 98, or Windows ME.
ZawEnabled | The operating system supports demand installation.
Scheduled | A custom action called from install script execution.
Rollback | A custom action called from rollback execution script.
Commit | A custom action called from commit execution script.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallState Enumeration

InstallState Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallState
Installed state of a Component or Feature.
Declaration Syntax
C# Visual Basic Visual C++
public enum InstallState
Public Enumeration InstallState
public enum class InstallState
Members
Member | Description
NotUsed | The component is disabled.
BadConfig | The installation configuration data is corrupt.
Incomplete | The installation is suspended or in progress.
SourceAbsent | Component is set to run from source, but source is unavailable.
MoreData | The buffer overflow is returned.
InvalidArgument | An invalid parameter was passed to the function.
Unknown | An unrecognized product or feature name was passed to the function.
Broken | The component is broken.
Advertised | The feature is advertised.
Removed | The component is being removed. In action state and not settable.
Absent | The component is not installed, or action state is absent but clients remain.
Local | The component is installed on the local drive.
Source | The component will run from the source, CD, or network.
Default | The component will be installed in the default location: local or source.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallType Enumeration

InstallType Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallType
Specifies the type of installation for ApplyPatch(String, String, InstallType, String).
Declaration Syntax
C# Visual Basic Visual C++
public enum InstallType
Public Enumeration InstallType
public enum class InstallType
Members
Member | Description
Default | Searches system for products to patch.
NetworkImage | Indicates a administrative installation.
SingleInstance | Indicates a particular instance.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallUIOptions Enumeration

InstallUIOptions Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallUIOptions
Level of the installation user interface, specified with SetInternalUI(InstallUIOptions).
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum InstallUIOptions
<FlagsAttribute> _
Public Enumeration InstallUIOptions
[FlagsAttribute]
public enum class InstallUIOptions
Members
Member | Description
NoChange | Does not change UI level.
Default | Uses Default UI level.
Silent | Silent installation.
Basic | Simple progress and error handling.
Reduced | Authored UI, wizard dialogs suppressed.
Full | Authored UI with wizards, progress, and errors.
HideCancel | When combined with the Basic value, the installer does not display the cancel button in the progress dialog.
ProgressOnly | When combined with the Basic value, the installer displays progress dialog boxes but does not display any modal dialog boxes or error dialog boxes.
EndDialog | When combined with another value, the installer displays a modal dialog box at the end of a successful installation or if there has been an error. No dialog box is displayed if the user cancels.
SourceResolutionOnly | Forces display of the source resolution dialog even if the UI is otherwise silent.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InvalidHandleException Class

InvalidHandleException Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InvalidHandleException
A method was called on an invalid installer handle. The handle may have been already closed.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class InvalidHandleException : InstallerException
<SerializableAttribute> _
Public Class InvalidHandleException _
    Inherits InstallerException
[SerializableAttribute]
public ref class InvalidHandleException : public InstallerException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InvalidHandleException(String, Exception) | Creates a new InvalidHandleException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | InvalidHandleException(String) | Creates a new InvalidHandleException with a specified error message.
 | InvalidHandleException()()() | Creates a new InvalidHandleException.
 | InvalidHandleException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidHandleException class with serialized data.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorCode | Gets the system error code that resulted in this exception, or 0 if not applicable. (Inherited from InstallerException.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetErrorRecord()()() | Gets extended information about the error, or null if no further information is available. (Inherited from InstallerException.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo with information about the exception. (Inherited from InstallerException.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the exception. This message may contain detailed formatted error data if it was available. (Inherited from InstallerException.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SystemException
 |  |  | InstallerException
 |  |  |  | InvalidHandleException

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InvalidHandleException Constructor

InvalidHandleException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InvalidHandleException ► InvalidHandleException()()()
Members
Icon | Member | Description
 | InvalidHandleException(String, Exception) | Creates a new InvalidHandleException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | InvalidHandleException(String) | Creates a new InvalidHandleException with a specified error message.
 | InvalidHandleException()()() | Creates a new InvalidHandleException.
 | InvalidHandleException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidHandleException class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InvalidHandleException Constructor

InvalidHandleException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InvalidHandleException ► InvalidHandleException()()()
Creates a new InvalidHandleException.
Declaration Syntax
C# Visual Basic Visual C++
public InvalidHandleException()
Public Sub New
public:
InvalidHandleException()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InvalidHandleException Constructor (info, context)

InvalidHandleException Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InvalidHandleException ► InvalidHandleException(SerializationInfo, StreamingContext)
Initializes a new instance of the InvalidHandleException class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected InvalidHandleException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
InvalidHandleException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InvalidHandleException Constructor (msg)

InvalidHandleException Constructor (msg)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InvalidHandleException ► InvalidHandleException(String)
Creates a new InvalidHandleException with a specified error message.
Declaration Syntax
C# Visual Basic Visual C++
public InvalidHandleException(
    string msg
)
Public Sub New ( _
    msg As String _
)
public:
InvalidHandleException(
    String^ msg
)
Parameters
msg (String)
The message that describes the error.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InvalidHandleException Constructor (msg, innerException)

InvalidHandleException Constructor (msg, innerException)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InvalidHandleException ► InvalidHandleException(String, Exception)
Creates a new InvalidHandleException with a specified error message and a reference to the inner exception that is the cause of this exception.
Declaration Syntax
C# Visual Basic Visual C++
public InvalidHandleException(
    string msg,
    Exception innerException
)
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
public:
InvalidHandleException(
    String^ msg,
    Exception^ innerException
)
Parameters
msg (String)
The message that describes the error.
innerException (Exception)
The exception that is the cause of the current exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


LocatorTypes Enumeration

LocatorTypes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► LocatorTypes
Defines values for the Type column of the CompLocator, IniLocator, and RegLocator tables.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum LocatorTypes
<FlagsAttribute> _
Public Enumeration LocatorTypes
[FlagsAttribute]
public enum class LocatorTypes
Members
Member | Description
Directory | Key path is a directory.
FileName | Key path is a file name.
RawValue | Key path is a registry value.
SixtyFourBit | Set this bit to have the installer search the 64-bit portion of the registry.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MediaDisk Structure

MediaDisk Structure
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MediaDisk
Represents a media disk source of a product or a patch.
Declaration Syntax
C# Visual Basic Visual C++
public struct MediaDisk
Public Structure MediaDisk
public value class MediaDisk
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MediaDisk(Int32, String, String) | Creates a new media disk.
 | DiskId | Gets or sets the disk id of the media disk.
 | DiskPrompt | Gets or sets the disk prompt of the media disk.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | VolumeLabel | Gets or sets the volume label of the media disk.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MediaDisk Constructor (diskId, volumeLabel, diskPrompt)

MediaDisk Constructor (diskId, volumeLabel, diskPrompt)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MediaDisk ► MediaDisk(Int32, String, String)
Creates a new media disk.
Declaration Syntax
C# Visual Basic Visual C++
public MediaDisk(
    int diskId,
    string volumeLabel,
    string diskPrompt
)
Public Sub New ( _
    diskId As Integer, _
    volumeLabel As String, _
    diskPrompt As String _
)
public:
MediaDisk(
    int diskId,
    String^ volumeLabel,
    String^ diskPrompt
)
Parameters
diskId (Int32)
volumeLabel (String)
diskPrompt (String)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DiskId Property

DiskId Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MediaDisk ► DiskId
Gets or sets the disk id of the media disk.
Declaration Syntax
C# Visual Basic Visual C++
public int DiskId { get; set; }
Public Property DiskId As Integer
public:
property int DiskId {
    int get ();
    void set (int value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DiskPrompt Property

DiskPrompt Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MediaDisk ► DiskPrompt
Gets or sets the disk prompt of the media disk.
Declaration Syntax
C# Visual Basic Visual C++
public string DiskPrompt { get; set; }
Public Property DiskPrompt As String
public:
property String^ DiskPrompt {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


VolumeLabel Property

VolumeLabel Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MediaDisk ► VolumeLabel
Gets or sets the volume label of the media disk.
Declaration Syntax
C# Visual Basic Visual C++
public string VolumeLabel { get; set; }
Public Property VolumeLabel As String
public:
property String^ VolumeLabel {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MergeException Class

MergeException Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MergeException
A failure occurred when executing Merge(Database, String). The exception may contain details about the merge conflict.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MergeException : InstallerException
<SerializableAttribute> _
Public Class MergeException _
    Inherits InstallerException
[SerializableAttribute]
public ref class MergeException : public InstallerException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MergeException(String, Exception) | Creates a new MergeException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | MergeException(String) | Creates a new MergeException with a specified error message.
 | MergeException()()() | Creates a new MergeException.
 | MergeException(SerializationInfo, StreamingContext) | Initializes a new instance of the MergeException class with serialized data.
 | ConflictCounts | Gets the number of merge conflicts in each table, corresponding to the tables returned by ConflictTables.
 | ConflictTables | Gets the list of tables containing merge conflicts.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorCode | Gets the system error code that resulted in this exception, or 0 if not applicable. (Inherited from InstallerException.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetErrorRecord()()() | Gets extended information about the error, or null if no further information is available. (Inherited from InstallerException.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Sets the SerializationInfo with information about the exception. (Overrides InstallerException.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the merge conflits. (Overrides InstallerException.Message.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | SystemException
 |  |  | InstallerException
 |  |  |  | MergeException

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MergeException Constructor

MergeException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MergeException ► MergeException()()()
Members
Icon | Member | Description
 | MergeException(String, Exception) | Creates a new MergeException with a specified error message and a reference to the inner exception that is the cause of this exception.
 | MergeException(String) | Creates a new MergeException with a specified error message.
 | MergeException()()() | Creates a new MergeException.
 | MergeException(SerializationInfo, StreamingContext) | Initializes a new instance of the MergeException class with serialized data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MergeException Constructor

MergeException Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MergeException ► MergeException()()()
Creates a new MergeException.
Declaration Syntax
C# Visual Basic Visual C++
public MergeException()
Public Sub New
public:
MergeException()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MergeException Constructor (info, context)

MergeException Constructor (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MergeException ► MergeException(SerializationInfo, StreamingContext)
Initializes a new instance of the MergeException class with serialized data.
Declaration Syntax
C# Visual Basic Visual C++
protected MergeException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
MergeException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MergeException Constructor (msg)

MergeException Constructor (msg)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MergeException ► MergeException(String)
Creates a new MergeException with a specified error message.
Declaration Syntax
C# Visual Basic Visual C++
public MergeException(
    string msg
)
Public Sub New ( _
    msg As String _
)
public:
MergeException(
    String^ msg
)
Parameters
msg (String)
The message that describes the error.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MergeException Constructor (msg, innerException)

MergeException Constructor (msg, innerException)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MergeException ► MergeException(String, Exception)
Creates a new MergeException with a specified error message and a reference to the inner exception that is the cause of this exception.
Declaration Syntax
C# Visual Basic Visual C++
public MergeException(
    string msg,
    Exception innerException
)
Public Sub New ( _
    msg As String, _
    innerException As Exception _
)
public:
MergeException(
    String^ msg,
    Exception^ innerException
)
Parameters
msg (String)
The message that describes the error.
innerException (Exception)
The exception that is the cause of the current exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ConflictCounts Property

ConflictCounts Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MergeException ► ConflictCounts
Gets the number of merge conflicts in each table, corresponding to the tables returned by ConflictTables.
Declaration Syntax
C# Visual Basic Visual C++
public IList<int> ConflictCounts { get; }
Public ReadOnly Property ConflictCounts As IList(Of Integer)
public:
property IList<int>^ ConflictCounts {
    IList<int>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ConflictTables Property

ConflictTables Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MergeException ► ConflictTables
Gets the list of tables containing merge conflicts.
Declaration Syntax
C# Visual Basic Visual C++
public IList<string> ConflictTables { get; }
Public ReadOnly Property ConflictTables As IList(Of String)
public:
property IList<String^>^ ConflictTables {
    IList<String^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MergeException ► GetObjectData(SerializationInfo, StreamingContext)
Sets the SerializationInfo with information about the exception.
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Message Property

Message Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MergeException ► Message
Gets a message that describes the merge conflits.
Declaration Syntax
C# Visual Basic Visual C++
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
public:
virtual property String^ Message {
    String^ get () override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MessageResult Enumeration

MessageResult Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► MessageResult
Specifies a return status value for message handlers. These values are returned by Message(InstallMessage, Record), ExternalUIHandler, and ProcessMessage(InstallMessage, Record, MessageBoxButtons, MessageBoxIcon, MessageBoxDefaultButton).
Declaration Syntax
C# Visual Basic Visual C++
public enum MessageResult
Public Enumeration MessageResult
public enum class MessageResult
Members
Member | Description
Error | An error was found in the message handler.
None | No action was taken.
OK | IDOK
Cancel | IDCANCEL
Abort | IDABORT
Retry | IDRETRY
Ignore | IDIGNORE
Yes | IDYES
No | IDNO

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


PatchInstallation Class

PatchInstallation Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation
The Patch object represents a unique instance of a patch that has been registered or applied.
Declaration Syntax
C# Visual Basic Visual C++
public class PatchInstallation : Installation
Public Class PatchInstallation _
    Inherits Installation
public ref class PatchInstallation : public Installation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PatchInstallation(String, String) | Creates a new object for accessing information about a patch installation on the current system.
 | PatchInstallation(String, String, String, UserContexts) | Creates a new object for accessing information about a patch installation on the current system.
 | AllPatches | Enumerates all patch installations on the system.
 | Context | Gets the user context of this product or patch installation. (Inherited from Installation.)
 | DisplayName | Get the registered display name for the patch.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPatches(String, String, String, UserContexts, PatchStates) | Enumerates patch installations based on certain criteria.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InstallDate | Gets the date and time when the patch is applied to the product.
 | IsInstalled | Gets a value indicating whether this patch is currently installed. (Overrides Installation.IsInstalled.)
 | IsObsoleted | Gets a value indicating whether this patch is marked as obsolte.
 | IsSuperseded | Gets a value indicating whether this patch is present but has been superseded by a more recent installed patch.
 | Item[([(String])]) | Gets information about a specific patch installation. (Overrides Installation.Item[([(String])]).)
 | LocalPackage | Gets the cached patch file that the product uses.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoreInfoUrl | Gets the registered support information URL for the patch.
 | PatchCode | Gets the patch code (GUID) of the patch.
 | ProductCode | Gets the ProductCode (GUID) of the product.
 | SourceList | Gets the source list of this product or patch installation. (Inherited from Installation.)
 | State | Gets the installation state of this instance of the patch.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transforms | Gets the set of patch transforms that the last patch installation applied to the product.
 | Uninstallable | True patch is marked as possible to uninstall from the product.
 | UserSid | Gets the user security identifier (SID) under which this product or patch installation is available. (Inherited from Installation.)
Inheritance Hierarchy
Object
 | Installation
 |  | PatchInstallation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


PatchInstallation Constructor

PatchInstallation Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► PatchInstallation()()()
Members
Icon | Member | Description
 | PatchInstallation(String, String) | Creates a new object for accessing information about a patch installation on the current system.
 | PatchInstallation(String, String, String, UserContexts) | Creates a new object for accessing information about a patch installation on the current system.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


PatchInstallation Constructor (patchCode, productCode)

PatchInstallation Constructor (patchCode, productCode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► PatchInstallation(String, String)
Creates a new object for accessing information about a patch installation on the current system.
Declaration Syntax
C# Visual Basic Visual C++
public PatchInstallation(
    string patchCode,
    string productCode
)
Public Sub New ( _
    patchCode As String, _
    productCode As String _
)
public:
PatchInstallation(
    String^ patchCode,
    String^ productCode
)
Parameters
patchCode (String)
Patch code (GUID) of the patch.
productCode (String)
ProductCode (GUID) the patch has been applied to. This parameter may be null for patches that are registered only and not yet applied to any product.
Remarks

All available user contexts will be queried.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


PatchInstallation Constructor (patchCode, productCode, userSid, context)

PatchInstallation Constructor (patchCode, productCode, userSid, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► PatchInstallation(String, String, String, UserContexts)
Creates a new object for accessing information about a patch installation on the current system.
Declaration Syntax
C# Visual Basic Visual C++
public PatchInstallation(
    string patchCode,
    string productCode,
    string userSid,
    UserContexts context
)
Public Sub New ( _
    patchCode As String, _
    productCode As String, _
    userSid As String, _
    context As UserContexts _
)
public:
PatchInstallation(
    String^ patchCode,
    String^ productCode,
    String^ userSid,
    UserContexts context
)
Parameters
patchCode (String)
Registered patch code (GUID) of the patch.
productCode (String)
ProductCode (GUID) the patch has been applied to. This parameter may be null for patches that are registered only and not yet applied to any product.
userSid (String)
The specific user, when working in a user context. This parameter may be null to indicate the current user. The parameter must be null when working in a machine context.
context (UserContexts)
The user context. The calling process must have administrative privileges to get information for a product installed for a user other than the current user.
Remarks

If the productCode is null, the Patch object may only be used to read and update the patch's SourceList information.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AllPatches Property

AllPatches Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► AllPatches
Enumerates all patch installations on the system.
Declaration Syntax
C# Visual Basic Visual C++
public static IEnumerable<PatchInstallation> AllPatches { get; }
Public Shared ReadOnly Property AllPatches As IEnumerable(Of PatchInstallation)
public:
static property IEnumerable<PatchInstallation^>^ AllPatches {
    IEnumerable<PatchInstallation^>^ get ();
}
Return Value
Enumeration of patch objects.
Remarks

Win32 MSI API: MsiEnumPatches

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DisplayName Property

DisplayName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► DisplayName
Get the registered display name for the patch.
Declaration Syntax
C# Visual Basic Visual C++
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
public:
property String^ DisplayName {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetPatches Method (patchCode, targetProductCode, userSid, context, states)

GetPatches Method (patchCode, targetProductCode, userSid, context, states)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► GetPatches(String, String, String, UserContexts, PatchStates)
Enumerates patch installations based on certain criteria.
Declaration Syntax
C# Visual Basic Visual C++
public static IEnumerable<PatchInstallation> GetPatches(
    string patchCode,
    string targetProductCode,
    string userSid,
    UserContexts context,
    PatchStates states
)
Public Shared Function GetPatches ( _
    patchCode As String, _
    targetProductCode As String, _
    userSid As String, _
    context As UserContexts, _
    states As PatchStates _
) As IEnumerable(Of PatchInstallation)
public:
static IEnumerable<PatchInstallation^>^ GetPatches(
    String^ patchCode,
    String^ targetProductCode,
    String^ userSid,
    UserContexts context,
    PatchStates states
)
Parameters
patchCode (String)
PatchCode (GUID) of the patch to be enumerated. Only instances of patches within the scope of the context specified by the userSid and context parameters will be enumerated. This parameter may be set to null to enumerate all patches in the specified context.
targetProductCode (String)
ProductCode (GUID) product whose patches are to be enumerated. If non-null, patch enumeration is restricted to instances of this product within the specified context. If null, the patches for all products under the specified context are enumerated.
userSid (String)
Specifies a security identifier (SID) that restricts the context of enumeration. A SID value other than s-1-1-0 is considered a user SID and restricts enumeration to the current user or any user in the system. The special SID string s-1-1-0 (Everyone) specifies enumeration across all users in the system. This parameter can be set to null to restrict the enumeration scope to the current user. When installContext is set to the machine context only, userSid must be null.
context (UserContexts)
Specifies the user context.
states (PatchStates)
The PatchStates of patches to return.
Remarks

Win32 MSI APIs: MsiEnumPatchesEx

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallDate Property

InstallDate Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► InstallDate
Gets the date and time when the patch is applied to the product.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime InstallDate { get; }
Public ReadOnly Property InstallDate As DateTime
public:
property DateTime InstallDate {
    DateTime get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsInstalled Property

IsInstalled Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► IsInstalled
Gets a value indicating whether this patch is currently installed.
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsInstalled { get; }
Public Overrides ReadOnly Property IsInstalled As Boolean
public:
virtual property bool IsInstalled {
    bool get () override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsObsoleted Property

IsObsoleted Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► IsObsoleted
Gets a value indicating whether this patch is marked as obsolte.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsObsoleted { get; }
Public ReadOnly Property IsObsoleted As Boolean
public:
property bool IsObsoleted {
    bool get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsSuperseded Property

IsSuperseded Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► IsSuperseded
Gets a value indicating whether this patch is present but has been superseded by a more recent installed patch.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSuperseded { get; }
Public ReadOnly Property IsSuperseded As Boolean
public:
property bool IsSuperseded {
    bool get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (propertyName)

Item Property (propertyName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► Item[([(String])])
Gets information about a specific patch installation.
Declaration Syntax
C# Visual Basic Visual C++
public override string this[
    string propertyName
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    propertyName As String _
) As String
public:
virtual property String^ default[String^ propertyName] {
    String^ get (String^ propertyName) override;
}
Parameters
propertyName (String)
The property being retrieved; see remarks for valid properties.
Return Value
The property value, or an empty string if the property is not set for the patch.
Remarks

Win32 MSI APIs: MsiGetPatchInfo, MsiGetPatchInfoEx

Exceptions
Exception | Condition
ArgumentOutOfRangeException | An unknown patch or property was requested
InstallerException | The installer configuration data is corrupt

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


LocalPackage Property

LocalPackage Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► LocalPackage
Gets the cached patch file that the product uses.
Declaration Syntax
C# Visual Basic Visual C++
public string LocalPackage { get; }
Public ReadOnly Property LocalPackage As String
public:
property String^ LocalPackage {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MoreInfoUrl Property

MoreInfoUrl Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► MoreInfoUrl
Gets the registered support information URL for the patch.
Declaration Syntax
C# Visual Basic Visual C++
public Uri MoreInfoUrl { get; }
Public ReadOnly Property MoreInfoUrl As Uri
public:
property Uri^ MoreInfoUrl {
    Uri^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


PatchCode Property

PatchCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► PatchCode
Gets the patch code (GUID) of the patch.
Declaration Syntax
C# Visual Basic Visual C++
public string PatchCode { get; }
Public ReadOnly Property PatchCode As String
public:
property String^ PatchCode {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProductCode Property

ProductCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► ProductCode
Gets the ProductCode (GUID) of the product.
Declaration Syntax
C# Visual Basic Visual C++
public string ProductCode { get; }
Public ReadOnly Property ProductCode As String
public:
property String^ ProductCode {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


State Property

State Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► State
Gets the installation state of this instance of the patch.
Declaration Syntax
C# Visual Basic Visual C++
public PatchStates State { get; }
Public ReadOnly Property State As PatchStates
public:
property PatchStates State {
    PatchStates get ();
}
Exceptions
Exception | Condition
ArgumentException | An unknown patch was requested
InstallerException | The installer configuration data is corrupt

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Transforms Property

Transforms Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► Transforms
Gets the set of patch transforms that the last patch installation applied to the product.
Declaration Syntax
C# Visual Basic Visual C++
public string Transforms { get; }
Public ReadOnly Property Transforms As String
public:
property String^ Transforms {
    String^ get ();
}
Remarks

This value may not be available for per-user, non-managed applications if the user is not logged on.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Uninstallable Property

Uninstallable Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchInstallation ► Uninstallable
True patch is marked as possible to uninstall from the product.
Declaration Syntax
C# Visual Basic Visual C++
public bool Uninstallable { get; }
Public ReadOnly Property Uninstallable As Boolean
public:
property bool Uninstallable {
    bool get ();
}
Remarks

Even if this property is true, the installer can still block the uninstallation if this patch is required by another patch that cannot be uninstalled.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


PatchStates Enumeration

PatchStates Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► PatchStates
Specifies the different patch states for GetPatches(String, String, String, UserContexts, PatchStates).
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum PatchStates
<FlagsAttribute> _
Public Enumeration PatchStates
[FlagsAttribute]
public enum class PatchStates
Members
Member | Description
None | Invalid value.
Applied | Patches applied to a product.
Superseded | Patches that are superseded by other patches.
Obsoleted | Patches that are obsolesced by other patches.
Registered | Patches that are registered to a product but not applied.
All | All valid patch states.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProductInstallation Class

ProductInstallation Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation
Represents a unique instance of a product that is either advertised, installed or unknown.
Declaration Syntax
C# Visual Basic Visual C++
public class ProductInstallation : Installation
Public Class ProductInstallation _
    Inherits Installation
public ref class ProductInstallation : public Installation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProductInstallation(String) | Creates a new object for accessing information about a product installation on the current system.
 | ProductInstallation(String, String, UserContexts) | Creates a new object for accessing information about a product installation on the current system.
 | AdvertisedLanguage | Product language.
 | AdvertisedPackageCode | Identifier of the package that a product is installed from.
 | AdvertisedPackageName | Name of the installation package for the advertised product.
 | AdvertisedPerMachine | True if the product is advertised per-machine; false if it is per-user or not advertised.
 | AdvertisedProductIcon | Primary icon for the package.
 | AdvertisedProductName | Human readable product name.
 | AdvertisedTransforms | Transforms.
 | AdvertisedVersion | Version of the advertised product.
 | AllProducts | Enumerates all product installations on the system.
 | CollectUserInfo()()() | Obtains and stores the user information and product ID from an installation wizard.
 | Context | Gets the user context of this product or patch installation. (Inherited from Installation.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Features | Gets the set of published features for the product.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetComponentState(String) | Gets the installed state for a product component.
 | GetFeatureState(String) | Gets the installed state for a product feature.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProducts(String, String, UserContexts) | Enumerates product installations based on certain criteria.
 | GetRelatedProducts(String) | Gets the set of all products with a specified upgrade code. This method lists the currently installed and advertised products that have the specified UpgradeCode property in their Property table.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HelpLink | The support link.
 | HelpTelephone | The support telephone.
 | InstallDate | Date and time the product was installed.
 | InstallLocation | The installation location.
 | InstallSource | The installation source.
 | IsAdvertised | Gets a value indicating whether this product is advertised on the current system.
 | IsElevated | Checks whether the product is installed with elevated privileges. An application is called a "managed application" if elevated (system) privileges are used to install the application.
 | IsInstalled | Gets a value indicating whether this product is installed on the current system. (Overrides Installation.IsInstalled.)
 | Item[([(String])]) | Gets information about an installation of a product. (Overrides Installation.Item[([(String])]).)
 | LocalPackage | The local cached package.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrivilegedPatchingAuthorized | True if the advertised product can be serviced by non-administrators without elevation.
 | ProductCode | Gets the ProductCode (GUID) of the product.
 | ProductId | The product identifier.
 | ProductName | The installed product name.
 | ProductVersion | The product version.
 | Publisher | The publisher.
 | RegCompany | The company that is registered to use the product.
 | RegOwner | The owner who is registered to use the product.
 | SourceList | Gets the source list of this product installation. (Overrides Installation.SourceList.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UrlInfoAbout | URL about information.
 | UrlUpdateInfo | The URL update information.
 | UserSid | Gets the user security identifier (SID) under which this product or patch installation is available. (Inherited from Installation.)
Inheritance Hierarchy
Object
 | Installation
 |  | ProductInstallation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProductInstallation Constructor

ProductInstallation Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► ProductInstallation()()()
Members
Icon | Member | Description
 | ProductInstallation(String) | Creates a new object for accessing information about a product installation on the current system.
 | ProductInstallation(String, String, UserContexts) | Creates a new object for accessing information about a product installation on the current system.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProductInstallation Constructor (productCode)

ProductInstallation Constructor (productCode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► ProductInstallation(String)
Creates a new object for accessing information about a product installation on the current system.
Declaration Syntax
C# Visual Basic Visual C++
public ProductInstallation(
    string productCode
)
Public Sub New ( _
    productCode As String _
)
public:
ProductInstallation(
    String^ productCode
)
Parameters
productCode (String)
ProductCode (GUID) of the product.
Remarks

All available user contexts will be queried.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProductInstallation Constructor (productCode, userSid, context)

ProductInstallation Constructor (productCode, userSid, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► ProductInstallation(String, String, UserContexts)
Creates a new object for accessing information about a product installation on the current system.
Declaration Syntax
C# Visual Basic Visual C++
public ProductInstallation(
    string productCode,
    string userSid,
    UserContexts context
)
Public Sub New ( _
    productCode As String, _
    userSid As String, _
    context As UserContexts _
)
public:
ProductInstallation(
    String^ productCode,
    String^ userSid,
    UserContexts context
)
Parameters
productCode (String)
ProductCode (GUID) of the product.
userSid (String)
The specific user, when working in a user context. This parameter may be null to indicate the current user. The parameter must be null when working in a machine context.
context (UserContexts)
The user context. The calling process must have administrative privileges to get information for a product installed for a user other than the current user.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AdvertisedLanguage Property

AdvertisedLanguage Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► AdvertisedLanguage
Product language.
Declaration Syntax
C# Visual Basic Visual C++
public string AdvertisedLanguage { get; }
Public ReadOnly Property AdvertisedLanguage As String
public:
property String^ AdvertisedLanguage {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AdvertisedPackageCode Property

AdvertisedPackageCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► AdvertisedPackageCode
Identifier of the package that a product is installed from.
Declaration Syntax
C# Visual Basic Visual C++
public string AdvertisedPackageCode { get; }
Public ReadOnly Property AdvertisedPackageCode As String
public:
property String^ AdvertisedPackageCode {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AdvertisedPackageName Property

AdvertisedPackageName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► AdvertisedPackageName
Name of the installation package for the advertised product.
Declaration Syntax
C# Visual Basic Visual C++
public string AdvertisedPackageName { get; }
Public ReadOnly Property AdvertisedPackageName As String
public:
property String^ AdvertisedPackageName {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AdvertisedPerMachine Property

AdvertisedPerMachine Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► AdvertisedPerMachine
True if the product is advertised per-machine; false if it is per-user or not advertised.
Declaration Syntax
C# Visual Basic Visual C++
public bool AdvertisedPerMachine { get; }
Public ReadOnly Property AdvertisedPerMachine As Boolean
public:
property bool AdvertisedPerMachine {
    bool get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AdvertisedProductIcon Property

AdvertisedProductIcon Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► AdvertisedProductIcon
Primary icon for the package.
Declaration Syntax
C# Visual Basic Visual C++
public string AdvertisedProductIcon { get; }
Public ReadOnly Property AdvertisedProductIcon As String
public:
property String^ AdvertisedProductIcon {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AdvertisedProductName Property

AdvertisedProductName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► AdvertisedProductName
Human readable product name.
Declaration Syntax
C# Visual Basic Visual C++
public string AdvertisedProductName { get; }
Public ReadOnly Property AdvertisedProductName As String
public:
property String^ AdvertisedProductName {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AdvertisedTransforms Property

AdvertisedTransforms Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► AdvertisedTransforms
Transforms.
Declaration Syntax
C# Visual Basic Visual C++
public string AdvertisedTransforms { get; }
Public ReadOnly Property AdvertisedTransforms As String
public:
property String^ AdvertisedTransforms {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AdvertisedVersion Property

AdvertisedVersion Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► AdvertisedVersion
Version of the advertised product.
Declaration Syntax
C# Visual Basic Visual C++
public Version AdvertisedVersion { get; }
Public ReadOnly Property AdvertisedVersion As Version
public:
property Version^ AdvertisedVersion {
    Version^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


AllProducts Property

AllProducts Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► AllProducts
Enumerates all product installations on the system.
Declaration Syntax
C# Visual Basic Visual C++
public static IEnumerable<ProductInstallation> AllProducts { get; }
Public Shared ReadOnly Property AllProducts As IEnumerable(Of ProductInstallation)
public:
static property IEnumerable<ProductInstallation^>^ AllProducts {
    IEnumerable<ProductInstallation^>^ get ();
}
Return Value
An enumeration of product objects.
Remarks

Win32 MSI API: MsiEnumProducts,

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CollectUserInfo Method

CollectUserInfo Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► CollectUserInfo()()()
Obtains and stores the user information and product ID from an installation wizard.
Declaration Syntax
C# Visual Basic Visual C++
public void CollectUserInfo()
Public Sub CollectUserInfo
public:
void CollectUserInfo()
Remarks

This method is typically called by an application during the first run of the application. The application first gets the ProductId or RegOwner. If those properties are missing, the application calls CollectUserInfo. CollectUserInfo opens the product's installation package and invokes a wizard sequence that collects user information. Upon completion of the sequence, user information is registered. Since this API requires an authored user interface, the user interface level should be set to full by calling SetInternalUI(InstallUIOptions) as Full.

The CollectUserInfo method invokes a FirstRun dialog from the product installation database.

Win32 MSI API: MsiCollectUserInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Features Property

Features Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► Features
Gets the set of published features for the product.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<FeatureInstallation> Features { get; }
Public ReadOnly Property Features As IEnumerable(Of FeatureInstallation)
public:
property IEnumerable<FeatureInstallation^>^ Features {
    IEnumerable<FeatureInstallation^>^ get ();
}
Return Value
Enumeration of published features for the product.
Remarks

Because features are not ordered, any new feature has an arbitrary index, meaning this property can return features in any order.

Win32 MSI API: MsiEnumFeatures

Exceptions
Exception | Condition
InstallerException | The installer configuration data is corrupt

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetComponentState Method (component)

GetComponentState Method (component)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► GetComponentState(String)
Gets the installed state for a product component.
Declaration Syntax
C# Visual Basic Visual C++
public InstallState GetComponentState(
    string component
)
Public Function GetComponentState ( _
    component As String _
) As InstallState
public:
InstallState GetComponentState(
    String^ component
)
Parameters
component (String)
The component being queried; GUID of the component as found in the ComponentId column of the Component table.
Return Value
Installation state of the component for the product instance: either Local or Source.
Remarks

Win32 MSI API: MsiQueryComponentState

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetFeatureState Method (feature)

GetFeatureState Method (feature)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► GetFeatureState(String)
Gets the installed state for a product feature.
Declaration Syntax
C# Visual Basic Visual C++
public InstallState GetFeatureState(
    string feature
)
Public Function GetFeatureState ( _
    feature As String _
) As InstallState
public:
InstallState GetFeatureState(
    String^ feature
)
Parameters
feature (String)
The feature being queried; identifier from the Feature table
Return Value
Installation state of the feature for the product instance: either Local, Source, or Advertised.
Remarks

Win32 MSI APIs: MsiQueryFeatureState, MsiQueryFeatureStateEx

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetProducts Method (productCode, userSid, context)

GetProducts Method (productCode, userSid, context)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► GetProducts(String, String, UserContexts)
Enumerates product installations based on certain criteria.
Declaration Syntax
C# Visual Basic Visual C++
public static IEnumerable<ProductInstallation> GetProducts(
    string productCode,
    string userSid,
    UserContexts context
)
Public Shared Function GetProducts ( _
    productCode As String, _
    userSid As String, _
    context As UserContexts _
) As IEnumerable(Of ProductInstallation)
public:
static IEnumerable<ProductInstallation^>^ GetProducts(
    String^ productCode,
    String^ userSid,
    UserContexts context
)
Parameters
productCode (String)
ProductCode (GUID) of the product instances to be enumerated. Only instances of products within the scope of the context specified by the userSid and installContext parameters will be enumerated. This parameter may be set to null to enumerate all products in the specified context.
userSid (String)
Specifies a security identifier (SID) that restricts the context of enumeration. A SID value other than s-1-1-0 is considered a user SID and restricts enumeration to the current user or any user in the system. The special SID string s-1-1-0 (Everyone) specifies enumeration across all users in the system. This parameter can be set to null to restrict the enumeration scope to the current user. When context is set to the machine context only, userSid must be null.
context (UserContexts)
Specifies the user context.
Return Value
An enumeration of product objects for enumerated product instances.
Remarks

Win32 MSI API: MsiEnumProductsEx

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetRelatedProducts Method (upgradeCode)

GetRelatedProducts Method (upgradeCode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► GetRelatedProducts(String)
Gets the set of all products with a specified upgrade code. This method lists the currently installed and advertised products that have the specified UpgradeCode property in their Property table.
Declaration Syntax
C# Visual Basic Visual C++
public static IEnumerable<ProductInstallation> GetRelatedProducts(
    string upgradeCode
)
Public Shared Function GetRelatedProducts ( _
    upgradeCode As String _
) As IEnumerable(Of ProductInstallation)
public:
static IEnumerable<ProductInstallation^>^ GetRelatedProducts(
    String^ upgradeCode
)
Parameters
upgradeCode (String)
Upgrade code of related products
Return Value
Enumeration of product codes
Remarks

Win32 MSI API: MsiEnumRelatedProducts

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


HelpLink Property

HelpLink Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► HelpLink
The support link.
Declaration Syntax
C# Visual Basic Visual C++
public string HelpLink { get; }
Public ReadOnly Property HelpLink As String
public:
property String^ HelpLink {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


HelpTelephone Property

HelpTelephone Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► HelpTelephone
The support telephone.
Declaration Syntax
C# Visual Basic Visual C++
public string HelpTelephone { get; }
Public ReadOnly Property HelpTelephone As String
public:
property String^ HelpTelephone {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallDate Property

InstallDate Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► InstallDate
Date and time the product was installed.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime InstallDate { get; }
Public ReadOnly Property InstallDate As DateTime
public:
property DateTime InstallDate {
    DateTime get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallLocation Property

InstallLocation Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► InstallLocation
The installation location.
Declaration Syntax
C# Visual Basic Visual C++
public string InstallLocation { get; }
Public ReadOnly Property InstallLocation As String
public:
property String^ InstallLocation {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InstallSource Property

InstallSource Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► InstallSource
The installation source.
Declaration Syntax
C# Visual Basic Visual C++
public string InstallSource { get; }
Public ReadOnly Property InstallSource As String
public:
property String^ InstallSource {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsAdvertised Property

IsAdvertised Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► IsAdvertised
Gets a value indicating whether this product is advertised on the current system.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAdvertised { get; }
Public ReadOnly Property IsAdvertised As Boolean
public:
property bool IsAdvertised {
    bool get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsElevated Property

IsElevated Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► IsElevated
Checks whether the product is installed with elevated privileges. An application is called a "managed application" if elevated (system) privileges are used to install the application.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsElevated { get; }
Public ReadOnly Property IsElevated As Boolean
public:
property bool IsElevated {
    bool get ();
}
Return Value
True if the product is elevated; false otherwise
Remarks

Note that this property does not take into account policies such as AlwaysInstallElevated, but verifies that the local system owns the product's registry data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsInstalled Property

IsInstalled Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► IsInstalled
Gets a value indicating whether this product is installed on the current system.
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsInstalled { get; }
Public Overrides ReadOnly Property IsInstalled As Boolean
public:
virtual property bool IsInstalled {
    bool get () override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (propertyName)

Item Property (propertyName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► Item[([(String])])
Gets information about an installation of a product.
Declaration Syntax
C# Visual Basic Visual C++
public override string this[
    string propertyName
] { get; }
Public Overrides ReadOnly Default Property Item ( _
    propertyName As String _
) As String
public:
virtual property String^ default[String^ propertyName] {
    String^ get (String^ propertyName) override;
}
Parameters
propertyName (String)
Name of the property being retrieved.
Remarks

Win32 MSI APIs: MsiGetProductInfo, MsiGetProductInfoEx

Exceptions
Exception | Condition
ArgumentOutOfRangeException | An unknown product or property was requested
InstallerException | The installer configuration data is corrupt

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


LocalPackage Property

LocalPackage Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► LocalPackage
The local cached package.
Declaration Syntax
C# Visual Basic Visual C++
public string LocalPackage { get; }
Public ReadOnly Property LocalPackage As String
public:
property String^ LocalPackage {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


PrivilegedPatchingAuthorized Property

PrivilegedPatchingAuthorized Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► PrivilegedPatchingAuthorized
True if the advertised product can be serviced by non-administrators without elevation.
Declaration Syntax
C# Visual Basic Visual C++
public bool PrivilegedPatchingAuthorized { get; }
Public ReadOnly Property PrivilegedPatchingAuthorized As Boolean
public:
property bool PrivilegedPatchingAuthorized {
    bool get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProductCode Property

ProductCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► ProductCode
Gets the ProductCode (GUID) of the product.
Declaration Syntax
C# Visual Basic Visual C++
public string ProductCode { get; }
Public ReadOnly Property ProductCode As String
public:
property String^ ProductCode {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProductId Property

ProductId Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► ProductId
The product identifier.
Declaration Syntax
C# Visual Basic Visual C++
public string ProductId { get; }
Public ReadOnly Property ProductId As String
public:
property String^ ProductId {
    String^ get ();
}
Remarks

For more information, see ProductID

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProductName Property

ProductName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► ProductName
The installed product name.
Declaration Syntax
C# Visual Basic Visual C++
public string ProductName { get; }
Public ReadOnly Property ProductName As String
public:
property String^ ProductName {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProductVersion Property

ProductVersion Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► ProductVersion
The product version.
Declaration Syntax
C# Visual Basic Visual C++
public Version ProductVersion { get; }
Public ReadOnly Property ProductVersion As Version
public:
property Version^ ProductVersion {
    Version^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Publisher Property

Publisher Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► Publisher
The publisher.
Declaration Syntax
C# Visual Basic Visual C++
public string Publisher { get; }
Public ReadOnly Property Publisher As String
public:
property String^ Publisher {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


RegCompany Property

RegCompany Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► RegCompany
The company that is registered to use the product.
Declaration Syntax
C# Visual Basic Visual C++
public string RegCompany { get; }
Public ReadOnly Property RegCompany As String
public:
property String^ RegCompany {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


RegOwner Property

RegOwner Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► RegOwner
The owner who is registered to use the product.
Declaration Syntax
C# Visual Basic Visual C++
public string RegOwner { get; }
Public ReadOnly Property RegOwner As String
public:
property String^ RegOwner {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SourceList Property

SourceList Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► SourceList
Gets the source list of this product installation.
Declaration Syntax
C# Visual Basic Visual C++
public override SourceList SourceList { get; }
Public Overrides ReadOnly Property SourceList As SourceList
public:
virtual property SourceList^ SourceList {
    SourceList^ get () override;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


UrlInfoAbout Property

UrlInfoAbout Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► UrlInfoAbout
URL about information.
Declaration Syntax
C# Visual Basic Visual C++
public Uri UrlInfoAbout { get; }
Public ReadOnly Property UrlInfoAbout As Uri
public:
property Uri^ UrlInfoAbout {
    Uri^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


UrlUpdateInfo Property

UrlUpdateInfo Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ProductInstallation ► UrlUpdateInfo
The URL update information.
Declaration Syntax
C# Visual Basic Visual C++
public Uri UrlUpdateInfo { get; }
Public ReadOnly Property UrlUpdateInfo As Uri
public:
property Uri^ UrlUpdateInfo {
    Uri^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Record Class

Record Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record
The Record object is a container for holding and transferring a variable number of values. Fields within the record are numerically indexed and can contain strings, integers, streams, and null values. Record fields are indexed starting with 1. Field 0 is a special format field.
Declaration Syntax
C# Visual Basic Visual C++
public class Record : InstallerHandle
Public Class Record _
    Inherits InstallerHandle
public ref class Record : public InstallerHandle
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Record(Int32) | Creates a new record object with the requested number of fields.
 | Record(array<Object>[]()[]) | Creates a new record object, providing values for an arbitrary number of fields.
 | Clear()()() | Sets all fields in a record to null.
 | Close()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Dispose(Boolean) | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Equals(Object) | Tests whether this handle object is equal to another handle object. Two handle objects are equal if their types are the same and their native integer handles are the same. (Inherited from InstallerHandle.)
 | FieldCount | Gets the number of fields in a record.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FormatString | Gets or sets field 0 of the Record, which is the format string.
 | FromHandle(IntPtr, Boolean) | Creates a new Record object from an integer record handle.
 | GetDataSize(Int32) | Gets the length of a record field. The count does not include the terminating null.
 | GetDataSize(String) | Gets the length of a record field. The count does not include the terminating null.
 | GetHashCode()()() | Gets a hash value for the handle object. (Inherited from InstallerHandle.)
 | GetInteger(Int32) | Gets a field value as an integer.
 | GetInteger(String) | Gets a field value as an integer.
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetNullableInteger(Int32) | Gets a field value as an integer.
 | GetNullableInteger(String) | Gets a field value as an integer.
 | GetStream(Int32, String) | Reads a record stream field into a file.
 | GetStream(String, String) | Reads a record stream field into a file.
 | GetStream(Int32) | Gets a record stream field.
 | GetStream(String) | Gets a record stream field.
 | GetString(Int32) | Gets a field value as a string.
 | GetString(String) | Gets a field value as a string.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets the native integer handle. (Inherited from InstallerHandle.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsClosed | Checks if the handle is closed. When closed, method calls on the handle object may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | IsNull(Int32) | Reports whether a record field is null.
 | IsNull(String) | Reports whether a record field is null.
 | Item[([(String])]) | Gets or sets a record field value.
 | Item[([(Int32])]) | Gets or sets a record field value.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetInteger(Int32, Int32) | Sets the value of a field to an integer.
 | SetInteger(String, Int32) | Sets the value of a field to an integer.
 | SetNullableInteger(Int32, Nullable<(Of <(Int32>)>)) | Sets the value of a field to a nullable integer.
 | SetNullableInteger(String, Nullable<(Of <(Int32>)>)) | Sets the value of a field to a nullable integer.
 | SetStream(Int32, String) | Sets a record stream field from a file. Stream data cannot be inserted into temporary fields.
 | SetStream(String, String) | Sets a record stream field from a file. Stream data cannot be inserted into temporary fields.
 | SetStream(Int32, Stream) | Sets a record stream field from a Stream object. Stream data cannot be inserted into temporary fields.
 | SetStream(String, Stream) | Sets a record stream field from a Stream object. Stream data cannot be inserted into temporary fields.
 | SetString(Int32, String) | Sets the value of a field to a string.
 | SetString(String, String) | Sets the value of a field to a string.
 | ToString()()() | Gets a formatted string representation of the Record. (Overrides Object.ToString()()().)
 | ToString(IFormatProvider) | Gets a formatted string representation of the Record, optionally using a Session to format properties.
 | ToString(String) | Gets a formatted string representation of the Record.
 | ToString(String, IFormatProvider) | Gets a formatted string representation of the Record, optionally using a Session to format properties.
Remarks

Most methods on the Record class have overloads that allow using either a number or a name to designate a field. However note that field names only exist when the Record is directly returned from a query on a database. For other records, attempting to access a field by name will result in an InvalidOperationException.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | InstallerHandle
 |  |  | Record

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Record Constructor

Record Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► Record()()()
Members
Icon | Member | Description
 | Record(Int32) | Creates a new record object with the requested number of fields.
 | Record(array<Object>[]()[]) | Creates a new record object, providing values for an arbitrary number of fields.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Record Constructor (fieldCount)

Record Constructor (fieldCount)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► Record(Int32)
Creates a new record object with the requested number of fields.
Declaration Syntax
C# Visual Basic Visual C++
public Record(
    int fieldCount
)
Public Sub New ( _
    fieldCount As Integer _
)
public:
Record(
    int fieldCount
)
Parameters
fieldCount (Int32)
Required number of fields, which may be 0. The maximum number of fields in a record is limited to 65535.
Remarks

The Record object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Win32 MSI API: MsiCreateRecord

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Record Constructor (fields)

Record Constructor (fields)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► Record(array<Object>[]()[])
Creates a new record object, providing values for an arbitrary number of fields.
Declaration Syntax
C# Visual Basic Visual C++
public Record(
    params Object[] fields
)
Public Sub New ( _
    ParamArray fields As Object() _
)
public:
Record(
    ... array<Object^>^ fields
)
Parameters
fields (array< Object >[]()[])
The values of the record fields. The parameters should be of type Int16, Int32 or String
Remarks

The Record object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Win32 MSI API: MsiCreateRecord

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Clear Method

Clear Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► Clear()()()
Sets all fields in a record to null.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear()
Remarks

Win32 MSI API: MsiRecordClearData

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FieldCount Property

FieldCount Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► FieldCount
Gets the number of fields in a record.
Declaration Syntax
C# Visual Basic Visual C++
public int FieldCount { get; }
Public ReadOnly Property FieldCount As Integer
public:
property int FieldCount {
    int get ();
}
Remarks

Win32 MSI API: MsiRecordGetFieldCount

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FormatString Property

FormatString Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► FormatString
Gets or sets field 0 of the Record, which is the format string.
Declaration Syntax
C# Visual Basic Visual C++
public string FormatString { get; set; }
Public Property FormatString As String
public:
property String^ FormatString {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FromHandle Method (handle, ownsHandle)

FromHandle Method (handle, ownsHandle)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► FromHandle(IntPtr, Boolean)
Creates a new Record object from an integer record handle.
Declaration Syntax
C# Visual Basic Visual C++
public static Record FromHandle(
    IntPtr handle,
    bool ownsHandle
)
Public Shared Function FromHandle ( _
    handle As IntPtr, _
    ownsHandle As Boolean _
) As Record
public:
static Record^ FromHandle(
    IntPtr handle,
    bool ownsHandle
)
Parameters
handle (IntPtr)
Integer record handle
ownsHandle (Boolean)
true to close the handle when this object is disposed or finalized
Remarks

This method is only provided for interop purposes. A Record object should normally be obtained by calling Fetch()()() other methods.

The handle will be closed when this object is disposed or finalized.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetDataSize Method

GetDataSize Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetDataSize()()()
Members
Icon | Member | Description
 | GetDataSize(Int32) | Gets the length of a record field. The count does not include the terminating null.
 | GetDataSize(String) | Gets the length of a record field. The count does not include the terminating null.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetDataSize Method (field)

GetDataSize Method (field)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetDataSize(Int32)
Gets the length of a record field. The count does not include the terminating null.
Declaration Syntax
C# Visual Basic Visual C++
public int GetDataSize(
    int field
)
Public Function GetDataSize ( _
    field As Integer _
) As Integer
public:
int GetDataSize(
    int field
)
Parameters
field (Int32)
Remarks

The returned data size is 0 if the field is null, non-existent, or an internal object pointer. The method also returns 0 if the handle is not a valid Record handle.

If the data is in integer format, the property returns 2 or 4.

If the data is in string format, the property returns the character count (not including the NULL terminator).

If the data is in stream format, the property returns the byte count.

Win32 MSI API: MsiRecordDataSize

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetDataSize Method (fieldName)

GetDataSize Method (fieldName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetDataSize(String)
Gets the length of a record field. The count does not include the terminating null.
Declaration Syntax
C# Visual Basic Visual C++
public int GetDataSize(
    string fieldName
)
Public Function GetDataSize ( _
    fieldName As String _
) As Integer
public:
int GetDataSize(
    String^ fieldName
)
Parameters
fieldName (String)
Specifies the field to check.
Remarks

The returned data size is 0 if the field is null, non-existent, or an internal object pointer. The method also returns 0 if the handle is not a valid Record handle.

If the data is in integer format, the property returns 2 or 4.

If the data is in string format, the property returns the character count (not including the NULL terminator).

If the data is in stream format, the property returns the byte count.

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field name does not match any of the named fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetInteger Method

GetInteger Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetInteger()()()
Members
Icon | Member | Description
 | GetInteger(Int32) | Gets a field value as an integer.
 | GetInteger(String) | Gets a field value as an integer.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetInteger Method (field)

GetInteger Method (field)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetInteger(Int32)
Gets a field value as an integer.
Declaration Syntax
C# Visual Basic Visual C++
public int GetInteger(
    int field
)
Public Function GetInteger ( _
    field As Integer _
) As Integer
public:
int GetInteger(
    int field
)
Parameters
field (Int32)
Specifies the field to retrieve.
Return Value
Integer value of the field, or 0 if the field is null.
Remarks

Win32 MSI API: MsiRecordGetInteger

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.
See Also
GetNullableInteger(Int32)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetInteger Method (fieldName)

GetInteger Method (fieldName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetInteger(String)
Gets a field value as an integer.
Declaration Syntax
C# Visual Basic Visual C++
public int GetInteger(
    string fieldName
)
Public Function GetInteger ( _
    fieldName As String _
) As Integer
public:
int GetInteger(
    String^ fieldName
)
Parameters
fieldName (String)
Specifies the field to retrieve.
Return Value
Integer value of the field, or 0 if the field is null.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field name does not match any of the named fields in the Record.
See Also
GetNullableInteger(String)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetNullableInteger Method

GetNullableInteger Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetNullableInteger()()()
Members
Icon | Member | Description
 | GetNullableInteger(Int32) | Gets a field value as an integer.
 | GetNullableInteger(String) | Gets a field value as an integer.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetNullableInteger Method (field)

GetNullableInteger Method (field)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetNullableInteger(Int32)
Gets a field value as an integer.
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<int> GetNullableInteger(
    int field
)
Public Function GetNullableInteger ( _
    field As Integer _
) As Nullable(Of Integer)
public:
Nullable<int> GetNullableInteger(
    int field
)
Parameters
field (Int32)
Specifies the field to retrieve.
Return Value
Integer value of the field, or null if the field is null.
Remarks

Win32 MSI API: MsiRecordGetInteger

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.
See Also
GetInteger(Int32)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetNullableInteger Method (fieldName)

GetNullableInteger Method (fieldName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetNullableInteger(String)
Gets a field value as an integer.
Declaration Syntax
C# Visual Basic Visual C++
public Nullable<int> GetNullableInteger(
    string fieldName
)
Public Function GetNullableInteger ( _
    fieldName As String _
) As Nullable(Of Integer)
public:
Nullable<int> GetNullableInteger(
    String^ fieldName
)
Parameters
fieldName (String)
Specifies the field to retrieve.
Return Value
Integer value of the field, or null if the field is null.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field name does not match any of the named fields in the Record.
See Also
GetInteger(String)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetStream Method

GetStream Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetStream()()()
Members
Icon | Member | Description
 | GetStream(Int32, String) | Reads a record stream field into a file.
 | GetStream(String, String) | Reads a record stream field into a file.
 | GetStream(Int32) | Gets a record stream field.
 | GetStream(String) | Gets a record stream field.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetStream Method (field)

GetStream Method (field)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetStream(Int32)
Gets a record stream field.
Declaration Syntax
C# Visual Basic Visual C++
public Stream GetStream(
    int field
)
Public Function GetStream ( _
    field As Integer _
) As Stream
public:
Stream^ GetStream(
    int field
)
Parameters
field (Int32)
Specifies the field of the Record to get.
Return Value
A Stream that reads the field data.
Remarks

This method is not capable of reading substorages. To extract a substorage, use GetStream(Int32, String).

Win32 MSI API: MsiRecordReadStream

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetStream Method (field, filePath)

GetStream Method (field, filePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetStream(Int32, String)
Reads a record stream field into a file.
Declaration Syntax
C# Visual Basic Visual C++
public void GetStream(
    int field,
    string filePath
)
Public Sub GetStream ( _
    field As Integer, _
    filePath As String _
)
public:
void GetStream(
    int field,
    String^ filePath
)
Parameters
field (Int32)
Specifies the field of the Record to get.
filePath (String)
Specifies the path to the file to contain the stream.
Remarks

This method is capable of directly extracting substorages. To do so, first select both the `Name` and `Data` column of the `_Storages` table, then get the stream of the `Data` field. However, substorages may only be extracted from a database that is open in read-only mode.

Win32 MSI API: MsiRecordReadStream

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.
NotSupportedException | Attempt to extract a storage from a database open in read-write mode, or from a database without an associated file path

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetStream Method (fieldName)

GetStream Method (fieldName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetStream(String)
Gets a record stream field.
Declaration Syntax
C# Visual Basic Visual C++
public Stream GetStream(
    string fieldName
)
Public Function GetStream ( _
    fieldName As String _
) As Stream
public:
Stream^ GetStream(
    String^ fieldName
)
Parameters
fieldName (String)
Specifies the field of the Record to get.
Return Value
A Stream that reads the field data.
Remarks

This method is not capable of reading substorages. To extract a substorage, use GetStream(String, String).

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field name does not match any of the named fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetStream Method (fieldName, filePath)

GetStream Method (fieldName, filePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetStream(String, String)
Reads a record stream field into a file.
Declaration Syntax
C# Visual Basic Visual C++
public void GetStream(
    string fieldName,
    string filePath
)
Public Sub GetStream ( _
    fieldName As String, _
    filePath As String _
)
public:
void GetStream(
    String^ fieldName,
    String^ filePath
)
Parameters
fieldName (String)
Specifies the field of the Record to get.
filePath (String)
Specifies the path to the file to contain the stream.
Remarks

This method is capable of directly extracting substorages. To do so, first select both the `Name` and `Data` column of the `_Storages` table, then get the stream of the `Data` field. However, substorages may only be extracted from a database that is open in read-only mode.

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field name does not match any of the named fields in the Record.
NotSupportedException | Attempt to extract a storage from a database open in read-write mode, or from a database without an associated file path

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetString Method

GetString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetString()()()
Members
Icon | Member | Description
 | GetString(Int32) | Gets a field value as a string.
 | GetString(String) | Gets a field value as a string.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetString Method (field)

GetString Method (field)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetString(Int32)
Gets a field value as a string.
Declaration Syntax
C# Visual Basic Visual C++
public string GetString(
    int field
)
Public Function GetString ( _
    field As Integer _
) As String
public:
String^ GetString(
    int field
)
Parameters
field (Int32)
Specifies the field to retrieve.
Return Value
String value of the field, or an empty string if the field is null.
Remarks

Win32 MSI API: MsiRecordGetString

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetString Method (fieldName)

GetString Method (fieldName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► GetString(String)
Gets a field value as a string.
Declaration Syntax
C# Visual Basic Visual C++
public string GetString(
    string fieldName
)
Public Function GetString ( _
    fieldName As String _
) As String
public:
String^ GetString(
    String^ fieldName
)
Parameters
fieldName (String)
Specifies the field to retrieve.
Return Value
String value of the field, or an empty string if the field is null.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field name does not match any of the named fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsNull Method

IsNull Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► IsNull()()()
Members
Icon | Member | Description
 | IsNull(Int32) | Reports whether a record field is null.
 | IsNull(String) | Reports whether a record field is null.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsNull Method (field)

IsNull Method (field)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► IsNull(Int32)
Reports whether a record field is null.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNull(
    int field
)
Public Function IsNull ( _
    field As Integer _
) As Boolean
public:
bool IsNull(
    int field
)
Parameters
field (Int32)
Specifies the field to check.
Return Value
True if the field is null, false otherwise.
Remarks

Win32 MSI API: MsiRecordIsNull

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsNull Method (fieldName)

IsNull Method (fieldName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► IsNull(String)
Reports whether a record field is null.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsNull(
    string fieldName
)
Public Function IsNull ( _
    fieldName As String _
) As Boolean
public:
bool IsNull(
    String^ fieldName
)
Parameters
fieldName (String)
Specifies the field to check.
Return Value
True if the field is null, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field name does not match any of the named fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property

Item Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► Item
Members
Icon | Member | Description
 | Item[([(String])]) | Gets or sets a record field value.
 | Item[([(Int32])]) | Gets or sets a record field value.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (field)

Item Property (field)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► Item[([(Int32])])
Gets or sets a record field value.
Declaration Syntax
C# Visual Basic Visual C++
public Object this[
    int field
] { get; set; }
Public Default Property Item ( _
    field As Integer _
) As Object
public:
property Object^ default[int field] {
    Object^ get (int field);
    void set (int field, Object^ value);
}
Parameters
field (Int32)
Specifies the field of the Record to get or set.
Remarks

Record fields are indexed starting with 1. Field 0 is a special format field.

When getting a field, the type of the object returned depends on the type of the Record field. The object will be one of: Int16, Int32, String, Stream, or null. If the Record was returned from a View, the type will match that of the field from the View query. Otherwise, the type will match the type of the last value set for the field.

When setting a field, the type of the object provided will be converted to match the View query that returned the Record, or if Record was not returned from a View then the type of the object provided will determine the type of the Record field. The object should be one of: Int16, Int32, String, Stream, or null.

The type-specific getters and setters are slightly more efficient than this property, since they don't have to do the extra work to infer the value's type every time.

Win32 MSI APIs: MsiRecordGetInteger, MsiRecordGetString, MsiRecordSetInteger, MsiRecordSetString

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (fieldName)

Item Property (fieldName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► Item[([(String])])
Gets or sets a record field value.
Declaration Syntax
C# Visual Basic Visual C++
public Object this[
    string fieldName
] { get; set; }
Public Default Property Item ( _
    fieldName As String _
) As Object
public:
property Object^ default[String^ fieldName] {
    Object^ get (String^ fieldName);
    void set (String^ fieldName, Object^ value);
}
Parameters
fieldName (String)
Specifies the name of the field of the Record to get or set.
Remarks

When getting a field, the type of the object returned depends on the type of the Record field. The object will be one of: Int16, Int32, String, Stream, or null.

When setting a field, the type of the object provided will be converted to match the View query that returned the record, or if Record was not returned from a view then the type of the object provided will determine the type of the Record field. The object should be one of: Int16, Int32, String, Stream, or null.

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The name does not match any known field of the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetInteger Method

SetInteger Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetInteger()()()
Members
Icon | Member | Description
 | SetInteger(Int32, Int32) | Sets the value of a field to an integer.
 | SetInteger(String, Int32) | Sets the value of a field to an integer.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetInteger Method (field, value)

SetInteger Method (field, value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetInteger(Int32, Int32)
Sets the value of a field to an integer.
Declaration Syntax
C# Visual Basic Visual C++
public void SetInteger(
    int field,
    int value
)
Public Sub SetInteger ( _
    field As Integer, _
    value As Integer _
)
public:
void SetInteger(
    int field,
    int value
)
Parameters
field (Int32)
Specifies the field to set.
value (Int32)
new value of the field
Remarks

Win32 MSI API: MsiRecordSetInteger

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.
See Also
SetNullableInteger(Int32, Nullable<(Of <(Int32>)>))

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetInteger Method (fieldName, value)

SetInteger Method (fieldName, value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetInteger(String, Int32)
Sets the value of a field to an integer.
Declaration Syntax
C# Visual Basic Visual C++
public void SetInteger(
    string fieldName,
    int value
)
Public Sub SetInteger ( _
    fieldName As String, _
    value As Integer _
)
public:
void SetInteger(
    String^ fieldName,
    int value
)
Parameters
fieldName (String)
Specifies the field to set.
value (Int32)
new value of the field
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field name does not match any of the named fields in the Record.
See Also
SetNullableInteger(String, Nullable<(Of <(Int32>)>))

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetNullableInteger Method

SetNullableInteger Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetNullableInteger()()()
Members
Icon | Member | Description
 | SetNullableInteger(Int32, Nullable<(Of <(Int32>)>)) | Sets the value of a field to a nullable integer.
 | SetNullableInteger(String, Nullable<(Of <(Int32>)>)) | Sets the value of a field to a nullable integer.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetNullableInteger Method (field, value)

SetNullableInteger Method (field, value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetNullableInteger(Int32, Nullable<(Of <(Int32>)>))
Sets the value of a field to a nullable integer.
Declaration Syntax
C# Visual Basic Visual C++
public void SetNullableInteger(
    int field,
    Nullable<int> value
)
Public Sub SetNullableInteger ( _
    field As Integer, _
    value As Nullable(Of Integer) _
)
public:
void SetNullableInteger(
    int field,
    Nullable<int> value
)
Parameters
field (Int32)
Specifies the field to set.
value (Nullable <(Of <( Int32 >)>))
new value of the field
Remarks

Win32 MSI API: MsiRecordSetInteger

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.
See Also
SetInteger(Int32, Int32)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetNullableInteger Method (fieldName, value)

SetNullableInteger Method (fieldName, value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetNullableInteger(String, Nullable<(Of <(Int32>)>))
Sets the value of a field to a nullable integer.
Declaration Syntax
C# Visual Basic Visual C++
public void SetNullableInteger(
    string fieldName,
    Nullable<int> value
)
Public Sub SetNullableInteger ( _
    fieldName As String, _
    value As Nullable(Of Integer) _
)
public:
void SetNullableInteger(
    String^ fieldName,
    Nullable<int> value
)
Parameters
fieldName (String)
Specifies the field to set.
value (Nullable <(Of <( Int32 >)>))
new value of the field
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field name does not match any of the named fields in the Record.
See Also
SetInteger(String, Int32)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetStream Method

SetStream Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetStream()()()
Members
Icon | Member | Description
 | SetStream(Int32, String) | Sets a record stream field from a file. Stream data cannot be inserted into temporary fields.
 | SetStream(String, String) | Sets a record stream field from a file. Stream data cannot be inserted into temporary fields.
 | SetStream(Int32, Stream) | Sets a record stream field from a Stream object. Stream data cannot be inserted into temporary fields.
 | SetStream(String, Stream) | Sets a record stream field from a Stream object. Stream data cannot be inserted into temporary fields.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetStream Method (field, stream)

SetStream Method (field, stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetStream(Int32, Stream)
Sets a record stream field from a Stream object. Stream data cannot be inserted into temporary fields.
Declaration Syntax
C# Visual Basic Visual C++
public void SetStream(
    int field,
    Stream stream
)
Public Sub SetStream ( _
    field As Integer, _
    stream As Stream _
)
public:
void SetStream(
    int field,
    Stream^ stream
)
Parameters
field (Int32)
Specifies the field of the Record to set.
stream (Stream)
Specifies the stream data.
Remarks

The stream persists if the Record is inserted into the Database and the Database is committed.

Win32 MSI API: MsiRecordsetStream

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetStream Method (field, filePath)

SetStream Method (field, filePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetStream(Int32, String)
Sets a record stream field from a file. Stream data cannot be inserted into temporary fields.
Declaration Syntax
C# Visual Basic Visual C++
public void SetStream(
    int field,
    string filePath
)
Public Sub SetStream ( _
    field As Integer, _
    filePath As String _
)
public:
void SetStream(
    int field,
    String^ filePath
)
Parameters
field (Int32)
Specifies the field of the Record to set.
filePath (String)
Specifies the path to the file containing the stream.
Remarks

The contents of the specified file are read into a stream object. The stream persists if the Record is inserted into the Database and the Database is committed.

To reset the stream to its beginning you must pass in null for filePath. Do not pass an empty string, "", to reset the stream.

Setting a stream with this method is more efficient than setting a field to a FileStream object.

Win32 MSI API: MsiRecordsetStream

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetStream Method (fieldName, stream)

SetStream Method (fieldName, stream)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetStream(String, Stream)
Sets a record stream field from a Stream object. Stream data cannot be inserted into temporary fields.
Declaration Syntax
C# Visual Basic Visual C++
public void SetStream(
    string fieldName,
    Stream stream
)
Public Sub SetStream ( _
    fieldName As String, _
    stream As Stream _
)
public:
void SetStream(
    String^ fieldName,
    Stream^ stream
)
Parameters
fieldName (String)
Specifies the field name of the Record to set.
stream (Stream)
Specifies the stream data.
Remarks

The stream persists if the Record is inserted into the Database and the Database is committed.

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field name does not match any of the named fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetStream Method (fieldName, filePath)

SetStream Method (fieldName, filePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetStream(String, String)
Sets a record stream field from a file. Stream data cannot be inserted into temporary fields.
Declaration Syntax
C# Visual Basic Visual C++
public void SetStream(
    string fieldName,
    string filePath
)
Public Sub SetStream ( _
    fieldName As String, _
    filePath As String _
)
public:
void SetStream(
    String^ fieldName,
    String^ filePath
)
Parameters
fieldName (String)
Specifies the field name of the Record to set.
filePath (String)
Specifies the path to the file containing the stream.
Remarks

The contents of the specified file are read into a stream object. The stream persists if the Record is inserted into the Database and the Database is committed. To reset the stream to its beginning you must pass in null for filePath. Do not pass an empty string, "", to reset the stream.

Setting a stream with this method is more efficient than setting a field to a FileStream object.

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field name does not match any of the named fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetString Method

SetString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetString()()()
Members
Icon | Member | Description
 | SetString(Int32, String) | Sets the value of a field to a string.
 | SetString(String, String) | Sets the value of a field to a string.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetString Method (field, value)

SetString Method (field, value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetString(Int32, String)
Sets the value of a field to a string.
Declaration Syntax
C# Visual Basic Visual C++
public void SetString(
    int field,
    string value
)
Public Sub SetString ( _
    field As Integer, _
    value As String _
)
public:
void SetString(
    int field,
    String^ value
)
Parameters
field (Int32)
Specifies the field to set.
value (String)
new value of the field
Remarks

Win32 MSI API: MsiRecordSetString

Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field is less than 0 or greater than the number of fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetString Method (fieldName, value)

SetString Method (fieldName, value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► SetString(String, String)
Sets the value of a field to a string.
Declaration Syntax
C# Visual Basic Visual C++
public void SetString(
    string fieldName,
    string value
)
Public Sub SetString ( _
    fieldName As String, _
    value As String _
)
public:
void SetString(
    String^ fieldName,
    String^ value
)
Parameters
fieldName (String)
Specifies the field to set.
value (String)
new value of the field
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The field name does not match any of the named fields in the Record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ToString Method

ToString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► ToString()()()
Members
Icon | Member | Description
 | ToString()()() | Gets a formatted string representation of the Record. (Overrides Object.ToString()()().)
 | ToString(IFormatProvider) | Gets a formatted string representation of the Record, optionally using a Session to format properties.
 | ToString(String) | Gets a formatted string representation of the Record.
 | ToString(String, IFormatProvider) | Gets a formatted string representation of the Record, optionally using a Session to format properties.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ToString Method

ToString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► ToString()()()
Gets a formatted string representation of the Record.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A formatted string representation of the Record.
Remarks

If field 0 of the Record is set to a nonempty string, it is used to format the data in the Record.

Win32 MSI API: MsiFormatRecord

See Also
FormatString
FormatRecord(Record)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ToString Method (provider)

ToString Method (provider)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► ToString(IFormatProvider)
Gets a formatted string representation of the Record, optionally using a Session to format properties.
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    IFormatProvider provider
)
Public Function ToString ( _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    IFormatProvider^ provider
)
Parameters
provider (IFormatProvider)
an optional Session instance that will be used to lookup any properties in the Record's format string
Return Value
A formatted string representation of the Record.
Remarks

If field 0 of the Record is set to a nonempty string, it is used to format the data in the Record.

Win32 MSI API: MsiFormatRecord

See Also
FormatString
FormatRecord(Record)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ToString Method (format)

ToString Method (format)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► ToString(String)
Gets a formatted string representation of the Record.
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format
)
Public Function ToString ( _
    format As String _
) As String
public:
String^ ToString(
    String^ format
)
Parameters
format (String)
String to be used to format the data in the Record, instead of the Record's format string.
Return Value
A formatted string representation of the Record.
Remarks

Win32 MSI API: MsiFormatRecord

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ToString Method (format, provider)

ToString Method (format, provider)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► ToString(String, IFormatProvider)
Gets a formatted string representation of the Record, optionally using a Session to format properties.
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString ( _
    format As String, _
    provider As IFormatProvider _
) As String
public:
String^ ToString(
    String^ format,
    IFormatProvider^ provider
)
Parameters
format (String)
String to be used to format the data in the Record, instead of the Record's format string.
provider (IFormatProvider)
an optional Session instance that will be used to lookup any properties in the Record's format string
Return Value
A formatted string representation of the Record.
Remarks

Win32 MSI API: MsiFormatRecord

See Also
FormatString
FormatRecord(Record)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


RegistryRoot Enumeration

RegistryRoot Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► RegistryRoot
Defines values for the Root column of the Registry, RemoveRegistry, and RegLocator tables.
Declaration Syntax
C# Visual Basic Visual C++
public enum RegistryRoot
Public Enumeration RegistryRoot
public enum class RegistryRoot
Members
Member | Description
UserOrMachine | HKEY_CURRENT_USER for a per-user installation, or HKEY_LOCAL_MACHINE for a per-machine installation.
ClassesRoot | HKEY_CLASSES_ROOT
CurrentUser | HKEY_CURRENT_USER
LocalMachine | HKEY_LOCAL_MACHINE
Users | HKEY_USERS

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ReinstallModes Enumeration

ReinstallModes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ReinstallModes
Specifies the reinstall mode for ReinstallFeature(String, String, ReinstallModes) or ReinstallProduct(String, ReinstallModes).
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum ReinstallModes
<FlagsAttribute> _
Public Enumeration ReinstallModes
[FlagsAttribute]
public enum class ReinstallModes
Members
Member | Description
FileMissing | Reinstall only if file is missing.
FileOlderVersion | Reinstall if file is missing, or older version.
FileEqualVersion | Reinstall if file is missing, or equal or older version.
FileExact | Reinstall if file is missing, or not exact version.
FileVerify | Checksum executables, reinstall if missing or corrupt.
FileReplace | Reinstall all files, regardless of version.
MachineData | Insure required machine reg entries.
UserData | Insure required user reg entries.
Shortcut | Validate shortcuts items.
Package | Use re-cache source install package.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


RemoveFileModes Enumeration

RemoveFileModes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► RemoveFileModes
Defines values for the InstallMode column of the RemoveFile table.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum RemoveFileModes
<FlagsAttribute> _
Public Enumeration RemoveFileModes
[FlagsAttribute]
public enum class RemoveFileModes
Members
Member | Description
None | Never remove.
OnInstall | Remove when the associated component is being installed (install state = local or source).
OnRemove | Remove when the associated component is being removed (install state = absent).

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ServiceAttributes Enumeration

ServiceAttributes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ServiceAttributes
Defines values for the ServiceType, StartType, and ErrorControl columns of the ServiceInstall table.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum ServiceAttributes
<FlagsAttribute> _
Public Enumeration ServiceAttributes
[FlagsAttribute]
public enum class ServiceAttributes
Members
Member | Description
None | No flags.
OwnProcess | A Win32 service that runs its own process.
ShareProcess | A Win32 service that shares a process.
Interactive | A Win32 service that interacts with the desktop. This value cannot be used alone and must be added to either OwnProcess or ShareProcess.
AutoStart | Service starts during startup of the system.
DemandStart | Service starts when the service control manager calls the StartService function.
Disabled | Specifies a service that can no longer be started.
ErrorMessage | Logs the error, displays a message box and continues the startup operation.
ErrorCritical | Logs the error if it is possible and the system is restarted with the last configuration known to be good. If the last-known-good configuration is being started, the startup operation fails.
ErrorControlVital | When combined with other error flags, specifies that the overall install should fail if the service cannot be installed into the system.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ServiceControlEvents Enumeration

ServiceControlEvents Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ServiceControlEvents
Defines values for the Event column of the ServiceControl table.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum ServiceControlEvents
<FlagsAttribute> _
Public Enumeration ServiceControlEvents
[FlagsAttribute]
public enum class ServiceControlEvents
Members
Member | Description
None | No control events.
Start | During an install, starts the service during the StartServices action.
Stop | During an install, stops the service during the StopServices action.
Delete | During an install, deletes the service during the DeleteServices action.
UninstallStart | During an uninstall, starts the service during the StartServices action.
UninstallStop | During an uninstall, stops the service during the StopServices action.
UninstallDelete | During an uninstall, deletes the service during the DeleteServices action.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Session Class

Session Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session
The Session object controls the installation process. It opens the install database, which contains the installation tables and data.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Session : InstallerHandle, IFormatProvider
Public NotInheritable Class Session _
    Inherits InstallerHandle _
    Implements IFormatProvider
public ref class Session sealed : public InstallerHandle,
    IFormatProvider
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Close()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Components | Gets an accessor for components in the current session.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CustomActionData | Gets custom action data for the session that was supplied by the caller.
 | Database | Gets the Database for the install session.
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Dispose(Boolean) | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | DoAction(String) | Executes a built-in action, custom action, or user-interface wizard action.
 | DoAction(String, CustomActionData) | Executes a built-in action, custom action, or user-interface wizard action.
 | DoActionSequence(String) | Executes an action sequence described in the specified table.
 | Equals(Object) | Tests whether this handle object is equal to another handle object. Two handle objects are equal if their types are the same and their native integer handles are the same. (Inherited from InstallerHandle.)
 | EvaluateCondition(String) | Evaluates a logical expression containing symbols and values.
 | EvaluateCondition(String, Boolean) | Evaluates a logical expression containing symbols and values, specifying a default value to be returned in case the condition is empty.
 | Features | Gets an accessor for features in the current session.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Format(String) | Formats a string containing installer properties.
 | FormatRecord(Record) | Returns a formatted string from record data.
 | FormatRecord(Record, String) | Returns a formatted string from record data using a specified format.
 | FromHandle(IntPtr, Boolean) | Creates a new Session object from an integer session handle.
 | GetHashCode()()() | Gets a hash value for the handle object. (Inherited from InstallerHandle.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetMode(InstallRunMode) | Gets the designated mode flag for the current install session.
 | GetProductProperty(String) | Retrieves product properties (not session properties) from the product database.
 | GetSourcePath(String) | Gets the full path to the designated folder on the source media or server image.
 | GetTargetPath(String) | Gets the full path to the designated folder on the installation target drive.
 | GetTotalCost()()() | Gets the total disk space per drive required for the installation.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets the native integer handle. (Inherited from InstallerHandle.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsClosed | Checks if the handle is closed. When closed, method calls on the handle object may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Item[([(String])]) | Gets or sets the string value of a named installer property, as maintained by the Session object in the in-memory Property table, or, if it is prefixed with a percent sign (%), the value of a system environment variable for the current process.
 | Language | Gets the numeric language ID used by the current install session.
 | Log(String) | Writes a message to the log, if logging is enabled.
 | Log(String, array<Object>[]()[]) | Writes a formatted message to the log, if logging is enabled.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message(InstallMessage, Record) | Performs any enabled logging operations and defers execution to the UI handler object associated with the engine.
 | SetInstallLevel(Int32) | Sets the install level for the current installation to a specified value and recalculates the Select and Installed states for all features in the Feature table. Also sets the Action state of each component in the Component table based on the new level.
 | SetMode(InstallRunMode, Boolean) | Sets the designated mode flag for the current install session.
 | SetTargetPath(String, String) | Sets the full path to the designated folder on the installation target drive.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VerifyDiskSpace()()() | Checks to see if sufficient disk space is present for the current installation.
Remarks

This object is associated with a standard set of action functions, each performing particular operations on data from one or more tables. Additional custom actions may be added for particular product installations. The basic engine function is a sequencer that fetches sequential records from a designated sequence table, evaluates any specified condition expression, and executes the designated action. Actions not recognized by the engine are deferred to the UI handler object for processing, usually dialog box sequences.

Note that only one Session object can be opened by a single process.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | InstallerHandle
 |  |  | Session

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Components Property

Components Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► Components
Gets an accessor for components in the current session.
Declaration Syntax
C# Visual Basic Visual C++
public ComponentInfoCollection Components { get; }
Public ReadOnly Property Components As ComponentInfoCollection
public:
property ComponentInfoCollection^ Components {
    ComponentInfoCollection^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CustomActionData Property

CustomActionData Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► CustomActionData
Gets custom action data for the session that was supplied by the caller.
Declaration Syntax
C# Visual Basic Visual C++
public CustomActionData CustomActionData { get; }
Public ReadOnly Property CustomActionData As CustomActionData
public:
property CustomActionData^ CustomActionData {
    CustomActionData^ get ();
}
See Also
DoAction(String, CustomActionData)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Database Property

Database Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► Database
Gets the Database for the install session.
Declaration Syntax
C# Visual Basic Visual C++
public Database Database { get; }
Public ReadOnly Property Database As Database
public:
property Database^ Database {
    Database^ get ();
}
Remarks

Normally there is no need to close this Database object. The same object can be used throughout the lifetime of the Session, and it will be closed when the Session is closed.

Win32 MSI API: MsiGetActiveDatabase

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
InstallerException | the Database cannot be accessed

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DoAction Method

DoAction Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► DoAction()()()
Members
Icon | Member | Description
 | DoAction(String) | Executes a built-in action, custom action, or user-interface wizard action.
 | DoAction(String, CustomActionData) | Executes a built-in action, custom action, or user-interface wizard action.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DoAction Method (action)

DoAction Method (action)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► DoAction(String)
Executes a built-in action, custom action, or user-interface wizard action.
Declaration Syntax
C# Visual Basic Visual C++
public void DoAction(
    string action
)
Public Sub DoAction ( _
    action As String _
)
public:
void DoAction(
    String^ action
)
Parameters
action (String)
Name of the action to execute. Case-sensitive.
Remarks

The DoAction method executes the action that corresponds to the name supplied. If the name is not recognized by the installer as a built-in action or as a custom action in the CustomAction table, the name is passed to the user-interface handler object, which can invoke a function or a dialog box. If a null action name is supplied, the installer uses the upper-case value of the ACTION property as the action to perform. If no property value is defined, the default action is performed, defined as "INSTALL".

Actions that update the system, such as the InstallFiles and WriteRegistryValues actions, cannot be run by calling MsiDoAction. The exception to this rule is if DoAction is called from a custom action that is scheduled in the InstallExecuteSequence table between the InstallInitialize and InstallFinalize actions. Actions that do not update the system, such as AppSearch or CostInitialize, can be called.

Win32 MSI API: MsiDoAction

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
InstallCanceledException | the user exited the installation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DoAction Method (action, actionData)

DoAction Method (action, actionData)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► DoAction(String, CustomActionData)
Executes a built-in action, custom action, or user-interface wizard action.
Declaration Syntax
C# Visual Basic Visual C++
public void DoAction(
    string action,
    CustomActionData actionData
)
Public Sub DoAction ( _
    action As String, _
    actionData As CustomActionData _
)
public:
void DoAction(
    String^ action,
    CustomActionData^ actionData
)
Parameters
action (String)
Name of the action to execute. Case-sensitive.
actionData (CustomActionData)
Optional data to be passed to a deferred custom action.
Remarks

The DoAction method executes the action that corresponds to the name supplied. If the name is not recognized by the installer as a built-in action or as a custom action in the CustomAction table, the name is passed to the user-interface handler object, which can invoke a function or a dialog box. If a null action name is supplied, the installer uses the upper-case value of the ACTION property as the action to perform. If no property value is defined, the default action is performed, defined as "INSTALL".

Actions that update the system, such as the InstallFiles and WriteRegistryValues actions, cannot be run by calling MsiDoAction. The exception to this rule is if DoAction is called from a custom action that is scheduled in the InstallExecuteSequence table between the InstallInitialize and InstallFinalize actions. Actions that do not update the system, such as AppSearch or CostInitialize, can be called.

If the called action is a deferred, rollback, or commit custom action, then the supplied actionData will be available via the CustomActionData property of that custom action's session.

Win32 MSI API: MsiDoAction

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
InstallCanceledException | the user exited the installation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DoActionSequence Method (sequenceTable)

DoActionSequence Method (sequenceTable)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► DoActionSequence(String)
Executes an action sequence described in the specified table.
Declaration Syntax
C# Visual Basic Visual C++
public void DoActionSequence(
    string sequenceTable
)
Public Sub DoActionSequence ( _
    sequenceTable As String _
)
public:
void DoActionSequence(
    String^ sequenceTable
)
Parameters
sequenceTable (String)
Name of the table containing the action sequence.
Remarks

This method queries the specified table, ordering the actions by the numbers in the Sequence column. For each row retrieved, an action is executed, provided that any supplied condition expression does not evaluate to FALSE.

An action sequence containing any actions that update the system, such as the InstallFiles and WriteRegistryValues actions, cannot be run by calling DoActionSequence. The exception to this rule is if DoActionSequence is called from a custom action that is scheduled in the InstallExecuteSequence table between the InstallInitialize and InstallFinalize actions. Actions that do not update the system, such as AppSearch or CostInitialize, can be called.

Win32 MSI API: MsiSequence

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
InstallCanceledException | the user exited the installation

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


EvaluateCondition Method

EvaluateCondition Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► EvaluateCondition()()()
Members
Icon | Member | Description
 | EvaluateCondition(String) | Evaluates a logical expression containing symbols and values.
 | EvaluateCondition(String, Boolean) | Evaluates a logical expression containing symbols and values, specifying a default value to be returned in case the condition is empty.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


EvaluateCondition Method (condition)

EvaluateCondition Method (condition)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► EvaluateCondition(String)
Evaluates a logical expression containing symbols and values.
Declaration Syntax
C# Visual Basic Visual C++
public bool EvaluateCondition(
    string condition
)
Public Function EvaluateCondition ( _
    condition As String _
) As Boolean
public:
bool EvaluateCondition(
    String^ condition
)
Parameters
condition (String)
conditional expression
Return Value
The result of the condition evaluation
Remarks

Win32 MSI API: MsiEvaluateCondition

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
ArgumentNullException | the condition is null or empty
SyntaxErrorException | the conditional expression is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


EvaluateCondition Method (condition, defaultValue)

EvaluateCondition Method (condition, defaultValue)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► EvaluateCondition(String, Boolean)
Evaluates a logical expression containing symbols and values, specifying a default value to be returned in case the condition is empty.
Declaration Syntax
C# Visual Basic Visual C++
public bool EvaluateCondition(
    string condition,
    bool defaultValue
)
Public Function EvaluateCondition ( _
    condition As String, _
    defaultValue As Boolean _
) As Boolean
public:
bool EvaluateCondition(
    String^ condition,
    bool defaultValue
)
Parameters
condition (String)
conditional expression
defaultValue (Boolean)
value to return if the condition is empty
Return Value
The result of the condition evaluation
Remarks

Win32 MSI API: MsiEvaluateCondition

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
SyntaxErrorException | the conditional expression is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Features Property

Features Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► Features
Gets an accessor for features in the current session.
Declaration Syntax
C# Visual Basic Visual C++
public FeatureInfoCollection Features { get; }
Public ReadOnly Property Features As FeatureInfoCollection
public:
property FeatureInfoCollection^ Features {
    FeatureInfoCollection^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Format Method (format)

Format Method (format)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► Format(String)
Formats a string containing installer properties.
Declaration Syntax
C# Visual Basic Visual C++
public string Format(
    string format
)
Public Function Format ( _
    format As String _
) As String
public:
String^ Format(
    String^ format
)
Parameters
format (String)
A format string containing property tokens
Return Value
A formatted string containing property data
Remarks

Win32 MSI API: MsiFormatRecord

Exceptions
Exception | Condition
InvalidHandleException | the Record handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FormatRecord Method

FormatRecord Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► FormatRecord()()()
Members
Icon | Member | Description
 | FormatRecord(Record) | Returns a formatted string from record data.
 | FormatRecord(Record, String) | Returns a formatted string from record data using a specified format.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FormatRecord Method (record)

FormatRecord Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► FormatRecord(Record)
Returns a formatted string from record data.
Declaration Syntax
C# Visual Basic Visual C++
public string FormatRecord(
    Record record
)
Public Function FormatRecord ( _
    record As Record _
) As String
public:
String^ FormatRecord(
    Record^ record
)
Parameters
record (Record)
Record object containing a template and data to be formatted. The template string must be set in field 0 followed by any referenced data parameters.
Return Value
A formatted string containing the record data
Remarks

Win32 MSI API: MsiFormatRecord

Exceptions
Exception | Condition
InvalidHandleException | the Record handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FormatRecord Method (record, format)

FormatRecord Method (record, format)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► FormatRecord(Record, String)
Returns a formatted string from record data using a specified format.
Declaration Syntax
C# Visual Basic Visual C++
public string FormatRecord(
    Record record,
    string format
)
Public Function FormatRecord ( _
    record As Record, _
    format As String _
) As String
public:
String^ FormatRecord(
    Record^ record,
    String^ format
)
Parameters
record (Record)
Record object containing a template and data to be formatted
format (String)
Format string to be used instead of field 0 of the Record
Return Value
A formatted string containing the record data
Remarks

Win32 MSI API: MsiFormatRecord

Exceptions
Exception | Condition
InvalidHandleException | the Record handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FromHandle Method (handle, ownsHandle)

FromHandle Method (handle, ownsHandle)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► FromHandle(IntPtr, Boolean)
Creates a new Session object from an integer session handle.
Declaration Syntax
C# Visual Basic Visual C++
public static Session FromHandle(
    IntPtr handle,
    bool ownsHandle
)
Public Shared Function FromHandle ( _
    handle As IntPtr, _
    ownsHandle As Boolean _
) As Session
public:
static Session^ FromHandle(
    IntPtr handle,
    bool ownsHandle
)
Parameters
handle (IntPtr)
Integer session handle
ownsHandle (Boolean)
true to close the handle when this object is disposed or finalized
Remarks

This method is only provided for interop purposes. A Session object should normally be obtained by calling OpenPackage(Database, Boolean) or OpenProduct(String).

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetMode Method (mode)

GetMode Method (mode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► GetMode(InstallRunMode)
Gets the designated mode flag for the current install session.
Declaration Syntax
C# Visual Basic Visual C++
public bool GetMode(
    InstallRunMode mode
)
Public Function GetMode ( _
    mode As InstallRunMode _
) As Boolean
public:
bool GetMode(
    InstallRunMode mode
)
Parameters
mode (InstallRunMode)
The type of mode to be checked.
Return Value
The value of the designated mode flag.
Remarks

Note that only the following run modes are available to read from a deferred custom action:

  • Scheduled
  • Rollback
  • Commit

Win32 MSI API: MsiGetMode

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
ArgumentOutOfRangeException | an invalid mode flag was specified

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetProductProperty Method (property)

GetProductProperty Method (property)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► GetProductProperty(String)
Retrieves product properties (not session properties) from the product database.
Declaration Syntax
C# Visual Basic Visual C++
public string GetProductProperty(
    string property
)
Public Function GetProductProperty ( _
    property As String _
) As String
public:
String^ GetProductProperty(
    String^ property
)
Parameters
property (String)
Return Value
Value of the property, or an empty string if the property is not set.
Remarks

Note this is not the correct method for getting ordinary session properties. For that, see the indexer on the Session class.

Win32 MSI API: MsiGetProductProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetSourcePath Method (directory)

GetSourcePath Method (directory)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► GetSourcePath(String)
Gets the full path to the designated folder on the source media or server image.
Declaration Syntax
C# Visual Basic Visual C++
public string GetSourcePath(
    string directory
)
Public Function GetSourcePath ( _
    directory As String _
) As String
public:
String^ GetSourcePath(
    String^ directory
)
Parameters
directory (String)
Remarks

Win32 MSI API: MsiGetSourcePath

Exceptions
Exception | Condition
ArgumentException | the folder was not found in the Directory table
InvalidHandleException | the Session handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetTargetPath Method (directory)

GetTargetPath Method (directory)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► GetTargetPath(String)
Gets the full path to the designated folder on the installation target drive.
Declaration Syntax
C# Visual Basic Visual C++
public string GetTargetPath(
    string directory
)
Public Function GetTargetPath ( _
    directory As String _
) As String
public:
String^ GetTargetPath(
    String^ directory
)
Parameters
directory (String)
Remarks

Win32 MSI API: MsiGetTargetPath

Exceptions
Exception | Condition
ArgumentException | the folder was not found in the Directory table
InvalidHandleException | the Session handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetTotalCost Method

GetTotalCost Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► GetTotalCost()()()
Gets the total disk space per drive required for the installation.
Declaration Syntax
C# Visual Basic Visual C++
public IList<InstallCost> GetTotalCost()
Public Function GetTotalCost As IList(Of InstallCost)
public:
IList<InstallCost>^ GetTotalCost()
Return Value
A list of InstallCost structures, specifying the cost for each drive
Remarks

Win32 MSI API: MsiEnumComponentCosts

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (property)

Item Property (property)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► Item[([(String])])
Gets or sets the string value of a named installer property, as maintained by the Session object in the in-memory Property table, or, if it is prefixed with a percent sign (%), the value of a system environment variable for the current process.
Declaration Syntax
C# Visual Basic Visual C++
public string this[
    string property
] { get; set; }
Public Default Property Item ( _
    property As String _
) As String
public:
property String^ default[String^ property] {
    String^ get (String^ property);
    void set (String^ property, String^ value);
}
Parameters
property (String)
Remarks

Win32 MSI APIs: MsiGetProperty, MsiSetProperty

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Language Property

Language Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► Language
Gets the numeric language ID used by the current install session.
Declaration Syntax
C# Visual Basic Visual C++
public int Language { get; }
Public ReadOnly Property Language As Integer
public:
property int Language {
    int get ();
}
Remarks

Win32 MSI API: MsiGetLanguage

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Log Method

Log Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► Log()()()
Members
Icon | Member | Description
 | Log(String) | Writes a message to the log, if logging is enabled.
 | Log(String, array<Object>[]()[]) | Writes a formatted message to the log, if logging is enabled.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Log Method (msg)

Log Method (msg)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► Log(String)
Writes a message to the log, if logging is enabled.
Declaration Syntax
C# Visual Basic Visual C++
public void Log(
    string msg
)
Public Sub Log ( _
    msg As String _
)
public:
void Log(
    String^ msg
)
Parameters
msg (String)
The line to be written to the log
Remarks

Win32 MSI API: MsiProcessMessage

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Log Method (format, args)

Log Method (format, args)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► Log(String, array<Object>[]()[])
Writes a formatted message to the log, if logging is enabled.
Declaration Syntax
C# Visual Basic Visual C++
public void Log(
    string format,
    params Object[] args
)
Public Sub Log ( _
    format As String, _
    ParamArray args As Object() _
)
public:
void Log(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format (String)
The line to be written to the log, containing 0 or more format specifiers
args (array< Object >[]()[])
An array containing 0 or more objects to be formatted
Remarks

Win32 MSI API: MsiProcessMessage

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Message Method (messageType, record)

Message Method (messageType, record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► Message(InstallMessage, Record)
Performs any enabled logging operations and defers execution to the UI handler object associated with the engine.
Declaration Syntax
C# Visual Basic Visual C++
public MessageResult Message(
    InstallMessage messageType,
    Record record
)
Public Function Message ( _
    messageType As InstallMessage, _
    record As Record _
) As MessageResult
public:
MessageResult Message(
    InstallMessage messageType,
    Record^ record
)
Parameters
messageType (InstallMessage)
Type of message to be processed
record (Record)
Contains message-specific fields
Return Value
A message-dependent return value
Remarks

Logging may be selectively enabled for the various message types. See the EnableLog(InstallLogModes, String) method.

If record field 0 contains a formatting string, it is used to format the data in the other fields. Else if the message is an error, warning, or user message, an attempt is made to find a message template in the Error table for the current database using the error number found in field 1 of the record for message types and return values.

The messageType parameter may also include message-box flags from the following enumerations: System.Windows.Forms.MessageBoxButtons, System.Windows.Forms.MessageBoxDefaultButton, System.Windows.Forms.MessageBoxIcon. These flags can be combined with the InstallMessage with a bitwise OR.

Note, this method never returns Cancel or Error values. Instead, appropriate exceptions are thrown in those cases.

Win32 MSI API: MsiProcessMessage

Exceptions
Exception | Condition
InvalidHandleException | the Session or Record handle is invalid
ArgumentOutOfRangeException | an invalid message kind is specified
InstallCanceledException | the user exited the installation
InstallerException | the message-handler failed for an unknown reason

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetInstallLevel Method (installLevel)

SetInstallLevel Method (installLevel)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► SetInstallLevel(Int32)
Sets the install level for the current installation to a specified value and recalculates the Select and Installed states for all features in the Feature table. Also sets the Action state of each component in the Component table based on the new level.
Declaration Syntax
C# Visual Basic Visual C++
public void SetInstallLevel(
    int installLevel
)
Public Sub SetInstallLevel ( _
    installLevel As Integer _
)
public:
void SetInstallLevel(
    int installLevel
)
Parameters
installLevel (Int32)
New install level
Remarks

The SetInstallLevel method sets the following:

  • The installation level for the current installation to a specified value
  • The Select and Installed states for all features in the Feature table
  • The Action state of each component in the Component table, based on the new level
If 0 or a negative number is passed in the ilnstallLevel parameter, the current installation level does not change, but all features are still updated based on the current installation level.

Win32 MSI API: MsiSetInstallLevel

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetMode Method (mode, value)

SetMode Method (mode, value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► SetMode(InstallRunMode, Boolean)
Sets the designated mode flag for the current install session.
Declaration Syntax
C# Visual Basic Visual C++
public void SetMode(
    InstallRunMode mode,
    bool value
)
Public Sub SetMode ( _
    mode As InstallRunMode, _
    value As Boolean _
)
public:
void SetMode(
    InstallRunMode mode,
    bool value
)
Parameters
mode (InstallRunMode)
The type of mode to be set.
value (Boolean)
The desired value of the mode.
Remarks

Win32 MSI API: MsiSetMode

Exceptions
Exception | Condition
InvalidHandleException | the Session handle is invalid
ArgumentOutOfRangeException | an invalid mode flag was specified
InvalidOperationException | the mode cannot not be set

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SetTargetPath Method (directory, value)

SetTargetPath Method (directory, value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► SetTargetPath(String, String)
Sets the full path to the designated folder on the installation target drive.
Declaration Syntax
C# Visual Basic Visual C++
public void SetTargetPath(
    string directory,
    string value
)
Public Sub SetTargetPath ( _
    directory As String, _
    value As String _
)
public:
void SetTargetPath(
    String^ directory,
    String^ value
)
Parameters
directory (String)
value (String)
Remarks

Setting the target path of a directory changes the path specification for the directory in the in-memory Directory table. Also, the path specifications of all other path objects in the table that are either subordinate or equivalent to the changed path are updated to reflect the change. The properties for each affected path are also updated.

If an error occurs in this function, all updated paths and properties revert to their previous values. Therefore, it is safe to treat errors returned by this function as non-fatal.

Do not attempt to configure the target path if the components using those paths are already installed for the current user or for a different user. Check the ProductState property before setting the target path to determine if the product containing this component is installed.

Win32 MSI API: MsiSetTargetPath

Exceptions
Exception | Condition
ArgumentException | the folder was not found in the Directory table
InvalidHandleException | the Session handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


VerifyDiskSpace Method

VerifyDiskSpace Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► VerifyDiskSpace()()()
Checks to see if sufficient disk space is present for the current installation.
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyDiskSpace()
Public Function VerifyDiskSpace As Boolean
public:
bool VerifyDiskSpace()
Return Value
True if there is sufficient disk space; false otherwise.
Remarks

Win32 MSI API: MsiVerifyDiskSpace

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ShortcutTarget Structure

ShortcutTarget Structure
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ShortcutTarget
Holds information about the target of a shortcut file.
Declaration Syntax
C# Visual Basic Visual C++
public struct ShortcutTarget
Public Structure ShortcutTarget
public value class ShortcutTarget
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ComponentCode | Gets the target component code of the shortcut, or null if not available.
 | Equality(ShortcutTarget, ShortcutTarget) | Tests whether two shortcut targets have the same product code, feature, and/or component code.
 | Equals(Object) | Tests whether two shortcut targets have the same product code, feature, and/or component code. (Overrides ValueType.Equals(Object).)
 | Feature | Gets the name of the target feature of the shortcut, or null if not available.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Generates a hash code using all parts of the shortcut target. (Overrides ValueType.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inequality(ShortcutTarget, ShortcutTarget) | Tests whether two shortcut targets have the same product code, feature, and/or component code.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProductCode | Gets the target product code of the shortcut, or null if not available.
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ComponentCode Property

ComponentCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ShortcutTarget ► ComponentCode
Gets the target component code of the shortcut, or null if not available.
Declaration Syntax
C# Visual Basic Visual C++
public string ComponentCode { get; }
Public ReadOnly Property ComponentCode As String
public:
property String^ ComponentCode {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Equality Operator

Equality Operator
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ShortcutTarget ► Equality(ShortcutTarget, ShortcutTarget)
Tests whether two shortcut targets have the same product code, feature, and/or component code.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator ==(
    ShortcutTarget st1,
    ShortcutTarget st2
)
Public Shared Operator = ( _
    st1 As ShortcutTarget, _
    st2 As ShortcutTarget _
) As Boolean
public:
static bool operator ==(
    ShortcutTarget st1,
    ShortcutTarget st2
)
Parameters
st1 (ShortcutTarget)
The first shortcut target to compare.
st2 (ShortcutTarget)
The second shortcut target to compare.
Return Value
True if all parts of the targets are the same, else false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Equals Method (obj)

Equals Method (obj)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ShortcutTarget ► Equals(Object)
Tests whether two shortcut targets have the same product code, feature, and/or component code.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)
The shortcut target to compare to the current object.
Return Value
True if obj is a shortcut target and all parts of the targets are the same, else false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Feature Property

Feature Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ShortcutTarget ► Feature
Gets the name of the target feature of the shortcut, or null if not available.
Declaration Syntax
C# Visual Basic Visual C++
public string Feature { get; }
Public ReadOnly Property Feature As String
public:
property String^ Feature {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetHashCode Method

GetHashCode Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ShortcutTarget ► GetHashCode()()()
Generates a hash code using all parts of the shortcut target.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value
An integer suitable for hashing the shortcut target.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Inequality Operator

Inequality Operator
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ShortcutTarget ► Inequality(ShortcutTarget, ShortcutTarget)
Tests whether two shortcut targets have the same product code, feature, and/or component code.
Declaration Syntax
C# Visual Basic Visual C++
public static bool operator !=(
    ShortcutTarget st1,
    ShortcutTarget st2
)
Public Shared Operator <> ( _
    st1 As ShortcutTarget, _
    st2 As ShortcutTarget _
) As Boolean
public:
static bool operator !=(
    ShortcutTarget st1,
    ShortcutTarget st2
)
Parameters
st1 (ShortcutTarget)
The first shortcut target to compare.
st2 (ShortcutTarget)
The second shortcut target to compare.
Return Value
True if any parts of the targets are different, else false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ProductCode Property

ProductCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ShortcutTarget ► ProductCode
Gets the target product code of the shortcut, or null if not available.
Declaration Syntax
C# Visual Basic Visual C++
public string ProductCode { get; }
Public ReadOnly Property ProductCode As String
public:
property String^ ProductCode {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SourceList Class

SourceList Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList
A list of sources for an installed product or patch.
Declaration Syntax
C# Visual Basic Visual C++
public class SourceList : ICollection<string>,
    IEnumerable<string>, IEnumerable
Public Class SourceList _
    Implements ICollection(Of String), IEnumerable(Of String),  _
    IEnumerable
public ref class SourceList : ICollection<String^>,
    IEnumerable<String^>, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(String) | Adds a network or URL source to the source list of the installed product.
 | Clear()()() | Clears sources of all types: network, url, and media.
 | ClearNetworkSources()()() | Removes all network sources from the list. URL sources are not affected.
 | ClearUrlSources()()() | Removes all URL sources from the list. Network sources are not affected.
 | Contains(String) | Checks if the specified source exists in the list.
 | CopyTo(array<String>[]()[], Int32) | Copies the network and URL sources from this list into an array.
 | Count | Gets the number of network and URL sources in the list.
 | DiskPrompt | Gets or sets the prompt template that is used when prompting the user for installation media.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForceResolution()()() | Forces the installer to search the source list for a valid source the next time a source is required. For example, when the installer performs an installation or reinstallation, or when it requires the path for a component that is set to run from source.
 | GetEnumerator()()() | Enumerates the network and URL sources in the source list of the patch or product installation.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Insert(String, Int32) | Adds or reorders a network or URL source for the product or patch.
 | IsReadOnly | Gets a boolean value indicating whether the list is read-only. A SourceList is never read-only.
 | Item[([(String])]) | Gets or sets source list information properties of a product or patch installation.
 | LastUsedSource | Gets or sets the most recently used source location for the product.
 | LastUsedType | Gets the type of the last-used source.
 | MediaList | Gets the list of disks registered for the media source of the patch or product installation.
 | MediaPackagePath | Gets or sets the path relative to the root of the installation media.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PackageName | Gets or sets the name of the Windows Installer package or patch package on the source.
 | Remove(String) | Removes a network or URL source.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SourceList

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Add Method (item)

Add Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► Add(String)
Adds a network or URL source to the source list of the installed product.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string item
)
Public Sub Add ( _
    item As String _
)
public:
virtual void Add(
    String^ item
) sealed
Parameters
item (String)
Path to the source to be added. This parameter is expected to contain only the path without the filename.
Remarks

If this method is called with a new source, the installer adds the source to the end of the source list.

If this method is called with a source already existing in the source list, it has no effect.

Win32 MSI APIs: MsiSourceListAddSource, MsiSourceListAddSourceEx

See Also
Insert(String, Int32)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Clear Method

Clear Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► Clear()()()
Clears sources of all types: network, url, and media.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
Remarks

Win32 MSI API: MsiSourceListClearAll

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ClearNetworkSources Method

ClearNetworkSources Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► ClearNetworkSources()()()
Removes all network sources from the list. URL sources are not affected.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearNetworkSources()
Public Sub ClearNetworkSources
public:
void ClearNetworkSources()
Remarks

Win32 MSI API: MsiSourceListClearAllEx

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ClearUrlSources Method

ClearUrlSources Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► ClearUrlSources()()()
Removes all URL sources from the list. Network sources are not affected.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearUrlSources()
Public Sub ClearUrlSources
public:
void ClearUrlSources()
Remarks

Win32 MSI API: MsiSourceListClearAllEx

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Contains Method (item)

Contains Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► Contains(String)
Checks if the specified source exists in the list.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string item
)
Public Function Contains ( _
    item As String _
) As Boolean
public:
virtual bool Contains(
    String^ item
) sealed
Parameters
item (String)
case-insensitive source to look for
Return Value
true if the source exists in the list, false otherwise

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► CopyTo(array<String>[]()[], Int32)
Copies the network and URL sources from this list into an array.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    string[] array,
    int arrayIndex
)
Public Sub CopyTo ( _
    array As String(), _
    arrayIndex As Integer _
)
public:
virtual void CopyTo(
    array<String^>^ array,
    int arrayIndex
) sealed
Parameters
array (array< String >[]()[])
destination array to be filed
arrayIndex (Int32)
offset into the destination array where copying begins

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Count Property

Count Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► Count
Gets the number of network and URL sources in the list.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


DiskPrompt Property

DiskPrompt Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► DiskPrompt
Gets or sets the prompt template that is used when prompting the user for installation media.
Declaration Syntax
C# Visual Basic Visual C++
public string DiskPrompt { get; set; }
Public Property DiskPrompt As String
public:
property String^ DiskPrompt {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ForceResolution Method

ForceResolution Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► ForceResolution()()()
Forces the installer to search the source list for a valid source the next time a source is required. For example, when the installer performs an installation or reinstallation, or when it requires the path for a component that is set to run from source.
Declaration Syntax
C# Visual Basic Visual C++
public void ForceResolution()
Public Sub ForceResolution
public:
void ForceResolution()
Remarks

Win32 MSI APIs: MsiSourceListForceResolution, MsiSourceListForceResolutionEx

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► GetEnumerator()()()
Enumerates the network and URL sources in the source list of the patch or product installation.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<string> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of String)
public:
virtual IEnumerator<String^>^ GetEnumerator() sealed
Remarks

Win32 MSI API: MsiSourceListEnumSources

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Insert Method (item, index)

Insert Method (item, index)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► Insert(String, Int32)
Adds or reorders a network or URL source for the product or patch.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    string item,
    int index
)
Public Sub Insert ( _
    item As String, _
    index As Integer _
)
public:
void Insert(
    String^ item,
    int index
)
Parameters
item (String)
Path to the source to be added. This parameter is expected to contain only the path without the filename.
index (Int32)
Specifies the priority order in which the source will be inserted
Remarks

If this method is called with a new source and index is set to 0, the installer adds the source to the end of the source list.

If this method is called with a source already existing in the source list and index is set to 0, the installer retains the source's existing index.

If the method is called with an existing source in the source list and index is set to a non-zero value, the source is removed from its current location in the list and inserted at the position specified by Index, before any source that already exists at that position.

If the method is called with a new source and Index is set to a non-zero value, the source is inserted at the position specified by index, before any source that already exists at that position. The index value for all sources in the list after the index specified by Index are updated to ensure unique index values and the pre-existing order is guaranteed to remain unchanged.

If index is greater than the number of sources in the list, the source is placed at the end of the list with an index value one larger than any existing source.

Win32 MSI API: MsiSourceListAddSourceEx

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsReadOnly Property

IsReadOnly Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► IsReadOnly
Gets a boolean value indicating whether the list is read-only. A SourceList is never read-only.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
Value
read-only status of the list

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (property)

Item Property (property)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► Item[([(String])])
Gets or sets source list information properties of a product or patch installation.
Declaration Syntax
C# Visual Basic Visual C++
public string this[
    string property
] { get; set; }
Public Default Property Item ( _
    property As String _
) As String
public:
property String^ default[String^ property] {
    String^ get (String^ property);
    void set (String^ property, String^ value);
}
Parameters
property (String)
The source list information property name.
Remarks

Win32 MSI API: MsiSourceListGetInfo

Exceptions
Exception | Condition
ArgumentOutOfRangeException | An unknown product, patch, or property was requested

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


LastUsedSource Property

LastUsedSource Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► LastUsedSource
Gets or sets the most recently used source location for the product.
Declaration Syntax
C# Visual Basic Visual C++
public string LastUsedSource { get; set; }
Public Property LastUsedSource As String
public:
property String^ LastUsedSource {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


LastUsedType Property

LastUsedType Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► LastUsedType
Gets the type of the last-used source.
Declaration Syntax
C# Visual Basic Visual C++
public string LastUsedType { get; }
Public ReadOnly Property LastUsedType As String
public:
property String^ LastUsedType {
    String^ get ();
}
Remarks

  • "n" = network location
  • "u" = URL location
  • "m" = media location
  • (empty string) = no last used source

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MediaList Property

MediaList Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► MediaList
Gets the list of disks registered for the media source of the patch or product installation.
Declaration Syntax
C# Visual Basic Visual C++
public SourceMediaList MediaList { get; }
Public ReadOnly Property MediaList As SourceMediaList
public:
property SourceMediaList^ MediaList {
    SourceMediaList^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MediaPackagePath Property

MediaPackagePath Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► MediaPackagePath
Gets or sets the path relative to the root of the installation media.
Declaration Syntax
C# Visual Basic Visual C++
public string MediaPackagePath { get; set; }
Public Property MediaPackagePath As String
public:
property String^ MediaPackagePath {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


PackageName Property

PackageName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► PackageName
Gets or sets the name of the Windows Installer package or patch package on the source.
Declaration Syntax
C# Visual Basic Visual C++
public string PackageName { get; set; }
Public Property PackageName As String
public:
property String^ PackageName {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Remove Method (item)

Remove Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceList ► Remove(String)
Removes a network or URL source.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string item
)
Public Function Remove ( _
    item As String _
) As Boolean
public:
virtual bool Remove(
    String^ item
) sealed
Parameters
item (String)
Remarks

Win32 MSI API: MsiSourceListClearSource

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SourceMediaList Class

SourceMediaList Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceMediaList
A list of source media for an installed product or patch.
Declaration Syntax
C# Visual Basic Visual C++
public class SourceMediaList : ICollection<MediaDisk>,
    IEnumerable<MediaDisk>, IEnumerable
Public Class SourceMediaList _
    Implements ICollection(Of MediaDisk), IEnumerable(Of MediaDisk),  _
    IEnumerable
public ref class SourceMediaList : ICollection<MediaDisk>,
    IEnumerable<MediaDisk>, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(MediaDisk) | Adds or updates a disk of the media source for the product or patch.
 | Clear()()() | Removes all source media from the list.
 | Contains(Int32) | Checks if the specified media disk id exists in the list.
 | CopyTo(array<MediaDisk>[]()[], Int32) | Copies the source media info from this list into an array.
 | Count | Gets the number of source media in the list.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Enumerates the source media in the source list of the patch or product installation.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsReadOnly | Gets a boolean value indicating whether the list is read-only. A SourceMediaList is never read-only.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(Int32) | Removes a specified disk from the set of registered disks.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SourceMediaList

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Add Method (item)

Add Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceMediaList ► Add(MediaDisk)
Adds or updates a disk of the media source for the product or patch.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    MediaDisk item
)
Public Sub Add ( _
    item As MediaDisk _
)
public:
virtual void Add(
    MediaDisk item
) sealed
Parameters
item (MediaDisk)
Remarks

To change the disk prompt only, get the existing volume label from the registry and provide it in this call along with the new disk prompt. Passing a null or empty string for volumeLabel registers an empty string as the volume label.

To change the volume label only, get the existing disk prompt that is registered and provide it when calling SourceListAddMediaDisk along with the new volume label. Passing null or an empty string registers an empty string as the disk prompt.

Win32 MSI API: MsiSourceListAddMediaDisk

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Clear Method

Clear Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceMediaList ► Clear()()()
Removes all source media from the list.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
Remarks

Win32 MSI API: MsiSourceListClearAllEx

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Contains Method (diskId)

Contains Method (diskId)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceMediaList ► Contains(Int32)
Checks if the specified media disk id exists in the list.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    int diskId
)
Public Function Contains ( _
    diskId As Integer _
) As Boolean
public:
bool Contains(
    int diskId
)
Parameters
diskId (Int32)
disk id of the media to look for
Return Value
true if the media exists in the list, false otherwise

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceMediaList ► CopyTo(array<MediaDisk>[]()[], Int32)
Copies the source media info from this list into an array.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MediaDisk[] array,
    int arrayIndex
)
Public Sub CopyTo ( _
    array As MediaDisk(), _
    arrayIndex As Integer _
)
public:
virtual void CopyTo(
    array<MediaDisk>^ array,
    int arrayIndex
) sealed
Parameters
array (array< MediaDisk >[]()[])
destination array to be filed
arrayIndex (Int32)
offset into the destination array where copying begins

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Count Property

Count Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceMediaList ► Count
Gets the number of source media in the list.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceMediaList ► GetEnumerator()()()
Enumerates the source media in the source list of the patch or product installation.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<MediaDisk> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of MediaDisk)
public:
virtual IEnumerator<MediaDisk>^ GetEnumerator() sealed
Remarks

Win32 MSI API: MsiSourceListEnumMediaDisks

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsReadOnly Property

IsReadOnly Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceMediaList ► IsReadOnly
Gets a boolean value indicating whether the list is read-only. A SourceMediaList is never read-only.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
Value
read-only status of the list

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Remove Method (diskId)

Remove Method (diskId)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SourceMediaList ► Remove(Int32)
Removes a specified disk from the set of registered disks.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    int diskId
)
Public Function Remove ( _
    diskId As Integer _
) As Boolean
public:
bool Remove(
    int diskId
)
Parameters
diskId (Int32)
ID of the disk to remove
Remarks

Win32 MSI API: MsiSourceListClearMediaDisk

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SummaryInfo Class

SummaryInfo Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo
Provides access to summary information of a Windows Installer database.
Declaration Syntax
C# Visual Basic Visual C++
public class SummaryInfo : InstallerHandle
Public Class SummaryInfo _
    Inherits InstallerHandle
public ref class SummaryInfo : public InstallerHandle
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SummaryInfo(String, Boolean) | Gets a SummaryInfo object that can be used to examine, update, and add properties to the summary information stream of a package or transform.
 | Author | Gets or sets the Author summary information property.
 | CharacterCount | Gets or sets the CharacterCount summary information property.
 | Close()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | CodePage | Gets or sets the CodePage summary information property.
 | Comments | Gets or sets the Comments summary information property.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateTime | Gets or sets the CreateTime summary information property.
 | CreatingApp | Gets or sets the CreatingApp summary information property.
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Dispose(Boolean) | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Equals(Object) | Tests whether this handle object is equal to another handle object. Two handle objects are equal if their types are the same and their native integer handles are the same. (Inherited from InstallerHandle.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Gets a hash value for the handle object. (Inherited from InstallerHandle.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets the native integer handle. (Inherited from InstallerHandle.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsClosed | Checks if the handle is closed. When closed, method calls on the handle object may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Keywords | Gets or sets the Keywords summary information property.
 | LastPrintTime | Gets or sets the LastPrintTime summary information property.
 | LastSavedBy | Gets or sets the LastSavedBy summary information property.
 | LastSaveTime | Gets or sets the LastSaveTime summary information property.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PageCount | Gets or sets the PageCount summary information property.
 | Persist()()() | Formats and writes the previously stored properties into the standard summary information stream.
 | RevisionNumber | Gets or sets the RevisionNumber summary information property.
 | Security | Gets or sets the Security summary information property.
 | Subject | Gets or sets the Subject summary information property.
 | Template | Gets or sets the Template summary information property.
 | Title | Gets or sets the Title summary information property.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WordCount | Gets or sets the WordCount summary information property.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | InstallerHandle
 |  |  | SummaryInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SummaryInfo Constructor (packagePath, enableWrite)

SummaryInfo Constructor (packagePath, enableWrite)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► SummaryInfo(String, Boolean)
Gets a SummaryInfo object that can be used to examine, update, and add properties to the summary information stream of a package or transform.
Declaration Syntax
C# Visual Basic Visual C++
public SummaryInfo(
    string packagePath,
    bool enableWrite
)
Public Sub New ( _
    packagePath As String, _
    enableWrite As Boolean _
)
public:
SummaryInfo(
    String^ packagePath,
    bool enableWrite
)
Parameters
packagePath (String)
Path to the package (database) or transform
enableWrite (Boolean)
True to reserve resources for writing summary information properties.
Remarks

The SummaryInfo object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Win32 MSI API: MsiGetSummaryInformation

Exceptions
Exception | Condition
FileNotFoundException | the package does not exist or could not be read
InstallerException | the package is an invalid format

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Author Property

Author Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► Author
Gets or sets the Author summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public string Author { get; set; }
Public Property Author As String
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}
Remarks

The Author summary information property conveys to a file browser the manufacturer of the installation database. This value is typically set from the installer property Manufacturer.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CharacterCount Property

CharacterCount Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► CharacterCount
Gets or sets the CharacterCount summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public int CharacterCount { get; set; }
Public Property CharacterCount As Integer
public:
property int CharacterCount {
    int get ();
    void set (int value);
}
Remarks

The CharacterCount summary information property is only used in transforms. This part of the summary information stream is divided into two 16-bit words. The upper word contains the transform validation flags. The lower word contains the transform error condition flags.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CodePage Property

CodePage Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► CodePage
Gets or sets the CodePage summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public short CodePage { get; set; }
Public Property CodePage As Short
public:
property short CodePage {
    short get ();
    void set (short value);
}
Remarks

The Codepage summary information property is the numeric value of the ANSI code page used for any strings that are stored in the summary information. Note that this is not the same code page for strings in the installation database. The Codepage summary information property is used to translate the strings in the summary information into Unicode when calling the Unicode API functions. The Codepage summary information property must be set before any string properties are set in the summary information.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Comments Property

Comments Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► Comments
Gets or sets the Comments summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public string Comments { get; set; }
Public Property Comments As String
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}
Remarks

The Comments summary information property conveys the general purpose of the installer database. By convention, the value for this summary property is set to the following:

"This installer database contains the logic and data required to install <product name>."

where <product name> is the name of the product being installed. In general the value for this summary property only changes in the product name, nothing else.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CreateTime Property

CreateTime Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► CreateTime
Gets or sets the CreateTime summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreateTime { get; set; }
Public Property CreateTime As DateTime
public:
property DateTime CreateTime {
    DateTime get ();
    void set (DateTime value);
}
Remarks

The CreateTime summary information property conveys when the installer database was created.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CreatingApp Property

CreatingApp Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► CreatingApp
Gets or sets the CreatingApp summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public string CreatingApp { get; set; }
Public Property CreatingApp As String
public:
property String^ CreatingApp {
    String^ get ();
    void set (String^ value);
}
Remarks

The CreatingApp summary information property conveys which application created the installer database. In general the value for this summary property is the name of the software used to author this database.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Keywords Property

Keywords Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► Keywords
Gets or sets the Keywords summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public string Keywords { get; set; }
Public Property Keywords As String
public:
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}
Remarks

The Keywords summary information property is used by file browsers to hold keywords that permit the database file to be found in a keyword search. The set of keywords typically includes "Installer" as well as product-specific keywords, and may be localized.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


LastPrintTime Property

LastPrintTime Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► LastPrintTime
Gets or sets the LastPrintTime summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastPrintTime { get; set; }
Public Property LastPrintTime As DateTime
public:
property DateTime LastPrintTime {
    DateTime get ();
    void set (DateTime value);
}
Remarks

The LastPrintTime summary information property can be set to the date and time during an administrative installation to record when the administrative image was created. For non-administrative installations this property is the same as the CreateTime summary information property.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


LastSavedBy Property

LastSavedBy Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► LastSavedBy
Gets or sets the LastSavedBy summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public string LastSavedBy { get; set; }
Public Property LastSavedBy As String
public:
property String^ LastSavedBy {
    String^ get ();
    void set (String^ value);
}
Remarks

The installer sets the Last Saved By summary information property to the value of the LogonUser property during an administrative installation. The installer never uses this property and a user never needs to modify it. Developers of a database editing tool may use this property to track the last person to modify the database. This property should be left set to null in a final shipping database.

In a transform, this summary property contains the platform and language ID(s) that a database should have after it has been transformed. The property specifies to what the Template should be set in the new database.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


LastSaveTime Property

LastSaveTime Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► LastSaveTime
Gets or sets the LastSaveTime summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastSaveTime { get; set; }
Public Property LastSaveTime As DateTime
public:
property DateTime LastSaveTime {
    DateTime get ();
    void set (DateTime value);
}
Remarks

The LastSaveTime summary information property conveys when the last time the installer database was modified. Each time a user changes an installation the value for this summary property is updated to the current system time/date at the time the installer database was saved. Initially the value for this summary property is set to null to indicate that no changes have yet been made.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


PageCount Property

PageCount Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► PageCount
Gets or sets the PageCount summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public int PageCount { get; set; }
Public Property PageCount As Integer
public:
property int PageCount {
    int get ();
    void set (int value);
}
Remarks

For an installation package, the PageCount summary information property contains the minimum installer version required. For Windows Installer version 1.0, this property must be set to the integer 100. For 64-bit Windows Installer Packages, this property must be set to the integer 200.

For a transform package, the PageCount summary information property contains minimum installer version required to process the transform. Set to the greater of the two PageCount summary information property values belonging to the databases used to generate the transform.

The PageCount summary information property is set to null in patch packages.

This summary property is REQUIRED.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Persist Method

Persist Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► Persist()()()
Formats and writes the previously stored properties into the standard summary information stream.
Declaration Syntax
C# Visual Basic Visual C++
public void Persist()
Public Sub Persist
public:
void Persist()
Remarks

This method may only be called once after all the property values have been set. Properties may still be read after the stream is written.

Win32 MSI API: MsiSummaryInfoPersist

Exceptions
Exception | Condition
InstallerException | The stream cannot be successfully written.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


RevisionNumber Property

RevisionNumber Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► RevisionNumber
Gets or sets the RevisionNumber summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public string RevisionNumber { get; set; }
Public Property RevisionNumber As String
public:
property String^ RevisionNumber {
    String^ get ();
    void set (String^ value);
}
Remarks

The Revision Number summary information property contains the package code for the installer package. The package code is a unique identifier of the installer package.

The Revision Number summary information property of a patch package specifies the GUID patch code for the patch. This is followed by a list of patch code GUIDs for obsolete patches that are removed when this patch is applied. The patch codes are concatenated with no delimiters separating GUIDs in the list.

The Revision Number summary information property of a transform package lists the product code GUIDs and version of the new and original products and the upgrade code GUID. The list is separated with semicolons as follows.

Original-Product-Code Original-Product-Version ; New-Product Code New-Product-Version; Upgrade-Code

This summary property is REQUIRED.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Security Property

Security Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► Security
Gets or sets the Security summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public int Security { get; set; }
Public Property Security As Integer
public:
property int Security {
    int get ();
    void set (int value);
}
Remarks

The Security summary information property conveys whether the package should be opened as read-only. The database editing tool should not modify a read-only enforced database and should issue a warning at attempts to modify a read-only recommended database. The following values of this property are applicable to Windows Installer files:

  • 0 - no restriction
  • 2 - read only recommended
  • 4 - read only enforced

This property should be set to read-only recommended (2) for an installation database and to read-only enforced (4) for a transform or patch.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Subject Property

Subject Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► Subject
Gets or sets the Subject summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; set; }
Public Property Subject As String
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
Remarks

The Subject summary information property conveys to a file browser the product that can be installed using the logic and data in this installer database. For example, the value of the summary property for Microsoft Office 97 would be "Microsoft Office 97 Professional". This value is typically set from the installer property ProductName.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Template Property

Template Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► Template
Gets or sets the Template summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public string Template { get; set; }
Public Property Template As String
public:
property String^ Template {
    String^ get ();
    void set (String^ value);
}
Remarks

The Template summary information propery indicates the platform and language versions supported by the database.

The syntax of the Template Summary property information is: [platform property][,platform property][,...];[language id][,language id][,...]

For example, the following are all valid values for the Template Summary property:

  • Intel;1033
  • Intel64;1033
  • ;1033
  • ;
  • Intel ;1033,2046
  • Intel64;1033,2046
  • Intel;0

If this is a 64-bit Windows Installer, enter Intel64 in the Template summary information property. Note that an installation package cannot have both the Intel and Intel64 properties set.

If the current platform does not match one of the platforms specified then the installer will not process the package. Not specifying a platform implies that the package is platform-independent.

Entering 0 in the language ID field of the Template summary information property, or leaving this field empty, indicates that the package is language neutral.

There are variations of this property depending on whether it is in a source installer database or a transform.

Source Installer Database - Only one language can be specified in a source installer database. Merge Modules are the only packages that may have multiple languages. For more information, see Multiple Language Merge Modules.

Transform - In a transform file, only one language may be specified. The specified platform and language determine whether a transform can be applied to a particular database. The platform property and the language property can be left blank if no transform restriction relies on them to validate the transform.

This summary property is REQUIRED.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Title Property

Title Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► Title
Gets or sets the Title summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; set; }
Public Property Title As String
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
Remarks

The Title summary information property briefly describes the type of installer package. Phrases such as "Installation Database" or "Transform" or "Patch" may be used for this property.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


WordCount Property

WordCount Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► WordCount
Gets or sets the WordCount summary information property.
Declaration Syntax
C# Visual Basic Visual C++
public int WordCount { get; set; }
Public Property WordCount As Integer
public:
property int WordCount {
    int get ();
    void set (int value);
}
Remarks

The WordCount summary information property indicates the type of source file image. If this property is not present, it defaults to 0. Note that this property is stored in place of the standard Count property.

This property is a bit field. New bits may be added in the future. At present the following bits are available:

  • Bit 0: 0 = long file names, 1 = short file names
  • Bit 1: 0 = source is uncompressed, 1 = source is compressed
  • Bit 2: 0 = source is original media, 1 = source is administrative installation
  • [MSI 4.0] Bit 3: 0 = elevated privileges can be required to install, 1 = elevated privileges are not required to install

These are combined to give the WordCount summary information property one of the following values indicating a type of source file image:

  • 0 - Original source using long file names. Matches tree in Directory table.
  • 1 - Original source using short file names. Matches tree in Directory table.
  • 2 - Compressed source files using long file names. Matches cabinets and files in the Media table.
  • 3 - Compressed source files using short file names. Matches cabinets and files in the Media table.
  • 4 - Administrative image using long file names. Matches tree in Directory table.
  • 5 - Administrative image using short file names. Matches tree in Directory table.

Note that if the package is marked as compressed (bit 1 is set), the installer only installs files located at the root of the source. In this case, even files marked as uncompressed in the File table must be located at the root to be installed. To specify a source image that has both a cabinet file (compressed files) and uncompressed files that match the tree in the Directory table, mark the package as uncompressed by leaving bit 1 unset (value=0) in the WordCount summary information property and set Compressed (value=16384) in the Attributes column of the File table for each file in the cabinet.

For a patch package, the WordCount summary information property specifies the patch engine that was used to create the patch files. The default value is 1 and indicates that MSPATCH was used to create the patch A value of "2" means that the patch is using smaller, optimized, files available only with Windows Installer version 1.2 or later. A patch with a WordCount of "2" fails immediately if used with a Windows Installer version earlier than 1.2. A patch with a WordCount of "3" fails immediately if used with a Windows Installer version earlier than 2.0.

This summary property is REQUIRED.

Win32 MSI APIs: MsiSummaryInfoGetProperty, MsiSummaryInfoSetProperty

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


TableCollection Class

TableCollection Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableCollection
Contains information about all the tables in a Windows Installer database.
Declaration Syntax
C# Visual Basic Visual C++
public class TableCollection : ICollection<TableInfo>,
    IEnumerable<TableInfo>, IEnumerable
Public Class TableCollection _
    Implements ICollection(Of TableInfo), IEnumerable(Of TableInfo),  _
    IEnumerable
public ref class TableCollection : ICollection<TableInfo^>,
    IEnumerable<TableInfo^>, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(TableInfo) | Adds a new table to the database.
 | Clear()()() | Removes all tables (and all data) from the database.
 | Contains(String) | Checks if the database contains a table with the given name.
 | CopyTo(array<TableInfo>[]()[], Int32) | Copies the table information from this collection into an array.
 | Count | Gets the number of tables in the database.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Enumerates the tables in the database.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsReadOnly | Gets a boolean value indicating whether the collection is read-only. A TableCollection is read-only when the database is read-only.
 | Item[([(String])]) | Gets information about a given table.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes a table from the database.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TableCollection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Add Method (item)

Add Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableCollection ► Add(TableInfo)
Adds a new table to the database.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    TableInfo item
)
Public Sub Add ( _
    item As TableInfo _
)
public:
virtual void Add(
    TableInfo^ item
) sealed
Parameters
item (TableInfo)
information about the table to be added
Exceptions
Exception | Condition
InvalidOperationException | a table with the same name already exists in the database

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Clear Method

Clear Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableCollection ► Clear()()()
Removes all tables (and all data) from the database.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Contains Method (item)

Contains Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableCollection ► Contains(String)
Checks if the database contains a table with the given name.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string item
)
Public Function Contains ( _
    item As String _
) As Boolean
public:
bool Contains(
    String^ item
)
Parameters
item (String)
case-sensitive name of the table to search for
Return Value
True if the table exists, false otherwise.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (array, arrayIndex)

CopyTo Method (array, arrayIndex)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableCollection ► CopyTo(array<TableInfo>[]()[], Int32)
Copies the table information from this collection into an array.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    TableInfo[] array,
    int arrayIndex
)
Public Sub CopyTo ( _
    array As TableInfo(), _
    arrayIndex As Integer _
)
public:
virtual void CopyTo(
    array<TableInfo^>^ array,
    int arrayIndex
) sealed
Parameters
array (array< TableInfo >[]()[])
destination array to be filed
arrayIndex (Int32)
offset into the destination array where copying begins

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Count Property

Count Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableCollection ► Count
Gets the number of tables in the database.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableCollection ► GetEnumerator()()()
Enumerates the tables in the database.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<TableInfo> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of TableInfo)
public:
virtual IEnumerator<TableInfo^>^ GetEnumerator() sealed

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


IsReadOnly Property

IsReadOnly Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableCollection ► IsReadOnly
Gets a boolean value indicating whether the collection is read-only. A TableCollection is read-only when the database is read-only.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
Value
read-only status of the collection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Item Property (table)

Item Property (table)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableCollection ► Item[([(String])])
Gets information about a given table.
Declaration Syntax
C# Visual Basic Visual C++
public TableInfo this[
    string table
] { get; }
Public ReadOnly Default Property Item ( _
    table As String _
) As TableInfo
public:
property TableInfo^ default[String^ table] {
    TableInfo^ get (String^ table);
}
Parameters
table (String)
case-sensitive name of the table
Return Value
information about the requested table, or null if the table does not exist in the database

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Remove Method (item)

Remove Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableCollection ► Remove(String)
Removes a table from the database.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string item
)
Public Function Remove ( _
    item As String _
) As Boolean
public:
bool Remove(
    String^ item
)
Parameters
item (String)
case-sensitive name of the table to be removed
Return Value
true if the table was removed, false if the table did not exist

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


TableInfo Class

TableInfo Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableInfo
Defines a table in an installation database.
Declaration Syntax
C# Visual Basic Visual C++
public class TableInfo
Public Class TableInfo
public ref class TableInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TableInfo(String, ICollection<(Of <(ColumnInfo>)>), IList<(Of <(String>)>)) | Creates a table definition.
 | Columns | Gets information about the columns in this table.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the table.
 | PrimaryKeys | Gets the names of the columns that are primary keys of the table.
 | SqlCreateString | Gets an SQL CREATE string that can be used to create the table.
 | SqlInsertString | Gets an SQL INSERT string that can be used insert a new record into the table.
 | SqlSelectString | Gets an SQL SELECT string that can be used to select all columns of the table.
 | ToString()()() | Gets a string representation of the table. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
TableInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


TableInfo Constructor (name, columns, primaryKeys)

TableInfo Constructor (name, columns, primaryKeys)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableInfo ► TableInfo(String, ICollection<(Of <(ColumnInfo>)>), IList<(Of <(String>)>))
Creates a table definition.
Declaration Syntax
C# Visual Basic Visual C++
public TableInfo(
    string name,
    ICollection<ColumnInfo> columns,
    IList<string> primaryKeys
)
Public Sub New ( _
    name As String, _
    columns As ICollection(Of ColumnInfo), _
    primaryKeys As IList(Of String) _
)
public:
TableInfo(
    String^ name,
    ICollection<ColumnInfo^>^ columns,
    IList<String^>^ primaryKeys
)
Parameters
name (String)
Name of the table.
columns (ICollection <(Of <( ColumnInfo >)>))
Columns in the table.
primaryKeys (IList <(Of <( String >)>))
The primary keys of the table.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Columns Property

Columns Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableInfo ► Columns
Gets information about the columns in this table.
Declaration Syntax
C# Visual Basic Visual C++
public ColumnCollection Columns { get; }
Public ReadOnly Property Columns As ColumnCollection
public:
property ColumnCollection^ Columns {
    ColumnCollection^ get ();
}
Remarks

This property queries the database every time it is called, to ensure the returned values are up-to-date. For best performance, hold onto the returned collection if using it more than once.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Name Property

Name Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableInfo ► Name
Gets the name of the table.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


PrimaryKeys Property

PrimaryKeys Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableInfo ► PrimaryKeys
Gets the names of the columns that are primary keys of the table.
Declaration Syntax
C# Visual Basic Visual C++
public IList<string> PrimaryKeys { get; }
Public ReadOnly Property PrimaryKeys As IList(Of String)
public:
property IList<String^>^ PrimaryKeys {
    IList<String^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SqlCreateString Property

SqlCreateString Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableInfo ► SqlCreateString
Gets an SQL CREATE string that can be used to create the table.
Declaration Syntax
C# Visual Basic Visual C++
public string SqlCreateString { get; }
Public ReadOnly Property SqlCreateString As String
public:
property String^ SqlCreateString {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SqlInsertString Property

SqlInsertString Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableInfo ► SqlInsertString
Gets an SQL INSERT string that can be used insert a new record into the table.
Declaration Syntax
C# Visual Basic Visual C++
public string SqlInsertString { get; }
Public ReadOnly Property SqlInsertString As String
public:
property String^ SqlInsertString {
    String^ get ();
}
Remarks

The values are expressed as question-mark tokens, to be supplied by the record.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


SqlSelectString Property

SqlSelectString Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableInfo ► SqlSelectString
Gets an SQL SELECT string that can be used to select all columns of the table.
Declaration Syntax
C# Visual Basic Visual C++
public string SqlSelectString { get; }
Public ReadOnly Property SqlSelectString As String
public:
property String^ SqlSelectString {
    String^ get ();
}
Remarks

The columns are listed explicitly in the SELECT string, as opposed to using "SELECT *".

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ToString Method

ToString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TableInfo ► ToString()()()
Gets a string representation of the table.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
The name of the table.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


TextStyles Enumeration

TextStyles Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TextStyles
Defines values for the StyleBits column of the TextStyle table.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum TextStyles
<FlagsAttribute> _
Public Enumeration TextStyles
[FlagsAttribute]
public enum class TextStyles
Members
Member | Description
Bold | Bold
Italic | Italic
Underline | Underline
Strike | Strike out

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Transaction Class

Transaction Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Transaction
[MSI 4.5] Handle to a multi-session install transaction.
Declaration Syntax
C# Visual Basic Visual C++
public class Transaction : InstallerHandle
Public Class Transaction _
    Inherits InstallerHandle
public ref class Transaction : public InstallerHandle
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Transaction(String, TransactionAttributes) | [MSI 4.5] Begins transaction processing of a multi-package installation.
 | Close()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Commit()()() | Ends the install transaction and commits all changes to the system belonging to the transaction.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Dispose(Boolean) | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Equals(Object) | Tests whether this handle object is equal to another handle object. Two handle objects are equal if their types are the same and their native integer handles are the same. (Inherited from InstallerHandle.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromHandle(IntPtr, Boolean) | Creates a new Transaction object from an integer handle.
 | GetHashCode()()() | Gets a hash value for the handle object. (Inherited from InstallerHandle.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets the native integer handle. (Inherited from InstallerHandle.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsClosed | Checks if the handle is closed. When closed, method calls on the handle object may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Join(TransactionAttributes) | Makes the current process the owner of the multi-package installation transaction.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the name of the transaction.
 | OwnerChanged | Notifies listeners when the process that owns the transaction changed.
 | Rollback()()() | Ends the install transaction and undoes changes to the system belonging to the transaction.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks

Win32 MSI APIs: MsiBeginTransaction MsiJoinTransaction MsiEndTransaction

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | InstallerHandle
 |  |  | Transaction

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Transaction Constructor (name, attributes)

Transaction Constructor (name, attributes)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Transaction ► Transaction(String, TransactionAttributes)
[MSI 4.5] Begins transaction processing of a multi-package installation.
Declaration Syntax
C# Visual Basic Visual C++
public Transaction(
    string name,
    TransactionAttributes attributes
)
Public Sub New ( _
    name As String, _
    attributes As TransactionAttributes _
)
public:
Transaction(
    String^ name,
    TransactionAttributes attributes
)
Parameters
name (String)
Name of the multi-package installation.
attributes (TransactionAttributes)
Select optional behavior when beginning the transaction.
Remarks

Win32 MSI API: MsiBeginTransaction

Exceptions
Exception | Condition
InstallerException | The transaction could not be initialized.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Commit Method

Commit Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Transaction ► Commit()()()
Ends the install transaction and commits all changes to the system belonging to the transaction.
Declaration Syntax
C# Visual Basic Visual C++
public void Commit()
Public Sub Commit
public:
void Commit()
Remarks

Runs any Commit Custom Actions and commits to the system any changes to Win32 or common language runtime assemblies. Deletes the rollback script, and after using this option, the transaction's changes can no longer be undone with a Rollback Installation.

This method can only be called by the current owner of the transaction.

Win32 MSI API: MsiEndTransaction

Exceptions
Exception | Condition
InstallerException | The transaction could not be committed.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


FromHandle Method (handle, ownsHandle)

FromHandle Method (handle, ownsHandle)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Transaction ► FromHandle(IntPtr, Boolean)
Creates a new Transaction object from an integer handle.
Declaration Syntax
C# Visual Basic Visual C++
public static Transaction FromHandle(
    IntPtr handle,
    bool ownsHandle
)
Public Shared Function FromHandle ( _
    handle As IntPtr, _
    ownsHandle As Boolean _
) As Transaction
public:
static Transaction^ FromHandle(
    IntPtr handle,
    bool ownsHandle
)
Parameters
handle (IntPtr)
Integer transaction handle
ownsHandle (Boolean)
true to close the handle when this object is disposed

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Join Method (attributes)

Join Method (attributes)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Transaction ► Join(TransactionAttributes)
Makes the current process the owner of the multi-package installation transaction.
Declaration Syntax
C# Visual Basic Visual C++
public void Join(
    TransactionAttributes attributes
)
Public Sub Join ( _
    attributes As TransactionAttributes _
)
public:
void Join(
    TransactionAttributes attributes
)
Parameters
attributes (TransactionAttributes)
Select optional behavior when joining the transaction.
Remarks

Win32 MSI API: MsiJoinTransaction

Exceptions
Exception | Condition
InvalidHandleException | The transaction handle is not valid.
InstallerException | The transaction could not be joined.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Name Property

Name Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Transaction ► Name
Gets the name of the transaction.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


OwnerChanged Event

OwnerChanged Event
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Transaction ► OwnerChanged
Notifies listeners when the process that owns the transaction changed.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EventArgs> OwnerChanged
Public Event OwnerChanged As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ OwnerChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Rollback Method

Rollback Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Transaction ► Rollback()()()
Ends the install transaction and undoes changes to the system belonging to the transaction.
Declaration Syntax
C# Visual Basic Visual C++
public void Rollback()
Public Sub Rollback
public:
void Rollback()
Remarks

This method can only be called by the current owner of the transaction.

Win32 MSI API: MsiEndTransaction

Exceptions
Exception | Condition
InstallerException | The transaction could not be rolled back.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


TransactionAttributes Enumeration

TransactionAttributes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TransactionAttributes
Attributes for Transaction methods.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum TransactionAttributes
<FlagsAttribute> _
Public Enumeration TransactionAttributes
[FlagsAttribute]
public enum class TransactionAttributes
Members
Member | Description
None | No attributes.
ChainEmbeddedUI | Request that the Windows Installer not shutdown the embedded UI until the transaction is complete.
JoinExistingEmbeddedUI | Request that the Windows Installer transfer the embedded UI from the original installation.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


TransformErrors Enumeration

TransformErrors Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TransformErrors
Transform error conditions available for CreateTransformSummaryInfo(Database, String, TransformErrors, TransformValidations) or ApplyTransform(String, TransformErrors).
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum TransformErrors
<FlagsAttribute> _
Public Enumeration TransformErrors
[FlagsAttribute]
public enum class TransformErrors
Members
Member | Description
None | No error conditions.
AddExistingRow | Adding a row that already exists.
DelMissingRow | Deleting a row that doesn't exist.
AddExistingTable | Adding a table that already exists.
DelMissingTable | Deleting a table that doesn't exist.
UpdateMissingRow | Updating a row that doesn't exist.
ChangeCodePage | Transform and database code pages do not match and neither code page is neutral.
ViewTransform | Create the temporary _TransformView table when applying the transform.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


TransformValidations Enumeration

TransformValidations Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► TransformValidations
Transform validation flags available for CreateTransformSummaryInfo(Database, String, TransformErrors, TransformValidations).
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum TransformValidations
<FlagsAttribute> _
Public Enumeration TransformValidations
[FlagsAttribute]
public enum class TransformValidations
Members
Member | Description
None | Validate no properties.
Language | Default language must match base database.
Product | Product must match base database.
MajorVersion | Check major version only.
MinorVersion | Check major and minor versions only.
UpdateVersion | Check major, minor, and update versions.
NewLessBaseVersion | Installed version < base version.
NewLessEqualBaseVersion | Installed version <= base version.
NewEqualBaseVersion | Installed version = base version.
NewGreaterEqualBaseVersion | Installed version >= base version.
NewGreaterBaseVersion | Installed version > base version.
UpgradeCode | UpgradeCode must match base database.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


UpgradeAttributes Enumeration

UpgradeAttributes Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► UpgradeAttributes
Defines values for the Attributes column of the Upgrade table.
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum UpgradeAttributes
<FlagsAttribute> _
Public Enumeration UpgradeAttributes
[FlagsAttribute]
public enum class UpgradeAttributes
Members
Member | Description
MigrateFeatures | Migrates feature states by enabling the logic in the MigrateFeatureStates action.
OnlyDetect | Detects products and applications but does not remove.
IgnoreRemoveFailure | Continues installation upon failure to remove a product or application.
VersionMinInclusive | Detects the range of versions including the value in VersionMin.
VersionMaxInclusive | Dectects the range of versions including the value in VersionMax.
LanguagesExclusive | Detects all languages, excluding the languages listed in the Language column.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


UserContexts Enumeration

UserContexts Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► UserContexts
Specifies the installation context for ProductInstallations, PatchInstallationes, and DetermineApplicablePatches(String, array<String>[]()[], InapplicablePatchHandler, String, UserContexts)
Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum UserContexts
<FlagsAttribute> _
Public Enumeration UserContexts
[FlagsAttribute]
public enum class UserContexts
Members
Member | Description
None | Not installed.
UserManaged | User managed install context.
UserUnmanaged | User non-managed context.
Machine | Per-machine context.
All | All contexts, or all valid values.
AllUserManaged | All user-managed contexts.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ValidationError Enumeration

ValidationError Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ValidationError
Defines the type of error encountered by the Validate(Record), ValidateNew(Record), or ValidateFields(Record) methods of the View class.
Declaration Syntax
C# Visual Basic Visual C++
public enum ValidationError
Public Enumeration ValidationError
public enum class ValidationError
Members
Member | Description
None | No error.
DuplicateKey | The new record duplicates primary keys of the existing record in a table.
Required | There are no null values allowed, or the column is about to be deleted but is referenced by another row.
BadLink | The corresponding record in a foreign table was not found.
Overflow | The data is greater than the maximum value allowed.
Underflow | The data is less than the minimum value allowed.
NotInSet | The data is not a member of the values permitted in the set.
BadVersion | An invalid version string was supplied.
BadCase | The case was invalid. The case must be all uppercase or all lowercase.
BadGuid | An invalid GUID was supplied.
BadWildcard | An invalid wildcard file name was supplied, or the use of wildcards was invalid.
BadIdentifier | An invalid identifier was supplied.
BadLanguage | Invalid language IDs were supplied.
BadFileName | An invalid file name was supplied.
BadPath | An invalid path was supplied.
BadCondition | An invalid conditional statement was supplied.
BadFormatted | An invalid format string was supplied.
BadTemplate | An invalid template string was supplied.
BadDefaultDir | An invalid string was supplied in the DefaultDir column of the Directory table.
BadRegPath | An invalid registry path string was supplied.
BadCustomSource | An invalid string was supplied in the CustomSource column of the CustomAction table.
BadProperty | An invalid property string was supplied.
MissingData | The _Validation table is missing a reference to a column.
BadCategory | The category column of the _Validation table for the column is invalid.
BadKeyTable | The table in the Keytable column of the _Validation table was not found or loaded.
BadMaxMinValues | The value in the MaxValue column of the _Validation table is less than the value in the MinValue column.
BadCabinet | An invalid cabinet name was supplied.
BadShortcut | An invalid shortcut target name was supplied.
StringOverflow | The string is too long for the length specified by the column definition.
BadLocalizeAttrib | An invalid localization attribute was supplied. (Primary keys cannot be localized.)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ValidationErrorInfo Structure

ValidationErrorInfo Structure
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ValidationErrorInfo
Contains specific information about an error encountered by the Validate(Record), ValidateNew(Record), or ValidateFields(Record) methods of the View class.
Declaration Syntax
C# Visual Basic Visual C++
public struct ValidationErrorInfo
Public Structure ValidationErrorInfo
public value class ValidationErrorInfo
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Column | Gets the column containing the error, or null if the error applies to the whole row.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Error | Gets the type of validation error encountered.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Column Property

Column Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ValidationErrorInfo ► Column
Gets the column containing the error, or null if the error applies to the whole row.
Declaration Syntax
C# Visual Basic Visual C++
public string Column { get; }
Public ReadOnly Property Column As String
public:
property String^ Column {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Error Property

Error Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ValidationErrorInfo ► Error
Gets the type of validation error encountered.
Declaration Syntax
C# Visual Basic Visual C++
public ValidationError Error { get; }
Public ReadOnly Property Error As ValidationError
public:
property ValidationError Error {
    ValidationError get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


View Class

View Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View
A View represents a result set obtained when processing a query using the OpenView(String, array<Object>[]()[]) method of a Database. Before any data can be transferred, the query must be executed using the Execute(Record) method, passing to it all replaceable parameters designated within the SQL query string.
Declaration Syntax
C# Visual Basic Visual C++
public class View : InstallerHandle, IEnumerable<Record>,
    IEnumerable
Public Class View _
    Inherits InstallerHandle _
    Implements IEnumerable(Of Record), IEnumerable
public ref class View : public InstallerHandle,
    IEnumerable<Record^>, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Assign(Record) | Updates or inserts a Record into the View.
 | Close()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Columns | Gets the set of columns that were included in the query for this View, or null if this view is not a SELECT query.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Database | Gets the Database on which this View was opened.
 | Delete(Record) | Deletes a Record from the View.
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Dispose(Boolean) | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Equals(Object) | Tests whether this handle object is equal to another handle object. Two handle objects are equal if their types are the same and their native integer handles are the same. (Inherited from InstallerHandle.)
 | Execute(Record) | Executes a SQL View query and supplies any required parameters. The query uses the question mark token to represent parameters as described in SQL Syntax. The values of these parameters are passed in as the corresponding fields of a parameter record.
 | Execute()()() | Executes a SQL View query.
 | Fetch()()() | Fetches the next sequential record from the view, or null if there are no more records.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Enumerates over the Records retrieved by the View.
 | GetHashCode()()() | Gets a hash value for the handle object. (Inherited from InstallerHandle.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets the native integer handle. (Inherited from InstallerHandle.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Insert(Record) | Inserts a Record into the view.
 | InsertTemporary(Record) | Inserts a Record into the View. The inserted data is not persistent.
 | IsClosed | Checks if the handle is closed. When closed, method calls on the handle object may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(Record) | Inserts or validates a record.
 | Modify(ViewModifyMode, Record) | Updates a fetched Record.
 | QueryString | Gets the SQL query string used to open this View.
 | Refresh(Record) | Refreshes the data in a Record.
 | Replace(Record) | Updates or deletes and inserts a Record into the View.
 | Seek(Record) | Refreshes the information in the supplied record without changing the position in the result set and without affecting subsequent fetch operations.
 | Tables | Gets the set of tables that were included in the SQL query for this View.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(Record) | Updates the View with new data from the Record.
 | Validate(Record) | Validates a record, returning information about any errors.
 | ValidateDelete(Record) | Validates a record that will be deleted later, returning information about any errors.
 | ValidateFields(Record) | Validates fields of a fetched or new record, returning information about any errors. Can validate one or more fields of an incomplete record.
 | ValidateNew(Record) | Validates a new record, returning information about any errors.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | InstallerHandle
 |  |  | View

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Assign Method (record)

Assign Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Assign(Record)
Updates or inserts a Record into the View.
Declaration Syntax
C# Visual Basic Visual C++
public void Assign(
    Record record
)
Public Sub Assign ( _
    record As Record _
)
public:
void Assign(
    Record^ record
)
Parameters
record (Record)
the Record to be assigned
Remarks

Updates record if the primary keys match an existing row and inserts if they do not match. Fails with a read-only database. This method cannot be used with a View containing joins.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI API: MsiViewModify

Exceptions
Exception | Condition
InstallerException | the assignment failed
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Columns Property

Columns Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Columns
Gets the set of columns that were included in the query for this View, or null if this view is not a SELECT query.
Declaration Syntax
C# Visual Basic Visual C++
public ColumnCollection Columns { get; }
Public ReadOnly Property Columns As ColumnCollection
public:
property ColumnCollection^ Columns {
    ColumnCollection^ get ();
}
Remarks

Win32 MSI API: MsiViewGetColumnInfo

Exceptions
Exception | Condition
InstallerException | the View is not in an active state
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Database Property

Database Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Database
Gets the Database on which this View was opened.
Declaration Syntax
C# Visual Basic Visual C++
public Database Database { get; }
Public ReadOnly Property Database As Database
public:
property Database^ Database {
    Database^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Delete Method (record)

Delete Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Delete(Record)
Deletes a Record from the View.
Declaration Syntax
C# Visual Basic Visual C++
public void Delete(
    Record record
)
Public Sub Delete ( _
    record As Record _
)
public:
void Delete(
    Record^ record
)
Parameters
record (Record)
the Record to be deleted
Remarks

The Record must have been obtained by calling Fetch()()(). Fails if the row has been deleted. Works only with read-write records. This method cannot be used with a View containing joins.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI API: MsiViewModify

Exceptions
Exception | Condition
InstallerException | the deletion failed
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Execute Method

Execute Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Execute()()()
Members
Icon | Member | Description
 | Execute(Record) | Executes a SQL View query and supplies any required parameters. The query uses the question mark token to represent parameters as described in SQL Syntax. The values of these parameters are passed in as the corresponding fields of a parameter record.
 | Execute()()() | Executes a SQL View query.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Execute Method

Execute Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Execute()()()
Executes a SQL View query.
Declaration Syntax
C# Visual Basic Visual C++
public void Execute()
Public Sub Execute
public:
void Execute()
Remarks

Win32 MSI API: MsiViewExecute

Exceptions
Exception | Condition
InstallerException | the View could not be executed
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Execute Method (executeParams)

Execute Method (executeParams)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Execute(Record)
Executes a SQL View query and supplies any required parameters. The query uses the question mark token to represent parameters as described in SQL Syntax. The values of these parameters are passed in as the corresponding fields of a parameter record.
Declaration Syntax
C# Visual Basic Visual C++
public void Execute(
    Record executeParams
)
Public Sub Execute ( _
    executeParams As Record _
)
public:
void Execute(
    Record^ executeParams
)
Parameters
executeParams (Record)
Optional Record that supplies the parameters. This Record contains values to replace the parameter tokens in the SQL query.
Remarks

Win32 MSI API: MsiViewExecute

Exceptions
Exception | Condition
InstallerException | the View could not be executed
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Fetch Method

Fetch Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Fetch()()()
Fetches the next sequential record from the view, or null if there are no more records.
Declaration Syntax
C# Visual Basic Visual C++
public Record Fetch()
Public Function Fetch As Record
public:
Record^ Fetch()
Remarks

The Record object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Win32 MSI API: MsiViewFetch

Exceptions
Exception | Condition
InstallerException | the View is not in an active state
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► GetEnumerator()()()
Enumerates over the Records retrieved by the View.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<Record> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Record)
public:
virtual IEnumerator<Record^>^ GetEnumerator() sealed
Return Value
An enumerator of Record objects.
Remarks

Each Record object should be Close()()()d after use. It is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance. However, note that it is not necessary to complete the enumeration just for the purpose of closing handles, because Records are fetched lazily on each step of the enumeration.

Win32 MSI API: MsiViewFetch

Exceptions
Exception | Condition
InstallerException | The View was not Execute(Record)d before attempting the enumeration.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Insert Method (record)

Insert Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Insert(Record)
Inserts a Record into the view.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    Record record
)
Public Sub Insert ( _
    record As Record _
)
public:
void Insert(
    Record^ record
)
Parameters
record (Record)
the Record to be inserted
Remarks

Fails if a row with the same primary keys exists. Fails with a read-only database. This method cannot be used with a View containing joins.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI API: MsiViewModify

Exceptions
Exception | Condition
InstallerException | the insertion failed
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


InsertTemporary Method (record)

InsertTemporary Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► InsertTemporary(Record)
Inserts a Record into the View. The inserted data is not persistent.
Declaration Syntax
C# Visual Basic Visual C++
public void InsertTemporary(
    Record record
)
Public Sub InsertTemporary ( _
    record As Record _
)
public:
void InsertTemporary(
    Record^ record
)
Parameters
record (Record)
the Record to be inserted
Remarks

Fails if a row with the same primary key exists. Works only with read-write records. This method cannot be used with a View containing joins.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI API: MsiViewModify

Exceptions
Exception | Condition
InstallerException | the insertion failed
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Merge Method (record)

Merge Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Merge(Record)
Inserts or validates a record.
Declaration Syntax
C# Visual Basic Visual C++
public bool Merge(
    Record record
)
Public Function Merge ( _
    record As Record _
) As Boolean
public:
bool Merge(
    Record^ record
)
Parameters
record (Record)
the Record to be merged
Return Value
true if the record was inserted or validated, false if there is an existing record with the same primary keys that is not identical
Remarks

Works only with read-write records. This method cannot be used with a View containing joins.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI API: MsiViewModify

Exceptions
Exception | Condition
InstallerException | the merge failed (for a reason other than invalid data)
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Modify Method (mode, record)

Modify Method (mode, record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Modify(ViewModifyMode, Record)
Updates a fetched Record.
Declaration Syntax
C# Visual Basic Visual C++
public void Modify(
    ViewModifyMode mode,
    Record record
)
Public Sub Modify ( _
    mode As ViewModifyMode, _
    record As Record _
)
public:
void Modify(
    ViewModifyMode mode,
    Record^ record
)
Parameters
mode (ViewModifyMode)
specifies the modify mode
record (Record)
the Record to modify
Remarks

You can update or delete a record immediately after inserting, or seeking provided you have NOT modified the 0th field of the inserted or sought record.

To execute any SQL statement, a View must be created. However, a View that does not create a result set, such as CREATE TABLE, or INSERT INTO, cannot be used with any of the Modify methods to update tables though the view.

You cannot fetch a record containing binary data from one database and then use that record to insert the data into another database. To move binary data from one database to another, you should export the data to a file and then import it into the new database using a query and the SetStream(Int32, String). This ensures that each database has its own copy of the binary data.

Note that custom actions can only add, modify, or remove temporary rows, columns, or tables from a database. Custom actions cannot modify persistent data in a database, such as data that is a part of the database stored on disk.

Win32 MSI API: MsiViewModify

Exceptions
Exception | Condition
InstallerException | the modification failed, or a validation was requested and the data did not pass
InvalidHandleException | the View handle is invalid
See Also
Refresh(Record)
Insert(Record)
Update(Record)
Assign(Record)
Replace(Record)
Delete(Record)
InsertTemporary(Record)
Seek(Record)
Merge(Record)
Validate(Record)
ValidateNew(Record)
ValidateFields(Record)
ValidateDelete(Record)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


QueryString Property

QueryString Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► QueryString
Gets the SQL query string used to open this View.
Declaration Syntax
C# Visual Basic Visual C++
public string QueryString { get; }
Public ReadOnly Property QueryString As String
public:
property String^ QueryString {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Refresh Method (record)

Refresh Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Refresh(Record)
Refreshes the data in a Record.
Declaration Syntax
C# Visual Basic Visual C++
public void Refresh(
    Record record
)
Public Sub Refresh ( _
    record As Record _
)
public:
void Refresh(
    Record^ record
)
Parameters
record (Record)
the Record to be refreshed
Remarks

The Record must have been obtained by calling Fetch()()(). Fails with a deleted Record. Works only with read-write Records.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI API: MsiViewModify

Exceptions
Exception | Condition
InstallerException | the refresh failed
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Replace Method (record)

Replace Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Replace(Record)
Updates or deletes and inserts a Record into the View.
Declaration Syntax
C# Visual Basic Visual C++
public void Replace(
    Record record
)
Public Sub Replace ( _
    record As Record _
)
public:
void Replace(
    Record^ record
)
Parameters
record (Record)
the Record to be replaced
Remarks

The Record must have been obtained by calling Fetch()()(). Updates record if the primary keys are unchanged. Deletes old row and inserts new if primary keys have changed. Fails with a read-only database. This method cannot be used with a View containing joins.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI API: MsiViewModify

Exceptions
Exception | Condition
InstallerException | the replacement failed
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Seek Method (record)

Seek Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Seek(Record)
Refreshes the information in the supplied record without changing the position in the result set and without affecting subsequent fetch operations.
Declaration Syntax
C# Visual Basic Visual C++
public bool Seek(
    Record record
)
Public Function Seek ( _
    record As Record _
) As Boolean
public:
bool Seek(
    Record^ record
)
Parameters
record (Record)
the Record to be filled with the result of the seek
Remarks

After seeking, the Record may then be used for subsequent Update, Delete, and Refresh operations. All primary key columns of the table must be in the query and the Record must have at least as many fields as the query. Seek cannot be used with multi-table queries. This method cannot be used with a View containing joins.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI API: MsiViewModify

Exceptions
Exception | Condition
InstallerException | the seek failed
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Tables Property

Tables Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Tables
Gets the set of tables that were included in the SQL query for this View.
Declaration Syntax
C# Visual Basic Visual C++
public IList<TableInfo> Tables { get; }
Public ReadOnly Property Tables As IList(Of TableInfo)
public:
property IList<TableInfo^>^ Tables {
    IList<TableInfo^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Update Method (record)

Update Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Update(Record)
Updates the View with new data from the Record.
Declaration Syntax
C# Visual Basic Visual C++
public void Update(
    Record record
)
Public Sub Update ( _
    record As Record _
)
public:
void Update(
    Record^ record
)
Parameters
record (Record)
the new data
Remarks

Only non-primary keys can be updated. The Record must have been obtained by calling Fetch()()(). Fails with a deleted Record. Works only with read-write Records.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI API: MsiViewModify

Exceptions
Exception | Condition
InstallerException | the update failed
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Validate Method (record)

Validate Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Validate(Record)
Validates a record, returning information about any errors.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<ValidationErrorInfo> Validate(
    Record record
)
Public Function Validate ( _
    record As Record _
) As ICollection(Of ValidationErrorInfo)
public:
ICollection<ValidationErrorInfo>^ Validate(
    Record^ record
)
Parameters
record (Record)
the Record to be validated
Return Value
null if the record was validated; if there is an existing record with the same primary keys that has conflicting data then error information is returned
Remarks

The Record must have been obtained by calling Fetch()()(). Works with read-write and read-only records. This method cannot be used with a View containing joins.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI APIs: MsiViewModify, MsiViewGetError

Exceptions
Exception | Condition
InstallerException | the validation failed (for a reason other than invalid data)
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ValidateDelete Method (record)

ValidateDelete Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► ValidateDelete(Record)
Validates a record that will be deleted later, returning information about any errors.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<ValidationErrorInfo> ValidateDelete(
    Record record
)
Public Function ValidateDelete ( _
    record As Record _
) As ICollection(Of ValidationErrorInfo)
public:
ICollection<ValidationErrorInfo>^ ValidateDelete(
    Record^ record
)
Parameters
record (Record)
the Record to be validated
Return Value
null if the record is safe to delete; if another row refers to the primary keys of this row then error information is returned
Remarks

Validation does not check for the existence of the primary keys of this row in properties or strings. Does not check if a column is a foreign key to multiple tables. Works with read-write and read-only records. This method cannot be used with a View containing joins.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI APIs: MsiViewModify, MsiViewGetError

Exceptions
Exception | Condition
InstallerException | the validation failed (for a reason other than invalid data)
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ValidateFields Method (record)

ValidateFields Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► ValidateFields(Record)
Validates fields of a fetched or new record, returning information about any errors. Can validate one or more fields of an incomplete record.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<ValidationErrorInfo> ValidateFields(
    Record record
)
Public Function ValidateFields ( _
    record As Record _
) As ICollection(Of ValidationErrorInfo)
public:
ICollection<ValidationErrorInfo>^ ValidateFields(
    Record^ record
)
Parameters
record (Record)
the Record to be validated
Return Value
null if the record was validated; if there is an existing record with the same primary keys that has conflicting data then error information is returned
Remarks

Works with read-write and read-only records. This method cannot be used with a View containing joins.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI APIs: MsiViewModify, MsiViewGetError

Exceptions
Exception | Condition
InstallerException | the validation failed (for a reason other than invalid data)
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ValidateNew Method (record)

ValidateNew Method (record)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► ValidateNew(Record)
Validates a new record, returning information about any errors.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<ValidationErrorInfo> ValidateNew(
    Record record
)
Public Function ValidateNew ( _
    record As Record _
) As ICollection(Of ValidationErrorInfo)
public:
ICollection<ValidationErrorInfo>^ ValidateNew(
    Record^ record
)
Parameters
record (Record)
the Record to be validated
Return Value
null if the record was validated; if there is an existing record with the same primary keys then error information is returned
Remarks

Checks for duplicate keys. The Record must have been obtained by calling Fetch()()(). Works with read-write and read-only records. This method cannot be used with a View containing joins.

See Modify(ViewModifyMode, Record) for more remarks.

Win32 MSI APIs: MsiViewModify, MsiViewGetError

Exceptions
Exception | Condition
InstallerException | the validation failed (for a reason other than invalid data)
InvalidHandleException | the View handle is invalid

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ViewModifyMode Enumeration

ViewModifyMode Enumeration
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► ViewModifyMode
Specifies the modify mode for Modify(ViewModifyMode, Record).
Declaration Syntax
C# Visual Basic Visual C++
public enum ViewModifyMode
Public Enumeration ViewModifyMode
public enum class ViewModifyMode
Members
Member | Description
Seek | Refreshes the information in the supplied record without changing the position in the result set and without affecting subsequent fetch operations.
Refresh | Refreshes the data in a Record.
Insert | Inserts a Record into the view.
Update | Updates the View with new data from the Record.
Assign | Updates or inserts a Record into the View.
Replace | Updates or deletes and inserts a Record into the View.
Merge | Inserts or validates a record.
Delete | Deletes a Record from the View.
InsertTemporary | Inserts a Record into the View. The inserted data is not persistent.
Validate | Validates a record.
ValidateNew | Validates a new record.
ValidateField | Validates fields of a fetched or new record. Can validate one or more fields of an incomplete record.
ValidateDelete | Validates a record that will be deleted later.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Microsoft.Deployment.WindowsInstaller.Linq Namespace

Microsoft.Deployment.WindowsInstaller.Linq Namespace
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq
LINQ extensions for querying Windows Installer databases (experimental).
Declaration Syntax
C# Visual Basic Visual C++
namespace Microsoft.Deployment.WindowsInstaller.Linq
Namespace Microsoft.Deployment.WindowsInstaller.Linq
namespace Microsoft.Deployment.WindowsInstaller.Linq
Types
All Types Classes
Icon | Type | Description
 | DatabaseColumnAttribute | Apply to a property on a subclass of QRecord to indicate the name of the column the property is to be associated with.
 | DatabaseTableAttribute | Apply to a subclass of QRecord to indicate the name of the table the record type is to be used with.
 | QDatabase | Queryable MSI database - extends the base Database class with LINQ query functionality along with predefined entity types for common tables.
 | QRecord | Generic record entity for queryable databases, and base for strongly-typed entity subclasses.
 | QTable<(Of <(TRecord>)>) | Represents one table in a LINQ-queryable Database.
 | Queryable | Allows any Database instance to be converted into a queryable database.


DatabaseColumnAttribute Class

DatabaseColumnAttribute Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► DatabaseColumnAttribute
Apply to a property on a subclass of QRecord to indicate the name of the column the property is to be associated with.
Declaration Syntax
C# Visual Basic Visual C++
public class DatabaseColumnAttribute : Attribute
Public Class DatabaseColumnAttribute _
    Inherits Attribute
public ref class DatabaseColumnAttribute : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseColumnAttribute(String) | Creates a new DatabaseColumnAttribute which maps a record property to a column.
 | Column | Gets or sets the column associated with the record property.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Remarks
If this attribute is not used on a property, the default column name will be the same as the property name.
Inheritance Hierarchy
Object
 | Attribute
 |  | DatabaseColumnAttribute

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


DatabaseColumnAttribute Constructor (column)

DatabaseColumnAttribute Constructor (column)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► DatabaseColumnAttribute ► DatabaseColumnAttribute(String)
Creates a new DatabaseColumnAttribute which maps a record property to a column.
Declaration Syntax
C# Visual Basic Visual C++
public DatabaseColumnAttribute(
    string column
)
Public Sub New ( _
    column As String _
)
public:
DatabaseColumnAttribute(
    String^ column
)
Parameters
column (String)
name of the column associated with the property

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Column Property

Column Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► DatabaseColumnAttribute ► Column
Gets or sets the column associated with the record property.
Declaration Syntax
C# Visual Basic Visual C++
public string Column { get; set; }
Public Property Column As String
public:
property String^ Column {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


DatabaseTableAttribute Class

DatabaseTableAttribute Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► DatabaseTableAttribute
Apply to a subclass of QRecord to indicate the name of the table the record type is to be used with.
Declaration Syntax
C# Visual Basic Visual C++
public class DatabaseTableAttribute : Attribute
Public Class DatabaseTableAttribute _
    Inherits Attribute
public ref class DatabaseTableAttribute : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatabaseTableAttribute(String) | Creates a new DatabaseTableAttribute for the specified table.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Table | Gets or sets the table associated with the record type.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Remarks
If this attribute is not used on a record type, the default table name will be derived from the record type name. (An optional underscore suffix is stripped.)
Inheritance Hierarchy
Object
 | Attribute
 |  | DatabaseTableAttribute

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


DatabaseTableAttribute Constructor (table)

DatabaseTableAttribute Constructor (table)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► DatabaseTableAttribute ► DatabaseTableAttribute(String)
Creates a new DatabaseTableAttribute for the specified table.
Declaration Syntax
C# Visual Basic Visual C++
public DatabaseTableAttribute(
    string table
)
Public Sub New ( _
    table As String _
)
public:
DatabaseTableAttribute(
    String^ table
)
Parameters
table (String)
name of the table associated with the record type

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Table Property

Table Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► DatabaseTableAttribute ► Table
Gets or sets the table associated with the record type.
Declaration Syntax
C# Visual Basic Visual C++
public string Table { get; set; }
Public Property Table As String
public:
property String^ Table {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


QDatabase Class

QDatabase Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase
Queryable MSI database - extends the base Database class with LINQ query functionality along with predefined entity types for common tables.
Declaration Syntax
C# Visual Basic Visual C++
public class QDatabase : Database
Public Class QDatabase _
    Inherits Database
public ref class QDatabase : public Database
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QDatabase(String) | Opens an existing database in read-only mode.
 | QDatabase(String, String) | Opens an existing database with another database as output.
 | QDatabase(String, DatabaseOpenMode) | Opens an existing database or creates a new one.
 | QDatabase(IntPtr, Boolean, String, DatabaseOpenMode) | Creates a new database from an MSI handle.
 | ApplyTransform(String) | Apply a transform to the database, suppressing any error conditions specified by the transform's summary information. (Inherited from Database.)
 | ApplyTransform(String, TransformErrors) | Apply a transform to the database, specifying error conditions to suppress. (Inherited from Database.)
 | Close()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | CodePage | Gets or sets the code page of the Database. (Inherited from Database.)
 | Commit()()() | Finalizes the persistent form of the database. All persistent data is written to the writeable database, and no temporary columns or rows are written. (Inherited from Database.)
 | Components | Queryable standard table with predefined specialized record type.
 | CountRows(String) | Gets the count of all rows in the table. (Inherited from Database.)
 | CountRows(String, String) | Gets the count of all rows in the table that satisfy a given condition. (Inherited from Database.)
 | CreateFolders | Queryable standard table with predefined specialized record type.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateRecord(Int32) | Creates a new record object with the requested number of fields. (Inherited from Database.)
 | CreateTransformSummaryInfo(Database, String, TransformErrors, TransformValidations) | Creates and populates the summary information stream of an existing transform file, and fills in the properties with the base and reference ProductCode and ProductVersion. (Inherited from Database.)
 | CustomActions | Queryable standard table with predefined specialized record type.
 | DeleteOnClose(String) | Schedules a file or directory for deletion after the database handle is closed. (Inherited from Database.)
 | Directories | Queryable standard table with predefined specialized record type.
 | Dispose(Boolean) | Closes the database handle. After closing a handle, further method calls may throw InvalidHandleException. (Inherited from Database.)
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | DuplicateFiles | Queryable standard table with predefined specialized record type.
 | Equals(Object) | Tests whether this handle object is equal to another handle object. Two handle objects are equal if their types are the same and their native integer handles are the same. (Inherited from InstallerHandle.)
 | Execute(String, array<Object>[]()[]) | Executes the query specified by a SQL string. The query may not be a SELECT statement. (Inherited from Database.)
 | Execute(String, Record) | Executes the query specified by a SQL string. The query may not be a SELECT statement. (Inherited from Database.)
 | ExecuteIntegerQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as integers. (Inherited from Database.)
 | ExecuteIntegerQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as integers. (Inherited from Database.)
 | ExecuteQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results. (Inherited from Database.)
 | ExecuteQuery(String, Record) | Executes the specified SQL SELECT query and returns all results. (Inherited from Database.)
 | ExecuteScalar(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns a single result. (Inherited from Database.)
 | ExecuteScalar(String, Record) | Executes the specified SQL SELECT query and returns a single result. (Inherited from Database.)
 | ExecuteStringQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as strings. (Inherited from Database.)
 | ExecuteStringQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as strings. (Inherited from Database.)
 | Export(String, String) | Copies the structure and data from a specified table to a text archive file. (Inherited from Database.)
 | ExportAll(String) | Exports all database tables, streams, and summary information to archive files. (Inherited from Database.)
 | FeatureComponents | Queryable standard table with predefined specialized record type.
 | Features | Queryable standard table with predefined specialized record type.
 | FileHashes | Queryable standard table with predefined specialized record type.
 | FilePath | Gets the file path the Database was originally opened from, or null if not known. (Inherited from Database.)
 | Files | Queryable standard table with predefined specialized record type.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateTransform(Database, String) | Creates a transform that, when applied to the object database, results in the reference database. (Inherited from Database.)
 | GetHashCode()()() | Gets a hash value for the handle object. (Inherited from InstallerHandle.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets the native integer handle. (Inherited from InstallerHandle.)
 | Import(String) | Imports a database table from a text archive file, dropping any existing table. (Inherited from Database.)
 | ImportAll(String) | Imports all database tables, streams, and summary information from archive files. (Inherited from Database.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InstallExecuteSequences | Queryable standard table with predefined specialized record type.
 | InstallUISequences | Queryable standard table with predefined specialized record type.
 | IsClosed | Checks if the handle is closed. When closed, method calls on the handle object may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | IsColumnPersistent(String, String) | Checks whether a table contains a persistent column with a given name. (Inherited from Database.)
 | IsReadOnly | Gets a boolean value indicating whether this database was opened in read-only mode. (Inherited from Database.)
 | IsTablePersistent(String) | Checks whether a table exists and is persistent in the database. (Inherited from Database.)
 | IsTransformValid(String) | Checks whether a transform is valid for this Database, according to its validation data and flags. (Inherited from Database.)
 | IsTransformValid(SummaryInfo) | Checks whether a transform is valid for this Database, according to its SummaryInfo data. (Inherited from Database.)
 | Item[([(String])]) | Gets a queryable table from the datbaase.
 | LaunchConditions | Queryable standard table with predefined specialized record type.
 | Log | Gets or sets a log where all MSI SQL queries are written.
 | Medias | Queryable standard table with predefined specialized record type.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(Database, String) | Merges another database with this database. (Inherited from Database.)
 | Merge(Database) | Merges another database with this database. (Inherited from Database.)
 | OpenMode | Gets the open mode for the database. (Inherited from Database.)
 | OpenView(String, array<Object>[]()[]) | Gets a View object representing the query specified by a SQL string. (Inherited from Database.)
 | Properties | Queryable standard table with predefined specialized record type.
 | Registries | Queryable standard table with predefined specialized record type.
 | RemoveFiles | Queryable standard table with predefined specialized record type.
 | SummaryInfo | Gets the SummaryInfo object for this database that can be used to examine and modify properties to the summary information stream. (Inherited from Database.)
 | Tables | Gets the collection of tables in the Database. (Inherited from Database.)
 | ToString()()() | Returns the file path of this database, or the handle value if a file path was not specified. (Inherited from Database.)
 | ViewTransform(String) | Apply a transform to the database, recording the changes in the "_TransformView" table. (Inherited from Database.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | InstallerHandle
 |  |  | Database
 |  |  |  | QDatabase

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


QDatabase Constructor

QDatabase Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► QDatabase()()()
Members
Icon | Member | Description
 | QDatabase(String) | Opens an existing database in read-only mode.
 | QDatabase(String, String) | Opens an existing database with another database as output.
 | QDatabase(String, DatabaseOpenMode) | Opens an existing database or creates a new one.
 | QDatabase(IntPtr, Boolean, String, DatabaseOpenMode) | Creates a new database from an MSI handle.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


QDatabase Constructor (handle, ownsHandle, filePath, openMode)

QDatabase Constructor (handle, ownsHandle, filePath, openMode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► QDatabase(IntPtr, Boolean, String, DatabaseOpenMode)
Creates a new database from an MSI handle.
Declaration Syntax
C# Visual Basic Visual C++
protected QDatabase(
    IntPtr handle,
    bool ownsHandle,
    string filePath,
    DatabaseOpenMode openMode
)
Protected Sub New ( _
    handle As IntPtr, _
    ownsHandle As Boolean, _
    filePath As String, _
    openMode As DatabaseOpenMode _
)
protected:
QDatabase(
    IntPtr handle,
    bool ownsHandle,
    String^ filePath,
    DatabaseOpenMode openMode
)
Parameters
handle (IntPtr)
Native MSI database handle.
ownsHandle (Boolean)
True if the handle should be closed when the database object is disposed
filePath (String)
Path of the database file, if known
openMode (DatabaseOpenMode)
Mode the handle was originally opened in

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


QDatabase Constructor (filePath)

QDatabase Constructor (filePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► QDatabase(String)
Opens an existing database in read-only mode.
Declaration Syntax
C# Visual Basic Visual C++
public QDatabase(
    string filePath
)
Public Sub New ( _
    filePath As String _
)
public:
QDatabase(
    String^ filePath
)
Parameters
filePath (String)
Path to the database file.
Remarks
Because this constructor initiates database access, it cannot be used with a running installation.

The Database object should be Close()()()d after use. The finalizer will close the handle if it is still open, however due to the nondeterministic nature of finalization it is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Exceptions
Exception | Condition
InstallerException | the database could not be created/opened

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


QDatabase Constructor (filePath, mode)

QDatabase Constructor (filePath, mode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► QDatabase(String, DatabaseOpenMode)
Opens an existing database or creates a new one.
Declaration Syntax
C# Visual Basic Visual C++
public QDatabase(
    string filePath,
    DatabaseOpenMode mode
)
Public Sub New ( _
    filePath As String, _
    mode As DatabaseOpenMode _
)
public:
QDatabase(
    String^ filePath,
    DatabaseOpenMode mode
)
Parameters
filePath (String)
Path to the database file. If an empty string is supplied, a temporary database is created that is not persisted.
mode (DatabaseOpenMode)
Open mode for the database
Remarks
To make and save changes to a database first open the database in transaction, create or, or direct mode. After making the changes, always call the Commit method before closing the database handle. The Commit method flushes all buffers.

Always call the Commit method on a database that has been opened in direct mode before closing the database. Failure to do this may corrupt the database.

Because this constructor initiates database access, it cannot be used with a running installation.

The Database object should be Close()()()d after use. The finalizer will close the handle if it is still open, however due to the nondeterministic nature of finalization it is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Exceptions
Exception | Condition
InstallerException | the database could not be created/opened

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


QDatabase Constructor (filePath, outputPath)

QDatabase Constructor (filePath, outputPath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► QDatabase(String, String)
Opens an existing database with another database as output.
Declaration Syntax
C# Visual Basic Visual C++
public QDatabase(
    string filePath,
    string outputPath
)
Public Sub New ( _
    filePath As String, _
    outputPath As String _
)
public:
QDatabase(
    String^ filePath,
    String^ outputPath
)
Parameters
filePath (String)
Path to the database to be read.
outputPath (String)
Open mode for the database
Return Value
Database object representing the created or opened database
Remarks
When a database is opened as the output of another database, the summary information stream of the output database is actually a read-only mirror of the original database and thus cannot be changed. Additionally, it is not persisted with the database. To create or modify the summary information for the output database it must be closed and re-opened.

The returned Database object should be Close()()()d after use. The finalizer will close the handle if it is still open, however due to the nondeterministic nature of finalization it is best that the handle be closed manually as soon as it is no longer needed, as leaving lots of unused handles open can degrade performance.

Exceptions
Exception | Condition
InstallerException | the database could not be created/opened

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Components Property

Components Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► Components
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<Component_> Components { get; }
Public ReadOnly Property Components As QTable(Of Component_)
public:
property QTable<Component_^>^ Components {
    QTable<Component_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


CreateFolders Property

CreateFolders Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► CreateFolders
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<CreateFolder_> CreateFolders { get; }
Public ReadOnly Property CreateFolders As QTable(Of CreateFolder_)
public:
property QTable<CreateFolder_^>^ CreateFolders {
    QTable<CreateFolder_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


CustomActions Property

CustomActions Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► CustomActions
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<CustomAction_> CustomActions { get; }
Public ReadOnly Property CustomActions As QTable(Of CustomAction_)
public:
property QTable<CustomAction_^>^ CustomActions {
    QTable<CustomAction_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Directories Property

Directories Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► Directories
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<Directory_> Directories { get; }
Public ReadOnly Property Directories As QTable(Of Directory_)
public:
property QTable<Directory_^>^ Directories {
    QTable<Directory_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


DuplicateFiles Property

DuplicateFiles Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► DuplicateFiles
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<DuplicateFile_> DuplicateFiles { get; }
Public ReadOnly Property DuplicateFiles As QTable(Of DuplicateFile_)
public:
property QTable<DuplicateFile_^>^ DuplicateFiles {
    QTable<DuplicateFile_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


FeatureComponents Property

FeatureComponents Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► FeatureComponents
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<FeatureComponent_> FeatureComponents { get; }
Public ReadOnly Property FeatureComponents As QTable(Of FeatureComponent_)
public:
property QTable<FeatureComponent_^>^ FeatureComponents {
    QTable<FeatureComponent_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Features Property

Features Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► Features
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<Feature_> Features { get; }
Public ReadOnly Property Features As QTable(Of Feature_)
public:
property QTable<Feature_^>^ Features {
    QTable<Feature_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


FileHashes Property

FileHashes Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► FileHashes
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<FileHash_> FileHashes { get; }
Public ReadOnly Property FileHashes As QTable(Of FileHash_)
public:
property QTable<FileHash_^>^ FileHashes {
    QTable<FileHash_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Files Property

Files Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► Files
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<File_> Files { get; }
Public ReadOnly Property Files As QTable(Of File_)
public:
property QTable<File_^>^ Files {
    QTable<File_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


InstallExecuteSequences Property

InstallExecuteSequences Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► InstallExecuteSequences
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<InstallSequence_> InstallExecuteSequences { get; }
Public ReadOnly Property InstallExecuteSequences As QTable(Of InstallSequence_)
public:
property QTable<InstallSequence_^>^ InstallExecuteSequences {
    QTable<InstallSequence_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


InstallUISequences Property

InstallUISequences Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► InstallUISequences
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<InstallSequence_> InstallUISequences { get; }
Public ReadOnly Property InstallUISequences As QTable(Of InstallSequence_)
public:
property QTable<InstallSequence_^>^ InstallUISequences {
    QTable<InstallSequence_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Item Property (table)

Item Property (table)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► Item[([(String])])
Gets a queryable table from the datbaase.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<QRecord> this[
    string table
] { get; }
Public ReadOnly Default Property Item ( _
    table As String _
) As QTable(Of QRecord)
public:
property QTable<QRecord^>^ default[String^ table] {
    QTable<QRecord^>^ get (String^ table);
}
Parameters
table (String)
name of the table

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


LaunchConditions Property

LaunchConditions Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► LaunchConditions
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<LaunchCondition_> LaunchConditions { get; }
Public ReadOnly Property LaunchConditions As QTable(Of LaunchCondition_)
public:
property QTable<LaunchCondition_^>^ LaunchConditions {
    QTable<LaunchCondition_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Log Property

Log Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► Log
Gets or sets a log where all MSI SQL queries are written.
Declaration Syntax
C# Visual Basic Visual C++
public TextWriter Log { get; set; }
Public Property Log As TextWriter
public:
property TextWriter^ Log {
    TextWriter^ get ();
    void set (TextWriter^ value);
}
Remarks
The log can be useful for debugging, or simply to watch the LINQ magic in action.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Medias Property

Medias Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► Medias
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<Media_> Medias { get; }
Public ReadOnly Property Medias As QTable(Of Media_)
public:
property QTable<Media_^>^ Medias {
    QTable<Media_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Properties Property

Properties Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► Properties
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<Property_> Properties { get; }
Public ReadOnly Property Properties As QTable(Of Property_)
public:
property QTable<Property_^>^ Properties {
    QTable<Property_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Registries Property

Registries Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► Registries
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<Registry_> Registries { get; }
Public ReadOnly Property Registries As QTable(Of Registry_)
public:
property QTable<Registry_^>^ Registries {
    QTable<Registry_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


RemoveFiles Property

RemoveFiles Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► RemoveFiles
Queryable standard table with predefined specialized record type.
Declaration Syntax
C# Visual Basic Visual C++
public QTable<RemoveFile_> RemoveFiles { get; }
Public ReadOnly Property RemoveFiles As QTable(Of RemoveFile_)
public:
property QTable<RemoveFile_^>^ RemoveFiles {
    QTable<RemoveFile_^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


QRecord Class

QRecord Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord
Generic record entity for queryable databases, and base for strongly-typed entity subclasses.
Declaration Syntax
C# Visual Basic Visual C++
public class QRecord
Public Class QRecord
public ref class QRecord
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QRecord()()() | Do not call. Use QTable.NewRecord() instead.
 | Assign()()() | Not yet implemented.
 | Delete()()() | Deletes the record from the table if it exists.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldCount | Gets the number of fields in the record.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | I(Int32) | Used by subclasses to get a field as an integer.
 | Insert()()() | Inserts the record in the database.
 | Insert(Boolean) | Inserts the record into the table.
 | Item[([(String])]) | Gets or sets a record field.
 | Item[([(Int32])]) | Gets or sets a record field.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge()()() | Not yet implemented.
 | NI(Int32) | Used by subclasses to get a field as a nullable integer.
 | Refresh()()() | Not yet implemented.
 | ToString()()() | Dumps all record fields to a string. (Overrides Object.ToString()()().)
 | Update(IList<(Of <(String>)>), IList<(Of <(String>)>)) | Update multiple fields in the record (and the database).
 | Update(IList<(Of <(Int32>)>), IList<(Of <(String>)>)) | Update multiple fields in the record (and the database).
 | Validate()()() | Not yet implemented.
 | ValidateDelete()()() | Not yet implemented.
 | ValidateFields()()() | Not yet implemented.
 | ValidateNew()()() | Not yet implemented.
Remarks
Several predefined specialized subclasses are provided for common standard tables. Subclasses for additional standard tables or custom tables are not necessary, but they are easy to create and make the coding experience much nicer.

When creating subclasses, the following attributes may be useful: DatabaseTableAttribute, DatabaseColumnAttribute

Inheritance Hierarchy
Object
QRecord

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


QRecord Constructor

QRecord Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► QRecord()()()
Do not call. Use QTable.NewRecord() instead.
Declaration Syntax
C# Visual Basic Visual C++
public QRecord()
Public Sub New
public:
QRecord()
Remarks
Subclasses must also provide a public parameterless constructor.

QRecord constructors are only public due to implementation reasons (to satisfy the new() constraint on the QTable generic class). They are not intended to be called by user code other than a subclass constructor. If the constructor is invoked directly, the record instance will not be properly initialized (associated with a database table) and calls to methods on the instance will throw a NullReferenceException.

See Also
NewRecord()()()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Assign Method

Assign Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Assign()()()
Not yet implemented.
Declaration Syntax
C# Visual Basic Visual C++
public void Assign()
Public Sub Assign
public:
void Assign()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Delete Method

Delete Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Delete()()()
Deletes the record from the table if it exists.
Declaration Syntax
C# Visual Basic Visual C++
public void Delete()
Public Sub Delete
public:
void Delete()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


FieldCount Property

FieldCount Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► FieldCount
Gets the number of fields in the record.
Declaration Syntax
C# Visual Basic Visual C++
public int FieldCount { get; }
Public ReadOnly Property FieldCount As Integer
public:
property int FieldCount {
    int get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


I Method (index)

I Method (index)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► I(Int32)
Used by subclasses to get a field as an integer.
Declaration Syntax
C# Visual Basic Visual C++
protected int I(
    int index
)
Protected Function I ( _
    index As Integer _
) As Integer
protected:
int I(
    int index
)
Parameters
index (Int32)
zero-based column index of the field

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Insert Method

Insert Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Insert()()()
Members
Icon | Member | Description
 | Insert()()() | Inserts the record in the database.
 | Insert(Boolean) | Inserts the record into the table.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Insert Method

Insert Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Insert()()()
Inserts the record in the database.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert()
Public Sub Insert
public:
void Insert()
Remarks
The record (primary keys) may not already exist in the table.

Use NewRecord()()() to get a new record. Prmary keys and all required fields must be filled in before insertion.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Insert Method (temporary)

Insert Method (temporary)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Insert(Boolean)
Inserts the record into the table.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    bool temporary
)
Public Sub Insert ( _
    temporary As Boolean _
)
public:
void Insert(
    bool temporary
)
Parameters
temporary (Boolean)
true if the record is temporarily inserted, to be visible only as long as the database is open
Remarks
The record (primary keys) may not already exist in the table.

Use NewRecord()()() to get a new record. Prmary keys and all required fields must be filled in before insertion.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Item Property

Item Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Item
Members
Icon | Member | Description
 | Item[([(String])]) | Gets or sets a record field.
 | Item[([(Int32])]) | Gets or sets a record field.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Item Property (index)

Item Property (index)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Item[([(Int32])])
Gets or sets a record field.
Declaration Syntax
C# Visual Basic Visual C++
public string this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As String
public:
property String^ default[int index] {
    String^ get (int index);
    void set (int index, String^ value);
}
Parameters
index (Int32)
zero-based column index of the field
Remarks
Setting a field value will automatically update the database.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Item Property (field)

Item Property (field)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Item[([(String])])
Gets or sets a record field.
Declaration Syntax
C# Visual Basic Visual C++
public string this[
    string field
] { get; set; }
Public Default Property Item ( _
    field As String _
) As String
public:
property String^ default[String^ field] {
    String^ get (String^ field);
    void set (String^ field, String^ value);
}
Parameters
field (String)
column name of the field
Remarks
Setting a field value will automatically update the database.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Merge Method

Merge Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Merge()()()
Not yet implemented.
Declaration Syntax
C# Visual Basic Visual C++
public bool Merge()
Public Function Merge As Boolean
public:
bool Merge()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


NI Method (index)

NI Method (index)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► NI(Int32)
Used by subclasses to get a field as a nullable integer.
Declaration Syntax
C# Visual Basic Visual C++
protected Nullable<int> NI(
    int index
)
Protected Function NI ( _
    index As Integer _
) As Nullable(Of Integer)
protected:
Nullable<int> NI(
    int index
)
Parameters
index (Int32)
zero-based column index of the field

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Refresh Method

Refresh Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Refresh()()()
Not yet implemented.
Declaration Syntax
C# Visual Basic Visual C++
public void Refresh()
Public Sub Refresh
public:
void Refresh()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


ToString Method

ToString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► ToString()()()
Dumps all record fields to a string.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Update Method

Update Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Update()()()
Members
Icon | Member | Description
 | Update(IList<(Of <(String>)>), IList<(Of <(String>)>)) | Update multiple fields in the record (and the database).
 | Update(IList<(Of <(Int32>)>), IList<(Of <(String>)>)) | Update multiple fields in the record (and the database).

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Update Method (indexes, values)

Update Method (indexes, values)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Update(IList<(Of <(Int32>)>), IList<(Of <(String>)>))
Update multiple fields in the record (and the database).
Declaration Syntax
C# Visual Basic Visual C++
public void Update(
    IList<int> indexes,
    IList<string> values
)
Public Sub Update ( _
    indexes As IList(Of Integer), _
    values As IList(Of String) _
)
public:
void Update(
    IList<int>^ indexes,
    IList<String^>^ values
)
Parameters
indexes (IList <(Of <( Int32 >)>))
column indexes of fields to update
values (IList <(Of <( String >)>))
new values for each field being updated
Remarks
The record (primary keys) must already exist in the table.

Updating primary key fields is not yet implemented; use Delete() and Insert() instead.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Update Method (fields, values)

Update Method (fields, values)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Update(IList<(Of <(String>)>), IList<(Of <(String>)>))
Update multiple fields in the record (and the database).
Declaration Syntax
C# Visual Basic Visual C++
public void Update(
    IList<string> fields,
    IList<string> values
)
Public Sub Update ( _
    fields As IList(Of String), _
    values As IList(Of String) _
)
public:
void Update(
    IList<String^>^ fields,
    IList<String^>^ values
)
Parameters
fields (IList <(Of <( String >)>))
column names of fields to update
values (IList <(Of <( String >)>))
new values for each field being updated

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Validate Method

Validate Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► Validate()()()
Not yet implemented.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<ValidationErrorInfo> Validate()
Public Function Validate As ICollection(Of ValidationErrorInfo)
public:
ICollection<ValidationErrorInfo>^ Validate()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


ValidateDelete Method

ValidateDelete Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► ValidateDelete()()()
Not yet implemented.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<ValidationErrorInfo> ValidateDelete()
Public Function ValidateDelete As ICollection(Of ValidationErrorInfo)
public:
ICollection<ValidationErrorInfo>^ ValidateDelete()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


ValidateFields Method

ValidateFields Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► ValidateFields()()()
Not yet implemented.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<ValidationErrorInfo> ValidateFields()
Public Function ValidateFields As ICollection(Of ValidationErrorInfo)
public:
ICollection<ValidationErrorInfo>^ ValidateFields()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


ValidateNew Method

ValidateNew Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QRecord ► ValidateNew()()()
Not yet implemented.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<ValidationErrorInfo> ValidateNew()
Public Function ValidateNew As ICollection(Of ValidationErrorInfo)
public:
ICollection<ValidationErrorInfo>^ ValidateNew()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


QTable(TRecord) Class

QTable<(Of <(TRecord>)>) Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QTable<(Of <(TRecord>)>)
Represents one table in a LINQ-queryable Database.
Declaration Syntax
C# Visual Basic Visual C++
public sealed class QTable<TRecord> : IOrderedQueryable<TRecord>,
    IQueryable<TRecord>, IEnumerable<TRecord>, IOrderedQueryable, IQueryable,
    IEnumerable, IQueryProvider where TRecord : new(), QRecord
Public NotInheritable Class QTable(Of TRecord As {New, QRecord}) _
    Implements IOrderedQueryable(Of TRecord), IQueryable(Of TRecord),  _
    IEnumerable(Of TRecord), IOrderedQueryable, IQueryable, IEnumerable,  _
    IQueryProvider
generic<typename TRecord>
where TRecord : gcnew(), QRecord
public ref class QTable sealed : IOrderedQueryable<TRecord>,
    IQueryable<TRecord>, IEnumerable<TRecord>, IOrderedQueryable, IQueryable,
    IEnumerable, IQueryProvider
Generic Template Parameters
TRecord
type that represents one record in the table
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QTable<(Of <(TRecord>)>)(QDatabase) | Creates a new QTable, inferring the table name from the name of the record type parameter.
 | QTable<(Of <(TRecord>)>)(QDatabase, String) | Creates a new QTable with an explicit table name.
 | Database | Gets the database this table is associated with.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Enumerates over all records in the table.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewRecord()()() | Creates a new record that can be inserted into this table.
 | TableInfo | Gets schema information about the table.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class is the primary gateway to all LINQ to MSI query functionality.

The TRecord generic parameter may be the general QRecord class, or a specialized subclass of QRecord.

Inheritance Hierarchy
Object
QTable<(Of <(TRecord>)>)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


QTable(TRecord) Constructor

QTable<(Of <(TRecord>)>) Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QTable<(Of <(TRecord>)>) ► QTable<(Of <(TRecord>)>)()()()
Members
Icon | Member | Description
 | QTable<(Of <(TRecord>)>)(QDatabase) | Creates a new QTable, inferring the table name from the name of the record type parameter.
 | QTable<(Of <(TRecord>)>)(QDatabase, String) | Creates a new QTable with an explicit table name.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


QTable(TRecord) Constructor (db)

QTable<(Of <(TRecord>)>) Constructor (db)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QTable<(Of <(TRecord>)>) ► QTable<(Of <(TRecord>)>)(QDatabase)
Creates a new QTable, inferring the table name from the name of the record type parameter.
Declaration Syntax
C# Visual Basic Visual C++
public QTable(
    QDatabase db
)
Public Sub New ( _
    db As QDatabase _
)
public:
QTable(
    QDatabase^ db
)
Parameters
db (QDatabase)
database that contains the table

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


QTable(TRecord) Constructor (db, table)

QTable<(Of <(TRecord>)>) Constructor (db, table)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QTable<(Of <(TRecord>)>) ► QTable<(Of <(TRecord>)>)(QDatabase, String)
Creates a new QTable with an explicit table name.
Declaration Syntax
C# Visual Basic Visual C++
public QTable(
    QDatabase db,
    string table
)
Public Sub New ( _
    db As QDatabase, _
    table As String _
)
public:
QTable(
    QDatabase^ db,
    String^ table
)
Parameters
db (QDatabase)
database that contains the table
table (String)
name of the table

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Database Property

Database Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QTable<(Of <(TRecord>)>) ► Database
Gets the database this table is associated with.
Declaration Syntax
C# Visual Basic Visual C++
public QDatabase Database { get; }
Public ReadOnly Property Database As QDatabase
public:
property QDatabase^ Database {
    QDatabase^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QTable<(Of <(TRecord>)>) ► GetEnumerator()()()
Enumerates over all records in the table.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<TRecord> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of TRecord)
public:
virtual IEnumerator<TRecord>^ GetEnumerator() sealed
Return Value

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


NewRecord Method

NewRecord Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QTable<(Of <(TRecord>)>) ► NewRecord()()()
Creates a new record that can be inserted into this table.
Declaration Syntax
C# Visual Basic Visual C++
public TRecord NewRecord()
Public Function NewRecord As TRecord
public:
TRecord NewRecord()
Return Value
a record with all fields initialized to null
Remarks
Primary keys and required fields must be filled in with non-null values before the record can be inserted.

The record is tied to this table in this database; it cannot be inserted into another table or database.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


TableInfo Property

TableInfo Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QTable<(Of <(TRecord>)>) ► TableInfo
Gets schema information about the table.
Declaration Syntax
C# Visual Basic Visual C++
public TableInfo TableInfo { get; }
Public ReadOnly Property TableInfo As TableInfo
public:
property TableInfo^ TableInfo {
    TableInfo^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Queryable Class

Queryable Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► Queryable
Allows any Database instance to be converted into a queryable database.
Declaration Syntax
C# Visual Basic Visual C++
public static class Queryable
Public NotInheritable Class Queryable
public ref class Queryable abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AsQueryable(Database) | Converts any Database instance into a queryable database.
Inheritance Hierarchy
Object
Queryable

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


AsQueryable Method (db)

AsQueryable Method (db)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► Queryable ► AsQueryable(Database)
Converts any Database instance into a queryable database.
Declaration Syntax
C# Visual Basic Visual C++
public static QDatabase AsQueryable(
    Database db
)
Public Shared Function AsQueryable ( _
    db As Database _
) As QDatabase
public:
static QDatabase^ AsQueryable(
    Database^ db
)
Parameters
db (Database)
Return Value
Queryable database instance that operates on the same MSI handle.
Remarks
This extension method is meant for convenient on-the-fly conversion. If the existing database instance already happens to be a QDatabase, then it is returned unchanged. Otherwise since the new database carries the same MSI handle, only one of the instances needs to be closed, not both.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Microsoft.Deployment.WindowsInstaller.Package Namespace

Microsoft.Deployment.WindowsInstaller.Package Namespace
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package
Extended classes for working with Windows Installer installation and patch packages.
Declaration Syntax
C# Visual Basic Visual C++
namespace Microsoft.Deployment.WindowsInstaller.Package
Namespace Microsoft.Deployment.WindowsInstaller.Package
namespace Microsoft.Deployment.WindowsInstaller.Package
Types
All Types Classes Delegates
Icon | Type | Description
 | InstallPackage | Provides access to powerful build, maintenance, and analysis operations on an installation package (.MSI or .MSM).
 | InstallPackageMessageHandler | Handles status messages generated when operations are performed on an InstallPackage or PatchPackage.
 | InstallPackageProperties | Accessor for getting and setting properties of the InstallPackage database.
 | InstallPath | Represents the installation path of a file or directory from an installer product database.
 | InstallPathCollection | Represents a collection of InstallPaths that are the child paths of the same parent directory.
 | InstallPathMap | Represents a mapping of install paths for all directories, components, or files in an installation database.
 | PatchPackage | Provides access to convenient properties and operations on a patch package (.MSP).
 | TransformInfo | Contains properties of a transform package (.MST).


InstallPackage Class

InstallPackage Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage
Provides access to powerful build, maintenance, and analysis operations on an installation package (.MSI or .MSM).
Declaration Syntax
C# Visual Basic Visual C++
public class InstallPackage : Database
Public Class InstallPackage _
    Inherits Database
public ref class InstallPackage : public Database
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstallPackage(String, DatabaseOpenMode) | Creates a new InstallPackage object. The file source directory and working directory are the same as the location as the package file.
 | InstallPackage(String, DatabaseOpenMode, String, String) | Creates a new InstallPackage object, specifying an alternate file source directory and/or working directory.
 | ApplyPatch(PatchPackage, String) | Applies a patch package to the database, resulting in an installation package that has the patch built-in.
 | ApplyTransform(String) | Apply a transform to the database, suppressing any error conditions specified by the transform's summary information. (Inherited from Database.)
 | ApplyTransform(String, TransformErrors) | Apply a transform to the database, specifying error conditions to suppress. (Inherited from Database.)
 | Close()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | CodePage | Gets or sets the code page of the Database. (Inherited from Database.)
 | Commit()()() | Finalizes the persistent form of the database. All persistent data is written to the writeable database, and no temporary columns or rows are written. (Inherited from Database.)
 | CompressionLevel | Gets or sets the compression level used by UpdateFiles()()() and Consolidate(String).
 | Consolidate(String) | Consolidates a package by combining and re-compressing all files into a single internal or external cabinet.
 | CountRows(String) | Gets the count of all rows in the table. (Inherited from Database.)
 | CountRows(String, String) | Gets the count of all rows in the table that satisfy a given condition. (Inherited from Database.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateRecord(Int32) | Creates a new record object with the requested number of fields. (Inherited from Database.)
 | CreateTransformSummaryInfo(Database, String, TransformErrors, TransformValidations) | Creates and populates the summary information stream of an existing transform file, and fills in the properties with the base and reference ProductCode and ProductVersion. (Inherited from Database.)
 | DeleteOnClose(String) | Schedules a file or directory for deletion after the database handle is closed. (Inherited from Database.)
 | Directories | Gets a mapping from Directory keys to source/target paths.
 | Dispose(Boolean) | Closes the database handle. After closing a handle, further method calls may throw InvalidHandleException. (Inherited from Database.)
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Equals(Object) | Tests whether this handle object is equal to another handle object. Two handle objects are equal if their types are the same and their native integer handles are the same. (Inherited from InstallerHandle.)
 | Execute(String, array<Object>[]()[]) | Executes the query specified by a SQL string. The query may not be a SELECT statement. (Inherited from Database.)
 | Execute(String, Record) | Executes the query specified by a SQL string. The query may not be a SELECT statement. (Inherited from Database.)
 | ExecuteIntegerQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as integers. (Inherited from Database.)
 | ExecuteIntegerQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as integers. (Inherited from Database.)
 | ExecuteQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results. (Inherited from Database.)
 | ExecuteQuery(String, Record) | Executes the specified SQL SELECT query and returns all results. (Inherited from Database.)
 | ExecuteScalar(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns a single result. (Inherited from Database.)
 | ExecuteScalar(String, Record) | Executes the specified SQL SELECT query and returns a single result. (Inherited from Database.)
 | ExecuteStringQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as strings. (Inherited from Database.)
 | ExecuteStringQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as strings. (Inherited from Database.)
 | Export(String, String) | Copies the structure and data from a specified table to a text archive file. (Inherited from Database.)
 | ExportAll(String) | Exports all database tables, streams, and summary information to archive files. (Inherited from Database.)
 | ExtractFiles()()() | Extracts all files to the WorkingDirectory. The files are extracted to the relative directory matching their SourcePath.
 | ExtractFiles(ICollection<(Of <(String>)>)) | Extracts a specified list of files to the WorkingDirectory. The files are extracted to the relative directory matching their SourcePath.
 | FilePath | Gets the file path the Database was originally opened from, or null if not known. (Inherited from Database.)
 | Files | Gets a mapping from File keys to source/target paths.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindFiles(String) | Gets the list of file keys that have the specified long file name.
 | FindFiles(Regex) | Gets the list of file keys whose long file names match a specified regular-expression search pattern.
 | GenerateTransform(Database, String) | Creates a transform that, when applied to the object database, results in the reference database. (Inherited from Database.)
 | GetHashCode()()() | Gets a hash value for the handle object. (Inherited from InstallerHandle.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Handle | Gets the native integer handle. (Inherited from InstallerHandle.)
 | Import(String) | Imports a database table from a text archive file, dropping any existing table. (Inherited from Database.)
 | ImportAll(String) | Imports all database tables, streams, and summary information from archive files. (Inherited from Database.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsClosed | Checks if the handle is closed. When closed, method calls on the handle object may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | IsColumnPersistent(String, String) | Checks whether a table contains a persistent column with a given name. (Inherited from Database.)
 | IsReadOnly | Gets a boolean value indicating whether this database was opened in read-only mode. (Inherited from Database.)
 | IsTablePersistent(String) | Checks whether a table exists and is persistent in the database. (Inherited from Database.)
 | IsTransformValid(String) | Checks whether a transform is valid for this Database, according to its validation data and flags. (Inherited from Database.)
 | IsTransformValid(SummaryInfo) | Checks whether a transform is valid for this Database, according to its SummaryInfo data. (Inherited from Database.)
 | LogMessage(String, array<Object>[]()[]) | Sends a message to the Message event-handler.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(Database, String) | Merges another database with this database. (Inherited from Database.)
 | Merge(Database) | Merges another database with this database. (Inherited from Database.)
 | Message | Handle this event to receive status messages when operations are performed on the install package.
 | OpenMode | Gets the open mode for the database. (Inherited from Database.)
 | OpenView(String, array<Object>[]()[]) | Gets a View object representing the query specified by a SQL string. (Inherited from Database.)
 | Property | Accessor for getting and setting properties of the InstallPackage database.
 | SourceDirectory | Gets or sets the location to obtain source files and cabinets when extracting or updating files in the working directory. This is often the location of an original copy of the package that is not meant to be modified.
 | SummaryInfo | Gets the SummaryInfo object for this database that can be used to examine and modify properties to the summary information stream. (Inherited from Database.)
 | Tables | Gets the collection of tables in the Database. (Inherited from Database.)
 | ToString()()() | Returns the file path of this database, or the handle value if a file path was not specified. (Inherited from Database.)
 | UpdateDirectories()()() | Rebuilds the cached directory structure information accessed by the Directories and Files properties. This should be done after modifying the File, Component, or Directory tables, or else the cached information may no longer be accurate.
 | UpdateFiles()()() | Updates the install package with new files from the WorkingDirectory. The files must be in the relative directory matching their SourcePath. This method re-compresses and packages the files if necessary, and also updates the following data: File.FileSize, File.Version, File.Language, MsiFileHash.HashPart*
 | UpdateFiles(ICollection<(Of <(String>)>)) | Updates the install package with new files from the WorkingDirectory. The files must be in the relative directory matching their SourcePath. This method re-compresses and packages the files if necessary, and also updates the following data: File.FileSize, File.Version, File.Language, MsiFileHash.HashPart?.
 | ViewTransform(String) | Apply a transform to the database, recording the changes in the "_TransformView" table. (Inherited from Database.)
 | WorkingDirectory | Gets or sets the location where files will be extracted to/updated from. Also the location where a temporary folder is created during some operations.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | InstallerHandle
 |  |  | Database
 |  |  |  | InstallPackage

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


InstallPackage Constructor

InstallPackage Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► InstallPackage()()()
Members
Icon | Member | Description
 | InstallPackage(String, DatabaseOpenMode) | Creates a new InstallPackage object. The file source directory and working directory are the same as the location as the package file.
 | InstallPackage(String, DatabaseOpenMode, String, String) | Creates a new InstallPackage object, specifying an alternate file source directory and/or working directory.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


InstallPackage Constructor (packagePath, openMode)

InstallPackage Constructor (packagePath, openMode)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► InstallPackage(String, DatabaseOpenMode)
Creates a new InstallPackage object. The file source directory and working directory are the same as the location as the package file.
Declaration Syntax
C# Visual Basic Visual C++
public InstallPackage(
    string packagePath,
    DatabaseOpenMode openMode
)
Public Sub New ( _
    packagePath As String, _
    openMode As DatabaseOpenMode _
)
public:
InstallPackage(
    String^ packagePath,
    DatabaseOpenMode openMode
)
Parameters
packagePath (String)
Path to the install package to be created or opened
openMode (DatabaseOpenMode)
Open mode for the database

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


InstallPackage Constructor (packagePath, openMode, sourceDir, workingDir)

InstallPackage Constructor (packagePath, openMode, sourceDir, workingDir)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► InstallPackage(String, DatabaseOpenMode, String, String)
Creates a new InstallPackage object, specifying an alternate file source directory and/or working directory.
Declaration Syntax
C# Visual Basic Visual C++
public InstallPackage(
    string packagePath,
    DatabaseOpenMode openMode,
    string sourceDir,
    string workingDir
)
Public Sub New ( _
    packagePath As String, _
    openMode As DatabaseOpenMode, _
    sourceDir As String, _
    workingDir As String _
)
public:
InstallPackage(
    String^ packagePath,
    DatabaseOpenMode openMode,
    String^ sourceDir,
    String^ workingDir
)
Parameters
packagePath (String)
Path to the install package to be created or opened
openMode (DatabaseOpenMode)
Open mode for the database
sourceDir (String)
Location to obtain source files and cabinets when extracting or updating files in the working directory. This is often the location of an original copy of the package that is not meant to be modified. If this parameter is null, it defaults to the directory of packagePath.
workingDir (String)
Location where files will be extracted to/updated from. Also the location where a temporary folder is created during some operations. If this parameter is null, it defaults to the directory of packagePath.
Remarks
If the source location is different than the working directory, then no files will be modified at the source location.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ApplyPatch Method (patchPackage, transform)

ApplyPatch Method (patchPackage, transform)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► ApplyPatch(PatchPackage, String)
Applies a patch package to the database, resulting in an installation package that has the patch built-in.
Declaration Syntax
C# Visual Basic Visual C++
public void ApplyPatch(
    PatchPackage patchPackage,
    string transform
)
Public Sub ApplyPatch ( _
    patchPackage As PatchPackage, _
    transform As String _
)
public:
void ApplyPatch(
    PatchPackage^ patchPackage,
    String^ transform
)
Parameters
patchPackage (PatchPackage)
The patch package to be applied
transform (String)
Optional name of the specific transform to apply. This parameter is usually left null, which causes the patch to be searched for a transform that is valid to apply to this database.
Remarks
If the patch contains any binary file patches, they will not immediately be applied to the target files, though they will at installation time.

After calling this method you can use Consolidate(String) to apply the file patches immediately and also discard any outdated files from the package.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


CompressionLevel Property

CompressionLevel Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► CompressionLevel
Gets or sets the compression level used by UpdateFiles()()() and Consolidate(String).
Declaration Syntax
C# Visual Basic Visual C++
public CompressionLevel CompressionLevel { get; set; }
Public Property CompressionLevel As CompressionLevel
public:
property CompressionLevel CompressionLevel {
    CompressionLevel get ();
    void set (CompressionLevel value);
}
Remarks
If the Directory table is modified, this mapping will be outdated until you close and reopen the install package.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Consolidate Method (mediaCabinet)

Consolidate Method (mediaCabinet)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► Consolidate(String)
Consolidates a package by combining and re-compressing all files into a single internal or external cabinet.
Declaration Syntax
C# Visual Basic Visual C++
public void Consolidate(
    string mediaCabinet
)
Public Sub Consolidate ( _
    mediaCabinet As String _
)
public:
void Consolidate(
    String^ mediaCabinet
)
Parameters
mediaCabinet (String)
Remarks
If an installation package was built from many merge modules, this method can somewhat decrease package size, complexity, and installation time.

This method will also convert a package with all or mostly uncompressed files into a package where all files are compressed.

If the package contains any not-yet-applied binary file patches (for example, a package generated by a call to ApplyPatch(PatchPackage, String)) then this method will apply the patches before compressing the updated files.

This method edits the database summary information and the File, Media and Patch tables as necessary to maintain a valid installation package.

The cabinet compression level used during re-cabbing can be configured with the CompressionLevel property.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Directories Property

Directories Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► Directories
Gets a mapping from Directory keys to source/target paths.
Declaration Syntax
C# Visual Basic Visual C++
public InstallPathMap Directories { get; }
Public ReadOnly Property Directories As InstallPathMap
public:
property InstallPathMap^ Directories {
    InstallPathMap^ get ();
}
Remarks
If the Directory table is modified, this mapping will be outdated until you call UpdateDirectories()()().

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ExtractFiles Method

ExtractFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► ExtractFiles()()()
Members
Icon | Member | Description
 | ExtractFiles()()() | Extracts all files to the WorkingDirectory. The files are extracted to the relative directory matching their SourcePath.
 | ExtractFiles(ICollection<(Of <(String>)>)) | Extracts a specified list of files to the WorkingDirectory. The files are extracted to the relative directory matching their SourcePath.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ExtractFiles Method

ExtractFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► ExtractFiles()()()
Extracts all files to the WorkingDirectory. The files are extracted to the relative directory matching their SourcePath.
Declaration Syntax
C# Visual Basic Visual C++
public void ExtractFiles()
Public Sub ExtractFiles
public:
void ExtractFiles()
Remarks
If any files have the uncompressed attribute, they will be copied from the SourceDirectory.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ExtractFiles Method (fileKeys)

ExtractFiles Method (fileKeys)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► ExtractFiles(ICollection<(Of <(String>)>))
Extracts a specified list of files to the WorkingDirectory. The files are extracted to the relative directory matching their SourcePath.
Declaration Syntax
C# Visual Basic Visual C++
public void ExtractFiles(
    ICollection<string> fileKeys
)
Public Sub ExtractFiles ( _
    fileKeys As ICollection(Of String) _
)
public:
void ExtractFiles(
    ICollection<String^>^ fileKeys
)
Parameters
fileKeys (ICollection <(Of <( String >)>))
List of file key strings to extract
Remarks
If any files have the uncompressed attribute, they will be copied from the SourceDirectory.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Files Property

Files Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► Files
Gets a mapping from File keys to source/target paths.
Declaration Syntax
C# Visual Basic Visual C++
public InstallPathMap Files { get; }
Public ReadOnly Property Files As InstallPathMap
public:
property InstallPathMap^ Files {
    InstallPathMap^ get ();
}
Remarks
If the File, Component, or Directory tables are modified, this mapping may be outdated until you call UpdateDirectories()()().

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


FindFiles Method

FindFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► FindFiles()()()
Members
Icon | Member | Description
 | FindFiles(String) | Gets the list of file keys that have the specified long file name.
 | FindFiles(Regex) | Gets the list of file keys whose long file names match a specified regular-expression search pattern.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


FindFiles Method (longFileName)

FindFiles Method (longFileName)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► FindFiles(String)
Gets the list of file keys that have the specified long file name.
Declaration Syntax
C# Visual Basic Visual C++
public string[] FindFiles(
    string longFileName
)
Public Function FindFiles ( _
    longFileName As String _
) As String()
public:
array<String^>^ FindFiles(
    String^ longFileName
)
Parameters
longFileName (String)
File name to search for (case-insensitive)
Return Value
Array of file keys, or a 0-length array if none are found

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


FindFiles Method (pattern)

FindFiles Method (pattern)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► FindFiles(Regex)
Gets the list of file keys whose long file names match a specified regular-expression search pattern.
Declaration Syntax
C# Visual Basic Visual C++
public string[] FindFiles(
    Regex pattern
)
Public Function FindFiles ( _
    pattern As Regex _
) As String()
public:
array<String^>^ FindFiles(
    Regex^ pattern
)
Parameters
pattern (Regex)
Regular expression search pattern
Return Value
Array of file keys, or a 0-length array if none are found

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


LogMessage Method (format, args)

LogMessage Method (format, args)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► LogMessage(String, array<Object>[]()[])
Sends a message to the Message event-handler.
Declaration Syntax
C# Visual Basic Visual C++
protected void LogMessage(
    string format,
    params Object[] args
)
Protected Sub LogMessage ( _
    format As String, _
    ParamArray args As Object() _
)
protected:
void LogMessage(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format (String)
Message string, containing 0 or more format items
args (array< Object >[]()[])
Items to be formatted

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Message Event

Message Event
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► Message
Handle this event to receive status messages when operations are performed on the install package.
Declaration Syntax
C# Visual Basic Visual C++
public event InstallPackageMessageHandler Message
Public Event Message As InstallPackageMessageHandler
public:
 event InstallPackageMessageHandler^ Message {
    void add (InstallPackageMessageHandler^ value);
    void remove (InstallPackageMessageHandler^ value);
}
Examples
installPackage.Message += new InstallPackageMessageHandler(Console.WriteLine);

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Property Property

Property Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► Property
Accessor for getting and setting properties of the InstallPackage database.
Declaration Syntax
C# Visual Basic Visual C++
public InstallPackageProperties Property { get; }
Public ReadOnly Property Property As InstallPackageProperties
public:
property InstallPackageProperties^ Property {
    InstallPackageProperties^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


SourceDirectory Property

SourceDirectory Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► SourceDirectory
Gets or sets the location to obtain source files and cabinets when extracting or updating files in the working directory. This is often the location of an original copy of the package that is not meant to be modified.
Declaration Syntax
C# Visual Basic Visual C++
public string SourceDirectory { get; set; }
Public Property SourceDirectory As String
public:
property String^ SourceDirectory {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


UpdateDirectories Method

UpdateDirectories Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► UpdateDirectories()()()
Rebuilds the cached directory structure information accessed by the Directories and Files properties. This should be done after modifying the File, Component, or Directory tables, or else the cached information may no longer be accurate.
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateDirectories()
Public Sub UpdateDirectories
public:
void UpdateDirectories()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


UpdateFiles Method

UpdateFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► UpdateFiles()()()
Members
Icon | Member | Description
 | UpdateFiles()()() | Updates the install package with new files from the WorkingDirectory. The files must be in the relative directory matching their SourcePath. This method re-compresses and packages the files if necessary, and also updates the following data: File.FileSize, File.Version, File.Language, MsiFileHash.HashPart*
 | UpdateFiles(ICollection<(Of <(String>)>)) | Updates the install package with new files from the WorkingDirectory. The files must be in the relative directory matching their SourcePath. This method re-compresses and packages the files if necessary, and also updates the following data: File.FileSize, File.Version, File.Language, MsiFileHash.HashPart?.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


UpdateFiles Method

UpdateFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► UpdateFiles()()()
Updates the install package with new files from the WorkingDirectory. The files must be in the relative directory matching their SourcePath. This method re-compresses and packages the files if necessary, and also updates the following data: File.FileSize, File.Version, File.Language, MsiFileHash.HashPart*
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateFiles()
Public Sub UpdateFiles
public:
void UpdateFiles()
Remarks
The cabinet compression level used during re-cabbing can be configured with the CompressionLevel property.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


UpdateFiles Method (fileKeys)

UpdateFiles Method (fileKeys)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► UpdateFiles(ICollection<(Of <(String>)>))
Updates the install package with new files from the WorkingDirectory. The files must be in the relative directory matching their SourcePath. This method re-compresses and packages the files if necessary, and also updates the following data: File.FileSize, File.Version, File.Language, MsiFileHash.HashPart?.
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateFiles(
    ICollection<string> fileKeys
)
Public Sub UpdateFiles ( _
    fileKeys As ICollection(Of String) _
)
public:
void UpdateFiles(
    ICollection<String^>^ fileKeys
)
Parameters
fileKeys (ICollection <(Of <( String >)>))
List of file key strings to update
Remarks
This method does not change the media structure of the package, so it may require extracting and re-compressing a large cabinet just to update one file.

The cabinet compression level used during re-cabbing can be configured with the CompressionLevel property.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


WorkingDirectory Property

WorkingDirectory Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► WorkingDirectory
Gets or sets the location where files will be extracted to/updated from. Also the location where a temporary folder is created during some operations.
Declaration Syntax
C# Visual Basic Visual C++
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


InstallPackageMessageHandler Delegate

InstallPackageMessageHandler Delegate
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackageMessageHandler
Handles status messages generated when operations are performed on an InstallPackage or PatchPackage.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void InstallPackageMessageHandler(
    string format,
    params Object[] args
)
Public Delegate Sub InstallPackageMessageHandler ( _
    format As String, _
    ParamArray args As Object() _
)
public delegate void InstallPackageMessageHandler(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format (String)
args (array< Object >[]()[])
Examples
installPackage.Message += new InstallPackageMessageHandler(Console.WriteLine);

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


InstallPackageProperties Class

InstallPackageProperties Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackageProperties
Accessor for getting and setting properties of the InstallPackage database.
Declaration Syntax
C# Visual Basic Visual C++
public class InstallPackageProperties
Public Class InstallPackageProperties
public ref class InstallPackageProperties
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets or sets a property in the database. When getting a property that does not exist in the database, an empty string is returned. To remove a property from the database, set it to an empty string.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstallPackageProperties

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Item Property (name)

Item Property (name)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackageProperties ► Item[([(String])])
Gets or sets a property in the database. When getting a property that does not exist in the database, an empty string is returned. To remove a property from the database, set it to an empty string.
Declaration Syntax
C# Visual Basic Visual C++
public string this[
    string name
] { get; set; }
Public Default Property Item ( _
    name As String _
) As String
public:
property String^ default[String^ name] {
    String^ get (String^ name);
    void set (String^ name, String^ value);
}
Parameters
name (String)
Remarks
This has the same results as direct SQL queries on the Property table; it's only meant to be a more convenient way of access.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


InstallPath Class

InstallPath Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPath
Represents the installation path of a file or directory from an installer product database.
Declaration Syntax
C# Visual Basic Visual C++
public class InstallPath
Public Class InstallPath
public ref class InstallPath
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstallPath(String) | Creates a new InstallPath, specifying a filename.
 | InstallPath(String, Boolean) | Creates a new InstallPath, parsing out either the short or long filename.
 | ChildPaths | Gets the set of child paths if this InstallPath object represents a a directory.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentPath | Gets the path of the parent directory.
 | SourceName | Gets or sets the source name of the InstallPath.
 | SourcePath | Gets the full source path.
 | TargetName | Gets or sets the target name of the install path.
 | TargetPath | Gets the full target path.
 | ToString()()() | Gets the full source path. (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
InstallPath

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


InstallPath Constructor

InstallPath Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPath ► InstallPath()()()
Members
Icon | Member | Description
 | InstallPath(String) | Creates a new InstallPath, specifying a filename.
 | InstallPath(String, Boolean) | Creates a new InstallPath, parsing out either the short or long filename.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


InstallPath Constructor (name)

InstallPath Constructor (name)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPath ► InstallPath(String)
Creates a new InstallPath, specifying a filename.
Declaration Syntax
C# Visual Basic Visual C++
public InstallPath(
    string name
)
Public Sub New ( _
    name As String _
)
public:
InstallPath(
    String^ name
)
Parameters
name (String)
The name of the file or directory. Not a full path.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


InstallPath Constructor (name, useShortNames)

InstallPath Constructor (name, useShortNames)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPath ► InstallPath(String, Boolean)
Creates a new InstallPath, parsing out either the short or long filename.
Declaration Syntax
C# Visual Basic Visual C++
public InstallPath(
    string name,
    bool useShortNames
)
Public Sub New ( _
    name As String, _
    useShortNames As Boolean _
)
public:
InstallPath(
    String^ name,
    bool useShortNames
)
Parameters
name (String)
The name of the file or directory, in short|long syntax for a filename or targetshort|targetlong:sourceshort|sourcelong syntax for a directory.
useShortNames (Boolean)
true to parse the short part of the combined filename; false to parse the long part

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ChildPaths Property

ChildPaths Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPath ► ChildPaths
Gets the set of child paths if this InstallPath object represents a a directory.
Declaration Syntax
C# Visual Basic Visual C++
public InstallPathCollection ChildPaths { get; }
Public ReadOnly Property ChildPaths As InstallPathCollection
public:
property InstallPathCollection^ ChildPaths {
    InstallPathCollection^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ParentPath Property

ParentPath Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPath ► ParentPath
Gets the path of the parent directory.
Declaration Syntax
C# Visual Basic Visual C++
public InstallPath ParentPath { get; }
Public ReadOnly Property ParentPath As InstallPath
public:
property InstallPath^ ParentPath {
    InstallPath^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


SourceName Property

SourceName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPath ► SourceName
Gets or sets the source name of the InstallPath.
Declaration Syntax
C# Visual Basic Visual C++
public string SourceName { get; set; }
Public Property SourceName As String
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


SourcePath Property

SourcePath Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPath ► SourcePath
Gets the full source path.
Declaration Syntax
C# Visual Basic Visual C++
public string SourcePath { get; set; }
Public Property SourcePath As String
public:
property String^ SourcePath {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


TargetName Property

TargetName Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPath ► TargetName
Gets or sets the target name of the install path.
Declaration Syntax
C# Visual Basic Visual C++
public string TargetName { get; set; }
Public Property TargetName As String
public:
property String^ TargetName {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


TargetPath Property

TargetPath Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPath ► TargetPath
Gets the full target path.
Declaration Syntax
C# Visual Basic Visual C++
public string TargetPath { get; set; }
Public Property TargetPath As String
public:
property String^ TargetPath {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ToString Method

ToString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPath ► ToString()()()
Gets the full source path.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
SourcePath

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


InstallPathCollection Class

InstallPathCollection Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathCollection
Represents a collection of InstallPaths that are the child paths of the same parent directory.
Declaration Syntax
C# Visual Basic Visual C++
public class InstallPathCollection : IList<InstallPath>,
    ICollection<InstallPath>, IEnumerable<InstallPath>, IEnumerable
Public Class InstallPathCollection _
    Implements IList(Of InstallPath), ICollection(Of InstallPath),  _
    IEnumerable(Of InstallPath), IEnumerable
public ref class InstallPathCollection : IList<InstallPath^>,
    ICollection<InstallPath^>, IEnumerable<InstallPath^>, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(InstallPath) | Adds a new child path to the collection.
 | Clear()()() | Removes all items from the collection.
 | Contains(InstallPath) | Tests if the collection contains a child path.
 | CopyTo(array<InstallPath>[]()[], Int32) | Copies the collection into an array.
 | Count | Gets the number of items in the collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Gets an enumerator over all items in the collection.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(InstallPath) | Gets the index of a child path in the collection.
 | Insert(Int32, InstallPath) | Inserts a child path into the collection.
 | Item[([(Int32])]) | Gets or sets the element at the specified index.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(InstallPath) | Removes a child path to the collection.
 | RemoveAt(Int32) | Removes an item from the collection.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstallPathCollection

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Add Method (item)

Add Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathCollection ► Add(InstallPath)
Adds a new child path to the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    InstallPath item
)
Public Sub Add ( _
    item As InstallPath _
)
public:
virtual void Add(
    InstallPath^ item
) sealed
Parameters
item (InstallPath)
The InstallPath to add.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Clear Method

Clear Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathCollection ► Clear()()()
Removes all items from the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Contains Method (item)

Contains Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathCollection ► Contains(InstallPath)
Tests if the collection contains a child path.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    InstallPath item
)
Public Function Contains ( _
    item As InstallPath _
) As Boolean
public:
virtual bool Contains(
    InstallPath^ item
) sealed
Parameters
item (InstallPath)
The InstallPath to search for.
Return Value
true if the item is found; false otherwise

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method (array, index)

CopyTo Method (array, index)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathCollection ► CopyTo(array<InstallPath>[]()[], Int32)
Copies the collection into an array.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    InstallPath[] array,
    int index
)
Public Sub CopyTo ( _
    array As InstallPath(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<InstallPath^>^ array,
    int index
) sealed
Parameters
array (array< InstallPath >[]()[])
The array to copy into.
index (Int32)
The starting index in the destination array.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Count Property

Count Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathCollection ► Count
Gets the number of items in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathCollection ► GetEnumerator()()()
Gets an enumerator over all items in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<InstallPath> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of InstallPath)
public:
virtual IEnumerator<InstallPath^>^ GetEnumerator() sealed
Return Value
An enumerator for the collection.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


IndexOf Method (item)

IndexOf Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathCollection ► IndexOf(InstallPath)
Gets the index of a child path in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    InstallPath item
)
Public Function IndexOf ( _
    item As InstallPath _
) As Integer
public:
virtual int IndexOf(
    InstallPath^ item
) sealed
Parameters
item (InstallPath)
The InstallPath to search for.
Return Value
The index of the item, or -1 if not found.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Insert Method (index, item)

Insert Method (index, item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathCollection ► Insert(Int32, InstallPath)
Inserts a child path into the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    InstallPath item
)
Public Sub Insert ( _
    index As Integer, _
    item As InstallPath _
)
public:
virtual void Insert(
    int index,
    InstallPath^ item
) sealed
Parameters
index (Int32)
The insertion index.
item (InstallPath)
The InstallPath to insert.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Item Property (index)

Item Property (index)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathCollection ► Item[([(Int32])])
Gets or sets the element at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
public InstallPath this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As InstallPath
public:
virtual property InstallPath^ default[int index] {
    InstallPath^ get (int index) sealed;
    void set (int index, InstallPath^ value) sealed;
}
Parameters
index (Int32)

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Remove Method (item)

Remove Method (item)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathCollection ► Remove(InstallPath)
Removes a child path to the collection.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    InstallPath item
)
Public Function Remove ( _
    item As InstallPath _
) As Boolean
public:
virtual bool Remove(
    InstallPath^ item
) sealed
Parameters
item (InstallPath)
The InstallPath to remove.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


RemoveAt Method (index)

RemoveAt Method (index)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathCollection ► RemoveAt(Int32)
Removes an item from the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt(
    int index
) sealed
Parameters
index (Int32)
The index of the item to remove.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


InstallPathMap Class

InstallPathMap Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap
Represents a mapping of install paths for all directories, components, or files in an installation database.
Declaration Syntax
C# Visual Basic Visual C++
public class InstallPathMap : IDictionary<string, InstallPath>,
    ICollection<KeyValuePair<string, InstallPath>>, IEnumerable<KeyValuePair<string, InstallPath>>,
    IEnumerable
Public Class InstallPathMap _
    Implements IDictionary(Of String, InstallPath),  _
    ICollection(Of KeyValuePair(Of String, InstallPath)), IEnumerable(Of KeyValuePair(Of String, InstallPath)),  _
    IEnumerable
public ref class InstallPathMap : IDictionary<String^, InstallPath^>,
    ICollection<KeyValuePair<String^, InstallPath^>>, IEnumerable<KeyValuePair<String^, InstallPath^>>,
    IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstallPathMap()()() | Creates a new empty InstallPathMap.
 | Add(String, InstallPath) | Sets an install path for a direcotry, component, or file key.
 | BuildComponentPathMap(Database, InstallPathMap) | Builds a mapping from Component keys to installation paths.
 | BuildDirectoryPathMap(Database, Boolean) | Builds a mapping from Directory keys to installation paths.
 | BuildDirectoryPathMap(Database, Boolean, String, String) | Builds a mapping of Directory keys to directory paths, specifying root directories for the source and target paths.
 | BuildFilePathMap(Database, InstallPathMap, Boolean) | Builds a mapping from File keys to installation paths.
 | Clear()()() | Removes all entries from the dictionary.
 | ContainsKey(String) | Tests whether a direcotry, component, or file key exists in the map.
 | Count | Gets the number of entries in the dictionary.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Gets an enumerator over all entries in the dictionary.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(String])]) | Gets or sets an install path for a direcotry, component, or file key.
 | Keys | Gets the collection of keys in the InstallPathMap. Depending on the type of InstallPathMap, they are all directory, component, or file key strings.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Removes an install path from the map.
 | SourcePaths | Gets a mapping from keys to source paths.
 | TargetPaths | Gets a mapping from keys to target paths.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetValue(String, InstallPath%) | Attempts to get a value from the dictionary.
 | Values | Gets the collection of InstallPath values in the InstallPathMap.
Inheritance Hierarchy
Object
InstallPathMap

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


InstallPathMap Constructor

InstallPathMap Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► InstallPathMap()()()
Creates a new empty InstallPathMap.
Declaration Syntax
C# Visual Basic Visual C++
public InstallPathMap()
Public Sub New
public:
InstallPathMap()

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Add Method (key, installPath)

Add Method (key, installPath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► Add(String, InstallPath)
Sets an install path for a direcotry, component, or file key.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string key,
    InstallPath installPath
)
Public Sub Add ( _
    key As String, _
    installPath As InstallPath _
)
public:
virtual void Add(
    String^ key,
    InstallPath^ installPath
) sealed
Parameters
key (String)
Depending on the type of InstallPathMap, this is the primary key from the either the Directory, Component, or File table.
installPath (InstallPath)
The install path of the key item.
Remarks
Changing an install path does not modify the Database used to generate this InstallPathMap.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


BuildComponentPathMap Method (db, directoryPathMap)

BuildComponentPathMap Method (db, directoryPathMap)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► BuildComponentPathMap(Database, InstallPathMap)
Builds a mapping from Component keys to installation paths.
Declaration Syntax
C# Visual Basic Visual C++
public static InstallPathMap BuildComponentPathMap(
    Database db,
    InstallPathMap directoryPathMap
)
Public Shared Function BuildComponentPathMap ( _
    db As Database, _
    directoryPathMap As InstallPathMap _
) As InstallPathMap
public:
static InstallPathMap^ BuildComponentPathMap(
    Database^ db,
    InstallPathMap^ directoryPathMap
)
Parameters
db (Database)
Installation database.
directoryPathMap (InstallPathMap)
Directory mapping returned by BuildDirectoryPathMap(Database, Boolean).
Return Value
An InstallPathMap with the described mapping.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


BuildDirectoryPathMap Method

BuildDirectoryPathMap Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► BuildDirectoryPathMap()()()
Members
Icon | Member | Description
 | BuildDirectoryPathMap(Database, Boolean) | Builds a mapping from Directory keys to installation paths.
 | BuildDirectoryPathMap(Database, Boolean, String, String) | Builds a mapping of Directory keys to directory paths, specifying root directories for the source and target paths.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


BuildDirectoryPathMap Method (db, useShortNames)

BuildDirectoryPathMap Method (db, useShortNames)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► BuildDirectoryPathMap(Database, Boolean)
Builds a mapping from Directory keys to installation paths.
Declaration Syntax
C# Visual Basic Visual C++
public static InstallPathMap BuildDirectoryPathMap(
    Database db,
    bool useShortNames
)
Public Shared Function BuildDirectoryPathMap ( _
    db As Database, _
    useShortNames As Boolean _
) As InstallPathMap
public:
static InstallPathMap^ BuildDirectoryPathMap(
    Database^ db,
    bool useShortNames
)
Parameters
db (Database)
Installation database.
useShortNames (Boolean)
true to use short directory names; false to use long names
Return Value
An InstallPathMap with the described mapping.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


BuildDirectoryPathMap Method (db, useShortNames, sourceRootDir, targetRootDir)

BuildDirectoryPathMap Method (db, useShortNames, sourceRootDir, targetRootDir)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► BuildDirectoryPathMap(Database, Boolean, String, String)
Builds a mapping of Directory keys to directory paths, specifying root directories for the source and target paths.
Declaration Syntax
C# Visual Basic Visual C++
public static InstallPathMap BuildDirectoryPathMap(
    Database db,
    bool useShortNames,
    string sourceRootDir,
    string targetRootDir
)
Public Shared Function BuildDirectoryPathMap ( _
    db As Database, _
    useShortNames As Boolean, _
    sourceRootDir As String, _
    targetRootDir As String _
) As InstallPathMap
public:
static InstallPathMap^ BuildDirectoryPathMap(
    Database^ db,
    bool useShortNames,
    String^ sourceRootDir,
    String^ targetRootDir
)
Parameters
db (Database)
Database containing the Directory table.
useShortNames (Boolean)
true to use short directory names; false to use long names
sourceRootDir (String)
The root directory path of all source paths, or null to leave them relative.
targetRootDir (String)
The root directory path of all source paths, or null to leave them relative.
Return Value
An InstallPathMap with the described mapping.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


BuildFilePathMap Method (db, componentPathMap, useShortNames)

BuildFilePathMap Method (db, componentPathMap, useShortNames)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► BuildFilePathMap(Database, InstallPathMap, Boolean)
Builds a mapping from File keys to installation paths.
Declaration Syntax
C# Visual Basic Visual C++
public static InstallPathMap BuildFilePathMap(
    Database db,
    InstallPathMap componentPathMap,
    bool useShortNames
)
Public Shared Function BuildFilePathMap ( _
    db As Database, _
    componentPathMap As InstallPathMap, _
    useShortNames As Boolean _
) As InstallPathMap
public:
static InstallPathMap^ BuildFilePathMap(
    Database^ db,
    InstallPathMap^ componentPathMap,
    bool useShortNames
)
Parameters
db (Database)
Installation database.
componentPathMap (InstallPathMap)
Component mapping returned by BuildComponentPathMap(Database, InstallPathMap).
useShortNames (Boolean)
true to use short file names; false to use long names
Return Value
An InstallPathMap with the described mapping.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Clear Method

Clear Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► Clear()()()
Removes all entries from the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ContainsKey Method (key)

ContainsKey Method (key)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► ContainsKey(String)
Tests whether a direcotry, component, or file key exists in the map.
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsKey(
    string key
)
Public Function ContainsKey ( _
    key As String _
) As Boolean
public:
virtual bool ContainsKey(
    String^ key
) sealed
Parameters
key (String)
Depending on the type of InstallPathMap, this is the primary key from the either the Directory, Component, or File table.
Return Value
true if the key is found; false otherwise

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Count Property

Count Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► Count
Gets the number of entries in the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


GetEnumerator Method

GetEnumerator Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► GetEnumerator()()()
Gets an enumerator over all entries in the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<KeyValuePair<string, InstallPath>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, InstallPath))
public:
virtual IEnumerator<KeyValuePair<String^, InstallPath^>>^ GetEnumerator() sealed
Return Value
An enumerator for the dictionary.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Item Property (key)

Item Property (key)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► Item[([(String])])
Gets or sets an install path for a direcotry, component, or file key.
Declaration Syntax
C# Visual Basic Visual C++
public InstallPath this[
    string key
] { get; set; }
Public Default Property Item ( _
    key As String _
) As InstallPath
public:
virtual property InstallPath^ default[String^ key] {
    InstallPath^ get (String^ key) sealed;
    void set (String^ key, InstallPath^ value) sealed;
}
Parameters
key (String)
Depending on the type of InstallPathMap, this is the primary key from the either the Directory, Component, or File table.
Remarks
Changing an install path does not modify the Database used to generate this InstallPathMap.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Keys Property

Keys Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► Keys
Gets the collection of keys in the InstallPathMap. Depending on the type of InstallPathMap, they are all directory, component, or file key strings.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<string> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of String)
public:
virtual property ICollection<String^>^ Keys {
    ICollection<String^>^ get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Remove Method (key)

Remove Method (key)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► Remove(String)
Removes an install path from the map.
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string key
)
Public Function Remove ( _
    key As String _
) As Boolean
public:
virtual bool Remove(
    String^ key
) sealed
Parameters
key (String)
Depending on the type of InstallPathMap, this is the primary key from the either the Directory, Component, or File table.
Return Value
true if the item was removed, false if it did not exist
Remarks
Changing an install path does not modify the Database used to generate this InstallPathMap.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


SourcePaths Property

SourcePaths Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► SourcePaths
Gets a mapping from keys to source paths.
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<string, string> SourcePaths { get; }
Public ReadOnly Property SourcePaths As IDictionary(Of String, String)
public:
property IDictionary<String^, String^>^ SourcePaths {
    IDictionary<String^, String^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


TargetPaths Property

TargetPaths Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► TargetPaths
Gets a mapping from keys to target paths.
Declaration Syntax
C# Visual Basic Visual C++
public IDictionary<string, string> TargetPaths { get; }
Public ReadOnly Property TargetPaths As IDictionary(Of String, String)
public:
property IDictionary<String^, String^>^ TargetPaths {
    IDictionary<String^, String^>^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


TryGetValue Method (key, value)

TryGetValue Method (key, value)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► TryGetValue(String, InstallPath%)
Attempts to get a value from the dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public bool TryGetValue(
    string key,
    out InstallPath value
)
Public Function TryGetValue ( _
    key As String, _
    <OutAttribute> ByRef value As InstallPath _
) As Boolean
public:
virtual bool TryGetValue(
    String^ key,
    [OutAttribute] InstallPath^% value
) sealed
Parameters
key (String)
The key to lookup.
value ( InstallPath %)
Receives the value, or null if they key was not found.
Return Value
True if the value was found, else false.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Values Property

Values Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPathMap ► Values
Gets the collection of InstallPath values in the InstallPathMap.
Declaration Syntax
C# Visual Basic Visual C++
public ICollection<InstallPath> Values { get; }
Public ReadOnly Property Values As ICollection(Of InstallPath)
public:
virtual property ICollection<InstallPath^>^ Values {
    ICollection<InstallPath^>^ get () sealed;
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


PatchPackage Class

PatchPackage Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage
Provides access to convenient properties and operations on a patch package (.MSP).
Declaration Syntax
C# Visual Basic Visual C++
public class PatchPackage : Database
Public Class PatchPackage _
    Inherits Database
public ref class PatchPackage : public Database
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PatchPackage(String) | Creates a new patch package object; opening the patch database in read-only mode.
 | ApplyTransform(String) | Apply a transform to the database, suppressing any error conditions specified by the transform's summary information. (Inherited from Database.)
 | ApplyTransform(String, TransformErrors) | Apply a transform to the database, specifying error conditions to suppress. (Inherited from Database.)
 | Close()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | CodePage | Gets or sets the code page of the Database. (Inherited from Database.)
 | Commit()()() | Finalizes the persistent form of the database. All persistent data is written to the writeable database, and no temporary columns or rows are written. (Inherited from Database.)
 | CountRows(String) | Gets the count of all rows in the table. (Inherited from Database.)
 | CountRows(String, String) | Gets the count of all rows in the table that satisfy a given condition. (Inherited from Database.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateRecord(Int32) | Creates a new record object with the requested number of fields. (Inherited from Database.)
 | CreateTransformSummaryInfo(Database, String, TransformErrors, TransformValidations) | Creates and populates the summary information stream of an existing transform file, and fills in the properties with the base and reference ProductCode and ProductVersion. (Inherited from Database.)
 | DeleteOnClose(String) | Schedules a file or directory for deletion after the database handle is closed. (Inherited from Database.)
 | Dispose(Boolean) | Closes the database handle. After closing a handle, further method calls may throw InvalidHandleException. (Inherited from Database.)
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | Equals(Object) | Tests whether this handle object is equal to another handle object. Two handle objects are equal if their types are the same and their native integer handles are the same. (Inherited from InstallerHandle.)
 | Execute(String, array<Object>[]()[]) | Executes the query specified by a SQL string. The query may not be a SELECT statement. (Inherited from Database.)
 | Execute(String, Record) | Executes the query specified by a SQL string. The query may not be a SELECT statement. (Inherited from Database.)
 | ExecuteIntegerQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as integers. (Inherited from Database.)
 | ExecuteIntegerQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as integers. (Inherited from Database.)
 | ExecuteQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results. (Inherited from Database.)
 | ExecuteQuery(String, Record) | Executes the specified SQL SELECT query and returns all results. (Inherited from Database.)
 | ExecuteScalar(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns a single result. (Inherited from Database.)
 | ExecuteScalar(String, Record) | Executes the specified SQL SELECT query and returns a single result. (Inherited from Database.)
 | ExecuteStringQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as strings. (Inherited from Database.)
 | ExecuteStringQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as strings. (Inherited from Database.)
 | Export(String, String) | Copies the structure and data from a specified table to a text archive file. (Inherited from Database.)
 | ExportAll(String) | Exports all database tables, streams, and summary information to archive files. (Inherited from Database.)
 | ExtractTransform(String, String) | Extracts a transform (.MST) from a patch package.
 | FilePath | Gets the file path the Database was originally opened from, or null if not known. (Inherited from Database.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateTransform(Database, String) | Creates a transform that, when applied to the object database, results in the reference database. (Inherited from Database.)
 | GetHashCode()()() | Gets a hash value for the handle object. (Inherited from InstallerHandle.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetReplacedPatchCodes()()() | Gets the list of patch codes that are replaced by this patch package.
 | GetTargetProductCodes()()() | Gets the list of product codes of products targeted by this patch package.
 | GetTransformInfo(String) | Gets information about a transforms included in the patch package.
 | GetTransforms()()() | Gets the names of the transforms included in the patch package.
 | GetTransforms(Boolean) | Gets the names of the transforms included in the patch package.
 | GetTransformsInfo()()() | Gets information about the transforms included in the patch package.
 | GetTransformsInfo(Boolean) | Gets information about the transforms included in the patch package.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValidTransforms(InstallPackage) | Analyzes the transforms included in the patch package to find the ones that are applicable to an install package.
 | Handle | Gets the native integer handle. (Inherited from InstallerHandle.)
 | Import(String) | Imports a database table from a text archive file, dropping any existing table. (Inherited from Database.)
 | ImportAll(String) | Imports all database tables, streams, and summary information from archive files. (Inherited from Database.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsClosed | Checks if the handle is closed. When closed, method calls on the handle object may throw an InvalidHandleException. (Inherited from InstallerHandle.)
 | IsColumnPersistent(String, String) | Checks whether a table contains a persistent column with a given name. (Inherited from Database.)
 | IsReadOnly | Gets a boolean value indicating whether this database was opened in read-only mode. (Inherited from Database.)
 | IsTablePersistent(String) | Checks whether a table exists and is persistent in the database. (Inherited from Database.)
 | IsTransformValid(String) | Checks whether a transform is valid for this Database, according to its validation data and flags. (Inherited from Database.)
 | IsTransformValid(SummaryInfo) | Checks whether a transform is valid for this Database, according to its SummaryInfo data. (Inherited from Database.)
 | LogMessage(String, array<Object>[]()[]) | Sends a message to the Message event-handler.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(Database, String) | Merges another database with this database. (Inherited from Database.)
 | Merge(Database) | Merges another database with this database. (Inherited from Database.)
 | Message | Handle this event to receive status messages when operations are performed on the patch package.
 | OpenMode | Gets the open mode for the database. (Inherited from Database.)
 | OpenView(String, array<Object>[]()[]) | Gets a View object representing the query specified by a SQL string. (Inherited from Database.)
 | PatchCode | Gets the patch code (GUID) of the patch package.
 | SummaryInfo | Gets the SummaryInfo object for this database that can be used to examine and modify properties to the summary information stream. (Inherited from Database.)
 | Tables | Gets the collection of tables in the Database. (Inherited from Database.)
 | ToString()()() | Returns the file path of this database, or the handle value if a file path was not specified. (Inherited from Database.)
 | ViewTransform(String) | Apply a transform to the database, recording the changes in the "_TransformView" table. (Inherited from Database.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | InstallerHandle
 |  |  | Database
 |  |  |  | PatchPackage

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


PatchPackage Constructor (packagePath)

PatchPackage Constructor (packagePath)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► PatchPackage(String)
Creates a new patch package object; opening the patch database in read-only mode.
Declaration Syntax
C# Visual Basic Visual C++
public PatchPackage(
    string packagePath
)
Public Sub New ( _
    packagePath As String _
)
public:
PatchPackage(
    String^ packagePath
)
Parameters
packagePath (String)
Path to the patch package (.MSP)
Remarks
The PatchPackage object only opens the patch database in read-only mode, because transforms (sub-storages) cannot be read if the database is open in read-write mode.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ExtractTransform Method (transform, extractFile)

ExtractTransform Method (transform, extractFile)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► ExtractTransform(String, String)
Extracts a transform (.MST) from a patch package.
Declaration Syntax
C# Visual Basic Visual C++
public void ExtractTransform(
    string transform,
    string extractFile
)
Public Sub ExtractTransform ( _
    transform As String, _
    extractFile As String _
)
public:
void ExtractTransform(
    String^ transform,
    String^ extractFile
)
Parameters
transform (String)
Name of the transform to extract; this may optionally be a special transform prefixed by "#"
extractFile (String)
Location where the transform will be extracted

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


GetReplacedPatchCodes Method

GetReplacedPatchCodes Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► GetReplacedPatchCodes()()()
Gets the list of patch codes that are replaced by this patch package.
Declaration Syntax
C# Visual Basic Visual C++
public string[] GetReplacedPatchCodes()
Public Function GetReplacedPatchCodes As String()
public:
array<String^>^ GetReplacedPatchCodes()
Return Value
Array of replaced patch codes (GUIDs)
Remarks
The list of replaced patch codes is stored in the RevisionNumber field of the patch summary information.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


GetTargetProductCodes Method

GetTargetProductCodes Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► GetTargetProductCodes()()()
Gets the list of product codes of products targeted by this patch package.
Declaration Syntax
C# Visual Basic Visual C++
public string[] GetTargetProductCodes()
Public Function GetTargetProductCodes As String()
public:
array<String^>^ GetTargetProductCodes()
Return Value
Array of product codes (GUIDs)
Remarks
The list of target product codes is stored in the Template field of the patch summary information.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


GetTransformInfo Method (transform)

GetTransformInfo Method (transform)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► GetTransformInfo(String)
Gets information about a transforms included in the patch package.
Declaration Syntax
C# Visual Basic Visual C++
public TransformInfo GetTransformInfo(
    string transform
)
Public Function GetTransformInfo ( _
    transform As String _
) As TransformInfo
public:
TransformInfo^ GetTransformInfo(
    String^ transform
)
Parameters
transform (String)
Name of the transform to extract; this may optionally be a special transform prefixed by "#"
Return Value
Information about the transform

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


GetTransforms Method

GetTransforms Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► GetTransforms()()()
Members
Icon | Member | Description
 | GetTransforms()()() | Gets the names of the transforms included in the patch package.
 | GetTransforms(Boolean) | Gets the names of the transforms included in the patch package.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


GetTransforms Method

GetTransforms Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► GetTransforms()()()
Gets the names of the transforms included in the patch package.
Declaration Syntax
C# Visual Basic Visual C++
public string[] GetTransforms()
Public Function GetTransforms As String()
public:
array<String^>^ GetTransforms()
Return Value
Array of transform names
Remarks
The returned list does not include the "patch special transforms" that are prefixed with "#"

The list of transform names is stored in the LastSavedBy field of the patch summary information.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


GetTransforms Method (includeSpecialTransforms)

GetTransforms Method (includeSpecialTransforms)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► GetTransforms(Boolean)
Gets the names of the transforms included in the patch package.
Declaration Syntax
C# Visual Basic Visual C++
public string[] GetTransforms(
    bool includeSpecialTransforms
)
Public Function GetTransforms ( _
    includeSpecialTransforms As Boolean _
) As String()
public:
array<String^>^ GetTransforms(
    bool includeSpecialTransforms
)
Parameters
includeSpecialTransforms (Boolean)
Specifies whether to include the "patch special transforms" that are prefixed with "#"
Return Value
Array of transform names
Remarks
The list of transform names is stored in the LastSavedBy field of the patch summary information.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


GetTransformsInfo Method

GetTransformsInfo Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► GetTransformsInfo()()()
Members
Icon | Member | Description
 | GetTransformsInfo()()() | Gets information about the transforms included in the patch package.
 | GetTransformsInfo(Boolean) | Gets information about the transforms included in the patch package.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


GetTransformsInfo Method

GetTransformsInfo Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► GetTransformsInfo()()()
Gets information about the transforms included in the patch package.
Declaration Syntax
C# Visual Basic Visual C++
public TransformInfo[] GetTransformsInfo()
Public Function GetTransformsInfo As TransformInfo()
public:
array<TransformInfo^>^ GetTransformsInfo()
Return Value
Array containing information about each transform
Remarks
The returned info does not include the "patch special transforms" that are prefixed with "#"

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


GetTransformsInfo Method (includeSpecialTransforms)

GetTransformsInfo Method (includeSpecialTransforms)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► GetTransformsInfo(Boolean)
Gets information about the transforms included in the patch package.
Declaration Syntax
C# Visual Basic Visual C++
public TransformInfo[] GetTransformsInfo(
    bool includeSpecialTransforms
)
Public Function GetTransformsInfo ( _
    includeSpecialTransforms As Boolean _
) As TransformInfo()
public:
array<TransformInfo^>^ GetTransformsInfo(
    bool includeSpecialTransforms
)
Parameters
includeSpecialTransforms (Boolean)
Specifies whether to include the "patch special transforms" that are prefixed with "#"
Return Value
Array containing information about each transform

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


GetValidTransforms Method (installPackage)

GetValidTransforms Method (installPackage)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► GetValidTransforms(InstallPackage)
Analyzes the transforms included in the patch package to find the ones that are applicable to an install package.
Declaration Syntax
C# Visual Basic Visual C++
public string[] GetValidTransforms(
    InstallPackage installPackage
)
Public Function GetValidTransforms ( _
    installPackage As InstallPackage _
) As String()
public:
array<String^>^ GetValidTransforms(
    InstallPackage^ installPackage
)
Parameters
installPackage (InstallPackage)
The install package to validate the transforms against
Return Value
Array of valid transform names
Remarks
The returned list does not include the "patch special transforms" that are prefixed with "#" If a transform is valid, then its corresponding special transform is assumed to be valid as well.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


LogMessage Method (format, args)

LogMessage Method (format, args)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► LogMessage(String, array<Object>[]()[])
Sends a message to the Message event-handler.
Declaration Syntax
C# Visual Basic Visual C++
protected void LogMessage(
    string format,
    params Object[] args
)
Protected Sub LogMessage ( _
    format As String, _
    ParamArray args As Object() _
)
protected:
void LogMessage(
    String^ format,
    ... array<Object^>^ args
)
Parameters
format (String)
Message string, containing 0 or more format items
args (array< Object >[]()[])
Items to be formatted

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Message Event

Message Event
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► Message
Handle this event to receive status messages when operations are performed on the patch package.
Declaration Syntax
C# Visual Basic Visual C++
public event InstallPackageMessageHandler Message
Public Event Message As InstallPackageMessageHandler
public:
 event InstallPackageMessageHandler^ Message {
    void add (InstallPackageMessageHandler^ value);
    void remove (InstallPackageMessageHandler^ value);
}
Examples
patchPackage.Message += new InstallPackageMessageHandler(Console.WriteLine);

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


PatchCode Property

PatchCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► PatchCode
Gets the patch code (GUID) of the patch package.
Declaration Syntax
C# Visual Basic Visual C++
public string PatchCode { get; }
Public ReadOnly Property PatchCode As String
public:
property String^ PatchCode {
    String^ get ();
}
Remarks
The patch code is stored in the RevisionNumber field of the patch summary information.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


TransformInfo Class

TransformInfo Class
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo
Contains properties of a transform package (.MST).
Declaration Syntax
C# Visual Basic Visual C++
public class TransformInfo
Public Class TransformInfo
public ref class TransformInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TransformInfo(String) | Reads transform information from a transform package.
 | TransformInfo(String, SummaryInfo) | Reads transform information from the summary information of a transform package.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets the filename of the transform.
 | TargetLanguage | Gets the target language of the transform, or 0 if the transform is language-neutral.
 | TargetPlatform | Gets the target platform of the transform.
 | TargetProductCode | Gets the target product code of the transform.
 | TargetProductVersion | Gets the target product version of the transform.
 | ToString()()() | Returns the name of the transform. (Overrides Object.ToString()()().)
 | UpgradeCode | Gets the upgrade code of the transform.
 | UpgradeProductCode | Gets the upgrade product code of the transform.
 | UpgradeProductVersion | Gets the upgrade product version of the transform.
 | Validations | Gets the validation flags specified when the transform was generated.
Inheritance Hierarchy
Object
TransformInfo

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


TransformInfo Constructor

TransformInfo Constructor
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► TransformInfo()()()
Members
Icon | Member | Description
 | TransformInfo(String) | Reads transform information from a transform package.
 | TransformInfo(String, SummaryInfo) | Reads transform information from the summary information of a transform package.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


TransformInfo Constructor (mstFile)

TransformInfo Constructor (mstFile)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► TransformInfo(String)
Reads transform information from a transform package.
Declaration Syntax
C# Visual Basic Visual C++
public TransformInfo(
    string mstFile
)
Public Sub New ( _
    mstFile As String _
)
public:
TransformInfo(
    String^ mstFile
)
Parameters
mstFile (String)
Path to a transform package (.MST file).

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


TransformInfo Constructor (name, transformSummaryInfo)

TransformInfo Constructor (name, transformSummaryInfo)
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► TransformInfo(String, SummaryInfo)
Reads transform information from the summary information of a transform package.
Declaration Syntax
C# Visual Basic Visual C++
public TransformInfo(
    string name,
    SummaryInfo transformSummaryInfo
)
Public Sub New ( _
    name As String, _
    transformSummaryInfo As SummaryInfo _
)
public:
TransformInfo(
    String^ name,
    SummaryInfo^ transformSummaryInfo
)
Parameters
name (String)
Filename of the transform (optional).
transformSummaryInfo (SummaryInfo)
Handle to the summary information of a transform package (.MST file).

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Name Property

Name Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► Name
Gets the filename of the transform.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


TargetLanguage Property

TargetLanguage Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► TargetLanguage
Gets the target language of the transform, or 0 if the transform is language-neutral.
Declaration Syntax
C# Visual Basic Visual C++
public int TargetLanguage { get; }
Public ReadOnly Property TargetLanguage As Integer
public:
property int TargetLanguage {
    int get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


TargetPlatform Property

TargetPlatform Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► TargetPlatform
Gets the target platform of the transform.
Declaration Syntax
C# Visual Basic Visual C++
public string TargetPlatform { get; }
Public ReadOnly Property TargetPlatform As String
public:
property String^ TargetPlatform {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


TargetProductCode Property

TargetProductCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► TargetProductCode
Gets the target product code of the transform.
Declaration Syntax
C# Visual Basic Visual C++
public string TargetProductCode { get; }
Public ReadOnly Property TargetProductCode As String
public:
property String^ TargetProductCode {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


TargetProductVersion Property

TargetProductVersion Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► TargetProductVersion
Gets the target product version of the transform.
Declaration Syntax
C# Visual Basic Visual C++
public string TargetProductVersion { get; }
Public ReadOnly Property TargetProductVersion As String
public:
property String^ TargetProductVersion {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ToString Method

ToString Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► ToString()()()
Returns the name of the transform.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


UpgradeCode Property

UpgradeCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► UpgradeCode
Gets the upgrade code of the transform.
Declaration Syntax
C# Visual Basic Visual C++
public string UpgradeCode { get; }
Public ReadOnly Property UpgradeCode As String
public:
property String^ UpgradeCode {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


UpgradeProductCode Property

UpgradeProductCode Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► UpgradeProductCode
Gets the upgrade product code of the transform.
Declaration Syntax
C# Visual Basic Visual C++
public string UpgradeProductCode { get; }
Public ReadOnly Property UpgradeProductCode As String
public:
property String^ UpgradeProductCode {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


UpgradeProductVersion Property

UpgradeProductVersion Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► UpgradeProductVersion
Gets the upgrade product version of the transform.
Declaration Syntax
C# Visual Basic Visual C++
public string UpgradeProductVersion { get; }
Public ReadOnly Property UpgradeProductVersion As String
public:
property String^ UpgradeProductVersion {
    String^ get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Validations Property

Validations Property
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► TransformInfo ► Validations
Gets the validation flags specified when the transform was generated.
Declaration Syntax
C# Visual Basic Visual C++
public TransformValidations Validations { get; }
Public ReadOnly Property Validations As TransformValidations
public:
property TransformValidations Validations {
    TransformValidations get ();
}

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveFileInfo ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► ArchiveInfo ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabEngine ► Dispose()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Disposes of resources allocated by the cabinet engine. (Overrides CompressionEngine.Dispose(Boolean).)
 | Dispose()()() | Disposes of resources allocated by the compression engine.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


GetFileInfo Method

GetFileInfo Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabEngine ► GetFileInfo()()()
Members
Icon | Member | Description
 | GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Gets information about files in a cabinet or cabinet chain. (Overrides CompressionEngine.GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>)).)
 | GetFileInfo(Stream) | Gets information about all files in an archive stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method

GetFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabEngine ► GetFiles()()()
Members
Icon | Member | Description
 | GetFiles(Stream) | Gets the list of files in an archive Stream.
 | GetFiles(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Gets the list of files in an archive or archive chain.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Pack Method

Pack Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabEngine ► Pack()()()
Members
Icon | Member | Description
 | Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64) | Creates a cabinet or chain of cabinets. (Overrides CompressionEngine.Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64).)
 | Pack(IPackStreamContext, IEnumerable<(Of <(String>)>)) | Creates an archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Unpack Method

Unpack Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabEngine ► Unpack()()()
Members
Icon | Member | Description
 | Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Extracts files from a cabinet or cabinet chain. (Overrides CompressionEngine.Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>)).)
 | Unpack(Stream, String) | Reads a single file from an archive stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method

CopyTo Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabFileInfo ► CopyTo()()()
Members
Icon | Member | Description
 | CopyTo(String) | Extracts the file.
 | CopyTo(String, Boolean) | Extracts the file, optionally overwriting any existing file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabFileInfo ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Refresh Method

Refresh Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabFileInfo ► Refresh()()()
Members
Icon | Member | Description
 | Refresh(ArchiveFileInfo) | Refreshes the information in this object with new data retrieved from an archive. (Overrides ArchiveFileInfo.Refresh(ArchiveFileInfo).)
 | Refresh()()() | Refreshes the attributes and other cached information about the file, by re-reading the information from the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method

CopyTo Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► CopyTo()()()
Members
Icon | Member | Description
 | CopyTo(String) | Copies an existing archive to another location.
 | CopyTo(String, Boolean) | Copies an existing archive to another location, optionally overwriting the destination file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Pack Method

Pack Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► Pack()()()
Members
Icon | Member | Description
 | Pack(String) | Compresses all files in a directory into the archive. Does not include subdirectories.
 | Pack(String, Boolean, CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses all files in a directory into the archive, optionally including subdirectories.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


PackFiles Method

PackFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► PackFiles()()()
Members
Icon | Member | Description
 | PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.
 | PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


PackFileSet Method

PackFileSet Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► PackFileSet()()()
Members
Icon | Member | Description
 | PackFileSet(String, IDictionary<(Of <(String, String>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.
 | PackFileSet(String, IDictionary<(Of <(String, String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Unpack Method

Unpack Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► Unpack()()()
Members
Icon | Member | Description
 | Unpack(String) | Extracts all files from an archive to a destination directory.
 | Unpack(String, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts all files from an archive to a destination directory, optionally extracting only newer files.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


UnpackFiles Method

UnpackFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► UnpackFiles()()()
Members
Icon | Member | Description
 | UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>)) | Extracts multiple files from the archive.
 | UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>), EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts multiple files from the archive, optionally extracting only newer files.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


UnpackFileSet Method

UnpackFileSet Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Cab ► CabInfo ► UnpackFileSet()()()
Members
Icon | Member | Description
 | UnpackFileSet(IDictionary<(Of <(String, String>)>), String) | Extracts multiple files from the archive.
 | UnpackFileSet(IDictionary<(Of <(String, String>)>), String, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts multiple files from the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Cab (Module: Microsoft.Deployment.Compression.Cab) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the Stream.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► CargoStream ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the Stream.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► DuplicateStream ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the Stream.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression ► OffsetStream ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression (Module: Microsoft.Deployment.Compression) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the Stream.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► CrcStream ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Disposes of resources allocated by the compression engine.
 | Dispose(Boolean) | Disposes of resources allocated by the compression engine.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


GetFileInfo Method

GetFileInfo Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► GetFileInfo()()()
Members
Icon | Member | Description
 | GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Gets information about files in a zip archive or archive chain. (Overrides CompressionEngine.GetFileInfo(IUnpackStreamContext, Predicate<(Of <(String>)>)).)
 | GetFileInfo(Stream) | Gets information about all files in an archive stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


GetFiles Method

GetFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► GetFiles()()()
Members
Icon | Member | Description
 | GetFiles(Stream) | Gets the list of files in an archive Stream.
 | GetFiles(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Gets the list of files in an archive or archive chain.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Pack Method

Pack Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► Pack()()()
Members
Icon | Member | Description
 | Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64) | Creates a zip archive or chain of zip archives. (Overrides CompressionEngine.Pack(IPackStreamContext, IEnumerable<(Of <(String>)>), Int64).)
 | Pack(IPackStreamContext, IEnumerable<(Of <(String>)>)) | Creates an archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Unpack Method

Unpack Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipEngine ► Unpack()()()
Members
Icon | Member | Description
 | Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>)) | Extracts files from a zip archive or archive chain. (Overrides CompressionEngine.Unpack(IUnpackStreamContext, Predicate<(Of <(String>)>)).)
 | Unpack(Stream, String) | Reads a single file from an archive stream.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method

CopyTo Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipFileInfo ► CopyTo()()()
Members
Icon | Member | Description
 | CopyTo(String) | Extracts the file.
 | CopyTo(String, Boolean) | Extracts the file, optionally overwriting any existing file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipFileInfo ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Refresh Method

Refresh Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipFileInfo ► Refresh()()()
Members
Icon | Member | Description
 | Refresh()()() | Refreshes the attributes and other cached information about the file, by re-reading the information from the archive.
 | Refresh(ArchiveFileInfo) | Refreshes the information in this object with new data retrieved from an archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


CopyTo Method

CopyTo Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► CopyTo()()()
Members
Icon | Member | Description
 | CopyTo(String) | Copies an existing archive to another location.
 | CopyTo(String, Boolean) | Copies an existing archive to another location, optionally overwriting the destination file.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Pack Method

Pack Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► Pack()()()
Members
Icon | Member | Description
 | Pack(String) | Compresses all files in a directory into the archive. Does not include subdirectories.
 | Pack(String, Boolean, CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses all files in a directory into the archive, optionally including subdirectories.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


PackFiles Method

PackFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► PackFiles()()()
Members
Icon | Member | Description
 | PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.
 | PackFiles(String, IList<(Of <(String>)>), IList<(Of <(String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


PackFileSet Method

PackFileSet Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► PackFileSet()()()
Members
Icon | Member | Description
 | PackFileSet(String, IDictionary<(Of <(String, String>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.
 | PackFileSet(String, IDictionary<(Of <(String, String>)>), CompressionLevel, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Compresses files into the archive, specifying the names used to store the files in the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Unpack Method

Unpack Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► Unpack()()()
Members
Icon | Member | Description
 | Unpack(String) | Extracts all files from an archive to a destination directory.
 | Unpack(String, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts all files from an archive to a destination directory, optionally extracting only newer files.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


UnpackFiles Method

UnpackFiles Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► UnpackFiles()()()
Members
Icon | Member | Description
 | UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>)) | Extracts multiple files from the archive.
 | UnpackFiles(IList<(Of <(String>)>), String, IList<(Of <(String>)>), EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts multiple files from the archive, optionally extracting only newer files.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


UnpackFileSet Method

UnpackFileSet Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.Compression.Zip ► ZipInfo ► UnpackFileSet()()()
Members
Icon | Member | Description
 | UnpackFileSet(IDictionary<(Of <(String, String>)>), String) | Extracts multiple files from the archive.
 | UnpackFileSet(IDictionary<(Of <(String, String>)>), String, EventHandler<(Of <(ArchiveProgressEventArgs>)>)) | Extracts multiple files from the archive.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.Compression.Zip (Module: Microsoft.Deployment.Compression.Zip) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► Dispose()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Closes the database handle. After closing a handle, further method calls may throw InvalidHandleException. (Overrides InstallerHandle.Dispose(Boolean).)
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Database ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► InstallerHandle ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


ApplyTransform Method

ApplyTransform Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► ApplyTransform()()()
Members
Icon | Member | Description
 | ApplyTransform(String) | Apply a transform to the database, suppressing any error conditions specified by the transform's summary information.
 | ApplyTransform(String, TransformErrors) | Apply a transform to the database, specifying error conditions to suppress.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


CountRows Method

CountRows Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► CountRows()()()
Members
Icon | Member | Description
 | CountRows(String) | Gets the count of all rows in the table.
 | CountRows(String, String) | Gets the count of all rows in the table that satisfy a given condition.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► Dispose()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Closes the database handle. After closing a handle, further method calls may throw InvalidHandleException. (Overrides InstallerHandle.Dispose(Boolean).)
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Execute Method

Execute Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► Execute()()()
Members
Icon | Member | Description
 | Execute(String, array<Object>[]()[]) | Executes the query specified by a SQL string. The query may not be a SELECT statement.
 | Execute(String, Record) | Executes the query specified by a SQL string. The query may not be a SELECT statement.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


ExecuteIntegerQuery Method

ExecuteIntegerQuery Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► ExecuteIntegerQuery()()()
Members
Icon | Member | Description
 | ExecuteIntegerQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as integers.
 | ExecuteIntegerQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as integers.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


ExecuteQuery Method

ExecuteQuery Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► ExecuteQuery()()()
Members
Icon | Member | Description
 | ExecuteQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results.
 | ExecuteQuery(String, Record) | Executes the specified SQL SELECT query and returns all results.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


ExecuteScalar Method

ExecuteScalar Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns a single result.
 | ExecuteScalar(String, Record) | Executes the specified SQL SELECT query and returns a single result.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


ExecuteStringQuery Method

ExecuteStringQuery Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► ExecuteStringQuery()()()
Members
Icon | Member | Description
 | ExecuteStringQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as strings.
 | ExecuteStringQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as strings.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


IsTransformValid Method

IsTransformValid Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► IsTransformValid()()()
Members
Icon | Member | Description
 | IsTransformValid(String) | Checks whether a transform is valid for this Database, according to its validation data and flags.
 | IsTransformValid(SummaryInfo) | Checks whether a transform is valid for this Database, according to its SummaryInfo data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


Merge Method

Merge Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Linq ► QDatabase ► Merge()()()
Members
Icon | Member | Description
 | Merge(Database, String) | Merges another database with this database.
 | Merge(Database) | Merges another database with this database.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Linq (Module: Microsoft.Deployment.WindowsInstaller.Linq) Version: 3.0.0.0 (3.0.5419.0)


ApplyTransform Method

ApplyTransform Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► ApplyTransform()()()
Members
Icon | Member | Description
 | ApplyTransform(String) | Apply a transform to the database, suppressing any error conditions specified by the transform's summary information.
 | ApplyTransform(String, TransformErrors) | Apply a transform to the database, specifying error conditions to suppress.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


CountRows Method

CountRows Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► CountRows()()()
Members
Icon | Member | Description
 | CountRows(String) | Gets the count of all rows in the table.
 | CountRows(String, String) | Gets the count of all rows in the table that satisfy a given condition.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► Dispose()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Closes the database handle. After closing a handle, further method calls may throw InvalidHandleException. (Overrides InstallerHandle.Dispose(Boolean).)
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Execute Method

Execute Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► Execute()()()
Members
Icon | Member | Description
 | Execute(String, array<Object>[]()[]) | Executes the query specified by a SQL string. The query may not be a SELECT statement.
 | Execute(String, Record) | Executes the query specified by a SQL string. The query may not be a SELECT statement.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ExecuteIntegerQuery Method

ExecuteIntegerQuery Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► ExecuteIntegerQuery()()()
Members
Icon | Member | Description
 | ExecuteIntegerQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as integers.
 | ExecuteIntegerQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as integers.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ExecuteQuery Method

ExecuteQuery Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► ExecuteQuery()()()
Members
Icon | Member | Description
 | ExecuteQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results.
 | ExecuteQuery(String, Record) | Executes the specified SQL SELECT query and returns all results.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ExecuteScalar Method

ExecuteScalar Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns a single result.
 | ExecuteScalar(String, Record) | Executes the specified SQL SELECT query and returns a single result.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ExecuteStringQuery Method

ExecuteStringQuery Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► ExecuteStringQuery()()()
Members
Icon | Member | Description
 | ExecuteStringQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as strings.
 | ExecuteStringQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as strings.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


IsTransformValid Method

IsTransformValid Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► IsTransformValid()()()
Members
Icon | Member | Description
 | IsTransformValid(String) | Checks whether a transform is valid for this Database, according to its validation data and flags.
 | IsTransformValid(SummaryInfo) | Checks whether a transform is valid for this Database, according to its SummaryInfo data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Merge Method

Merge Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► InstallPackage ► Merge()()()
Members
Icon | Member | Description
 | Merge(Database, String) | Merges another database with this database.
 | Merge(Database) | Merges another database with this database.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ApplyTransform Method

ApplyTransform Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► ApplyTransform()()()
Members
Icon | Member | Description
 | ApplyTransform(String) | Apply a transform to the database, suppressing any error conditions specified by the transform's summary information.
 | ApplyTransform(String, TransformErrors) | Apply a transform to the database, specifying error conditions to suppress.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


CountRows Method

CountRows Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► CountRows()()()
Members
Icon | Member | Description
 | CountRows(String) | Gets the count of all rows in the table.
 | CountRows(String, String) | Gets the count of all rows in the table that satisfy a given condition.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► Dispose()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Closes the database handle. After closing a handle, further method calls may throw InvalidHandleException. (Overrides InstallerHandle.Dispose(Boolean).)
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Execute Method

Execute Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► Execute()()()
Members
Icon | Member | Description
 | Execute(String, array<Object>[]()[]) | Executes the query specified by a SQL string. The query may not be a SELECT statement.
 | Execute(String, Record) | Executes the query specified by a SQL string. The query may not be a SELECT statement.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ExecuteIntegerQuery Method

ExecuteIntegerQuery Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► ExecuteIntegerQuery()()()
Members
Icon | Member | Description
 | ExecuteIntegerQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as integers.
 | ExecuteIntegerQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as integers.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ExecuteQuery Method

ExecuteQuery Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► ExecuteQuery()()()
Members
Icon | Member | Description
 | ExecuteQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results.
 | ExecuteQuery(String, Record) | Executes the specified SQL SELECT query and returns all results.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ExecuteScalar Method

ExecuteScalar Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► ExecuteScalar()()()
Members
Icon | Member | Description
 | ExecuteScalar(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns a single result.
 | ExecuteScalar(String, Record) | Executes the specified SQL SELECT query and returns a single result.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


ExecuteStringQuery Method

ExecuteStringQuery Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► ExecuteStringQuery()()()
Members
Icon | Member | Description
 | ExecuteStringQuery(String, array<Object>[]()[]) | Executes the specified SQL SELECT query and returns all results as strings.
 | ExecuteStringQuery(String, Record) | Executes the specified SQL SELECT query and returns all results as strings.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


IsTransformValid Method

IsTransformValid Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► IsTransformValid()()()
Members
Icon | Member | Description
 | IsTransformValid(String) | Checks whether a transform is valid for this Database, according to its validation data and flags.
 | IsTransformValid(SummaryInfo) | Checks whether a transform is valid for this Database, according to its SummaryInfo data.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Merge Method

Merge Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller.Package ► PatchPackage ► Merge()()()
Members
Icon | Member | Description
 | Merge(Database, String) | Merges another database with this database.
 | Merge(Database) | Merges another database with this database.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller.Package (Module: Microsoft.Deployment.WindowsInstaller.Package) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.
 | Dispose(Boolean) | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Record ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.
 | Dispose(Boolean) | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Session ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.
 | Dispose(Boolean) | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► SummaryInfo ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Transaction ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.
 | Dispose(Boolean) | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► Transaction ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Dispose Method

Dispose Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.
 | Dispose(Boolean) | Closes the handle. After closing a handle, further method calls may throw an InvalidHandleException.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


MemberwiseClone Method

MemberwiseClone Method
Deployment Tools Foundation Namespaces ► Microsoft.Deployment.WindowsInstaller ► View ► MemberwiseClone()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.

Send comments on this topic to wix-users@lists.sourceforge.net

Assembly: Microsoft.Deployment.WindowsInstaller (Module: Microsoft.Deployment.WindowsInstaller) Version: 3.0.0.0 (3.0.5419.0)


Namespaces

Namespaces
Deployment Tools Foundation Namespaces
Namespaces
Namespace | Description
Microsoft.Deployment.Compression | Framework for archive packing and unpacking.
Microsoft.Deployment.Compression.Cab | Implements cabinet archive packing and unpacking.
Microsoft.Deployment.Compression.Zip | Implements zip archive packing and unpacking.
Microsoft.Deployment.Resources | Classes for reading and writing resource data in executable files.
Microsoft.Deployment.WindowsInstaller | Complete class library for the Windows Installer APIs.
Microsoft.Deployment.WindowsInstaller.Linq | LINQ extensions for querying Windows Installer databases (experimental).
Microsoft.Deployment.WindowsInstaller.Package | Extended classes for working with Windows Installer installation and patch packages.